Co je to automatické ukládání?

Přepínání automatického ukládání v Office

Automatické ukládání je nová funkce, kterou mají k dispozici předplatitelé Office 365 v Excelu, Wordu a PowerPointu. Ukládá soubory automaticky každých pár sekund, zatímco pracujete. 

Funkce Automatické ukládání je v Office 365 ve výchozím nastavení povolená, pokud je soubor uložený na OneDrivu, OneDrivu pro firmy nebo SharePointu Online. 

Důležité informace: Používáte po změně původního dokumentu nebo šablony funkci Soubor > Uložit jako? Pokud ano, doporučujeme před provedením změn použít Soubor > Uložit kopii, Pokud Automatické ukládání soubor přepíše a uloží do něj vaše změny, přečtěte si část Nechtěl(a) jsem změny uložit. Jak je vrátím zpátky?

Ve Windows je funkce Automatické ukládání dostupná předplatitelům Office 365 v Excelu, Wordu a PowerPointu. Tady jsou některé časté otázky k této funkci.

Předchozí verzi souboru můžete obnovit pomocí Historie verzí. 

Kliknutí ukazatelem myši na soubor, Zobrazit všechny verze

V horní části okna klikněte na název souboru a potom klikněte na Historie verzí. Zkontrolujte data a časy a najděte verzi, kterou chcete obnovit. Potom klikněte na Otevřít verzi. Otevře se druhé okno, které zobrazuje vybranou verzi souboru. Pokud se chcete vrátit zpátky k této verzi, klikněte na tlačítko Obnovit. Další informace o historii verzí najdete v článku Zobrazení předchozích verzí souborů Office.

Po otevření souboru a provedení prvních změn uloží funkce Automatické ukládání provedené změny a do historie verzí přibude nová verze souboru. Od tohoto okamžiku funkce Automatické ukládání pravidelně ukládá změny souboru a jeho nové verze se v pravidelných intervalech (zhruba každých 10 minut) přidávají do historie verzí, a to až do konce relace, ve které provádíte úpravy.

Pokud jste vlastníkem souboru, můžete nastavit, aby se soubor vždy otevřel jen pro čtení. Když lidé otevřou soubor s tímto nastavením, nebudou moct uložit úpravy souboru, pokud přímo nepovolí úpravy. Pokud chcete soubor takto nastavit, přejděte na Soubor > Informace > Zamknout dokument > Vždy otevírat jen pro čtení. Pokud budete toto nastavení chtít později vypnout, stačí tento postup zopakovat.

Ovládací prvek Zamknout dokument byl vybrán, čímž se zobrazila možnost Vždy otevírat jen pro čtení.

Soubor můžete chránit před úpravami i dalšími způsoby. Pokud je soubor uložený na OneDrivu, můžete změnit oprávnění k jeho úpravám. Pokud je soubor na uložený SharePointu, můžete nastavit konfiguraci knihovny tak, aby se požadovala rezervace souborů.

Soubor > Uložit kopii

Možnost Uložit jako není v nabídce Soubor při otevření dokumentu z OneDrivu, OneDrivu pro firmy nebo SharePointu Online. V těchto případech se místo toho v nabídce Soubor zobrazí příkaz Uložit kopii.

Používáte příkaz Uložit jako hodně? Řada lidí obvykle pracuje na souboru a pak použije příkaz Soubor > Uložit jako, aby zachovala změny v kopii a ne v originálu. Ale při zapnuté funkci Automatické ukládání se změny průběžně ukládají do originálu. Doporučujeme proto, pokud chcete použít změny v kopii a ne v originálu, použít před provedením změn možnost Soubor > Uložit kopii.

Pokud máte předplatné Office 365 a máte nainstalované nejnovější verze aplikací Excel, Word a PowerPoint pro Windows, je ovládací prvek funkce Automatické ukládání v levém horním rohu záhlaví aplikace. Nezapomeňte prosím, že pokud máte pracovní nebo školní účet, váš správce může určit verzi Office, kterou si můžete nainstalovat – a nemusí se jednat o nejnovější verzi. Další informace najdete v článku Kdy získám nejnovější funkce v Office 365?.

Pokud předplatné nemáte, nic se neděje. Pořád je k dispozici automatické obnovení. Automatické obnovení chrání soubory, pokud dojde k chybě. Pokud po chybě znovu otevřete soubor, zobrazí se v podokně Obnovení dokumentu verze souboru s nejnovějšími změnami. Další informace o tom, jak tuto funkci zapnout, najdete v článku Ochrana souborů pro nečekané případy.

A samozřejmě vždy můžete manuálně ukládat tak, jak jste vždy byli zvyklí, stisknutím kláves CTRL + S, kliknutím na tlačítko Uložit nebo přechodem na Soubor > Uložit.

Automatické ukládání je povolené při práci na souboru, který je uložený na OneDrivu, OneDrivu pro firmy nebo SharePointu Online. Pokud je soubor uložen v jiném umístění (nebo pokud ještě nebyl vůbec uložen), pak je funkce automatického ukládání vypnutá. K tomu dochází, když je soubor uložený na místním webu SharePointu, na souborovém serveru nebo na jiném cloudovém úložišti, nebo když je uložený na místní jednotce, například na jednotce C:\.

Automatické ukládání může být ale zakázané i z dalších příčin. Tady jsou některé běžné důvody pro zakázání:

  • Soubor je ve starším formátu, například .xls, .ppt nebo .doc.

  • Soubor je v místní složce OneDrivu a synchronizace OneDrivu je pozastavena.

  • Soubor je synchronizovaný starší verzí Synchronizační aplikace OneDrivu. Další informace o aktualizaci OneDrivu najdete v článku Synchronizace souborů pomocí OneDrivu ve Windows.

  • Soubor je vložený v jiném souboru Office.

  • Prezentace je v režimu prezentace.

Pokud používáte Excel a vyzkoušeli jste výše uvedené možnosti, můžete mít soubor obsahující funkce, které automatické ukládání nepodporuje. Proveďte alespoň jednu z následujících akcí, abyste ho povolili:

  • Vypne funkci Sdílený sešit. Tato funkce představuje starší metodu sdílení. Má řadu omezení, takže ji nahradilo spoluvytváření.

  • Pokud je to možné, odeberte ze souboru šifrování heslem: Přejděte na Soubor > Informace > Zamknout sešit. Odstraňte heslo a klikněte na OK.

  • Pokud je to možné, odeberte omezený přístup: Přejděte na Soubor > Informace > Zamknout sešit > Omezit přístup a klikněte na Neomezený přístup.

  • Pokud se pokoušíte otevřít snímek sešitu ze SharePointu, neotvírejte snímek, ale soubor.

  • U všech tabulek a kontingenčních tabulek v souboru vypněte nastavení Aktualizovat data při otevření souboru. Vyberte tabulku nebo kontingenční tabulku a přejděte na Nástroje tabulky – Návrh > Aktualizovat > Vlastnosti připojení. Pak zrušte zaškrtnutí políčka Aktualizovat data při otevření souboru.

  • Deaktivujte doplněk, který vypíná automatické ukládání. Vyberte Soubor > Možnosti > Doplňky > Doplňky Excelu > Přejít a zrušte zaškrtnutí políčka u příslušného doplňku.

Snadný způsob je vypnout před provedením změn přepínač Automatické ukládání. Pokud mají být změny dočasné a nechcete je ukládat, soubor zavřete. Po zobrazení dotazu, jestli chcete soubor uložit, pak klikněte na Ne. Pokud se rozhodnete, že chcete změny ukládat, jednoduše znovu zapněte automatické ukládání.

Pokud nechcete průběžně ukládat a nechcete, aby se změny ostatním zobrazovali, můžete automatické ukládání vypnout. Až budete připraveni, klikněte na Uložit (nebo stiskněte klávesy CTRL + S). Změny se uloží a zobrazí ostatním lidem, kteří na souboru pracují. (Můžete také Automatické ukládání znovu zapnout a změny tak uložit a sdílet.)

U souborů, které jsou v Microsoft Cloudu, je automatické ukládání ve výchozím nastavení vždycky zapnuto. Pokud ale u daného souboru automatické ukládání vypnete, program si bude nastavení pamatovat a při každém dalším otevření daného souboru zůstane automatické ukládání vypnuto. Pokud u souboru automatické ukládání znovu zapnete, zapamatuje si aplikace toto nastavení.

Když je automatické ukládání vypnuté, automatické obnovení pořád funguje pro případ selhání systému, když je soubor otevřen. Další informace najdete v článku Ochrana souborů pro nečekané případy.

Pokud automatické ukládání pro daný soubor vypnete, aplikace si bude toto nastavení při každém dalším otevření tohoto souboru pamatovat. Pokud u daného souboru automatické ukládání znovu zapnete, zapamatuje si aplikace toto nastavení.

Pokud chcete automatické ukládání vypnout standardně pro všechny soubory, přejděte na Soubor > Možnosti > Uložit a zrušte zaškrtnutí políčka Ve výchozím nastavení v <application> automaticky ukládat soubory na OneDrivu a SharePointu Online.

Dialogové okno Soubor > Možnosti > Uložit se zaškrtávacím políčkem k povolení nebo zakázání automatického ukládání

Restartujte Word (nebo jinou aplikaci, ve které jste) a změna se projeví.

Poznámky: 

  • Pokud chcete automatické ukládání vypnout standardně pro všechny aplikace Office, které používáte (třeba pro PowerPoint a Excel), opakujte tento postup u každé z těchto aplikací.

  • Pokud chcete, aby se jednotlivé soubory přesto automaticky ukládaly, můžete tyto soubory otevřít a ručně u nich automatické ukládání zase zapnout.

Na Macu je funkce Automatické ukládání dostupná předplatitelům Office 365 v Excelu, Wordu a PowerPointu. Tady jsou některé časté otázky k této funkci.

Můžete obnovit předchozí verzi souboru. Starší verze se tak nastaví jako aktuální. Klikněte na Soubor > Procházet historii verzí. V podokně Historie verzí se podívejte na data a časy a najděte verzi, kterou chcete obnovit. Potom klikněte na Otevřít verzi. Otevře se druhé okno. Pokud chcete se vrátit zpátky k této verzi, klikněte na tlačítko Obnovit.

Pokud je soubor uložený na OneDrivu, můžete změnit oprávnění pro soubor. Pokud je soubor na uložený SharePointu, můžete nastavit konfiguraci knihovny tak, aby se požadovala rezervace souborů.

Možnost Uložit jako není v nabídce Soubor při otevření dokumentu z OneDrivu, OneDrivu pro firmy nebo SharePointu Online. V těchto případech se místo toho v nabídce Soubor zobrazí příkaz Uložit kopii.

Používáte příkaz Uložit jako hodně? Řada lidí obvykle pracuje na souboru a pak použije příkaz Soubor > Uložit jako, aby zachovala změny v kopii a ne v originálu. Ale při zapnuté funkci Automatické ukládání se změny průběžně ukládají do originálu. Doporučujeme proto, pokud chcete použít změny v kopii a ne v originálu, použít hned na začátku možnost Soubor > Uložit kopii.

Pokud máte předplatné Office 365 a máte nainstalované nejnovější verze Excelu, Wordu a PowerPointu pro Mac, najdete Automatické ukládání v levém horním rohu. Nezapomeňte prosím, že pokud máte pracovní nebo školní účet, může váš správce určit verzi Office, kterou si můžete nainstalovat – a nemusí se jednat o nejnovější verzi. Další informace najdete v článku Kdy získám nejnovější funkce v Office 365?.

Pokud předplatné nemáte, nic se neděje. Pořád je k dispozici automatické obnovení. Automatické obnovení chrání soubory, pokud dojde k chybě. Když po chybovém ukončení aplikace soubor znovu otevřete, zobrazí se v podokně Obnovení dokumentu verze souboru s nejnovějšími změnami. Další informace o tom, jak tuto funkci zapnout, najdete v článku věnovaném obnovování souborů v Office pro Mac.

Automatické ukládání je povolené při práci na souboru, který je uložený na OneDrivu, OneDrivu pro firmy nebo SharePointu Online. Pokud je soubor uložen v jiném umístění (nebo pokud ještě nebyl vůbec uložen), pak je funkce automatického ukládání vypnutá. K tomu dochází, když je soubor uložený na místním webu SharePointu, souborovém serveru nebo v místní složce počítače.

Aby se automatické ukládání aktivovalo, je také nutné, abyste soubor otevřeli z nabídky Soubor ve Wordu, Excelu nebo PowerPointu.

Poznámka: Pokud vaše nabídka Soubor > Otevřít vypadá jako na obrázku níže, musíte kliknout na tlačítko Online umístění a vybrat soubor na OneDrivu nebo SharePointu, jinak automatické ukládání nebude funkční. Nabídka pro otevření souboru se zobrazením položek na počítači Mac

Automatické ukládání může být ale zakázané i z dalších příčin. Tady je seznam běžných příčin:

  • Soubor je ve starším formátu, například .xls, .ppt nebo .doc.

  • Soubor je v místní složce OneDrivu a synchronizace OneDrivu je pozastavena.

  • Soubor je vložený v jiném souboru Office.

  • Prezentace je v režimu prezentace.

Pokud používáte Excel a vyzkoušeli jste výše uvedené možnosti, můžete mít soubor obsahující funkce, které automatické ukládání nepodporuje. Proveďte alespoň jednu z následujících akcí, abyste ho povolili:

  • Vypne funkci Sdílený sešit. Tato funkce představuje starší metodu sdílení. Má řadu omezení, takže ji nahradilo spoluvytváření.

  • Pokud je to možné, odeberte ze souboru šifrování heslem: Na kartě Revize klikněte na Zamknout sešit. Odstraňte heslo a klikněte na OK.

  • Pokud je to možné, odeberte omezený přístup: Přejděte na Soubor > Omezit oprávnění > Bez omezení.

  • Pokud se pokoušíte otevřít snímek sešitu ze SharePointu, neotvírejte snímek, ale soubor.

  • U všech tabulek a kontingenčních tabulek v souboru vypněte nastavení Aktualizovat data při otevření souboru. Vyberte tabulku nebo kontingenční tabulku a přejděte na kartu Tabulka. Klikněte na Aktualizovat > Vlastnosti připojení a zrušte zaškrtnutí políčka Aktualizovat data při otevření souboru.

  • Deaktivujte doplněk, který vypíná automatické ukládání. Vyberte Soubor > Doplňky Excelu a zrušte zaškrtnutí políčka u příslušného doplňku.

Snadný způsob je vypnout před provedením změn přepínač Automatické ukládání. Pokud se rozhodnete, že chcete změny uložit, jednoduše znovu zapněte automatické ukládání. Pokud nechcete změny uložit, zavřete soubor. Po zobrazení dotazu, jestli chcete soubor uložit, pak klikněte na Ne.

Pokud nechcete průběžně ukládat a nechcete, aby se změny ostatním zobrazovali, můžete automatické ukládání vypnout. Až budete připraveni, klikněte na Uložit. Změny se zobrazí ostatním lidem, kteří na souboru pracují. (Můžete také Automatické ukládání znovu zapnout a změny tak uložit a sdílet.)

U souborů, které jsou v cloudu, je automatické ukládání ve výchozím nastavení vždycky Zapnuto. Pokud ale u souboru automatické ukládání vypnete, program si bude nastavení pamatovat a při každém dalším otevření daného souboru zůstane automatické ukládání vypnuto. Pokud u souboru automatické ukládání znovu zapnete, toto nastavení se u daného souboru zapamatuje.

Když je automatické ukládání vypnuté, automatické obnovení pořád funguje pro případ selhání systému, když je soubor otevřen. Další informace najdete v článku Automatické uložení a obnovení souborů.

Pokud automatické ukládání pro daný soubor vypnete, aplikace si bude toto nastavení při každém dalším otevření tohoto souboru pamatovat. Pokud u daného souboru automatické ukládání znovu zapnete, zapamatuje si aplikace toto nastavení.

Pokud chcete automatické ukládání vypnout standardně pro všechny soubory, přejděte na Předvolby > Uložit a zrušte zaškrtnutí políčka Ve výchozím nastavení zapnout automatické ukládání.

Ne. Můžete ho ale vypnout pro soubor a aplikace si bude toto nastavení při každém dalším otevření daného souboru pamatovat. Pokud u souboru automatické ukládání znovu zapnete, zapamatuje si aplikace toto nastavení.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×