Co je nového v aplikaci Excel 2010

Tento článek popisuje nové a vylepšené funkce v aplikaci Microsoft Excel 2010.

V tomto článku

Přístup ke správným nástrojům ve správný čas

Vylepšení pásu karet

Zobrazení Microsoft Office Backstage

Nástroje pro správu sešitu

Nové způsoby přístupu k sešitům

Microsoft Excel Online

Excel Mobile 2010 pro Windows Phone 7

Rychlé a efektivní porovnání seznamů dat

Minigrafy

Vylepšení kontingenčních tabulek

Průřezy

Vylepšení podmíněného formátování

Výkonné analýzy v Excelu

Doplněk PowerPivot pro Excel

Vylepšení doplňku Řešitel

Vylepšení přesnosti funkcí

Vylepšené schopnosti filtrování

64bitová verze Excelu

Zvýšení výkonu

Vytváření vizuálně působivějších sešitů

Vylepšení grafů

Podpora rovnic

Víc motivů

Vložení s dynamickým náhledem

Vylepšené nástroje pro úpravu obrázků

Nové způsoby spolupráce na sešitech

Spoluvytváření sešitů

Vylepšené služby Excel Services

Kontrola usnadnění

Vylepšení jazykových nástrojů

Nové způsoby rozšíření sešitů

Vylepšení programovacích funkcí

Podpora výkonných výpočetních clusterů

Přístup ke správným nástrojům ve správný čas

Nové a vylepšené funkce vám pomůžou dosáhnout vyšší produktivity, ale jenom za předpokladu, že je umíte najít ve chvíli, kdy je potřebujete. Stejně jako ostatní aplikace Microsoft Office 2010 taky aplikace Excel 2010 obsahuje rozhraní Fluent Microsoft Office, které se skládá z upravitelného vizuálního systému nástrojů a příkazů.

Vylepšení pásu karet

Pás karet, představený poprvé v aplikaci Excel 2007, usnadňuje vyhledávání příkazů a funkcí, které byly v minulosti ukryty ve složitých nabídkách a panelech nástrojů. I když jste v aplikaci Excel 2007 mohli přizpůsobit panel nástrojů Rychlý přístup, nebylo možné přidávat vlastní karty nebo skupiny na pás karet. V aplikaci Excel 2010 ale můžete vytvářet vlastní karty i skupiny a přejmenovat předdefinované karty a skupiny nebo změnit jejich pořadí.

Vlastní karta na pásu karet

Přečtěte si další informace o přizpůsobení pásu karet.

zobrazení Microsoft Office Backstage

Kliknutím na kartu Soubor otevřete zobrazení Backstage, kde můžete vytvářet nové soubory, otevírat existující soubory a pak taky soubory ukládat, odesílat a tisknout nebo nastavit jejich ochranu nebo zobrazit jejich náhled. Taky tady můžete nastavit možnosti pro Excel a dělat spoustu dalších věcí.

Karta Informace v zobrazení Backstage

Přečtěte si další informace nebo se podívejte na video o zobrazení Backstage v Excelu 2010.

Nástroje pro správu sešitu

Excel 2010 nabízí nástroje, které vám usnadní správu, ochranu a sdílení obsahu.

  • Obnovení předchozích verzí:    Teď můžete obnovit verze souborů, které jste zavřeli, aniž byste je uložili. To je užitečné, když zapomenete soubor ručně uložit, když uložíte změny, které jste uložit nechtěli, nebo když se jenom chcete vrátit k předchozí verzi sešitu. Přečtěte si další informace o obnovování souborů.

  • Chráněné zobrazení:    Součástí aplikace Excel 2010 je chráněné zobrazení, které umožňuje kvalifikovaně se rozhodnout ještě předtím, než dojde k ohrožení zabezpečení vašeho počítače. Ve výchozím nastavení se v chráněném zobrazení otevírají dokumenty pocházející z internetového zdroje. Pokud k tomu dojde, zobrazí se na panelu zpráv upozornění spolu s možností povolení úprav. Můžete určit, z jakých zdrojů se má chráněné zobrazení aktivovat. Můžete taky nastavit, jaké typy souborů se budou otevírat v chráněném zobrazení – bez ohledu na to, odkud pocházejí. Přečtěte si další informace o chráněném zobrazení.

  • Důvěryhodné dokumenty:    Funkce Důvěryhodné dokumenty je navržená tak, aby usnadnila otevírání sešitů a dalších dokumentů s aktivním obsahem, jako jsou datová připojení nebo makra. Když teď potvrdíte, že aktivní obsah v sešitě je možné bezpečně povolit, nemusíte tuto akci znovu opakovat. Excel 2010 si důvěryhodné sešity pamatuje, takže se vyhnete opakovaným dotazům při každém otevření sešitu. Přečtěte si další informace o důvěryhodných dokumentech.

Začátek stránky

Nové způsoby přístupu k sešitům

Svoje soubory teď můžete zpřístupnit a pracovat s nimi bez ohledu na to, jestli jste v práci, doma nebo na cestách.

Microsoft Excel Online

Excel Online rozšiřuje možnosti Excelu na webový prohlížeč, ve kterém můžete pracovat se sešity přímo na webu, kde je sešit uložený. Excel Online je součástí Microsoft Office Online a je dostupný v rámci služby OneDrive a v organizacích, které mají nakonfigurovaný Office Online na SharePointu 2010.

Excel Online umožňuje:

  • Zobrazení sešitu v prohlížeči:    Pokud kliknutím otevřete sešit v aplikaci Excel Online, otevře se v režimu zobrazení. V sešitu pak můžete řadit a filtrovat data, rozbalením kontingenčních tabulek znázornit relace a trendy v datech, přepočítat hodnoty a zobrazit různé listy.

  • Úpravy sešitu v prohlížeči:    Když máte Excel Online, všechno, co potřebujete pro přístup k sešitu, je prohlížeč. Vaši spolupracovníci s vámi můžou spolupracovat bez ohledu na to, jakou verzi Excelu mají. Když kliknete na excelový sešit uložený na sharepointovém webu nebo v úložišti OneDrive, sešit se otevře přímo v prohlížeči. Sešity vypadají v prohlížeči stejně jako v Excelu. Listy můžete upravovat v prohlížeči a přitom používat známý vzhled a chování Excelu. Když pracujete v prohlížeči, můžete v tabulce měnit data, zadávat nebo upravovat vzorce a používat základní formátování. Můžete taky současně spolupracovat s ostatními na stejném sešitu.

Přečtěte si další informace o Excelu Online.

Excel Mobile 2010 pro Windows Phone 7

Pokud máte Windows Phone 7, můžete se svými soubory pracovat pomocí Microsoft Office Mobile 2010, ať jste v práci, doma nebo na cestách. Software Excel Mobile 2010 je součástí Office Mobile a je už nainstalovaný v telefonu (najdete ho v centru Office). Nemusíte ho proto stahovat a instalovat, abyste ho mohli začít používat.

Sešit aplikace Excel otevřený v telefonu

Pomocí aplikace Excel Mobile můžete prohlížet a upravovat sešity, které máte uložené v telefonu, které vám došly jako e-mailové přílohy nebo které se uložily na web SharePointu 2010 pomocí aplikace SharePoint Workspace Mobile 2010. Při úpravách sešitu pomocí aplikace SharePoint Workspace Mobile můžete provedené změny uložit zpátky na sharepointový web, až budete online.

Tabulky můžete vytvářet, aktualizovat a okamžitě přepočítávat pomocí mnohých z těch nástrojů, které už znáte a používáte v desktopové verzi Excelu:

  • Použití zobrazení osnovy k přepínání mezi listy nebo grafy v sešitě

  • Řazení, filtrování a správa tabulek

  • Přidávání a úpravy textu a čísel

  • Přidávání komentářů

Přečtěte si o Office Mobile 2010 pro Windows Phone 7 něco víc.

Pokud máte Windows Phone 7, získejte podrobnou nápovědu k používání telefonu.

Začátek stránky

Rychlé a efektivní porovnání seznamů dat

Nové funkce aplikace Excel 2010, jako jsou minigrafy, průřezy a vylepšení kontingenčních tabulek a dalších existujících funkcí, pomáhají zjistit tendence nebo trendy dat.

Minigrafy

Minigrafy jsou malé grafy uvnitř buňky, pomocí kterých můžete vizuálně sumarizovat trendy přímo vedle dat. Protože minigrafy zobrazují trendy na malém prostoru, jsou užitečné hlavně pro řídicí panely nebo jiná místa, kde potřebujete vidět stav firmy ve srozumitelném vizuálním formátu. Minigrafy ve sloupci Trend na následujícím obrázku umožňují jediným pohledem zjistit výkon jednotlivých oddělení v květnu.

Minigrafy použité ke znázornění trendů dat prodeje

Přečtěte si další informace nebo se podívejte na video o minigrafech.

Vylepšení kontingenčních tabulek

Používání kontingenčních tabulek je teď rychlejší a snadnější. K hlavním vylepšením patří:

  • Zvýšení výkonu:    Multithreading využívaný aplikací Excel 2010 pomáhá zrychlit načítání, řazení a filtrování dat v kontingenčních tabulkách.

  • Popisky kontingenční tabulky:    Pro popisky v kontingenční tabulce je teď možné použít funkci vyplnění dolů. Popisky je možné v kontingenčních tabulkách taky opakovat, a zobrazit tak titulky vnořených polí ve všech řádcích a sloupcích. Podívejte se na video o opakování popisků položek.

  • Vylepšené filtrování:    Průřezy umožňují jedním kliknutím rychle filtrovat data v kontingenční tabulce a rychle zjistit, jaké filtry jsou použité, aniž by bylo nutné otevírat další nabídky. Rozhraní filtru navíc zahrnuje praktické vyhledávací pole, které vám může usnadnit vyhledání požadovaných údajů mezi potenciálně tisíci (nebo miliony) položek v kontingenčních tabulkách.

  • Podpora zpětného zápisu:    V aplikaci Excel 2010 je možné změnit hodnoty v oblasti hodnot kontingenční tabulky OLAP a nechat je zpětně zapsat do datové krychle služby Analysis Services na serveru OLAP. Funkci zpětného zápisu je možné použít v režimu citlivostní analýzy a potom vrátit změny, které už nepotřebujete, nebo můžete tyto změny uložit. Funkci zpětného zápisu je možné použít u každého zprostředkovatele OLAP, který podporuje příkaz UPDATE CUBE.

  • Funkce Zobrazit hodnoty jako:    Funkce Zobrazit hodnoty jako poskytuje nové automatické výpočty, jako je % součtu nadřazeného řádku, % součtu nadřazeného sloupce, % součtu nadřazené položky, % mezisoučtu, Seřadit od nejnižších po nejvyšší a Seřadit od nejvyšších po nejnižší. Podívejte se na video o změnách ve funkci Zobrazit hodnoty jako.

  • Vylepšení kontingenčních grafů:    Se sestavami kontingenčních grafů se teď snadněji pracuje. Konkrétně je možné data jednodušeji filtrovat přímo v kontingenčním grafu a měnit rozložení grafu přidáním nebo odebráním polí. Podobně je možné jediným kliknutím myší v sestavě kontingenčního grafu skrýt všechna tlačítka polí. Podívejte se na video o použití interaktivních ovládacích prvků v sestavě kontingenčního grafu.

Přečtěte si další informace o změnách v kontingenčních tabulkách.

Průřezy

Průřezy představují vizuální ovládací prvky, které umožňují rychlé filtrování dat v kontingenční tabulce interaktivním, intuitivním způsobem. Po vložení průřezu můžete rychlým segmentováním a filtrováním dat pomocí tlačítek zobrazit jenom požadované údaje. Při použití více filtrů v kontingenční tabulce už navíc nemusíte otevírat seznam, pokud chcete zjistit, jaké filtry se na data použily. Tyto údaje jsou teď vidět v průřezu. Průřezy můžete přizpůsobit podle formátování sešitu a snadno je opakovaně používat v jiných kontingenčních tabulkách, kontingenčních grafech a funkcích pro práci s datovými krychlemi.

Rychlý filtr v horní části kontingenční tabulky

Přečtěte si další informace nebo se podívejte na video o průřezech.

Vylepšení podmíněného formátování

Podmíněné formátování usnadňuje zvýraznění zajímavých buněk nebo oblastí buněk, zdůraznění neobvyklých hodnot a vizualizaci dat pomocí datových pruhů, barevných škál a sad ikon. Excel 2010 umožňuje ještě větší pružnost formátování:

  • Nové sady ikon:    Sady ikon se poprvé objevily v aplikaci Office Excel 2007 a umožňují zobrazení ikon pro různé kategorie dat na základě stanovené prahové hodnoty. Pomocí zelené šipky nahoru je možné například znázornit vyšší hodnoty, pomocí žluté šipky do strany střední hodnoty a pomocí červené šipky dolů nižší hodnoty. Excel 2010 nabízí přístup k většímu počtu sad ikon, které zahrnují i trojúhelníčky, hvězdičky a čtverečky. Navíc je možné směšovat a sdružovat ikony z různých sad a snadněji ikony v zobrazení skrýt – můžete se například rozhodnout zobrazit ikony jenom pro hodnoty vysokého zisku a nepoužívat je pro střední a nízké hodnoty.

    Příklad zobrazení ikon pouze u vyšších hodnot

  • Více možností pro datové pruhy:   Excel 2010 přichází s novými možnostmi formátování datových pruhů. Datové pruhy je možné opatřit souvislými výplněmi nebo ohraničením, případně nastavit směr pruhu zprava doleva namísto zleva doprava. Datové pruhy záporných hodnot jsou navíc zobrazené na opačné straně osy než kladné hodnoty (viz následující příklad).

    Příklad datových pruhů se zápornými hodnotami

  • Další vylepšení:    Při zadávání kritérií podmíněných pravidel nebo pravidel ověření dat je teď možné odkazovat na hodnoty v jiných listech sešitu.

Přečtěte si další informace o podmíněném formátování.

Začátek stránky

Výkonné analýzy v Excelu

Ať jste v práci nebo doma, potřebujete mít možnost zpracovávat a analyzovat data takovým způsobem, který vám pomůže líp jim porozumět a líp se rozhodnout – a čím rychleji úkol dokončíte, tím lépe. Excel 2010 nabízí nové a vylepšené nástroje pro analýzu, které přesně takovou činnost umožňují.

Doplněk PowerPivot pro Excel

Pokud potřebujete analyzovat velké objemy dat, můžete si stáhnout doplněk Microsoft SQL Server PowerPivot pro Excel, čímž na pás karet Excelu přidáte kartu PowerPivot.

Okno doplňku PowerPivot pro Excel otevřené v aplikaci Excel 2010

Pomocí doplňku Power Pivot pro Excel můžete importovat miliony řádků dat z víc zdrojů dat do jediného excelového sešitu, nastavovat vztahy mezi nesourodými daty, vytvářet počítané sloupce a míry využívající vzorce, sestavovat kontingenční tabulky a grafy a potom dál analyzovat data, abyste dokázali dělat včasná obchodní rozhodnutí – to všechno bez toho, aby vám pomáhalo oddělení IT.

Přečtěte si další informace o doplňku Power Pivot pro Excel.

Vylepšení doplňku Řešitel

Excel 2010 obsahuje novou verzi doplňku Řešitel, který při citlivostní analýze umožňuje najít optimální řešení. Doplněk Řešitel má vylepšené uživatelské rozhraní, jehož součástí je nový modul Evolutionary založený na genetických algoritmech, který zpracovává modely pomocí libovolné funkce aplikace Excel. Doplněk dále nabízí nové možnosti globální optimalizace, lepší lineární programování a metody nelineární optimalizace, jakož i nové sestavy linearity a vhodnosti. Teď je k dispozici taky v 64bitové verzi.

Podrobnější nápovědu pro Řešitele od společnosti Frontline Systems najdete na stránce Nápověda k Řešiteli na webu www.solver.com.

Vylepšení přesnosti funkcí

Na základě odezvy od akademické, inženýrské a vědecké obce teď Excel 2010 obsahuje sadu přesnějších statistických a jiných funkcí. Některé existující funkce se rovněž přejmenovaly, aby jejich názvy výstižněji popisovaly to, co dělají.

  • Vylepšení přesnosti:    Celá řada funkcí se optimalizovala pro dosažení vyšší přesnosti. Aplikace Excel 2010 například vrací přesnější výsledky pro rozdělení beta a chí-kvadrát.

  • Konzistentnější funkce:    Některé statistické funkce se přejmenovaly, aby líp odpovídaly definicím funkcí používaných vědeckou obcí a názvům jiných funkcí Excelu. Nové názvy funkcí navíc přesněji popisují jejich účel. Sešity vytvořené v dřívějších verzích Excelu budou i přes tyto změny názvů fungovat, protože původní funkce stále existují v kategorii Kompatibilita.

    Funkce v aplikaci Excel 2010

Přečtěte si další informace nebo se podívejte na video o změnách provedených u funkcí.

Vylepšené schopnosti filtrování

Kromě průřezů, které jsou popsané výše v tomto článku, přináší Excel 2010 nové funkce, které usnadňují řazení a filtrování dat.

  • Nový vyhledávací filtr:    Při filtrování dat v tabulkách Excelu nebo v kontingenčních tabulkách a grafech můžete použít nové vyhledávací pole, které usnadňuje vyhledání požadovaných údajů v rozsáhlých seznamech. Pokud chcete například rychle vyhledat určitý výrobek v katalogu, ve kterém je přes 100 000 položek, začněte psát hledaný výraz, a relevantní položky se hned zobrazí v seznamu. Výsledky je možné dál zúžit tak, že zrušíte výběr položek, které nechcete zobrazit.

    Vyhledávací pole v seznamu filtrů

  • Filtrování a řazení bez ohledu na umístění:    Při procházení dlouhé tabulky jsou běžná záhlaví listu v horní části sloupců nahrazená záhlavími tabulky Excelu. Tlačítka automatického filtru teď zůstávají viditelná společně se záhlavími sloupců v tabulce, takže data můžete rychle řadit a filtrovat, aniž se musíte vracet zpátky na začátek tabulky.

    Automatické filtry zobrazené v záhlaví sloupců tabulky aplikace Excel

    Přečtěte si další informace nebo se podívejte na video o vytvoření excelové tabulky.

64bitová verze Excelu

Excel 2010 je dostupná taky v 64bitové verzi, což znamená, že pokročilí uživatelé a analytici můžou vytvářet větší a složitější sešity. 64bitová verze umožňuje adresovat fyzickou paměť (RAM) nad limit 2 GB, který platí pro 32bitovou verzi Excelu.

Zvýšení výkonu

Vylepšení výkonu v aplikaci Excel 2010 vám umožní pracovat s daty efektivněji. Mezi konkrétní vylepšení patří:

  • Obecná vylepšení:    Na základě odezvy od zákazníků došlo v aplikaci Excel 2010 pro podnikatele ke zvýšení výkonu v celé řadě oblastí. Excel 2010 například rychleji reaguje při přesunu grafů nebo změně jejich velikosti, při práci v zobrazení rozložení stránky nebo při manipulaci s obrazci na listu.

  • Podpora rozsáhlých sad dat:   Excel 2010 dokáže efektivněji pracovat se sešity, které obsahují velké množství dat. Méně času zaberou konkrétně činnosti, které se obvykle využívají u velkých sad dat, jako je filtrování a řazení dat, kopírování a vkládání z jednoho listu do druhého nebo použití funkce Výplň ke kopírování vzorců.

  • Vícejádrová vylepšení:    Vylepšený multithreading v aplikaci Excel 2010 pomáhá zrychlit proces načítání, řazení a filtrování dat v kontingenčních i normálních tabulkách Excelu. Otevírání a ukládání rozsáhlých souborů je obecně rychlejší než dříve.

  • Rychlejší výpočty:    Pokud mají sešity zásadní význam pro klíčové obchodní procesy vaší organizace, potom je důležité, aby se rychlost výpočtů nestala úzkým místem. Pro dosažení vyššího výkonu při výpočtech obsahuje Excel 2010 podporu asynchronních uživatelsky definovaných funkcí, které můžou běžet současně bez použití několika výpočetních vláken Excelu. To oceníte jak při vlastních způsobech importu dat do listů, tak při použití výkonných výpočetních clusterů HPC (High-Performance Computing).

Začátek stránky

Vytváření vizuálně působivějších sešitů

Bez ohledu na množství zpracovávaných dat je důležité, abyste měli k dispozici nástroje, které vám umožní zkoumat a sdělovat myšlenky pomocí přesvědčivých vizuálních prvků, jako jsou grafy, diagramy, obrázky nebo snímky.

Vylepšení grafů

Práce s grafy je teď v aplikaci Excel 2010 snadnější. Mezi konkrétní vylepšení patří:

  • Nové limity grafů:    V Excelu 2010 už neplatí omezení pro počet datových bodů, které je možné vytvořit v grafu. Počet datových bodů je omezený jenom dostupnou pamětí. Uživatelům, zejména z vědecké oblasti, to umožňuje efektivnější vizualizaci a analýzu velkých množin dat.

  • Rychlý přístup k možnostem formátování:   Excel 2010 poskytuje okamžitý přístup k možnostem formátování dvojím kliknutím na prvek grafu.

  • Záznam maker pro prvky grafu:    Pokud se v aplikaci Office Excel 2007 spustil záznam makra během formátování grafu nebo jiného objektu, nevznikl žádný kód makra. V aplikaci Excel 2010 ale můžete pomocí záznamu makra zaznamenávat změny formátování grafů a jiných objektů.

Přečtěte si další informace o vytváření grafů.

Podpora rovnic

Pomocí nových nástrojů pro úpravu rovnic v Excelu 2010 můžete do listů vkládat běžné matematické rovnice, případně je možné pomocí nich sestavit vlastní rovnice pomocí knihovny matematických symbolů. Nové rovnice můžete vkládat taky do textových polí a jiných obrazců. Začnete tak, že na kartě Vložení kliknete ve skupině Symboly na šipku vedle tlačítka Rovnice.

Předformátované rovnice v seznamu rovnic

Více motivů

V Excelu 2010 je víc motivů a stylů než kdykoliv předtím. Tyto prvky umožňují jednotné používání profesionálních návrhů v sešitech a jiných dokumentech Microsoft Office. Jakmile vyberete motiv, Excel 2010 udělá návrhářskou práci za vás. Text, grafy, obrázky, tabulky i nakreslené objekty se změní podle vybraného motivu a všechny prvky v sešitu se budou vizuálně vzájemně doplňovat.

Galerie motivů v aplikaci Excel 2010

Přečtěte si další informace o použití motivů v excelových sešitech.

Vložení s dynamickým náhledem

Funkce vložení s dynamickým náhledem šetří čas při opakovaném použití obsahu z aplikace Excel 2010 nebo jiných programů. Je možné ji využít k zobrazení náhledu různých možností vložení, jako je Ponechat šířky sloupců zdroje, Bez ohraničení nebo Zachovat formátování zdroje. Dynamický náhled umožňuje zjistit, jak bude vkládaný obsah vypadat ještě předtím, než ho skutečně vložíte do listu. Při posunování ukazatele myši přes jednotlivé možnosti vložení se zobrazí náhled výsledku a taky nabídka s položkami, které se kontextově mění tak, aby byly co nejvhodnější pro opakovaně vkládaný obsah. Další informace poskytují popisy, které napomáhají správnému rozhodnutí.

Možnosti v nabídce náhledu před vložením

Podívejte se na video o zobrazení náhledu obsahu před jeho vložením.

Vylepšené nástroje pro úpravu obrázků

Sdělování myšlenek pomocí aplikace Excel 2010 nespočívá jenom v předkládání čísel nebo grafů. Pokud k vizuálnímu sdělení potřebujete použít fotografie, kresby nebo obrázky SmartArt, můžete využít následující funkce:

  • Kopie obrazovek:    Můžete rychle vytvořit kopii (snímek) obrazovky, přidat ji do sešitu a pak ji pomocí nástrojů na kartě Nástroje obrázku upravit a vylepšit. Přečtěte si další informace o snímcích obrazovek.

    Tlačítko Kopie obrazovky

  • Nová rozložení obrázků SmartArt:    Díky novým rozložením obrázků můžete svoje sdělení vyjádřit pomocí fotografií. Rozložení Obrázky s titulky například umožňuje zobrazit snímky, pod kterými jsou umístěné ozdobné titulky. Přečtěte si další informace o obrázcích SmartArt.

  • Úpravy obrázků:    U obrázku můžete jemně doladit barvu, upravit jas, kontrast nebo ostrost, aniž byste potřebovali další software pro úpravu fotografií. Přečtěte si další informace o úpravách obrázků.

  • Nové a vylepšené grafické efekty:    U obrázku můžete použít různé grafické efekty, takže bude vypadat jako skica, kresba nebo malba. Mezi nové grafické efekty patří skica tužkou, perokresba, vodové barvy nanášené houbou, bubliny, sklo, jemné pastely, plastický efekt, fotokopie, tahy štětcem a spousta dalších. Přečtěte si další informace o přidávání efektů.

  • Lepší komprese a oříznutí:    Máte teď lepší kontrolu nad kompromisem mezi kvalitou obrázku a jeho kompresí, takže můžete zvolit správné médium (tisk, obrazovka, e-mail), pro které je sešit určený. Přečtěte si další informace o oříznutí a kompresi obrázků.

Začátek stránky

Nové způsoby spolupráce na sešitech

Excel 2010 nabízí dokonalejší způsoby publikování, úpravy a sdílení sešitů s ostatními uživateli ve vaší organizaci.

Spoluvytváření sešitů

Díky aplikaci Excel Online, která patří mezi aplikace Office Online, teď můžou různí uživatelé současně upravovat sešit z různých míst. Pokud jste malá firma nebo pracujete sami z domova nebo školy, stačí vám k současné spolupráci na sešitech s ostatními uživateli účet služby Windows Live. Uživatelé v podnicích, které provozují službu Microsoft SharePoint 2010, můžou tyto funkce používat taky v rámci brány firewall.

Podívejte se na video o spolupráci na sešitu v prohlížeči.

Vylepšené služby Excel Services

Pokud vaše organizace dřív používala služby Excel Services ke sdílení excelových sešitů na webech serveru SharePoint Server, všimnete si následujících vylepšení:

  • Rozšířené možnosti uživatelů:    K viditelným změnám patří možnost aktualizace prvků stránky namísto aktualizace celé stránky po každé změně a přidání posuvníků, které umožňují snadné procházení listu.

  • Lepší integrace s funkcemi SharePointu 2010:    Služby Excel Services v této verzi poskytují lepší integraci s důležitými funkcemi SharePointu 2010, jako je zabezpečení, správa obsahu, kontrola verzí, správa datových připojení a správa služeb. Služby Excel Services jsou navíc líp integrované s integrovanými funkcemi Business Intelligence SharePointu.

  • Lepší podpora funkcí sešitu:    Pokud sešit v minulosti obsahoval nepodporované funkce, nebylo ho vůbec možné v prohlížeči otevřít. Pokud teď sešit obsahuje nepodporované funkce Excelu, ve většině případů bude možné ho v prohlížeči otevřít. Služby Excel Services navíc podporují víc funkcí Excelu včetně nových funkcí aplikace Excel 2010, jako jsou minigrafy a průřezy.

  • Lepší podpora pro vývoj aplikací:    Vývojáři i další uživatelé, kteří se zabývají vývojem, můžou využívat nové nástroje, například aplikační programové rozhraní REST, které umožňuje vytvářet podnikové aplikace.

Přečtěte si další informace o službách Excel Services.

Kontrola usnadnění

Nový nástroj Kontrola usnadnění v aplikaci Excel 2010 umožňuje vyhledat a opravit problémy, které můžou uživatelům s postižením ztížit čtení sešitu nebo interakci s ním. Tento nástroj je možné spustit kliknutím na kartu Soubor, kliknutím na tlačítko Zkontrolovat problémy a následným kliknutím na možnost Zkontrolovat usnadnění. V podokně úloh se zobrazí chyby a upozornění. Pak můžete zkontrolovat problémy a zjistit, které z nich musíte opravit.

Kromě použití nástroje Kontrola usnadnění můžete navíc přidat alternativní text do více objektů v listu, včetně běžných a kontingenčních tabulek Excelu. Tyto informace jsou užitečné pro uživatele s poruchou zraku, kteří nemusejí objekt vidět jasně nebo zřetelně.

Přečtěte si další informace nebo se podívejte na video o funkci Kontrola usnadnění.

Vylepšení jazykových nástrojů

V dialogovém okně Možnosti aplikace Excel můžou vícejazyční uživatelé rychle nastavit předvolby jazyka pro úpravy, zobrazení, popisy a nápovědu. Pokud v Excelu změníte nastavení jazyka, dojde k automatické změně ve všech aplikacích Microsoft Office 2010, které připadají v úvahu. Zobrazí se vám oznámení, pokud nemáte nainstalovaný potřebný software nebo rozložení klávesnice, a zobrazí se odkazy, které povedou ke snadnému vyřešení těchto problémů.

Přečtěte si další informace o nastavení jazykových předvoleb.

Začátek stránky

Nové způsoby rozšíření sešitů

Pokud vyvinete v sešitu vlastní řešení, můžete využít nové způsoby, jak je rozšířit.

Vylepšení programovacích funkcí

Mezi vylepšení pro vývojáře patří:

  • Změny sady XLL SDK:    Sada XLL Software Development Kit (SDK) nyní podporuje volání nových funkcí listu, vývoj uživatelsky definovaných asynchronních funkcí, vývoj uživatelsky definovaných funkcí XLL s podporou clusterů, které je možné přesměrovat do výpočetního clusteru, a konečně sestavení 64bitových doplňků XLL.

  • Vylepšení jazyka VBA:   Excel 2010 nabízí řadu funkcí, které umožňují migrovat zbývající makra Excelu 4.0 na jazyk VBA. Vylepšení zahrnují lepší výkon metod souvisejících s tiskem a vlastnosti grafu, ke kterým v minulosti nebyl přístup pomocí jazyka VBA.

  • Lepší rozšiřitelnost uživatelského rozhraní:    Pokud vyvíjíte v sešitu vlastní řešení, máte teď víc možností programového přizpůsobení nejenom pásu karet, ale i nového zobrazení Backstage. Můžete například programově aktivovat karty na pásu karet a vytvářet vlastní karty, které se chovají stejně jako předdefinované kontextové karty, kdy se zobrazí jenom při výskytu určitých událostí. Navíc můžete na pásu karet vytvářet vlastní skupiny, které se budou zvětšovat a zmenšovat podle toho, jak se změní velikost pásu karet. Pomocí ovládacích prvků pro formátování můžete upravit místní nabídky a můžete taky přidat vlastní uživatelské rozhraní a další prvky do zobrazení Backstage.

  • Změny sady Open XML SDK:    Kromě podpory objektů na úrovni částí, kterou zavádí sada Open XML SDK 1.0, teď sada Open XML SDK 2.0 podporuje taky objekty na úrovni schématu. Je tak možné snadněji programově manipulovat se sešity a jinými dokumenty mimo desktopové aplikace Office 2010, například v rámci serverového řešení.

Přečtěte si další informace o funkcích pro vývojáře.

Podpora výkonných výpočetních clusterů

Kvůli větší výpočetní kapacitě spoléhá řada organizací na výkonné výpočetní clustery HPC (High-Performance Computing). Finanční firma například může používat výpočetní clustery k rychlejšímu výpočtu časově a výpočetně náročných finančních modelů. Excel 2010 nabízí možnost integrace s clustery HPC. Pokud je podporovaný cluster k dispozici, uživatelé můžou dát Excelu pokyn, aby tento cluster použil, a to výběrem konektoru a konfigurací použitého názvu v dialogovém okně Možnosti aplikace Excel v části Upřesnit.

Přečtěte si další informace o Excelu 2010 a výkonných výpočetních operacích.

Začátek stránky

Použít na: Excel 2010



Byly tyto informace užitečné?

Ano Ne

Jak ji můžeme vylepšit?

255 zbývajících znaků

Pokud si chcete chránit soukromí, nedávejte do zpětné vazby kontaktní informace. Ohodnoťte aplikaci zásady ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

Zdroje technické podpory

Změnit jazyk