Co je nového v Excelu 2016 pro Windows

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Excel 2016 pro Windows má všechny funkce, na které jste zvyklí, a taky několik nových funkcí a přidaných vylepšení. Pokud jste si Excel 2016 koupili bez předplatného Office 365, budete mít všechny funkce, které jsou uvedené pod položkou „Září 2015“ v dolní části stránky. Pokud máte předplatné Office 365, získáte funkce, které jsou uvedené pod položkou „Září 2015“ a také všechny další aktualizace. Mějte na paměti, že tyto aktualizace získají nejdříve účastníci programu Office Insider a později předplatitelé Office 365 z řad běžných spotřebitelů i komerční sféry. Pokud máte předplatné Office 365, zkontrolujte si, jestli máte nejnovější verzi Office.

Poznámka : Pokud jste odborník na IT a spravujete proces aktualizace Office 365, na stránce verzí pro kanály aktualizací zjistíte, jaké aktualizace jsou poskytované v jednotlivých kanálech.

Aktualizace pro leden*

* V současnosti jsou dostupné jenom pro účastníky programu Insider.

Aktualizace funkce Načíst a transformovat a doplňku Power Query

  • Vylepšený konektor SQL Serveru – podpora převzetí služeb při selhání SQL Serveru: Vylepšili jsme konektor SQL Serveru a přidali novou možnost povolit převzetí služeb při selhání SQL Serveru. Další informace o této možnosti najdete v tomto článku na webu MSDN. Tuto novou možnost najdete v dialogu konektoru SQL Serveru v části Upřesnit možnosti.

  • Nová transformace – vodorovné rozbalení seznamu: Zjednodušili jsme extrahování datových hodnot ze sloupců obsahujících vnořené seznamy. Dříve jste mohli rozbalit vnořené seznamy ve sloupci tabulky a výsledkem byl jeden nový řádek tabulky pro každou položku ve vnořeném seznamu. Tuto transformaci najdete v záhlaví sloupců seznamu nebo jako volbu Rozbalit na pásu karet.

    Když ji vyberete, objeví se výzva k zadání oddělovače, který se má použít v novém sloupci. Budete moct zvolit ze seznamu předdefinovaných oddělovačů nebo zadat vlastní oddělovač, který může také zahrnovat speciální znaky. Transformace převede sloupec s vnořenými seznamy na sloupec textu.

Laso na dosah ruky

Excel teď nabízí Laso Tlačítko Nepravidelný výběr na kartě Kreslení v PowerPointu , což je nástroj pro volný výběr rukopisu. Tažením tohoto nástroje vyberete konkrétní oblast ruční kresby a pak můžete s tímto objektem podle potřeby manipulovat. Další informace najdete v článku Kreslení a psaní rukopisných poznámek v Office 2016.

Použití pera digitální vybrat a změnit objektů

V aplikaci Excel digitální perem, můžete vybrat oblast bez i klepnutím nástroj pro výběr na pásu karet. Pouze stiskněte tlačítko pero na pero a nakreslete perem na výběr z nabídky. Přesunutí, změna velikosti nebo otočit Rukopisný objekt můžete pomocí pera. Další informace najdete v tématu Kreslení a opatřit poznámkami s rukopisu v Office 2016.

Zobrazení a obnovení změn ve sdílených sešitech

Rychle si můžete zobrazit informace o tom, kdo udělal změny ve sdílených sešitech, a snadno dokážete obnovit dřívější verze. Další informace najdete v článku Zobrazení historických verzí souborů Office.

Aktualizace funkce Načíst a transformovat a doplňku Power Query

  • Nový konektor OLEDB: V této aktualizaci jsme umožnili připojení k ovladačům OLEDB přes nový konektor OLEDB. OLEDB je přídavkem k široké řadě podporovaných předdefinovaných zdrojů. Značně zvyšuje počet zdrojů, ze kterých teď uživatelé můžou importovat data pomocí excelových funkcí Načíst a transformovat.

  • Vylepšené prostředí „kombinování binárních souborů“ při importu z libovolné složky: Jedním z nejoblíbenějších scénářů v Excelu je využití jednoho ze „složkových“ konektorů (například konektoru složky, konektoru sharepointové složky a podobně) ke zkombinování více souborů se stejným schématem do jediné logické tabulky.

  • Podpora procentního datového typu: V této aktualizaci jsme přidali podporu procentních datových typů, které se dají snadno používat v aritmetických operacích u scénářů Načíst a transformovat. Vstupní hodnota (například „5%“) bude automaticky rozpoznána jako procentní hodnota a převedena na desetinné číslo s přesností na dvě desetinná místa (0,05). Toto číslo se pak dá použít v aritmetických operacích v tabulce, v Editoru dotazů nebo v datovém modelu.

  • Vylepšené prostředí „vytváření funkcí“: Také usnadňujeme aktualizaci definic funkcí – bez údržby podkladového strojového kódu.

  • Vylepšený výkon konektoru OData: V této aktualizaci jsme přidali podporu pro provádění operací rozbalení záznamu v podkladové službě OData. Díky tomu se zlepší výkon při rozbalování záznamů z kanálu OData.

  • Tlačítka Maximalizovat/Obnovit v dialogových oknech Navigátor a Závislosti dotazů: Dialogová okna Navigátor a Závislosti dotazů (aktivovaná z Editoru dotazů) podporují změny velikosti přetažením pravého dolního rohu dialogu. V této verzi také umožňujeme maximalizovat/obnovit tato dialogová okna pomocí ikon Maximalizovat a Obnovit v pravém horním rohu dialogů.

Podrobné informace o výše uvedené, najdete v článku blog Power BI.

Nové mapové grafy

Mapový graf Excelu s údajem hodnoty

K porovnání hodnot a zobrazení kategorií v různých geografických oblastech můžete vytvořit mapový graf. Používejte ho, když máte v datech geografické oblasti, jako země/oblasti, státy, okresy nebo PSČ. Tady se můžete podívat na krátké video o mapových grafech.

Nové ikony dostupné na kartě Vložení

Potřebujete vložit ikonu, která vyjadřuje určitou myšlenku nebo koncept, ale nechcete si ji kreslit sami? Vyzkoušejte tlačítko Ikona na kartě Vložení. Zvolte kategorii jako třeba lidé, technologie nebo sport. Potom klikněte na ikonu, která vyjadřuje myšlenku nebo koncept, které máte na mysli.

Rychlé ukládání do naposledy použitých složek

Tuto funkci naši zákazníci velmi požadovali: Přejděte na Soubor > Uložit jako > Poslední a uvidíte seznam naposledy používaných složek, do kterých můžete soubor uložit.

Vylepšení přístupnosti

Vylepšili jsme podporu programu Předčítání a dalších technologií usnadnění, které umožňují číst buňky, vytvářet tabulky, řadit data a další věci. Další informace najdete v článku Novinky ve funkcích přístupnosti pro Excel.

SVG (Scalable Vector Graphics)

Teď můžete vkládat soubory SVG (Scalable Vector Graphics) a pracovat s nimi. Další informace najdete v článku Vkládání obrázků SVG.

Nové tlačítko Přehrání rukopisu

Používáte ve svých tabulkách rukopis? Rukopis si teď můžete přehrát nebo převinout zpět, abyste lépe pochopili jeho tok. Přehrát si ho můžou i vaši kolegové, aby tak získali podrobné pokyny. Přehrání rukopisu najdete na kartě Kreslení. Vyzkoušejte si to!

Sdílí se se mnou

Zní to povědomě? Někdo vám nasdílel soubor na OneDrivu, ale nemůžete najít e-mail s potřebným odkazem. Žádný problém. Díky této aktualizaci stačí kliknout na Soubor > Otevřít > Sdílí se se mnou. Zobrazí se všechny soubory, které s vámi někdo sdílí.

Podpora formátu CSV (UTF-8)

Požádali jste o ni na fóru Excel User Voice: Teď můžete otevírat a ukládat soubory CSV používající kódování znaků UTF-8. Přejděte na Soubor > Uložit jako > Procházet. Potom klikněte na nabídku Uložit jako typ, kde najdete novou možnost pro CSV UTF-8 (s oddělovači). CSV UTF-8 je běžně používaný formát souboru, který podporuje více znaků než stávají možnost Excelu CSV (ANSI). Co to znamená? Poskytuje lepší podporu pro práci s daty, která nejsou v angličtině, a pro přesun dat do jiných aplikací.

Aktualizace funkce Načíst a transformovat a doplňku Power Query

  • Webový konektor: Přidali jsme podporu pro zadání záhlaví žádostí protokolu HTTP v dialogovém okně webového konektoru. Uživatelé můžou v tomto dialogovém okně v rozšířeném režimu zadat dvojice název záhlaví – hodnota.

  • Konektor OData: V této aktualizaci jsme přidali podporu pro zjišťování vztahů u kanálů OData V4. Při připojování ke kanálům OData V4 můžou uživatelé použít v dialogovém okně Navigátor tlačítko Vybrat související tabulky a pak snadno vybrat všechny tabulky, které potřebují pro svoje sestavy.

  • Konektor Oracle: Značně jsme vylepšili výkon při zobrazování náhledu tabulek v dialogovém okně Navigátor při připojování k databázím Oracle. Zobrazení náhledu by ve většině případů mělo trvat až o 30 procent kratší dobu než dřív.

  • Konektor SAP HANA: V dialogovém okně Navigátor jsme vylepšili ovládací prvky pro zadání parametrů při připojování k SAP HANA.

  • Zobrazení závislostí dotazů z Editoru dotazů: Všechny dotazy a závislosti na jiných dotazech nebo zdrojích dat uvidíte na první pohled.

  • Podpora pásu karet Editoru dotazů pro skalární hodnoty: Přidali jsme podporu pásu karet Editoru dotazů pro běžné operace při zacházení s dotazy skalárního typu. Zahrnuje to nové kontextové karty pásu karet, které obsahují příkazy pro běžné transformace hodnot typu Text, Datum a čas a Číslo.

  • Přidání vlastního sloupce na základě vyvolání funkce: Teď můžete jednoduše využívat novou operaci Vyvolat vlastní funkci z karty Přidat sloupec na pásu karet.

  • Sloupce Rozbalit a agregovat podporují hodnoty typu „Načíst další“: V této aktualizaci jsme do seznamu sloupců Rozbalit a agregovat v Editoru dotazů přidali možnost Načíst další. Uživatelé tak můžou dát Excelu pokyn, aby se podíval na další řádky a snažil se zjistit další vnořené sloupce/pole.

  • Převedení sloupce tabulky na seznam – nová transformace: V této aktualizaci jsme uživatelům značně usnadnili převedení určeného sloupce v tabulce na seznam. V náhledu Editoru dotazů stačí vybrat sloupec a použít nové tlačítko Převést na seznam, které se na pásu karet nachází na kartě Transformace.

  • Vybírání při psaní v rozevíracích nabídkách: V této aktualizaci jsme značně vylepšili navigaci a vybírání v rozevíracích nabídkách přidáním funkce „vybírání při psaní“. Uživatelé díky tomu můžou napsat jeden nebo více znaků a okamžitě se vyhledávají položky rozevírací nabídky s odpovídající předponou. Toto chování je teď k dispozici ve všech rozevíracích nabídkách funkce Načíst a transformovat, ale zvlášť užitečné je u nabídek s velkým počtem položek seznamu (například v dialogovém okně Změnit typ pomocí národního prostředí nebo v seznamech jednohodnotových parametrů pro SAP HANA a podobně).

Další informace k výše uvedeným aktualizacím najdete v blogu o Power BI.

Nové školení k Excelu

Centrum školení Office obsahuje 10 nových kurzů k Excelu, které vznikly v rámci partnerství s programem LinkedIn Learning. Videa si můžete projít vlastním tempem – seznámíte se v nich s Excelem 2016 a dozvíte se například, jak používat vzorce a analyzovat data grafů. A také můžete zjistit, jak získat neomezený přístup k více než 4 000 videokurzů z webu LinkedIn Learning. Projděte si celé naše školení k Excelu.

Nový příkaz pro vaše názory v nabídce Soubor

Máte k Microsoft Office nějaký komentář nebo návrh? Vaše názory nám pomáhají dodávat skvělé produkty. Když v Excelu kliknete na Soubor > Váš názor, můžete navrhnout nové funkce a napsat nám, co se vám líbí nebo co nefunguje.

Pokud máte nějaké komentáře nebo návrhy k Excelu, dejte o nich Microsoftu vědět kliknutím na Soubor > Váš názor.

Aktualizace funkce Načíst a transformovat a doplňku Power Query

  • Přidaná podpora pro parametry dotazu: Do dotazů v Editoru dotazů teď můžete přidat parametry. Stačí kliknout na Domů > Spravovat parametry > Nový parametr.

    Power Query – Možnost Spravovat parametry

    Power Query – Dialog Spravovat parametry

  • Vytvoření nových dotazů na základě operací sloučení nebo připojení: K vytvoření nových dotazů v Editoru dotazů teď můžete použít operace sloučení a připojení. Klikněte na kartu Domů. Klikněte na šipku dolů u Sloučit dotazy a potom klikněte na Sloučit dotazy jako nový. Pokud chcete dotaz připojit jako nový, klikněte na šipku u Připojit dotazy a pak klikněte na Připojit dotazy jako nové.

    Power Query – Možnost sloučení dotazů jako nových

    Power Query – Připojení dotazů jako nových

  • Vylepšený webový konektor s náhledem stránky: Vylepšili jsme prostředí webového konektoru. Teď můžete vidět dynamický náhled webové stránky a vybrat si požadované tabulky, které chcete importovat. Vyberte Data > Nový dotaz > Z jiných zdrojů > Z webu. Po zadání adresy URL a kliknutí na OK se zobrazí Navigátor. Na pravé straně klikněte na tlačítko Webové zobrazení. Teď se můžete na stránce posunovat. Všechny tabulky s kartou a ohraničením jsou připravené k importu. Vyberte požadovanou tabulku a potom ji kliknutím na Načíst nebo Upravit dále zpracujte.

Pole Řekněte mi, co chcete udělat v horní části pásu karet se aktualizovalo a teď nabízí vylepšené hledání, obsah a doporučení, takže na vaše dotazy poskytuje lepší a rychlejší odpovědi. Když teď začnete hledat určitý úkol, funkci nebo otázku, uvidíte celou řadu možností. Pokud jde o rychlou akci, Excel se vám pokusí její provedení umožnit přímo z podokna Řekněte mi. Pokud jde o složitější dotaz, zobrazíme vám nápovědu, která podle našeho názoru nejlépe odpovídá vašim potřebám. Vyzkoušejte si to, ať víte, jak rychle dokážete najít, co potřebujete, abyste mohli dokončovat úkoly.

Klikněte na pole Řekněte mi v Excelu a zadejte, co chcete udělat. Řekněte mi se vám pokusí pomoct s provedením daného úkolu.

Aktualizace funkce Načíst a transformovat a doplňku Power Query

  • Aktualizace dotazu – zachování rozložení:Formáty a počítané sloupce pro data importovaná přes Načíst a transformovat se nyní po aktualizaci dotazů zachovají.

  • Vylepšený konektor SAP HANA – umožňuje vícenásobný výběr hodnot proměnných a parametrů: Díky této aktualizaci teď uživatelé můžou při použití konektoru SAP HANA vybrat pro danou proměnnou nebo parametr více hodnot. K tomu se dá použít dialog Navigátor.

  • Vylepšený konektor OData – možnost importu sloupců otevřeného typu z datových kanálů OData: Konektor OData teď podporuje import sloupců otevřeného typu z datových kanálů OData. Před touto aktualizací se tyto sloupce v Power Query nepodporovaly. Tato možnost se zobrazuje v části Upřesnit možnosti v dialogu konektoru OData.

    Power Query – Vylepšený konektor OData – možnost importu sloupců otevřeného typu z datových kanálů OData
  • Vylepšený konektor databáze Access – nové tlačítko Vybrat související tabulky v dialogu Navigátoru: Konektor databáze Access jsme vylepšili tak, že jsme do dialogu Navigátoru přidali tlačítko Vybrat související tabulky, které uživatelům umožňuje snadno vybrat související tabulky. Databáze se po kliknutí na toto tlačítko chová stejně jako všechny ostatní databáze, které už tuto funkci podporují. Vybere všechny tabulky s přímou relací k jakékoli z už vybraných tabulek.

    Power Query – Vylepšený konektor databáze Access – nové tlačítko Vybrat související tabulky v dialogu Navigátoru
  • Možnost generování názvů kroků v angličtině v Editoru dotazů: Když v Editoru dotazů vytváříte nové kroky založené na transformacích na pásu karet, budou výchozí názvy kroků vycházet z názvů těchto transformací (např. SplitColumns, FilteredRows atd.). Tyto názvy kroků se lokalizují do aktuálního jazyka instalace Excelu.

    V této aktualizaci jsme představili novou možnost, která uživatelům umožňuje toto výchozí chování změnit tak, aby automaticky generované názvy kroků používaly anglické názvy daných transformací. Uživatelé pak můžou přispívat do jedné excelové sestavy s použitím několika lokalizovaných desktopových verzí a zároveň zachovat názvy kroků, aby byly rozpoznatelné pro všechny zúčastněné strany (tj. ve výchozím nastavení jsou všechny anglicky). Nové nastavení konfigurace je pro jiné než anglické instalace k dispozici v části Data > Nový dotaz > Globální > Místní nastavení.

    Power Query – Možnost generování názvů kroků v angličtině v Editoru dotazů
  • Popis kroků dotazu v Editoru dotazů: V Editoru dotazů jsme také představili nové pole Popis pro kroky dotazu, které uživatelům umožňuje vytvářet dokumentaci a poskytovat komentáře ke svým transformacím dotazů. K novému poli Popis můžete přistupovat v nabídce zobrazené po kliknutí pravým tlačítkem myši u jakéhokoli příkazu Krok dotazu > Vlastnosti.

    Power Query – Popis kroků dotazu v Editoru dotazů
  • Extrakce názvu týdne, dne nebo měsíce ze sloupce Datum/Čas v Editoru dotazů: Díky této aktualizaci teď uživatelé můžou extrahovat název týdne, dne nebo měsíce ze zadaného sloupce Datum/Čas. Tato možnost je dostupná na pásu karet Editoru dotazů. Pokud chcete upravit existující sloupec, najdete ji na kartě Transformace, nebo pokud chcete vložit nový sloupec, bude na kartě Přidat sloupec.

    Tyto dvě možnosti můžete najít v části Datum > Den > Název dne a Datum> Měsíc > Název měsíce. Názvy dnů a měsíců jsou lokalizované v závislosti na místním nastavení aktuálního souboru (k dispozici na kartě Data > Nový dotaz > Možnosti dotazu > Aktuální sešit > Místní nastavení vašeho excelového sešitu).

    Power Query – Extrakce názvu týdne, dne nebo měsíce ze sloupce Datum/Čas v Editoru dotazů
  • Sloučení dat a časů do sloupce Datum/Čas v Editoru dotazů: Další nová transformace tohoto měsíce umožňuje uživatelům kombinovat sloupec Datum a sloupec Čas do jednoho sloupce Datum/Čas. Tohoto sloučení můžete dosáhnout tak, že vyberete tyto dva sloupce a kliknete na Kombinovat datum a čas v nabídkách Datum a Čas na kartách Transformace a Přidat sloupec.

    Power Query – Sloučení dat a časů do sloupce Datum/Čas v Editoru dotazů
  • Extrakce začátku/konce hodiny ze sloupce Datum/Čas nebo Čas v Editoru dotazů: Poslední nová transformace dat tohoto měsíce umožňuje uživatelům jednoduše extrahovat počátek nebo konec hodiny na základě sloupce Datum/Čas nebo Čas. Tyto dvě možnosti najdete v nabídce Čas > Hodina na kartách Transformace a Přidat sloupec.

    Power Query – Extrakce začátku/konce hodiny ze sloupce Datum/Čas nebo Čas v Editoru dotazů
  • Aktualizace dotazu – zachování rozložení: Pokud funkci Načíst a transformovat používáte pro práci s externími daty, můžete chtít změnit formát nebo rozložení. Můžete dokonce i přidat počítaný sloupec. Dříve se takové změny při načítání dat do Excelu nezachovávaly. Tato aktualizace to však mění. Důvodem je, že políčko Zachovat řazení, filtrování a rozložení sloupců je teď ve výchozím nastavení zaškrtnuté. (Pokud chcete k tomuto zaškrtávacímu políčku získat přístup, klikněte do tabulky externích dat a pak klikněte na Návrh > Vlastnosti.)

  • Časový limit příkazu dostupný v konektoru Z webu: Pro případ, že by zpracování webových dotazů trvalo příliš dlouho, teď můžete nastavit časový limit. Vyberte Data > Nový dotaz > Z jiných zdrojů > Z webu. Klikněte na Upřesnit. V dolní části dialogu určete, kolik minut by mělo před vypršením dotazu uplynout.

    Dialogové okno Z webu, pole Časový limit příkazu v minutách

  • Podpora souborů s oddělovači a pevnou šířkou v konektoru CSV/Text: Pokud máte textový soubor nebo soubor CSV, který mezi sloupci obsahuje oddělovače, můžete nastavit šířky sloupců na určité pozice znaků.

    Nejdřív spusťte konektor CSV nebo Z textu: Data > Nový dotaz > Ze souboru > Ze souboru CSV (nebo Z textu). Potom vyberte soubor, který mezi hodnotami obsahuje oddělovače. V části Oddělovač vyberte Pevná šířka. Nakonec v části Pevná šířka zadejte pozici znaku pro konec každého sloupce.

    Pevná šířka, příkaz oddělovače, hodnoty 0, 7, 24 zadané pro pozice znaku

Publikování do Power BI

Pokud máte předplatné Power BI, můžete teď do Power BI publikovat soubory, které jsou uložené místně. Abyste mohli začít, uložte nejdřív soubor do počítače. Pak klikněte na Soubor > Publikovat > Publikovat na Power BI. Po nahrání můžete kliknout na tlačítko Přejít na Power BI a zobrazit si soubor ve webovém prohlížeči.

Žádná upozornění při ukládání souboru CSV

Pamatujete na toto upozornění? Tento soubor může obsahovat funkce, které nejsou kompatibilní s formátem CSV. Chtěli jste to, máte to mít! Při ukládání souborů CSV se už toto upozornění nebude zobrazovat.

Aktualizace funkce Načíst a transformovat a doplňku Power Query

  • Nový konektor SAP HANA: V této aktualizaci jsme přidali nový konektor, který vám umožní importovat data z databází SAP HANA. Tento nový konektor můžete najít v části Data > Nový dotaz > Z databáze nebo v okně Editor dotazů. Další informace najdete v tématu Připojení k databázi SAP HANA.

    Dialog importu databáze SAP HANA v Power BI v Excelu
  • Nový konektor sharepointové složky: Nový konektor sharepointové složky dostupný v části Data > Nový dotaz > Soubor umožňuje importovat data z více souborů v sharepointové složce. Podobá se konektoru složky, který umožňuje importovat a kombinovat více souborů ze složky systému souborů.

    Dialog konektoru sharepointové složky v Power BI v Excelu
  • Nová kategorie konektorů služby Online Services: V této aktualizaci jsme přidali novou kategorii, která obsahuje všechny dostupné konektory pro službu Online Services v Excelu. Nová kategorie je k dispozici v části Data > Nový dotaz > Ze služby Online Services nebo v okně Editor dotazů.

    Dialog konektoru služby Online Services v Power BI v Excelu
  • Vylepšený konektor DB2: V této verzi jsme vylepšili konektor IBM DB2, aby poskytoval možnost použití ovladače Microsoftu pro IBM DB2, který je také automaticky zahrnutý v instalaci Excelu / Power Query. V dialogu konektoru IBM DB2 si teď můžete vybrat ovladač, který se má použít, v části Upřesnit možnosti.

    Dialog konektoru databáze IBM DB2 v Power BI v Excelu
  • Vylepšený konektor Text/CSV teď v dialogu náhledu zobrazuje upravitelná nastavení: V této aktualizaci jsme vylepšili konektory textových souborů a souborů CSV. Základní nastavení importu teď můžete konfigurovat v dialogu náhledu. Mezi tato nastavení patří: Původ souboru, Oddělovač a Rozpoznat datový typ (strategie zahrnují: Založit na horních 200 řádcích, Založit na celé datové sadě nebo Nezjišťovat datový typ). Na základě vašeho výběru se náhled v tomto dialogu automaticky aktualizuje. Potom se můžete rozhodnout, jestli chcete data přímo načíst nebo nejprve upravit, aby se mohly použít další transformace dat.

    Dialog vylepšeného konektoru Text/CSV v Power BI v Excelu
  • Vylepšená relační databáze: V této aktualizaci jsme vylepšili konektory relační databáze. Teď máte možnost zahrnout informace schématu jako součást navigační hierarchie. Tato možnost je k dispozici v části s rozšířenými možnostmi ve všech dialozích konektorů databáze, jako je například dialog databáze SQL Serveru níže:

    Vylepšené konektory relační databáze v Power BI v Excelu
  • Vylepšení nastavení zdroje dat, včetně možnosti Změnit zdroj: Umístění zdroje dat teď můžete snadno aktualizovat pro všechny dotazy připojené k tomuto zdroji dat v rámci jednoho excelového sešitu. (Před touto aktualizací bylo nutné aktualizovat umístění zdroje dat pro každý dotaz zvlášť. Nové řešení vám to umožňuje provést v jediném kroku.) V dialogu Nastavení zdroje dat je také nová možnost rozsahu Aktuální sešit, která umožňuje omezit seznam zobrazených zdrojů dat jenom na ty, které se používají v aktuálním souboru. V tomto zobrazení můžete změnit přihlašovací údaje, úrovně ochrany osobních údajů a další nastavení pro tento zdroj dat. Ke změně umístění daného zdroje dat můžete také použít možnost Změnit zdroj.

    Vylepšení nastavení zdroje dat v Power BI v Excelu
  • Rozšířený režim dialogu Filtrovat řádky v Editoru dotazů: Představujeme nový režim v dialogu Filtrovat řádky v Editoru dotazů. Tento nový režim umožňuje přidat více klauzulí filtru v jednom kroku Filtrovat řádky. (Před touto aktualizací bylo možné přidat jenom jednu nebo dvě klauzule.) Umožňuje také kombinovat klauzule filtru založené na více sloupcích. (Dříve se všechny klauzule používaly na jeden sloupec.)

    Rozšířený dialog Filtrovat řádky v Editoru dotazů v Power BI v Excelu
  • Vložené ovládací prvky pro vstup pro vyvolání funkce v Editoru dotazů: Vylepšili jsme vložený náhled funkcí v dialogu Editoru dotazů. Teď umožňuje vstupní hodnoty pro vyvolání funkce. Tento nový oddíl Zadat parametry ve vloženém náhledu funkcí je k dispozici pro předem připravené funkce (funkce M Engine) a také pro funkce definované uživatelem.

    Vložené ovládací prvky v Power BI v Excelu pro vstup pro vyvolání funkce v Editoru dotazů
  • Podpora změny pořadí kroků dotazu v Editoru dotazů pomocí gest přetažení: Podporujeme změnu pořadí kroků dotazu v Editoru dotazů pomocí gest přetažení. Tento postup je dostupný pro každý dotaz v části Použitý postup v Editoru dotazů.

    Změna pořadí kroků dotazu pomocí gesta přetažení v Power BI v Excelu
  • Podpora výběru data pro vstupní hodnoty data v dialozích Filtrovat řádky a Podmíněný sloupec: V této aktualizaci teď můžete využít ovládací prvek Výběr data, který umožní poskytnout vstupní hodnoty data v dialozích Filtrovat řádky a Podmíněný sloupec.

    Podpora výběru data v Power BI v Excelu pro vstupní hodnoty data v dialozích Filtrovat řádky a Podmíněný sloupec
  • Nová položka místní nabídky pro vytvoření nových dotazů v podokně Dotazy v Editoru dotazů: V podokně Dotazy v Editoru dotazů teď můžete přidat nový dotaz. Pravým tlačítkem myši klikněte na pozadí podokna nebo uzlu skupiny dotazu. Díky tomu je přidávání nových dotazů při práci v podokně Editoru dotazů intuitivnější. Když pravým tlačítkem kliknete na skupinu dotazů, přidá se nový dotaz do vybrané skupiny.

    Nová položka místní nabídky pro vytvoření nových dotazů v podokně Dotazy v Editoru dotazů v Power BI v Excelu

Převedení ručních kreseb na obrazce

Předchozí aktualizace vám poskytla novou kartu Kreslení pro vaše dotykové zařízení. Tato karta vám umožňuje vybrat si styly rukopisu a začít psát rukopisné poznámky. Díky této aktualizaci můžete tyto rukopisné poznámky převést na obrazce. Stačí je vybrat a potom zvolit Převést na obrazce. Takto získáte volnost používání volných tvarů s jednotností a standardizací grafických obrazců Office. Další informace o rukopisu v Office najdete v tématu Kreslení a psaní rukopisných poznámek v Office 2016.

Rychlejší kontingenční tabulky OLAP

Pokud pracujete s připojeními k OLAP serverům, jsou teď vaše kontingenční tabulky rychlejší. Aktualizace z června 2016 obsahuje vylepšení dotazů a mezipaměti pro výkon této vysoce efektivní funkce. Tato aktualizace vám poskytne výhody, ať už používáte kontingenční tabulky k zodpovězení jednorázových otázek, nebo vytváříte komplikované sešity obsahující desítky kontingenčních tabulek. Nezáleží na tom, jestli jsou vaše kontingenční tabulky připojené k tabulkovému nebo vícerozměrovému modelu. Jakákoli kontingenční tabulka připojená ke službě Microsoft SQL Server Analysis Services, zprostředkovatelům OLAP třetích stran nebo datovému modelu Power Pivotu vám pravděpodobně poskytne aktuální data rychleji. Když teď zakážete Souhrny a Celkové součty, můžou se navíc kontingenční tabulky rychleji aktualizovat, rozbalit, sbalit a můžou rychleji přecházet k datům. Čím větší je kontingenční tabulka, tím větší je potenciální zlepšení. Konkrétně jsme vylepšili tři velké oblasti týkající se dotazování OLAP serverů:

  • Vylepšená efektivita dotazu: Excel se teď bude dotazovat na Souhrny a Celkové součty, jenom pokud jsou potřeba k vykreslení výsledků kontingenční tabulky. To znamená, že se zkrátí doba čekání na dokončení zpracování dotazu OLAP serverem a také přenos výsledků přes síťové připojení bude trvat kratší dobu. Na kartě Návrh kontingenční tabulky jednoduše jako obvykle zakažte Souhrny a Celkové součty. Podívejte se na článek: Zobrazení nebo skrytí souhrnů a součtů v kontingenční tabulce

  • Snížený počet dotazů: Při aktualizaci dat postupuje Excel efektivněji. Dotazy se teď aktualizují, jenom pokud jste je skutečně změnili a je potřeba je aktualizovat.

  • Efektivnější mezipaměti: Schéma kontingenční tabulky se teď po načtení sdílí se všemi kontingenčními tabulkami daného připojení a snižuje tak počet dotazů.

Aktualizace funkce Načíst a transformovat a doplňku Power Query

  • Podmíněné sloupce: Díky této aktualizaci je vytváření nových sloupců v dotazech založených na hodnotách z jiných sloupců pro uživatele neuvěřitelně jednoduché. Typický případ použití zahrnuje vytvoření sady kategorií založených na rozsazích ze sloupce souvislých hodnot. Jedná se například o zařazení indexu BMI osoby do kategorií Podváha, Normální, Nadváha nebo Obezita založených na obecně známých rozsazích hodnot BMI nebo definici kategorií jako například Tento týden, Minulý týden atd. na základě sloupce Datum. Dříve jste toho mohli dosáhnout vytvořením vlastních sloupců a zaznamenáním logiky podmínky pomocí sady příkazů if-then-else. Vytváření a správa těchto výrazů se může s přidáváním dalších podmínek výrazně zkomplikovat. Od této aktualizace můžou uživatelé definovat sadu pravidel a výstupních hodnot nového sloupce založeného na hodnotách v jiných sloupcích uvnitř tabulek. K tomu slouží nový dialog Podmíněné sloupce dostupný v Editoru dotazů na kartě Přidat sloupec na pásu karet.

    Power Query – Podmíněné sloupce
  • Indikátor typu sloupce v záhlavích sloupců náhledu Editoru dotazů: V této aktualizaci jsme přidali indikátory typu sloupce v záhlavích sloupců náhledu Editoru dotazů. Tyto nové indikátory typu sloupce umožňují rychle porozumět typům jednotlivých sloupců tabulky a také je změnit na jiný typ kliknutím na tyto indikátory nebo použitím dříve dostupných možností na pásu karet (rozevírací nabídka Datový typ na kartě Domů nebo příkaz Rozpoznat typ na kartě Transformace.)

    Power Query – Indikátor typu sloupce v záhlavích sloupců náhledu Editoru dotazů
  • Změna pořadí dotazů a skupin dotazů v Editoru dotazů pomocí gest přetažení: Pořadí dotazů a skupin dotazů teď můžete jednoduše změnit v podokně Dotazy v Editoru dotazů tak, že vyberete jeden nebo několik objektů a přetáhnete je do požadovaného umístění. Tento postup můžete použít ke změně pořadí položek uvnitř dané skupiny (nebo nejvyšší úrovně) a také k přesunutí objektů do skupiny dotazů. Přidáním gest přetažení do podokna Dotazy uvnitř Editoru dotazů se výrazně zlepšila práce při změnách pořadí dotazů a skupin dotazů. Tyto změny jste dříve mohli provádět jenom prostřednictvím možností místní nabídky.

    Power Query – Změna pořadí dotazů a skupin dotazů v Editoru dotazů pomocí gest přetažení
  • Nabídka Správa dotazů v Editoru dotazů: V této aktualizaci představujeme novou rozevírací nabídku Spravovat pro dotazy na kartě Domů pásu karet Editoru dotazů. V této nabídce se zobrazují běžné operace správy dotazu, jako například odstranění, duplikování nebo odkazování.

    Power Query – Nabídka Správa dotazů v Editoru dotazů

Aktualizace funkce Načíst a transformovat a doplňku Power Query

  • Odebrání prázdných řádků prostřednictvím nabídky Filtr sloupce: V této aktualizaci jsme přidali novou možnost filtrování dat, která odebere všechny řádky, ve kterých je hodnota aktuálního sloupce null nebo prázdná. Tato možnost je přístupná prostřednictvím rozevírací nabídky Filtr sloupce.

    Power Query – Odebrání prázdných řádků prostřednictvím nabídky Filtr sloupce
  • Převod hodnoty trvání na roky: Tuto novou možnost transformace najdete na kartě Transformace nebo Přidat sloupec. V rozevírací nabídce Trvání je nová položka Celkový počet roků, která umožňuje vypočítat celkový počet roků na základě sloupce typu Trvání. Použitou logikou je vydělení celkového počtu dní číslem 365.

    Power Query – Převod hodnoty trvání na roky
  • Zachování duplicit: Tato nová transformace umožňuje uživatelům zachovat jenom řádky s duplicitními hodnotami ve vybraných sloupcích. Před touto aktualizací byla dostupná jenom možnost Odebrat duplicity. Tuto novou možnost najdete na pásu karet v části Domů > Odebrat duplicity (tlačítko pro rozdělení), potom vyberte příkaz Zachovat duplicity.

    Power Query – Zachovat duplicity
  • Nápověda pro ukázkové vstupní hodnoty v dialogu Změnit typ pomocí národního prostředí: Power Query umožňuje uživatelům změnit typ sloupce s ohledem na národní prostředí nebo místní nastavení nebo formát, ve kterém se data prezentují. To můžete udělat tak, že nastavíte hodnotu národního prostředí pro celý sešit (v části Data > Nový dotaz > Možnosti dotazu > Aktuální sešit > Načtení dat). Hodnotu můžete také přizpůsobit pro každý konkrétní krok Změnit typ v dotazech. V dialogu Změnit typ pomocí národního prostředí (přístupném po kliknutí pravým tlačítkem myši na záhlaví sloupce v náhledu Editoru dotazů a následném výběru možností Změnit typ > Použití národního prostředí…) teď uživatelé můžou získat několik ukázkových hodnot očekávaného formátu vstupu při výběru konkrétního datového typu a národního prostředí.

    Power Query – Nápověda pro ukázkové vstupní hodnoty v dialogu Změnit typ pomocí národního prostředí
  • Podpora prázdných znaků a znaků LF v náhledu Editoru dotazů: V této aktualizaci jsme přidali podporu zobrazení prázdných znaků v buňkách dat náhledu Editoru dotazů. Podpora zahrnuje všechny prázdné znaky, včetně znaků LF. Na kartě Zobrazení pásu karet Editoru dotazů můžete přepínat mezi možností Zobrazit prázdné znaky (výchozí chování) a nezobrazováním prázdných znaků (předchozí chování).

    Power Query – Podpora prázdných znaků a znaků LF v náhledu Editoru dotazů
  • Možnost zakázání náhledů z okna Navigátoru: Tato aktualizace přidává možnost zakázání náhledů v dialogu Navigátor. Tato možnost umožňuje uživatelům snížit počet volání zdroje dat za účelem načtení těchto náhledů.

    Power Query – Možnost zakázání náhledů z okna Navigátoru
  • Podpora technického názvu v okně Navigátoru: Některé zdroje dat podporují pojem „technický název“ pro objekty ve zdroji. Tyto technické názvy mají poskytovat výstižnější název připojení koncového uživatele ke zdroji dat než fyzický název objektu. V této aktualizaci jsme do dialogu Navigátor přidali novou možnost, která uživatelům umožňuje přepínat mezi fyzickým názvem (předchozí chování) a technickým názvem (nové chování).

  • Přejmenování dotazů přímo z podokna Dotazy v Editoru dotazů: Díky této aktualizaci teď můžete přejmenovat dotazy přímo v podokně Dotazy v Editoru dotazů. Pokud chcete dotaz přejmenovat v tomto podokně, stačí vybrat dotaz, kliknout na něj pravým tlačítkem myši a vybrat Přejmenovat. Můžete také na název dotazu poklikat nebo jej vybrat a pak stisknout F2.

    Power Query – Přejmenování dotazů přímo z podokna Dotazy v Editoru dotazů
  • Podpora časového limitu příkazu v uživatelském prostředí: Díky této aktualizaci teď uživatelé při připojování ke zdrojům databáze můžou určit hodnotu časového limitu příkazu (v minutách). Jedná se o významné vylepšení prostředí, protože před touto aktualizací byla tato úprava možná jenom prostřednictvím vytváření vlastních vzorců. Tuto novou možnost Časový limit příkazu najdete v části Upřesnit možnosti v dialogových oknech zdrojů dat.

    Power Query – Podpora časového limitu příkazu v uživatelském prostředí
  • Nastavení zákazu výzev úrovně ochrany osobních údajů na úrovni počítače (včetně klíče registru): Power Query umožňuje uživatelům kombinovat data z více zdrojů dat do jediného sešitu. Při práci s několika zdroji dat uživatelé můžou definovat dotazy, které vyžadují odeslání dat z jednoho zdroje dat do jiného zdroje dat. Power Query poskytuje za účelem zabránění náhodnému zpřístupnění soukromých nebo podnikových dat funkci nazvanou Úrovně ochrany osobních údajů. Tato funkce umožňuje uživatelům určit úroveň ochrany osobních údajů (veřejná, organizační nebo soukromá) pro jednotlivé zdroje dat, ke kterým se připojují při pokusu o zkombinování dat z více zdrojů. Power Query pak na základě vybrané úrovně ochrany osobních údajů zajistí, aby se data ze soukromého zdroje dat neodesílala do žádných jiných zdrojů a aby se data z organizačního zdroje odesílala jenom do zdrojů uvnitř organizace. V některých případech může toto vynucení ochrany osobních údajů stát v cestě uživatelům, kteří chtějí definovat kombinace dat obcházející tuto funkci ochrany osobních údajů. Dalším potenciálním efektem Úrovní ochrany osobních údajů je to, že při kombinaci dat z více zdrojů, u kterých se nepředpokládá odesílání dat mezi těmito zdroji kvůli Úrovním ochrany osobních údajů, bude Power Query provádět kompenzaci a stahovat data místně, aby se kombinace dat provedla zabezpečeným způsobem. Následkem takového chování může být snížení výkonu, protože se data musí ukládat do mezipaměti místně ze všech odvozených a kombinovaných zdrojů v paměti. V takových případech pak mají uživatelé možnost Úrovně ochrany osobních údajů ignorovat jako nastavení aktuálního sešitu. Vzhledem k tomu, že toto nastavení bylo dostupné jenom pro jeden soubor nebo uživatele, vyžadovalo, aby uživatel toto nastavení povolil pro každý sešit, který by chtěl použít. Ignorování této ochrany osobních údajů musí být navíc schválené každým uživatelem sešitu. To znamená, že uživatel otvírající soubor XLSX jiného uživatele v počítači by buď musel zadat Úrovně ochrany osobních údajů pro zdroje dat zahrnuté v sestavě, nebo tuto funkci ručně zakázat v dialogu Možnosti (v části Možnosti dotazu > Aktuální sešit > Ochrana osobních údajů).

    V této verzi představujeme nové nastavení, které uživatelům a podnikům umožňuje, aby si vybrali jedno z následujících chování:

    • Vždycky kombinovat data pro jednotlivé zdroje podle nastavení úrovně soukromí: Tato nová možnost umožňuje uživatelům vynucovat, aby se zohledňovaly Úrovně ochrany osobních údajů pro každý soubor XLSX v počítači, bez ohledu na to, jestli je nastavení Úrovně ochrany osobních údajů pro aktuální sešit povolené nebo zakázané.

    • Kombinovat data podle nastavení úrovně ochrany osobních údajů každého souboru: Toto je výchozí chování a odpovídá chování Power Query v minulých verzích.

    • Vždycky ignorovat nastavení úrovně ochrany osobních údajů: S touto novou možností může uživatel vždycky obejít nastavení úrovně ochrany osobních údajů pro každý soubor XLSX v počítači, bez ohledu na nastavení aktuálního sešitu.

    Tyto možnosti jsou uživatelům dostupné v dialogu Možnosti dotazu:

    Power Query – Nastavení zákazu výzev úrovně ochrany osobních údajů na úrovni počítače (včetně klíče registru)

Aktualizace funkce Načíst a transformovat a doplňku Power Query

  • Konektor rozhraní ODBC – podpora pro výběr názvů DSN uživatele/systému: Častým požadavkem zákazníků používajících konektor rozhraní ODBC bylo to, aby si při určování podrobností připojení v průvodci importem z ODBC v Power Query v Excelu mohli vybírat ze seznamu dostupných názvů DSN. Tato aktualizace přidává novou rozevírací nabídku, díky které si uživatelé můžou vybrat existující název DSN v seznamu dostupných názvů DSN uživatele/systému v jejich počítači. Kromě výběru existujícího názvu DSN můžou uživatelé určit i další podrobnosti připojovacího řetězce, nebo můžou v rozevírací nabídce DSN vybrat možnost Žádný a zadat úplný připojovací řetězec nezávisle na jakýchkoli existujících názvech DSN (což odpovídá chování před touto aktualizací).

    Power Query – Konektor rozhraní ODBC – podpora pro výběr názvů DSN uživatele/systému
  • Konektor CSV – možnost určení oddělovače sloupců v dialogu Zdroj: Dialog Zdroj pro konektor CSV jsme vylepšili tak, aby uživatelé mohli upravit možnost oddělovače sloupců. Před touto aktualizací bylo možné změnit možnost oddělovače sloupců jenom prostřednictvím úprav základního vzorce M kroku Zdroj.

    Power Query –Konektor CSV – možnost určení oddělovače sloupců v dialogu Zdroj

Aktualizace funkce Načíst a transformovat a doplňku Power Query

  • Filtrování podle dat, která nejsou prvními ani posledními daty: Do Editoru dotazů jsme přidali novou možnost filtrování sloupců Datum/Čas. Ta uživatelům umožňuje filtrovat podle dat, která nejsou prvními ani posledními daty aktuálního sloupce.

    Power Query – Filtrování podle dat, která nejsou prvními ani posledními daty
  • Filtrování podle toho, jestli hodnoty spadají do předchozích N minut/hodin/sekund: Další nový filtr Data/Času poskytuje možnost vyfiltrovat hodnoty, které spadají do předchozích N minut/hodin/sekund. Tuto možnost najdete v části Během předchozích… v nabídce Filtr pro sloupce Datum/Čas.

    Power Query – Filtrování podle toho, jestli hodnoty spadají do předchozích N minut/hodin/sekund

    Možnosti filtrování pak můžete definovat zadáním hodnot a požadovaného oboru filtrování v rozevírací nabídce. Všimněte si, že tato aktualizace přidala nové možnosti hodin, minut a sekund.

    Power Query – Definování možností filtrování s hodinami, minutami a sekundami
  • Kopírování a vkládání dotazů mezi nástrojem Power BI Desktop a Excelem: Víme o tom, že uživatelé při svých každodenních činnostech pracují s různými nástroji a že pro scénáře řídicích panelů a sdílení používají Power BI Desktop společně s Excelem. Předchozí aktualizace povolila možnost kopírovat a vkládat dotazy mezi různými sešity Excelu. Tato aktualizace umožňuje uživatelům bezproblémové kopírování a vkládání dotazů mezi Excelem a nástrojem Power BI Desktop. Uživatelé teď můžou na dotaz nebo skupinu dotazů v podokně úloh Dotazy v excelovém sešitu kliknout pravým tlačítkem a tyto dotazy tak zkopírovat. Pak je můžou vložit do podokna úloh Dotazy v Editoru dotazů pro Power BI Desktop. Podobným způsobem se dotazy z nástroje Power BI Desktop kopírují do Excelu.

  • Podpora pro speciální znaky v dialogu Rozdělit sloupec: Už dříve jsme přidali podporu používání speciálních znaků k vyhledání a nahrazení hodnot v dialogu Nahradit hodnoty. V této aktualizaci jsme tu stejnou funkci povolili i pro operace Rozdělit sloupec oddělovačem.

    Power Query – Podpora pro speciální znaky v dialogu Rozdělit sloupec
  • Aktualizace náhledů v dialogovém okně Sloučit dotazy: Náhledy tabulek teď můžete aktualizovat v dialogu Sloučit dotazy. Uživatelé tak můžou vybrat sloupce, které mají odpovídat nejnovějším dostupným datům.

    Power Query – Aktualizace náhledů v dialogovém okně Sloučit dotazy
  • Neproporcionální písmo pro náhled Editoru dotazů: Náhled Editoru dotazů teď můžete přizpůsobit tak, aby zobrazoval obsah pomocí neproporcionálního písma. Tuto možnost přizpůsobení najdete na kartě Zobrazení.

    Power Query – Neproporcionální písmo pro náhled Editoru dotazů
  • Vylepšené prostředí pro vyvolání funkce: Funkce teď můžete vyvolávat přímo z dialogu Navigátor. Můžete vyvolávat funkce a zobrazovat náhledy výsledků funkcí ve srovnání se zdrojem dat (například SQL Serverem). Přímo v okně Navigátor teď můžete určit parametry funkce:

    Power Query – Vylepšené prostředí pro vyvolání funkce

    A pak rovnou zobrazit náhled výsledků:

    Power Query – Okamžitý náhled výsledků
  • Možnost nastavení přihlašovacích údajů na úrovni serveru: Teď máte možnost nastavit obor pro přihlašovací údaje při zobrazení výzvy k zadání přihlašovacích údajů k databázi. Tato možnost je k dispozici jako přepínač v dolní části dialogu Přihlašovací údaje.

    Power Query – Možnost nastavení přihlašovacích údajů na úrovni serveru
  • Přidání předpony/přípony ke sloupci Text: Teď můžete v Editoru dotazů přidat k existujícímu sloupci Text předponu nebo příponu – pomocí této možnosti na kartě Transformace (přímá úprava sloupce) nebo v části Přidat sloupec pro vytvoření nového sloupce (dostupné v části Sloupec Text > Formát).

    Power Query – Přidání předpony/přípony ke sloupci Text

Aktualizace Power Pivotu v Excelu 2016

  • Uložení zobrazení diagramu relací jako obrázku: Uživatelé Excelu 2016 teď můžou ukládat zobrazení diagramu datového modelu jako soubor obrázku s vysokým rozlišením, který se pak dá použít ke sdílení, tisku nebo analýze datového modelu. Pokud chcete vytvořit soubor obrázku, klikněte v doplňku Power Pivot na Soubor a pak vyberte Uložit zobrazení jako obrázek.

    Power Pivot – Uložení zobrazení diagramu relací jako obrázku
  • Vylepšené dialogové okno Upravit relaci vytvoří relace dat rychleji a přesněji: Uživatelé Power Pivotu v Excelu 2016 teď můžou ručně přidat nebo upravit relaci tabulky při procházení vzorových dat (až pět řádků dat ve vybrané tabulce). Můžete vytvářet rychlejší a přesnější relace, aniž byste se museli neustále vracet k zobrazení dat pokaždé, když budete chtít vytvořit nebo upravit relaci tabulky.

    Power Pivot – Vylepšený dialog Upravit relaci
  • Výběr tabulky s použitím navigace pomocí klávesnice: V dialogu Upravit relaci zadejte první písmeno názvu tabulky, abyste se přesunuli na první název sloupce začínající vybraným písmenem.

  • Výběr sloupců pomocí navigace sloupce: V dialogu Upravit relaci zadejte první písmeno názvu sloupce, abyste se přesunuli na první sloupec začínající vybraným písmenem. Opětovným zadáním tohoto písmene se přesunete na další sloupec začínající tímto písmenem.

  • Automatický návrh sloupce pro stejný název sloupce v obou tabulkách: Jakmile vyberete první tabulku a sloupec, vybere se u druhé tabulky (v případě, že existuje sloupec se stejným názvem) automaticky (funguje oběma směry).

  • Opravy zlepšující celkové uživatelské prostředí pro modelování: 1) Datový model Power Pivotu už se při práci se skrytými sešity neztratí; 2) sešit Excelu 2010 teď můžete upgradovat pomocí datového modelu na verzi Excel 2016; 3) v Power Pivotu můžete přidat počítaný sloupec, pokud neobsahuje vzorec.

Kompletní seznam této zákaznické aktualizace najdete v tématu Opravy Power Pivotu a vloženého stroje služby Analysis Services v Excelu 2016.

Všichni uživatelé Excelu 2016 můžou získat nejnovější zákaznickou aktualizaci nainstalováním následujících aktualizací. Všimněte si, že každá z nich má 32bitovou a 64bitovou verzi, takže se ujistěte, že stahujete tu správnou:

  • KB3114374– aktualizace Office 2016 Excelu z 8. prosince 2015

  • KB3114297– aktualizace Office 2016 Power Pivotu v Excelu z 8. prosince 2015

Trychtýřové grafy

Trychtýřové grafy zobrazují hodnoty z různých fází procesu. Hodnoty se obvykle postupně zmenšují, takže pruhy připomínají trychtýř. Tady si o trychtýřových grafech můžete přečíst další informace.

Trychtýřový graf znázorňující obchodní profilaci – v prvním sloupci jsou fáze, ve druhém sloupci jsou hodnoty

Vylepšené automatické dokončování

Automatické dokončování v Excelu už není tak vybíravé. Řekněme například, že chcete použít funkci NETWORKDAYS, ale nemůžete si vzpomenout, jak se píše. Když napíšete jenom =DAYS, nabídka automatického dokončování vrátí všechny funkce, které v názvu obsahují řetězec „DAYS“, včetně funkce NETWORKDAYS. (Dřív jste museli napsat přesně celý název funkce.)

TEXTJOIN

Tato funkce spojí texty z několika oblastí a jednotlivé položky od sebe oddělí oddělovačem, který jste zadali. Tady si o funkci TEXTJOIN můžete přečíst další informace.

CONCAT

Tato nová funkce se podobá funkci CONCATENATE, ale je lepší. Především je kratší a jde snadněji napsat. Taky ale podporuje kromě odkazů na buňky i odkazy na oblasti. Tady si můžete přečíst další informace.

IFS

Unavuje vás zadávání složitých vnořených funkcí KDYŽ? Řešením je funkce IFS. U této funkce se podmínky testují v pořadí, v jakém je zadáte. Pokud je některá podmínka splněná, vrátí se odpovídající výsledek. Můžete taky zadat podmínku, která „vychytá“ případy, kdy není splněná žádná z ostatních podmínek. Tady si o funkci IFS můžete přečíst další informace.

SWITCH

Tato funkce porovnává hodnotu výrazu se seznamem hodnot v jejich pořadí a jako výsledek vrací první shodnou hodnotu. Pokud se nenajde žádná shoda, vrátí funkce hodnotu zadanou jako výchozí. Tady najdete podrobnosti a příklady.

MAXIFS

Tato funkce vrátí největší číslo z oblasti, která splňuje jednu nebo více podmínek. Tady najdete další informace.

MINIFS

Tato funkce se podobá funkci MAXIFS, ale vrátí nejmenší číslo z oblasti, která splňuje jednu nebo více podmínek. Tady si můžete o funkci MINIFS přečíst víc.

Černý motiv

Motiv Office s dosud nejvyšším kontrastem je tu. Pokud chcete změnit motiv Office, přejděte do nabídky Soubor > Účet a pak klikněte na rozevírací nabídku u položky Motiv Office. Vámi vybraný motiv se použije ve všech aplikacích Office. Další informace o motivech Office najdete v tématu Změna vzhledu Office 2016 pro Windows pomocí motivů Office.

Pokud není určeno jinak, předplatitelé Office 365 a uživatelé, kteří si jednorázově koupili Office 2016, získávají následující nové funkce.

Šest nových typů grafů

Vizualizace jsou důležité pro efektivní analýzu dat i pro vyprávění poutavých příběhů. Do Excelu 2016 jsme přidali šest nových grafů se stejně bohatými možnostmi formátování, na jaké jste zvyklí. Jejich pomocí můžete vytvářet nejčastěji používané vizualizace dat finančních nebo hierarchických informací k zjištění statistických vlastností dat.

Klikněte na Vložit hierarchický graf na kartě Vložení, pokud chcete použít proporční graf nebo vícevrstvý prstencový graf, klikněte na Vložit kaskádový nebo burzovní graf , pokud chcete použít kaskádový graf nebo klikněte na Vložit statistický graf, pokud chcete vložit histogram, Paretův graf nebo krabicový graf.

Ikony pro vložení hierarchického, vodopádového, burzovního nebo statistického grafu do Excelu 2016 pro Windows

Nebo pokud chcete zobrazit všechny nové grafy, klikněte na Doporučené grafy >Všechny grafy.

zobrazuje nové grafy v PowerPointu 2016

Načíst a transformovat (Query)

Před začátkem analýzy musíte umět přenést data relevantní pro obchodní otázku, na kterou se snažíte odpovědět. Excel 2016 se teď dodává s integrovanou funkcí, která usnadňuje a urychluje získání a transformaci dat. Umožňuje tak najít a přenést všechna potřebná data na jedno místo. Tyto nové možnosti, které dřív byly dostupné jenom jako samostatný doplněk nazvaný Power Query, jsou teď nativní součástí Excelu. Přístup k nim je možný ze skupiny Načíst a transformovat na kartě Data.

Zdroje dat pro dotaz

Prognózování jediným kliknutím

V dřívějších verzích Excelu bylo možné jenom lineární prognózování. V Excelu 2016 byla funkce FORECAST rozšířená tak, aby umožňovala prognózování na základě analytického nástroje Exponenciální vyrovnávání (například FORECAST.ETS() …). Tato funkce je dostupná taky jako nové tlačítko pro prognózování jedním kliknutím. Na kartě Data klikněte na tlačítko List prognózy pro rychlé vytvoření vizualizace prognózy datové řady. V průvodci taky najdete možnosti pro úpravu běžných parametrů prognózy, jako je sezónnost, která je automaticky zjištěná ve výchozím nastavení, a intervaly spolehlivosti.

Část listu s tabulkou předpovídaných čísel a grafem prognózy

3D mapy

Náš oblíbený nástroj pro 3D geografické vizualizace, Power Map, teď má nový název a je dostupný pro všechny uživatele Excelu 2016, protože v něm je integrovaný. Tato inovativní sada funkcí pro vyprávění příběhů se přejmenovala na 3D mapy a najdete ji společně s ostatními nástroji pro vizualizaci po kliknutí na 3D mapa na kartě Vložení.

Prohlídka Power Mapu je připravená k přehrání.

Přehledy kalendářů Finanční šablony

Můžete použít novou šablonu Moje Cashflow a šablonu Burzovní analýza. Tyto šablony vám umožní sledovat, kolik vyděláváte, kolik utrácíte a za co. Můžete taky rychle analyzovat a porovnávat chování vybraných akcií v průběhu času.

Šablona

Zobrazte si svůj kalendář jako řídicí panel a přecházejte k podrobnějším datům. Pomůže vám to udělat si přehled o tom, jak trávíte svůj čas, a přijít na způsoby, jak toho během dne víc stihnout.

Vylepšení kontingenční tabulky

O Excelu se ví, že v jeho známém autorském prostředí kontingenční tabulky je možné dělat flexibilní a efektivní analýzy. V Excelu 2010 a Excelu 2013 jsou tyto možnosti výrazně vylepšené díky zavedení doplňku Power Pivot a datového modelu, který přináší možnost snadno vytvářet složité modely přes data, posilovat je pomocí měřítek a klíčových ukazatelů výkonu a potom vysokou rychlostí vypočítávat víc než miliony řádků. Tady jsou některá vylepšení, která jsme zavedli v Excelu 2016, abyste se mohli méně věnovat správě dat a více odhalování přehledů, na kterých záleží.

Automatické zjišťování relací    zjišťuje a vytváří relace mezi tabulkami používanými pro datový model sešitu, takže je nemusíte vytvářet sami. Excel 2016 pozná, kdy analýza vyžaduje propojení dvou nebo víc tabulek, a upozorní vás na to. Stačí jedno kliknutí a vytvoří za vás relace, takže můžete hned začít využívat jejich výhod.

Vytváření, úpravy a odstraňování vlastních měr    je teď možné přímo z polí kontingenční tabulky. To vám ušetří spoustu času, když pro svou analýzu potřebujete přidat další výpočty.

Automatické seskupení času    pomáhá efektivněji využívat časově vázaná pole (rok, čtvrtletí, měsíc) v kontingenční tabulce díky tomu, že je za vás automaticky zjistí a seskupí. Po seskupení stačí skupinu přetáhnout do kontingenční tabulky v jedné akci a hned začít s analýzami na různých časových úrovních díky možnostem procházení.

Tlačítka pro procházení kontingenčního grafu    umožňují přibližování a oddalování časových seskupení a dalších hierarchických struktur dat.

Seznam polí Hledání v kontingenční tabulce    vám pomůže dostat se do polí, která jsou pro vás v celé datové sadě důležitá.

Inteligentní přejmenování    vám dává možnost přejmenovávat tabulky a sloupce v datovém modelu sešitu. S každou změnou Excel 2016 automaticky aktualizuje jakékoliv přidružené tabulky a výpočty v sešitu, včetně všech listů a vzorců DAX.

Udělali jsme taky několik vylepšení použitelnosti   . Zpožděné aktualizace třeba umožňují udělat v Power Pivotu víc změn bez nutnosti čekat, až se jednotlivé změny budou propagovat v sešitu. Změny se propagují jednou po zavření okna Power Pivotu.

Kontingenční tabulka s popisky zobrazující nové funkce v Excelu 2016

Vícenásobný výběr v průřezu

Teď můžete na dotykovém zařízení vybrat v excelovém průřezu několik položek. To je rozdíl proti předchozím verzím Excelu, ve kterých se pomocí dotykového vstupu dala najednou vybrat jenom jedna položka v průřezu. Pomocí nového tlačítka umístěného v popisku průřezu můžete přejít do režimu vícenásobného výběru.

Možnosti průřezu se zvýrazněným tlačítkem vícenásobného výběru

Publikování a sdílení analýz s Power BI

Sestava není úplná, když není možné ji nasdílet s těmi pravými lidmi. Až dokončíte přípravu analýzy dat, můžete ji nasdílet se členy vaší pracovní skupiny nebo klienty prostřednictvím Power BI s použitím jediného tlačítka. Po publikování datových modelů v Power BI je můžete použít k rychlému vytváření interaktivních sestav a řídicích panelů. Díky podpoře Excelu Online integrované ve službě Power BI můžete taky zobrazit plně formátované listy Excelu.

Karta Publikování v Excelu 2016 zobrazující tlačítko Publikovat do Power BI

Rychlé formátování obrazce

Tato funkce zvyšuje počet stylů obrazců zavedením nových přednastavených stylů v Excelu.

Galerie stylů obrazce zobrazující nové přednastavené styly v Excelu 2016 pro Windows

Vkládání obrázků se správnou orientací

Díky automatickému otáčení obrázků to funguje tak, že když vložíte do Excelu obrázek, automaticky se otočí, aby to odpovídalo orientaci fotoaparátu. Po vložení můžete obrázek ručně otočit do libovolné polohy. Takto to funguje jenom u nově vkládaných obrázků – netýká se to obrázků v existujících dokumentech.

Pracujte rychle díky funkci Řekněte mi

Excel 2016 nabízí na pásu karet textové pole, které hlásí Řekněte mi, co chcete udělat. Je to textové pole, kam můžete zadat slova a fráze související s vaším dalším plánovaným krokem. Pomůže vám rychle se dostat k funkcím, které chcete použít, nebo akcím, které chcete udělat. Taky si můžete nechat pomoct s tím, co hledáte, nebo použít inteligentní vyhledávání u zadaného pojmu.

Pole Řekněte mi na pásu karet Excelu 2016

Pole Řekněte mi s textem „waterfall“ a výsledky v Excelu 2016 pro Windows

Přehled o tom, na čem pracujete

V podokně Přehledy, které používá technologii Bing, najdete víc než jenom definice. Když vyberete slovo nebo slovní spojení, klikněte na něj pravým tlačítkem myši a zvolte Inteligentní vyhledávání. Otevře se podokno Další informace obsahující definice, články z Wikipedie a nejčastější související vyhledávání z webu. K inteligentnímu vyhledávání se taky můžete kdykoliv dostat tak, že přejdete na Revize > Inteligentní vyhledávání a zadáte sem dotaz.

Inteligentní vyhledávání v místní nabídce v Excelu 2016 pro Windows

Podokno Další informace v Excelu 2016 pro Windows

Rukopisné rovnice

Vkládání matematických rovnic je teď mnohem jednodušší. Nově můžete vždycky, když budete chtít vložit do sešitu složité matematické rovnice, přejít na Vložení > Rovnice > Rukopisná rovnice. Pokud máte dotykové zařízení, můžete použít prst nebo stylus a zapsat matematické rovnice ručně a Excel 2016 je převede na text. (Pokud nemáte dotykové zařízení, můžete k zápisu použít i myš). Průběžně taky můžete mazat, vybírat a opravovat, co jste napsali.

Tlačítko Rovnice na pásu karet Excelu 2016

Zobrazuje podokno Rukopisná rovnice v PowerPointu.

Jednodušší sdílení

Vyberte kartu Sdílet na pásu karet, pokud tabulku chcete sdílet s ostatními na SharePointu, OneDrivu nebo na OneDrivu pro firmy.

Tyto změny spojují dva klíčové aspekty spolupráce: kdo má přístup k příslušnému dokumentu a kdo na něm s vámi právě pracuje. Teď uvidíte obě tyto informace na jednom místě v dialogovém okně Sdílení.

Podokno sdílení v Excelu 2016 pro Windows

Vylepšená historie verzí

Nově teď můžete přejít na Soubor > Historie, zobrazit úplný seznam změn v sešitu a získat přístup ke starším verzím.

Podokno historie v Excelu 2016 pro Windows

Poznámka : Tato funkce se podporuje jenom pro soubory uložené na OneDrivu pro firmy nebo SharePointu.

Nové motivy

Rozbalovací nabídka Motiv Office, možnosti témat Více barev, Tmavě šedá a Bílá

K dispozici teď jsou tři nové motivy Office: barevný, tmavě šedý a bílý. K motivům se dostanete tak, že přejdete do nabídky Soubor>Možnosti> Obecné a pak kliknete na rozevírací nabídku vedle položky Motiv Office.

Ochrana před únikem informací (DLP – Data Loss Prevention) v Excelu

Ochrana DLP je podniková funkce s vysokou hodnotou, která je hodně oblíbená v Outlooku. V této verzi zavádíme funkci DLP v Excelu. Umožňuje skenování obsahu v reálném čase založené na sadě předdefinovaných zásad pro většinu běžných typů citlivých dat (třeba čísla kreditních karet, rodná čísla a čísla bankovních účtů). Tato funkce bude umožňovat synchronizaci zásad DLP z Office 365 v Excelu, Wordu a PowerPointu a bude nabízet organizacím sjednocené zásady napříč veškerým obsahem uloženým v Exchangi, SharePointu a OneDrivu pro firmy.

Obrázek zprávy s upozorněním na možný únik citlivých informací

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Viz taky

Novinky a vylepšení v Office 2016

Úvodní příručky pro Office 2016

Typy grafů dostupné v Office

Vytvoření prognózy v Excelu 2016 pro Windows

3 způsoby, jak k obchodnímu rozhodování používat nové grafy v Excelu 2016

Začínáme s 3D mapami

Začínáme s funkcí Načíst a transformovat v Excelu 2016

Pracujte rychle díky funkci Řekněte mi

Získání přehledu o tom, na čem pracujete, díky inteligentnímu vyhledávání

Sdílení sešitu Excelu 2016 s jinými lidmi

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×