CUBEVALUE (funkce)

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Tento článek popisuje syntaxi vzorce a použití funkce CUBEVALUE v Microsoft Excelu.

Popis

Vrátí úhrnnou hodnotu z krychle.

Syntaxe

CUBEVALUE(připojení;[výraz_člena1]; [výraz_člena2]; …)

Syntaxe funkce CUBEVALUE má následující argumenty:

  • Připojení:    Povinný argument. Textový řetězec názvu připojení k datové krychli.

  • Výraz_člena:    Nepovinný argument. Textový řetězec výrazu MDX (Multidimensional Expression), jehož výsledkem je prvek nebo řazená kolekce členů v datové krychli. Jako hodnotu argumentu výraz_člena lze použít i sadu definovanou pomocí funkce CUBESET. Argument výraz_člena použijte jako průřez k definování části datové krychle, jejíž úhrnná hodnota bude vrácena. Jestliže v argumentu výraz_člena není uvedena žádná míra, použije se výchozí míra příslušné krychle.

Poznámky

  • Při vyhodnocování funkce CUBEVALUE se v buňce před načtením všech dat přechodně zobrazí zpráva #NAČÍTÁNÍ_DAT…

  • Jestliže je v argumentu výraz_člena použit odkaz na buňku a tento odkaz obsahuje funkci CUBE, nepoužije argument výraz_člena hodnotu zobrazenou v buňce, do níž vede odkaz, ale výraz MDX platný pro položku v této buňce.

  • Pokud není název připojení platným připojením sešitu uloženým v sešitu, vrátí funkce CUBEVALUE #NAME? #HODNOTA!. Pokud server OLAP (Online Analytical Processing) není dostupný, není k dispozici nebo vrátí chybovou zprávu, vrátí funkce CUBEVALUE #NAME?. #HODNOTA!.

  • Pokud je alespoň jeden prvek v rámci řazené kolekce členů neplatný, vrátí funkce CUBEVALUE #VALUE. #HODNOTA!.

  • V následujících případech vrátí funkce CUBEVALUE chybovou hodnotu #NENÍ_K_DISPOZICI:

    • Syntaxe argumentu výraz_člena není správná.

    • V krychli neexistuje člen určený pomocí argumentu výraz_člena.

    • N-tice je neplatná, protože neexistuje průsečík zadaných hodnot. (Tato situace může nastat u více prvků ve stejné hierarchii.)

    • Sada obsahuje minimálně jeden člen s jiným rozměrem než ostatní členy.

    • Funkce CUBEVALUE může vrátit chybovou hodnotu #NENÍ_K_DISPOZICI, pokud v kontingenční tabulce při sdílení spojení odkazujete na objekt z relace, například na počítaný člen pojmenované sady, a příslušnou kontingenční tabulku odstraňujete nebo převádíte kontingenční tabulku na vzorce. (Na kartě Možnosti ve skupině Nástroje klikněte na položku Nástroje OLAP a poté klikněte na položku Převést na vzorce.)

Problém: Hodnoty Null jsou převáděny na řetězce nulové délky

Pokud nejsou v Excelu v buňce žádná data, protože jste ji nikdy nezměnili nebo smazali její obsah, obsahuje buňka prázdnou hodnotu. V řadě databázových systémů se prázdná hodnota nazývá hodnota Null. Je-li hodnota prázdná neboli Null, znamená to doslovně „Žádná hodnota“. Vzorec však nikdy nevrací prázdný řetězec nebo hodnotu Null. Vzorec vždy vrací jednu ze tří hodnot: číselnou hodnotu, textovou hodnotu (jíž může být řetězec nulové délky) nebo chybovou hodnotu, například #ČÍSLO! nebo #HODNOTA.

Pokud vzorec obsahuje funkci CUBEVALUE připojenou k databázi OLAP (Online Analytical Processing) a dotaz na tuto databázi bude mít za následek hodnotu null, převede Excel tuto hodnotu null na řetězec s nulovou délkou, i když by vzorec jinak vrátil číslo Vícehodnotový. To může vést k situaci, kdy oblast buněk obsahuje kombinaci číselných hodnot a řetězců nulové délky a tato situace může ovlivnit výsledky dalších vzorců, které odkazují na tuto oblast buněk. Pokud třeba a1 a a3 obsahují čísla a buňka a2 obsahuje vzorec se zapnutou funkcí CUBEVALUE, která vrací řetězec s nulovou délkou, vrátí následující vzorec #VALUE.! odoln

=A1+A2+A3

Chcete-li se tomu vyhnout, můžete testovat výskyt řetězce nulové délky pomocí funkce JE.TEXT a pomocí funkce KDYŽ nahradit nulovou délku číslem 0 (nula), jak ukazuje následující příklad:

=KDYŽ(JE.TEXT(A1);0;A1)+KDYŽ(JE.TEXT(A2);0;A2)+KDYŽ(JE.TEXT(A3);0;A3)

Můžete také vnořit funkci CUBEVALUE do podmínky KDYŽ, která vrátí hodnotu 0, kdykoli funkce CUBEVALUE vrátí řetězec nulové délky, viz následující příklad:

=KDYŽ(CUBEVALUE("Prodeje";"[Objemy].[Zisk]";"[Čas].[2004]";"[Všechny výrobky].[Nápoje]")=""; 0; CUBEVALUE("Prodeje";"[Objemy].[Zisk]";"[Čas].[2004]";"[Všechny výrobky].[Nápoje]"))

U funkce SUMA není třeba provádět test na řetězec nulové délky, protože při výpočtu návratové hodnoty automaticky ignoruje řetězce nulové délky.

Příklady

=CUBEVALUE("Prodeje";"[Objemy].[Zisk]";"[Čas].[2004]";"[Všechny výrobky].[Nápoje]")

=CUBEVALUE($A$1;"[Objemy].[Zisk]";D$12;$A23)

=CUBEVALUE("Prodeje";$B$7;D$12;$A23)

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×