CHYBA.TYP (funkce)

Tento článek popisuje syntaxi vzorce a použití funkce CHABA.TYP v Microsoft Excelu.

Popis

Vrátí číslo odpovídající jedné z chybových hodnot aplikace Microsoft Excel nebo vrátí chybovou hodnotu #N/A, pokud žádná chyba neexistuje. Funkci CHYBA.TYP lze použít ve funkci KDYŽ při hledání chyb. Místo chybových hodnot mohou být vraceny textové řetězce, například zpráva.

Syntaxe

CHYBA.TYP(chyba)

Syntaxe funkce CHYBA.TYP obsahuje následující argumenty:

  • Chyba:    Povinný argument. Typ chyby, jejíž číslo chcete zjistit. Ačkoliv argument chyba může mít přímo hodnotu aktuální chyby, přesto bývá častěji využíván odkaz na buňku obsahující testovaný vzorec.

Pokud je argument chyba

Výsledek funkce CHYBA.TYP

#NULL!

1

#DIV/0!

2

#HODNOTA!

3

#REF!

4

#NÁZEV?

5

#NUM!

6

#N/A

7

#NAČÍTÁNÍ_DAT

8

Cokoli jiného

#N/A

Příklad

Zkopírujte vzorová data v následující tabulce a vložte je do buňky A1 nového excelového sešitu. Aby vzorce zobrazily výsledky, vyberte je, stiskněte F2 a potom stiskněte Enter. Pokud potřebujete, můžete přizpůsobit šířky sloupců a zobrazit si všechna data.

Data

#NULL!

#DIV/0!

Vzorec

Popis

Výsledek

=CHYBA.TYP(A2)

Číslo chyby #NULL! (1).

1

=KDYŽ(CHYBA.TYP(A3)<3;ZVOLIT(CHYBA.TYP(A3),"Oblasti se neprotínají.";"Dělitel je nula."))

Zkontroluje, jestli buňka A3 neobsahuje chybovou hodnotu #NULL! nebo chybovou hodnotu #DIV/0!. Pokud buňka jednu z těchto hodnot obsahuje, zobrazí funkce ZVOLIT pomocí čísla pro danou chybovou hodnotu jednu ze dvou zpráv. V opačném případě se vrátí chybová hodnota #N/A.

Dělitel je nula.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×