CHYBA.TYP (funkce)

Tento článek popisuje syntaxi vzorce a použití funkce CHYBA.TYP v Microsoft Excelu.

Popis

Vrátí číslo odpovídající jedné z chybových hodnot aplikace Microsoft Excel nebo vrátí chybu #NENÍ_K_DISPOZICI, pokud žádná chyba neexistuje. Pokud chcete ověřit, jestli je ve funkci KDYŽ vrácená chybová hodnota, můžete použít funkci CHYBA.TYP, která místo chybových hodnot vrátí textový řetězec, například zprávu.

Syntaxe

CHYBA.TYP(chyba)

Syntaxe funkce CHYBA.TYP obsahuje následující argumenty:

  • Chyba:    Povinný argument. Typ chyby, jejíž číslo chcete zjistit. Ačkoliv argument chyba může mít přímo hodnotu aktuální chyby, přesto bývá častěji využíván odkaz na buňku obsahující testovaný vzorec.

Pokud je argument chyba

Výsledek funkce CHYBA.TYP

#NULL!

1

#DIV/0!

2

#HODNOTA!

3

#REF!

4

#NÁZEV?

5

#NUM!

6

#N/A

7

#NAČÍTÁNÍ_DAT

8

Cokoli jiného

#N/A

Příklad

Zkopírujte vzorová data v následující tabulce a vložte je do buňky A1 nového excelového sešitu. Aby vzorce zobrazily výsledky, vyberte je, stiskněte F2 a potom stiskněte Enter. Pokud potřebujete, můžete přizpůsobit šířky sloupců a zobrazit si všechna data.

Data

#NULL!

#DIV/0!

Vzorec

Popis

Výsledek

=CHYBA.TYP(A2)

Číslo chyby #NULL! (1).

1

=KDYŽ(CHYBA.TYP(A3)<3;ZVOLIT(CHYBA.TYP(A3),"Oblasti se neprotínají.";"Dělitel je nula."))

Zkontroluje, jestli buňka A3 neobsahuje chybovou hodnotu #NULL! nebo chybovou hodnotu #DIV/0!. Pokud buňka jednu z těchto hodnot obsahuje, zobrazí funkce ZVOLIT pomocí čísla pro danou chybovou hodnotu jednu ze dvou zpráv. V opačném případě se vrátí chybová hodnota #NENÍ_K_DISPOZICI.

Dělitel je nula.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×