Automatické vkládání textu

Automatické vkládání textu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

V aplikaci Word můžete vložit text automaticky s některý z bloků předem naformátované textu z galerie automatických textů nebo s slov, vět nebo vět aplikace Word automaticky provede po zadání pouze několik znaků.

Poznámka : Pokud hledáte informace o nastavení automatického formátování, například automatické formátování pomlčky a pomlčky zlomky, hypertextové odkazy, znak uzavírající a seznam s odrážkami nebo číslované seznamy, přečtěte si článek konfigurovat nebo vypnout automatické formátování (Automatické úpravy).

Položky automatického textu se ukládají jako stavební bloky. K vytvoření nové položky slouží dialogové okno Vytvořit nový stavební blok.

  1. V dokumentu vyberte text, který chcete přidat do galerie položek automatického textu.

  2. Na kartě Vložení klikněte ve skupině Text na tlačítko Rychlé části, přejděte na možnost Automatický text a potom klikněte na příkaz Uložit výběr do galerie automatických textů.

  3. Vyplňte informace o v dialogovém okně vytvořit nový stavební blok. Většina výchozích hodnot je pořádku, ale včetně jedinečný název a popis usnadňuje automatického textu použít.

    Dialog Vytvořit nový stavební blok

    • Název    Zadejte jedinečný název pro stavební blok automatického textu.

    • Galerie    Vyberte galerii Automatický text.

    • Kategorie    Vyberte kategorii Obecné nebo vytvořte novou kategorii.

    • Popis    Zadejte popis stavebního bloku.

    • Uložit do    Klikněte v rozevíracím seznamu na název šablony. Například na položku Normal.

      V rozevíracím seznamu s názvy šablon jsou zobrazeny pouze otevřené šablony.

    • Možnosti    Vyberte jednu z následujících možností:

      • Možnost Vložit obsah do samostatné stránky vyberte, chcete-li, aby se stavební blok umístil na samostatné stránce se zalomením stránky před stavebním blokem a za ním.

      • Možnost Vložit obsah do samostatného odstavce vyberte, chcete-li, aby se z obsahu vytvořil samostatný odstavec – a to i v případě, že bude kurzor umístěn uprostřed odstavce.

      • Možnost Vložit pouze obsah vyberte pro veškerý ostatní obsah.

Začátek stránky

  1. Na kartě Vložení klikněte na Rychlé části a potom na Automatický text.

  2. Klikněte na položku, kterou chcete přidat.

Přidáním textové položky v dialogovém okně Automatické opravy můžete nakonfigurovat Word automaticky dokončete slovo, slovní spojení nebo větu poté, co jste napsali jenom několik znaků.

  1. Vyberte text, který chcete automaticky vkládat.

  2. Klikněte na kartu Soubor.

  3. Klikněte na položku Možnosti.

  4. Klikněte na položku Kontrola pravopisu a mluvnice.

  5. Klikněte na tlačítko Možnosti automatických oprav a potom na kartu Automatické opravy.

    Dialog Automatické opravy

  6. Zaškrtněte políčko Nahrazovat text během psaní, pokud už není zaškrtnuté.

  7. Do pole Nahrazovat napište znaky, které chcete použít pro automatický text. Text, který jste vybrali v dokumentu, by měl být v poli Za.

Seznam Automatické opravy je globální pro všechny aplikace Office podporující tuto funkci, což znamená, že pokud přidáte slovo do seznamu nebo je odstraníte v jedné aplikaci, projeví se tato změna i v ostatních aplikacích Office.

Začátek stránky

Při psaní v dokumentu v levém sloupci seznamu Automatické opravy klikněte v části Nahradit, se automaticky nahrazuje s textem v pravém sloupci pod s.

Začátek stránky

Viz taky

Konfigurace nebo vypnutí automatického formátování textu (automatického formátu).

Volba možností Automatických oprav pro velká písmena, pravopis a symboly

  1. Na kartě Vložení klikněte na Rychlé části a potom na Automatický text.

  2. Klikněte na položku, kterou chcete přidat.

V aplikaci Word 2010 položek automatického textu uložená jako stavebních bloků. Pokud chcete vytvořit novou položku, použijte dialogové okno vytvořit nový stavební blok.

  1. Ve Wordovém dokumentu vyberte text, který chcete přidat do galerie automatických textů položek.

  2. Na kartě Vložení klikněte ve skupině Text na tlačítko Rychlé části, přejděte na možnost Automatický text a potom klikněte na příkaz Uložit výběr do galerie automatických textů.

  3. Zadejte informace do dialogového okna Vytvořit nový stavební blok:

    • Název    Zadejte jedinečný název pro stavební blok automatického textu.

    • Galerie    Vyberte galerii Automatický text.

    • Kategorie    Vyberte kategorii Obecné nebo vytvořte novou kategorii.

    • Popis    Zadejte popis stavebního bloku.

    • Uložit do    Klikněte v rozevíracím seznamu na název šablony. Například na položku Normal.

      V rozevíracím seznamu s názvy šablon jsou zobrazeny pouze otevřené šablony.

    • Možnosti    Vyberte jednu z následujících možností:

      • Možnost Vložit obsah do samostatné stránky vyberte, pokud chcete, aby se stavební blok umístil na samostatné stránce se zalomením stránky před stavebním blokem a za ním.

      • Možnost Vložit obsah do samostatného odstavce vyberte, chcete-li, aby se z obsahu vytvořil samostatný odstavec – a to i v případě, že bude kurzor umístěn uprostřed odstavce.

      • Možnost Vložit pouze obsah vyberte pro veškerý ostatní obsah.

Začátek stránky

Pokud jste použili položek automatického textu v aplikaci Microsoft Office Word 2003, můžete ručně migrovat je do aplikace Word 2010. Položky automatického textu, které jste vytvořili v aplikaci Word 2007 se migrují automaticky.

  1. Přejděte na soubor Normal11.dot jednu následujícím způsobem:

  2. Pokud váš počítač se systémem Windows 7    Spusťte Průzkumníka Windows a vyhledejte C:\Users\user name\AppData\Roaming\Microsoft\Templates.

    Poznámka : Pokud nevidíte složce AppData v programu Průzkumník Windows, klikněte na Uspořádat klikněte na Možnosti složky a hledání, klikněte na kartu zobrazení a klikněte na tlačítko Zobrazovat skryté soubory, složky a jednotky. Pak zavřete a znovu otevřete Průzkumníka Windows.

  3. Pokud váš počítač se systémem Windows Vista    Spusťte Průzkumníka Windows a vyhledejte C:\Users\user name\AppData\Roaming\Microsoft\Templates.

    Poznámka : Pokud nevidíte složce AppData v programu Průzkumník Windows, klikněte na Uspořádat klikněte na Možnosti složky a hledání, klikněte na kartu zobrazení a klikněte na tlačítko Zobrazovat skryté soubory, složky a jednotky. Pak zavřete a znovu otevřete Průzkumníka Windows.

  4. Pokud váš počítač se systémem Windows XP    Spusťte Průzkumníka Windows a pak přejděte k C:\Documents and Settings\uživatelské ukládají aplikací\microsoft\templates.

    Poznámka : Pokud nevidíte složku Application Data v programu Průzkumník Windows, klepněte v nabídceNástroje klikněte na Možnosti složky, klikněte na kartu zobrazení a klikněte na tlačítko Zobrazovat skryté soubory a složky. Pak zavřete a znovu otevřete Průzkumníka Windows.

  5. Klikněte pravým tlačítkem myši Normal11.dot a potom klikněte na Otevřít.

  6. Klikněte na kartu Soubor.

  7. Klikněte na Uložit jako.

  8. V dialogovém okně Uložit jako přejděte do správného umístění:

  9. Pokud váš počítač se systémem Windows 7    C:\Users\user name\AppData\Roaming\Microsoft\Word\Startup

  10. Pokud váš počítač se systémem Windows Vista    C:\Users\user name\AppData\Roaming\Microsoft\Word\Startup

  11. Pokud váš počítač se systémem Windows XP    C:\Documents and Settings\uživatelské ukládají Data\Microsoft\Word\Startup

    Poznámka : Možná bude potřeba vytvořit složky Po spuštění po kliknutí na nová složka.

  12. Do pole název souboru zadejte Automatický text.

  13. V seznamu Uložit jako typ klikněte na Šablona Word s podporou maker.

  14. Klikněte na Uložit.

    Pokud se zobrazí výzva, klikněte na OK.

  15. Ukončení Wordu

Začátek stránky

K přidání položek textu, které se mají vkládat automaticky po zadání určité skupiny znaků, budete muset použijte dialogové okno Automatické opravy.

  1. Klikněte na kartu Soubor.

  2. Klikněte na položku Možnosti.

  3. Klikněte na položku Kontrola pravopisu a mluvnice.

  4. Klikněte na tlačítko Možnosti automatických oprav a potom na kartu Automatické opravy.

  5. Zaškrtněte políčko Nahrazovat text během psaní, pokud dosud není zaškrtnuto.

  6. Do pole Nahrazovat zadejte znaky, které se mají nahrazovat automatickým textem.

Text, který jste vybrali v dokumentu, by měl být v poli Za.

Začátek stránky

V Microsoft Office Word 2007 můžete přidat položky automatického textu do galerie automatických textů.

Nebo pokud chcete vkládat text automaticky při psaní několik znaků, přidání položek textu v dialogovém okně Automatické opravy.

Pokud chcete přidat automatického textu z galerie, potřebujete přidat galerii na panel nástrojů Rychlý přístup. Až přidáte, můžete vytvořit nové položky a můžete migrovat se položky z aplikace Word 2003 do galerie.

  1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka a pak klikněte na Možnosti aplikace Word.

  2. Klikněte na Přizpůsobit.

  3. V seznamu Zvolit příkazy z klikněte na Všechny příkazy.

  4. Procházejte seznam příkazů se zobrazila Automatický text.

  5. Klikněte na Automatický text a potom klikněte na Přidat.

Tlačítko Automatický text se teď objeví panel nástrojů Rychlý přístup. Klikněte na výběr galerie automatických textů položky automatického textu.

Začátek stránky

  1. Ve Wordovém dokumentu vyberte text, který chcete přidat do galerie automatických textů položek.

  2. V panelu nástrojů Rychlý přístup klikněte na Automatický text a potom klikněte na Uložit výběr do galerie automatických textů.

  3. Zadejte informace do dialogového okna Vytvořit nový stavební blok:

    • Název     Zadejte jedinečný název stavebního bloku.

    • Galerie     Vyberte galerii, ve které se má stavební blok zobrazovat.

    • Kategorie     Vyberte kategorii, třeba Obecné nebo Předdefinované nebo vytvořte novou kategorii.

    • Popis     Zadejte popis stavebního bloku.

    • Uložit do     Klikněte v rozevíracím seznamu na název šablony.

    • V rozevíracím seznamu s názvy šablon jsou zobrazeny pouze otevřené šablony.

    • Možnosti     Vyberte jednu z následujících možností:

      • Možnost Vložit obsah do samostatné stránky vyberte, pokud chcete, aby se stavební blok umístil na samostatné stránce se zalomením stránky před stavebním blokem a za ním.

      • Možnost Vložit obsah do samostatného odstavce vyberte, chcete-li, aby se z obsahu vytvořil samostatný odstavec – a to i v případě, že bude kurzor umístěn uprostřed odstavce.

      • Možnost Vložit pouze obsah vyberte pro veškerý ostatní obsah.

Informace o použití Organizátoru stavebních bloků k vytváření a Správa položek automatického textu najdete v tématu použití rychlých částí a automatického textu ve Wordu.

Pokud jste použili položek automatického textu v aplikaci Microsoft Office Word 2003, můžete ručně migrovat je do aplikace Word 2007.

  1. Zkopírujte soubor Normal11.dot ke složce Document Building Blocks jednu následujícím způsobem:

    • Pokud váš počítač se systémem Windows Vista     Otevřete Průzkumníka Windows a zkopírujte Normal11.dot šablony z C:\Users\user name\AppData\Roaming\Microsoft\Templates C:\Users\user name\AppData\Roaming\Microsoft\Document stavebních bloků.

    • Pokud váš počítač se systémem Windows XP     Otevřete Průzkumníka Windows a zkopírujte Normal11.dot šablony z C:\Documents a Settings\uživatelské ukládají aplikací\microsoft\templates C:\Documents a Settings\uživatelské ukládají Data\Microsoft\Document stavebních bloků.

  2. V Office Word 2007 otevřete šablonu Normal11.dot.

  3. Uložte soubor jako AutoText.dotx.

    Po zobrazení výzvy klikněte na pokračovat.

    1. Klikněte na Tlačítko Microsoft Office Obrázek tlačítka a klikněte na Převést.

Po zobrazení dotazu klikněte na tlačítko OK.

Upgrade soubor nový formát souborů.

  1. Na kartě Vložení ve skupině Text na tlačítko Rychlé části a potom klikněte na Organizátor stavebních bloků.

  2. V Organizátoru stavebních bloků vyberte položku automatického textu, klikněte na Upravit vlastnosti a v seznamu Galerie vyberte galerii odpovídající.

  3. V seznamu Uložit do klikněte na Normal.dotm a klikněte na OK.

  4. Tento postup opakujte pro každou položku automatického textu, který chcete použít v Office Word 2007.

K přidání položek textu, které se mají vkládat automaticky po zadání určité skupiny znaků, budete muset použijte dialogové okno Automatické opravy.

  1. V aplikaci Word 2007 dokumentu, vyberte text, který chcete přidat automaticky.

  2. Klikněte na tlačítko Microsoft Office Obrázek tlačítka a pak klikněte na Možnosti aplikace Word.

  3. Klikněte na možnost Kontrola pravopisu a mluvnice.

  4. Klikněte na Možnosti automatických oprav a pak klikněte na kartu Automatické opravy.

  5. Zaškrtněte políčko Nahrazovat text během psaní, pokud dosud není zaškrtnuto.

  6. Do pole Nahrazovat zadejte znaky, které se mají nahrazovat automatickým textem.

    Text, který jste vybrali v dokumentu, by měl být v poli Za.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×