Archivace dat aplikace Access

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Svoje data můžete udržovat v pořádku pomocí pravidelné archivace starých a neaktivních záznamů. Dejme tomu, že aplikaci Access používáte ke správě výpůjček z knihovny. Pravděpodobně jste si k tomu vytvořili tabulku, v níž sledujete jednotlivé výpůjčky a která obsahuje pole pro zadání data zapůjčení a data vrácení. Předpokládejme, že podle vašich zásad úschovy záznamů chcete archivovat záznamy o výpůjčkách po uplynutí jednoho roku od vrácení a záznamy zcela zničit po uplynutí dvou let.

Archivovat lze všechny tabulky v databázi, pouze vybrané tabulky nebo pouze vybrané záznamy – například záznamy starší než uvedené datum. V tomto tématu se seznámíte s postupy archivace dat.

V tomto článku

Přehled

Pravidelné přesunování záznamů do archivní tabulky

Pravidelná výměna tabulky

Pravidelná výměna všech tabulek

Přehled

Archivaci dat je vhodné zvážit v případě, že existují data, která již nikdy neplánujete použít, ale chcete je mít k dispozici, pokud byste je náhodou potřebovali. Můžete také postupovat podle zásad určujících plánování archivace dat, například podle zásad úschovy dat.

Archivace se obvykle používá k ukládání dat k určitému datu, například ke konci kalendářního měsíce.

Způsoby archivace dat

Následující tabulka popisuje různé způsoby archivace dat, uvádí, kdy je vhodné jednotlivé metody použít, a obsahuje další související informace.

Metoda

Popis

Vhodné použití

Další informace

Pravidelné přesunování záznamů do archivní tabulky

Pravidelně můžete spouštět dotaz, který vybere data určená k archivaci a přidá je do archivní tabulky. Potom můžete spustit dotaz, který stejná data vybere (v původní tabulce) a smaže je.

Některé záznamy v tabulce splňují podmínku, podle níž se určují záznamy pro archivaci.

PŘÍKLAD: Chcete archivovat všechny knihovní položky (výpůjčky), jejichž Datum vrácení je starší než jeden rok.

  • Možná bude potřeba řešení problémů spojených Referenční integrita, zejména pokud jsou na jedné straně Relace 1:N záznamy, které chcete archivovat.

  • Jestliže v dotazech potřebujete používat parametry, je vhodné vytvořit si formulář pro jejich zpracování. V opačném případě hrozí riziko ztráty dat.

Pravidelná výměna tabulky

Pravidelně můžete vytvářet archivní kopii určité tabulky, kterou potom nahradíte novou prázdnou tabulkou.

Všechny záznamy v tabulce splňují podmínku, podle níž se určují záznamy pro archivaci.

PŘÍKLAD: Do tabulky zaznamenáváte nejvyšší a nejnižší denní teploty. Každoročně tabulku archivujete a začínáte znovu s prázdnou.

  • Může být nutné vyřešit referenční integritu.

Pravidelná výměna všech tabulek

Začínáte s rozdělenou databází (obsah databáze: soubor databáze back-end obsahující všechny tabulky; soubor databáze front-end obsahující všechny ostatní objekty databáze). Pravidelně můžete archivovat databázi back-end a potom ji nahradit novou prázdnou databází.

Všechny záznamy ve většině tabulek databáze splňují podmínku, podle níž se určují záznamy pro archivaci.

PŘÍKLAD: Databáze obsahuje několik tabulek s různými druhy meteorologických údajů. Každoročně archivujete všechny tabulky.

  • Jestliže používáte vyhledávací tabulky (tabulky sloužící k ukládání hodnot pro vyhledávání, například poštovních směrovacích čísel nebo názvů oddělení), může být nutné importovat příslušná data do nové databáze back-end.

  • K provedení této metody nelze použít makro. Databázi je nutné archivovat ručně.

Řešení referenční integrity

Pokud záznamy, které chcete archivovat se vztahují k záznamům v jiných tabulkách, bude pravděpodobně informace k alternativním řešením relace. Pokud záznamy, které chcete archivovat jsou záznamy "podřízené" (patří k straně "n" Relace 1:N ), je nejspíš bezpečně archivovat bez problém. Pokud záznamy, které chcete archivovat jsou záznamy parent"(patří k straně"1" Relace 1:N ), můžete archivovat jejich související"podřízené"záznamy dne:

  • Podřízené záznamy zabrání odstranění nadřazených záznamů. Může dojít k problémům v případě, že jste již přidali nadřazené záznamy do archivní tabulky.

    – nebo –

  • Vzniknou osamocené záznamy – záznamy příslušející k neexistujícímu nadřazenému záznamu. To může způsobit potíže s integritou dat a různými funkcemi v databázi, které používají osamocené záznamy.

K zajištění referenční integrity postupujte následujícím způsobem:

  1. Určete, které podřízené záznamy odpovídají záznamům, které chcete archivovat. Pokud například chcete archivovat záznamy o vypůjčených knihách z knihovny, nejdříve zjistěte, zda jsou u těchto knih otevřené nějaké transakce, například zda vypůjčené knihy nebyly dosud vráceny.

  2. Proveďte jednu z následujících akcí:

    • Pokud je možné podřízené záznamy za všech okolností bezpečně odstranit, přesvědčte se, zda relace splňuje referenční integritu, pomocí kaskádového odstranění. Tím zajistíte odstranění všech souvisejících podřízených záznamů.

    • Pokud podřízené záznamy nelze za všech okolností bezpečně odstranit, zvažte archivaci všech tabulek v databázi.

    • Vytvořte dotaz, jímž vyberete nadřazené záznamy, které nemají žádné podřízené záznamy. Potom pomocí tohoto prvního dotazu (nikoli pomocí nadřazené tabulky) vytvořte dotaz pro archivaci (viz oddíl Pravidelné přesunování záznamů do archivní tabulky).

      Tip : Použití Průvodce dotazem pro vyhledání neshodných záznamů. Další informace naleznete v článku porovnání dvou tabulek a vyhledání záznamů bez shody.

Začátek stránky

Pravidelné přesunování záznamů do archivní tabulky

Nejdřív zkontrolujte prázdné kopii tabulku obsahující záznamy, které chcete archivovat. Toto nové prázdné tabulce je tabulka archivu. Dále vytvořte Přidávací dotaz zkopírujte záznamy z původní tabulky do archivu tabulky. Pak vytvoříte Odstraňovací dotaz archivované odeberete z původní tabulky. Nakonec vytváření maker spouštěných obou dotazů. Když chcete archivovat záznamy, spusťte makro.

Tip : Makro lze přiřadit k tlačítku ve formuláři a snadno jej spouštět kliknutím na toto tlačítko.

Krok 1: Vytvoření archivní tabulky

Krok 2: Vytvoření dotazu ke zkopírování dat do archivní tabulky

Krok 3: Vytvoření odstraňovacího dotazu k odebrání archivovaných dat z původní tabulky

Krok 4: Vytvoření makra ke spuštění obou dotazů

Krok 1: Vytvoření archivní tabulky

Chcete-li umístit všechny archivované záznamy do jedné tabulky, stačí provést tento postup pouze jednou. Archivní tabulka vytvořená v tomto kroku bude obsahovat všechny archivované záznamy.

Pokud chcete odstranit staré tabulky archiv, když vytvoříte novou, není potřeba udělat tento krok. Zkopírujte data do archivu tabulky můžete použít Vytvářecí dotaz místo přidávacího dotazu. K tomuto účelu přejděte rovnou na Krok 2.

Pokud chcete při každé archivaci použít novou archivní tabulku a ponechat si staré archivní tabulky, nezapomeňte přejmenovat starou archivní tabulku před vytvořením nové. Pokud provádíte archivaci k určitému datu, zvažte pojmenování starých archivních tabulek podle období, která pokrývají.

Poznámka : Pokud vždy vytváříte novou archivní tabulku a ponecháváte si starou, je nutné starou archivní tabulku přejmenovat před spuštěním dotazu.

  1. V navigačním podokně vyberte tabulku, která obsahuje záznamy k archivaci, stiskněte klávesovou zkratku CTRL+C a potom klávesovou zkratku CTRL+V.

  2. V dialogovém okně Vložit tabulku jako klikněte v části Možnosti vložení na položku Jen struktura.

  3. V poli Název tabulky odstranění slov Kopie a přidat podtržítko a slovo "archivu" název existující tabulky a klikněte na OK. Například pokud původní tabulky jmenuje transakce tabulce archivu se jmenuje Transactions_archive.

    Vložit tabulku jako

Krok 2: Vytvoření dotazu ke zkopírování dat do archivní tabulky

  1. Ve skupině Jiné na kartě Vytvořit klikněte na Návrh dotazu.

  2. Pomocí dialogového okna Zobrazit tabulku přidejte tabulku obsahující záznamy, které chcete archivovat. Zavřete dialogové okno Zobrazit tabulku.

  3. V okně pro návrh dotazu dvakrát klikněte na hvězdičku (*) v právě přidané tabulce. Název tabulky a hvězdička se zobrazí v prvním sloupci návrhové mřížky dotazu.

    Poznámka : Hvězdička označuje skutečnost, že výstup dotazu by měl obsahovat všechna pole z tabulky. Pokud použijete hvězdičku, bude výstup dotazu obsahovat všechna pole i v případě, že dojde k přidání nebo odebrání polí z tabulky.

  4. V okně pro návrh dotazu dvakrát klikněte na pole, které chcete použít k zadání podmínky, kterou mají splňovat záznamy určené pro archivaci. Pokud například tabulka Výpůjčky obsahuje pole nazvané Datum vrácení a chcete archivovat všechny záznamy, jejichž datum vrácení je starší než jeden rok, dvakrát klikněte na pole Datum vrácení. Pole se zobrazí v následujícím prázdném sloupci návrhové mřížky dotazu.

    Návrhová mřížka dotazu

    Pokud chcete nastavit kritéria pro další pole, opakujte tento krok.

  5. Použijte řádek kritérií Pokud chcete určit kritéria pro pole, která jste právě přidali. Například, můžete určit, že zaškrtnuté políčko datum musí být starší než 1. ledna 2008 pomocí výrazu < #1/1/2008 # v řádku kritéria.

    Jestliže se hodnota kritérií mění při každé archivaci, měli byste vytvořit dotaz tak, aby umožňoval zadání hodnoty. Můžete to provést tak, že v řádku Kritéria použijete parametr, pomocí nějž bude možné zadat hodnotu do dotazu. Chcete-li použít parametr, použijte stejný vzorec, který byste běžně zadali, ale místo konkrétní hodnoty zadejte do hranatých závorek stručnou otázku. Můžete například použít výraz <[Archivovat výpůjčky vrácené před datem:], a to následujícím způsobem:

    Výraz s parametrem

    Další informace o používání parametrů naleznete v článku Vytvoření dotazu s výzvou k zadání vstupních hodnot.

    Můžete také použít řádek nebo a zadat další podmínky. Další informace o používání kritérií naleznete ve článku Příklady kritérií dotazů.

    Tip : Pokud k zadání kritérií používáte pole data a chcete archivovat všechny záznamy starší než je aktuální datum, zadejte výraz <Date() v řádku Kritéria pro pole data.

  6. Proveďte jednu z následujících akcí:

    • Pokud jste již vytvořili archivní tabulku, je třeba použít přidávací dotaz k přidání požadovaných záznamů do tabulky.

      1. Na kartě Návrh klikněte ve skupině Typ dotazu na položku Přidat.

      2. V dialogovém okně Přidat vyberte v poli Název tabulky název archivní tabulky a klikněte na tlačítko OK.

        Přidat do

        V návrhové mřížce dotazu se zobrazí řádek Přidat do.

      3. Z řádku Přidat do odstraňte všechna pole, která jste použili k zadání kritérií. (Jedinou hodnotou v poli Přidat do může být hvězdička.)

        Řádek Přidat do v návrhové mřížce dotazu

    • Pokud jste dosud nevytvořili archivní tabulku, použijte vytvářecí dotaz k vytvoření archivní tabulky pomocí vybraných záznamů.

      1. Na kartě Návrh klikněte ve skupině Typ dotazu na položku Vytvořit tabulku.

      2. V dialogovém okně Vytvořit tabulku zadejte do pole Název tabulky název archivní tabulky a klikněte na tlačítko OK.

  7. Stisknutím kombinace kláves CTRL+S dotaz uložte.

Krok 3: Vytvoření odstraňovacího dotazu k odebrání archivovaných dat z původní tabulky

  1. Ve skupině Jiné na kartě Vytvořit klikněte na Návrh dotazu.

  2. Pomocí dialogového okna Zobrazit tabulku přidejte tabulku obsahující záznamy, které chcete archivovat. Zavřete dialogové okno Zobrazit tabulku.

  3. V okně pro návrh dotazu dvakrát klikněte na hvězdičku (*) v právě přidané tabulce. Název tabulky a hvězdička se zobrazí v prvním sloupci návrhové mřížky dotazu.

  4. V okně pro návrh dotazu dvakrát klikněte na pole, které jste použili k zadání podmínky v přidávacím dotazu.

  5. Pomocí řádku Kritéria zadejte kritéria pro pole, která jste právě přidali. Další informace o používání kritérií naleznete v článku Příklady kritérií dotazů.

    Důležité : Pokud jste v přidávacím nebo vytvářecím dotazu použili parametr, je vhodné jej použít také v odstraňovacím dotazu. Navíc se přesvědčte, zda jste pro oba dotazy zadali stejnou hodnotu. Pokud zadáte rozdílné hodnoty parametrů, může dojít ke ztrátě dat. Chcete-li ztrátě dat zabránit, zvažte použití formuláře k zadání hodnot a navržení dotazů tak, aby vstupní hodnoty byly zjišťovány z formuláře. Další informace naleznete v článku Vytvoření dotazu s výzvou k zadání vstupních hodnot.

  6. Na kartě Návrh klikněte ve skupině Typ dotazu na položku Odstranit.

    V návrhové mřížce dotazu se zobrazí řádek Odstranit.

    Řádek Odstranit v návrhové mřížce dotazu

  7. Stisknutím kombinace kláves CTRL+S dotaz uložte.

Krok 4: Vytvoření makra ke spuštění obou dotazů

  1. Na kartě Vytvořit klikněte ve skupině Jiné na položku Makro. Není-li tento příkaz k dispozici, klikněte na šipku pod tlačítkem Modul nebo pod tlačítkem Modul třídy a potom klikněte na položku Makro.

  2. V prvním řádku návrhové mřížky, ve sloupci Akce vyberte OtevřítDotaz.

    Akce makra OtevřítDotaz

  3. V dolní části mřížky v seznamu Argumentů do pole Název dotazu vyberte (připojit nebo vytvářecích) dotaz, který jste vytvořili v kroku 2 z rozevíracího seznamu.

    Argument dotazu akce makra OtevřítDotaz

  4. Ve druhém řádku návrhové mřížky, ve sloupci Akce vyberte OtevřítDotaz.

  5. V dolní části mřížky v seznamu Argumentů do pole Název dotazu vyberte odstraňovacího dotazu z rozevíracího seznamu.

    Makro by měl vypadat nějak takto:

    Makro připravené k uložení

  6. Stisknutím klávesové zkratky CTRL+S makro uložte.

    Budete-li chtít archivovat záznamy, spusťte makro.

Začátek stránky

Pravidelná výměna tabulky

Budete-li vždy chtít archivovat všechna data v tabulce, nemusíte používat dotazy ani makra. Místo toho můžete pravidelně vyměňovat tabulku za její prázdnou kopii.

Důležité : Pokud je tabulka, kterou chcete archivovat, součástí relace s jinými tabulkami, může být nutné vyřešit referenční integritu.

  1. V navigačním podokně vyberte tabulku, kterou chcete archivovat, stiskněte klávesovou zkratku CTRL+C a potom klávesovou zkratku CTRL+V.

  2. V dialogovém okně Vložit tabulku jako klikněte v části Možnosti vložení na položku Jen struktura a potom na tlačítko OK.

    Access názvy výtisku kopie původní název tabulky.

  3. V navigačním podokně klikněte pravým tlačítkem myši na původní tabulku a potom v místní nabídce na příkaz Přejmenovat.

    Pojmenujte tabulku, která označuje, co je obsahuje, například "DailyTemperatureExtremes_archive_2007".

  4. V navigačním podokně klikněte pravým tlačítkem na prázdnou kopii tabulky a potom v místní nabídce klikněte na příkaz Přejmenovat.

    Přejmenujte prázdnou kopii podle názvu původního souboru.

Začátek stránky

Pravidelná výměna všech tabulek

Pokud používáte rozdělenou databázi, můžete pravidelně vyměňovat všechny tabulky náhradou databáze back-end její prázdnou kopií.

Nejdříve je třeba připravit si prázdnou kopii databáze. Jestliže se nebude měnit návrh databáze, můžete tuto kopii znovu použít při další archivaci. V takovém případě bude při archivaci stačit přejmenovat stávající databázi back-end na archivní a potom uložit prázdnou kopii jako novou databázi back-end.

Vytvoření prázdné kopie databáze back-end

Importujte definice tabulek pro všechny tabulky v databázi back-end.

  1. Vytvořte novou prázdnou databázi. Odstraňte Tabulku1.

  2. Na kartě Externí data klepněte ve skupině Importovat na položku Access.

  3. V dialogovém okně Načíst externí data klikněte na přepínač Importovat tabulky, dotazy, formuláře, sestavy, makra a moduly do aktuální databáze a potom na tlačítko Procházet.

  4. V dialogovém okně Otevřít soubor vyberte požadovanou databázi back-end. Kliknutím na tlačítko Otevřít zavřete dialogové okno Otevřít soubor a potom klikněte na tlačítko OK.

  5. V dialogovém okně Import objektů klikněte na tlačítko Možnosti.

  6. V části Import tabulek klikněte na přepínač Jen definice.

  7. Na kartě Tabulky klikněte na tlačítko Vybrat vše, potom na tlačítko OK a nakonec na tlačítko Zavřít.

Potom přidejte data do všech vyhledávacích tabulek v prázdné kopii tabulky. U každé vyhledávací tabulky proveďte následující kroky:

  1. Propojte vyhledávací tabulku z existující databáze back-end.

  2. Vytvořte přidávací dotaz, kterým přidáte všechny záznamy z původní tabulky do nové tabulky.

Náhrada databáze back-end prázdnou kopií

Nejprve přejmenujte stávající databázi back-end a označte ji jako archiv.

Potom otevřete novou prázdnou databázi a uložte ji s názvem původní databáze back-end.

  1. Klikněte na Tlačítko Microsoft Office Obrázek tlačítka a potom přejděte na příkaz Uložit jako. Otevření nabídky Uložit jako.

  2. V části Uložit databázi jako jiný formát klepněte na možnost Databáze aplikace Access 2007.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×