Aktualizace externího datového připojení

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Svůj excelový sešit můžete připojit k externímu zdroji dat, třeba k databázi SQL Serveru, krychli OLAP nebo i jinému excelovému sešitu. Toto připojení se může v sešitu zobrazovat jako tabulka, sestava kontingenční tabulky nebo kontingenční graf.

Data zobrazená v sešitu můžete udržovat v aktuálním stavu tak, že „obnovíte“ (aktualizujete) odkaz na jejich zdroj. Při každé aktualizaci připojení se zobrazí nejnovější verze dat se vším novým nebo odstraněným.

Začátek stránky

Aktualizace dat z aplikace Microsoft Query, Průvodce datovým připojením nebo webového dotazu

  1. Klikněte na libovolnou buňku v oblasti nebo tabulce, která obsahuje odkaz na externí data.

  2. Klikněte na Data > připojení a klikněte na šipku vedle Aktualizovat vše.

Aktualizovat datové připojení

  1. Když chcete aktualizovat jenom vybraná data, klikněte na Aktualizovat.

Můžete taky kliknout na buňku v oblasti nebo tabulce pravým tlačítkem a potom kliknout na Aktualizovat.

  1. Pokud chcete aktualizovat všechna datová připojení v sešitu, klikněte na Aktualizovat vše.

Poznámka : Pokud je otevřeno více sešitů, je potřeba opakovat tuto operaci v každém sešitu.

Začátek stránky

Aktualizace dat z importovaného textového souboru

  1. Klikněte na libovolnou buňku v oblasti nebo tabulce, která obsahuje odkaz na importovaný textový soubor.

  2. Na kartě Data klikněte ve skupině Připojení na šipku vedle Aktualizovat vše.

Aktualizovat datové připojení

  1. Když chcete aktualizovat jenom vybraná data, klikněte na Aktualizovat.

  2. Pokud chcete aktualizovat všechna datová připojení v sešitu, klikněte na Aktualizovat vše.

Můžete taky kliknout na buňku v oblasti nebo tabulce pravým tlačítkem a potom kliknout na Aktualizovat.

  1. V dialogovém okně Importovat textový soubor najděte textový soubor a potom klikněte na Importovat.

Začátek stránky

Aktualizace dat doplňku Power Pivot

  1. Na kartě Data klikněte ve skupině Připojení na Připojení.

Datová připojení

  1. V dialogu Připojení sešitu vyberte připojení pro svoje data doplňku Power Pivot a klikněte na Aktualizovat.

Začátek stránky

Aktualizace souboru offline datové krychle

Aktualizace souboru offline datové krychle, při které je soubor znovu vytvořený s použitím nejnovějších dat krychle na serveru, může být časově náročná a vyžadovat velké množství dočasného místa na disku. Proces aktualizace spusťte v době, kdy nepotřebujete okamžitý přístup k ostatním souborům v Excelu, a ujistěte se, jestli je na disku dost místa, aby se dal soubor uložit znovu.

  1. Klikněte na kontingenční tabulku připojenou k souboru offline datové krychle.

  2. Klikněte na Data > Připojení, klikněte na šipku vedle Aktualizovat vše a potom klikněte na Aktualizovat.

    Aktualizovat datové připojení

Začátek stránky

Aktualizace dat v importovaném souboru XML

  1. Na listu vyberte kliknutím na mapovanou buňku požadované mapování XML, které chcete aktualizovat.

  2. Pokud není dostupná karta Vývojář, zobrazte ji takto:

    1. Klikněte na Soubor > Možnosti.

    2. Klikněte na položku Přizpůsobit pás karet, a v části Hlavní karty, zaškrtněte políčko Vývojář.

    3. Klikněte na tlačítko OK.

  3. Na kartě Vývojář klikněte ve skupině XML na tlačítko Aktualizovat data.

    Aktualizovat data XML

Začátek stránky

Automatická aktualizace dat při otevření sešitu

Oblast externích dat můžete automaticky aktualizovat při otevření sešitu. Volitelně můžete sešit uložit, aniž byste ukládali externí data, aby se velikost souboru zmenšila.

  1. Klikněte na buňku v oblasti externích dat.

  2. Klikněte na Data > připojení, klikněte na šipku vedle Aktualizovat vše a potom klikněte na Vlastnosti připojení.

Vlastnosti připojení

  1. Klikněte na kartu Použití.

  2. V části Nastavení aktualizace zaškrtněte políčko Aktualizovat data při otevření souboru.

  3. Chcete-li sešit uložit s definicí dotazu, ale bez externích dat, zaškrtněte políčko Odebrat data z oblasti externích dat před uložením sešitu.

Začátek stránky

Automatická aktualizace dat v pravidelných intervalech

  1. Klikněte na buňku v oblasti externích dat.

  2. Klikněte na Data > Připojení, klikněte na šipku vedle Aktualizovat vše a potom klikněte na Vlastnosti připojení.

Vlastnosti připojení

  1. Klikněte na kartu Použití.

  2. Zaškrtněte políčko Obnovovat každých a potom zadejte počet minut mezi jednotlivými aktualizacemi.

Začátek stránky

Požadování hesla pro aktualizaci oblasti externích dat

Uložená hesla nejsou šifrovaná, takže se je nedoporučuje používat. Pokud je pro připojení ke zdroji dat potřebné Heslo, můžete požadovat, aby ho uživatelé museli zadat před aktualizací oblasti externích dat. Následující postup nejde použít pro data načítaná z textového souboru (.txt) nebo webového dotazu (.iqy).

Používejte silná hesla kombinující malá a velká písmena, čísla a symboly. Slabá hesla obsahují jenom některé z těchto znaků. Příklad silného hesla: Y6dh!et5. Příklad slabého hesla: Domek27. Hesla by měla obsahovat minimálně 8 znaků. Ještě vhodnější jsou hesla obsahující 14 nebo víc znaků.

Je nezbytné, abyste si svoje heslo pamatovali. Když ho zapomenete, nebude ho moct Microsoft načíst. Poznamenaná hesla si uložte na bezpečném místě, jinde, než jsou informace, které tato hesla pomáhají chránit.

  1. Klikněte na buňku v oblasti externích dat.

  2. Klikněte na Data > Připojení, klikněte na šipku vedle Aktualizovat vše a potom klikněte na Vlastnosti připojení.

Vlastnosti připojení

  1. Klikněte na kartu Definice.

  2. Zrušte zaškrtnutí políčka Uložit heslo.

Poznámka : V aplikaci Excel se výzva k zadání hesla zobrazí jen při první aktualizaci oblasti externích dat v každé relaci této aplikace. Pokud při dalším spuštění Excelu otevřete sešit obsahující dotaz a pokusíte se provést aktualizaci, budete k zadání hesla vyzvaní znovu.

Začátek stránky

Spuštění dotazu na pozadí nebo čekání na jeho výsledek

Pokud se jedná o rozsáhlé sady dat, měli byste zvážit použití aktualizace na pozadí. Budete moct zase pracovat s Excelem a nebudete muset čekat několik minut, než se aktualizace dokončí.

  1. Klikněte na buňku v oblasti externích dat.

  2. Klikněte na Data > Připojení, klikněte na šipku vedle Aktualizovat vše a potom klikněte na Vlastnosti připojení.

    Poznámky : 

    • Dotaz OLAP nejde spustit na pozadí.

    • Dotaz nejde spustit pro žádný typ připojení, který načítá data pro datový model.

Vlastnosti připojení

  1. Klikněte na kartu Použití.

  2. Pokud chcete dotaz spustit na pozadí, zaškrtněte políčko Povolit aktualizaci na pozadí. V případě, že chcete dotaz spustit a čekat na jeho výsledek, zrušte zaškrtnutí tohoto políčka.

Poznámka : Během zaznamenávání Makro, které obsahuje dotaz Excelu nepustí dotaz na pozadí. Pokud chcete změnit zaznamenané makro tak, aby dotaz běží na pozadí, upravte makro v Visual Basic Editor. Změňte způsob aktualizace objektu zBackgroundQuery: = FalseBackgroundQuery: = True. Informace o upravování maker naleznete v tématu Visual Basic aplikací Nápověda.

Začátek stránky

Zrušení nebo kontrola stavu aktualizace

Pokud je sešit připojený k rozsáhlému zdroji dat, může aktualizace trvat delší dobu. Pokud chcete zkontrolovat stav aktualizace nebo ji zrušit, udělejte jeden z následujících kroků:

  • Zkontrolujte stav dotazu:    Na stavovém řádku Excelu se zobrazí zpráva o tom, že je dotaz spuštěný. Poklikáním na tuto zprávu můžete zkontrolovat stav dotazu.

  • Zastavte aktualizaci na pozadí:    Pokud chcete zastavit dotaz spuštěný na pozadí, poklikejte na stavovém řádku na zprávu o stavu dotazu. Zobrazí se dialogové okno Stav aktualizace externích dat. V něm klikněte na Zastavit aktualizaci.

  • Zastavte dotaz:    Pokud chcete zastavit spuštěný dotaz a aktualizace na pozadí je vypnutá, stiskněte klávesu Esc.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×