Úvod do dotazů

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Pokud chcete zkontrolovat, přidání, změna nebo odstranění dat z databáze zvažte použití dotazu.

Pomocí dotazů můžete najít odpovědi na velmi specifické otázky týkající se dat, které by bylo obtížné získat přímým nahlížením do dat tabulky. Dotazy umožňují data filtrovat, provádět s nimi výpočty a vytvářet jejich souhrny. Rovněž lze pomocí nich automatizovat mnoho úloh správy dat a kontrolovat změny dat před jejich potvrzením.

Poznámka : Funkce agregace dotazu, jako třeba součtu nebo počtunejsou k dispozici ve webové dotazy.

Použití dotazů usnadňuje mnoho databázových úloh.

V tomto článku

Přehled

Zobrazení podmnožiny dat v tabulce

Současné prohlížení dat z více než jedné tabulky

Požádejte varianty dotazu pomocí parametrů

Provádění výpočtů na základě dat

Zobrazení souhrnných neboli agregovaných dat

Vytvoření nové tabulky z dat z jiných tabulek

Přidání dat z jiných tabulek do tabulky

Automatizované změny dat

Automatizované odstranění dat

Přehled

Tento článek obsahuje základní informace o dotazech a příklady různých typů dotazů.

Dotaz představuje požadavek na zobrazení výsledků dat, na provedení akce s daty nebo na kombinaci těchto dvou operací. Pomocí dotazu můžete odpovědět na jednoduchou otázku, provést výpočty, sloučit data z různých tabulek nebo dokonce přidat, změnit či odstranit data tabulky. Dotazy, které použijete k načtení dat z tabulky nebo provedení výpočtů, se nazývají výběrové dotazy. Dotazy, které slouží k přidání, změně nebo odstranění dat, se nazývají akční dotazy.

Dotaz může být rovněž zdrojem dat pro formulář nebo sestavu. V dobře navržené databázi se data, která chcete prezentovat ve formuláři nebo sestavě, nacházejí v několika různých tabulkách. Dotaz umožňuje před navržením formuláře nebo sestavy požadovaná data shromáždit.

Další informace o použití dotazu jako zdroje dat pro formuláře a sestavy naleznete v odkazech v části Viz také nebo v nápovědě.

Otevření existujícího dotazu

Pokud dosud nejste seznámeni s používáním navigačního okna, možná zatím nevíte, jak otevřít již existující dotaz. Navigační podokno je funkce, která nahrazuje okno Databáze používané ve verzích před aplikací Access 2007. Navigační podokno se zobrazuje na levé straně obrazovky.

Chcete-li otevřít databázový objekt, tedy i dotaz, stačí na něj v navigačním podokně dvakrát kliknout.

Vyzkoušení následujícího postupu pomocí ukázkové databáze Northwind

Poznámka : V příkladech v tomto článku se používá databáze vytvořená pomocí šablony databáze Northwind 2010.

  1. Klikněte na kartu Soubor a potom na položku Nový.

  2. V prostředním podokně klikněte v části Dostupné šablony na položku Ukázkové šablony a potom na položku Northwind.

  3. V pravém podokně zkontrolujte název databáze v poli Název souboru a případně proveďte změny názvu. Kliknutím na ikonu složky můžete vyhledat jiné umístění souboru.

  4. Klikněte na tlačítko Vytvořit.

  5. Podle pokynů na stránce Northwind Traders (na kartě objektu Úvodní obrazovka) otevřete databázi a potom zavřete přihlašovací dialogové okno.

Začátek stránky

Zobrazení podmnožiny dat v tabulce

V určitých případech je vhodné zobrazit všechna data z tabulky, ale jindy je výhodnější zobrazit pouze data z určitých polí nebo zobrazit pouze data z polí, která splňují určitá kritéria. Chcete-li zobrazit pouze určitá data z tabulky, použijte výběrový dotaz.

Předpokládejme, že chcete zobrazit seznam výrobků a jejich ceny. Dotaz vracející informace o výrobcích a cenách můžete vytvořit následujícím způsobem:

  1. Otevřete databázi Northwind, kterou jste dříve nastavili pomocí těchto kroků.

  2. Na kartě Vytvoření klikněte ve skupině Dotaz na tlačítko Návrh dotazu.

  3. V dialogovém okně Zobrazit tabulku poklepejte na kartě Tabulky na položku Výrobky.

  4. Zavřete dialogové okno Zobrazit tabulku.

  5. V tabulce Výrobky poklepejte na položky Název výrobku a Ceníková cena, čímž tato pole přidáte do Návrhová mřížka dotazu.

  6. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

    Dotaz se spustí a následně zobrazí seznam výrobků a jejich ceny.

Začátek stránky

Současné prohlížení dat z více než jedné tabulky

Tabulky v dobře navržené databázi mají mezi sebou logické vztahy. Tyto vztahy fungují na základě polí, které mají tabulky společné. Pro prohlížení dat ze souvisejících tabulek použijete výběrový dotaz.

Předpokládejme, že chcete prohlížet objednávky zákazníků, kteří mají bydliště v určitém městě. Údaje o objednávkách a údaje o zákaznících jsou uloženy ve dvou tabulkách ve stejné databázi. Každá tabulka má pole Kód zákazníka, které tvoří základ Relace 1:N mezi oběma tabulkami. Dotaz vracející objednávky pro zákazníky v konkrétním městě, například v Las Vegas, můžete vytvořit pomocí následujícího postupu:

  1. Otevřete databázi Northwind, kterou jste dříve nastavili pomocí těchto kroků.

  2. Na kartě Vytvoření klikněte ve skupině Dotaz na tlačítko Návrh dotazu.

  3. V dialogovém okně Zobrazit tabulku poklepejte na kartě Tabulky na položku Zákazníci a Objednávky.

  4. Zavřete dialogové okno Zobrazit tabulku.

    Povšimněte si čáry (zvané spojení), která spojuje pole ID v tabulce Zákazníci a pole ID zákazníka v tabulce Objednávky. Tato čára zobrazuje relaci mezi oběma tabulkami.

  5. V tabulce Zákazníci dvakrát klikněte na položky Společnost a Město, čímž tato pole přidáte do návrhové mřížky dotazu.

  6. V návrhové mřížce dotazu, ve sloupci Město zrušte zaškrtnutí políčka v řádek Zobrazit.

  7. V řádku Kritéria zadejte ve sloupci Město hodnotu Las Vegas.

    Zrušením zaškrtnutí políčka Zobrazit zabrání zobrazení město jeho výsledky dotazu a napíšou je do řádku kritériahodnotu Las Vegas Určuje, že chcete zobrazit jenom záznamy, které pole Město hodnotu Las Vegas. V tomto případě dotaz vrátí jenom zákazníky, které se nacházejí v Las Vegas – L a Společnost AA.

    Všimněte si, že pole, které chcete použít v kritériu, nemusíte zobrazit.

  8. V tabulce Objednávky dvakrát klikněte na položku ID objednávky a Datum objednávky, čímž tato pole přidáte do dalších dvou sloupců návrhové mřížky dotazu.

  9. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

    Dotaz se spustí a následně zobrazí seznam objednávek pro zákazníky v Las Vegas.

  10. Stisknutím kombinace kláves CTRL+S dotaz uložte.

    Zobrazí se dialogové okno Uložit jako.

  11. Do pole Název dotazu zadejte text Objednávky podle města a klepněte na tlačítko OK.

Začátek stránky

Požádejte varianty dotazu pomocí parametrů

Někdy může být potřeba spustit dotaz, který se jen mírně liší od existujícího dotazu. Původní dotaz sice můžete změnit tak, aby zahrnoval nová kritéria, avšak pokud chcete často spouštět varianty určitého dotazu, zvažte použití parametrického dotazu. Když spustíte parametrický dotaz, zobrazí se výzva k zadání hodnot polí a vámi zadané hodnoty se následně použijí k vytvoření kritérií pro daný dotaz.

V předchozím příkladu jste vytvořili dotaz vracející objednávky pro zákazníky se sídlem v Las Vegas. Dotaz můžete změnit tak, aby při každém spuštění zobrazoval výzvu k zadání města, a to následujícím způsobem:

  1. Otevřete databázi Northwind, kterou jste dříve nastavili pomocí těchto kroků.

  2. Stisknutím klávesy F11 zobrazte navigační podokno.

    Poznámka : Tento krok není nutný, je-li navigační podokno zobrazeno.

  3. V navigačním podokně klepněte pravým tlačítkem myši na dotaz s názvem Objednávky podle města (vytvořený v předchozí části) a potom klepněte na příkaz Návrhové zobrazení v místní nabídce.

  4. V návrhové mřížce dotazu, v řádku kritéria sloupce město odstranit Las Vegasa napište [jaké city?].

    Řetězec [pro jaké city?] je svoji výzvu k zadání parametru. Hranaté závorky znamená to, můžete dotaz požádání uživatele o zadání vstupních hodnot a textem (v tomto případě pro k čemu města?) je otázku, která se zobrazí výzva k zadání parametru.

    Poznámka : Text ve výzvě k zadání parametru nesmí obsahovat tečku (.) ani vykřičník (!).

  5. Zaškrtněte políčko na řádku Zobrazit sloupce Město, aby se ve výsledcích dotazu zobrazilo město.

  6. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

    Dotaz zobrazí výzvu k zadání hodnoty pro pole Město.

  7. Zadejte hodnotu New York a stiskněte klávesu ENTER.

    Dotaz se spustí a následně zobrazí objednávky pro zákazníky v New Yorku.

    Ale co v případě, že nevíte, jaké hodnoty lze zadat? Aby byl parametr flexibilnější, můžete jako součást výzvy použít zástupné znaky:

  8. Na kartě Domů klikněte ve skupině Zobrazení na položku Zobrazení a potom na položku Návrhové zobrazení.

  9. V návrhové mřížce dotazu zadejte na řádku Kritéria ve sloupci Město řetězec Like [Pro které město?]&"*".

    V tento parametr objeví se výzva, jako jsou klíčové slovo, ampersand (&), a na hvězdičku (*) mezi uvozovkami povolte tak uživateli zadejte kombinaci znaků včetně zástupné znaky, vrátíte různé výsledky. Například pokud uživatel zadá *, vrátí dotaz všech měst; Pokud uživatel zadá Ldotaz vrátí všech měst, které začínají písmenem "L"; a uživatel zadá * s *, dotaz vrací všechny měst, které obsahují písmeno "s".

  10. Na kartě Návrh klepněte ve skupině Výsledky na tlačítko Spustit.

    Do výzvy dotazu zadejte text New a potom stiskněte klávesu ENTER.

  11. Dotaz se spustí a následně zobrazí objednávky pro zákazníky v New Yorku.

Zadání datových typů parametrů

Měli byste rovněž zadat, jaký datový typ by měl parametr přijímat. Datový typ můžete nastavit pro libovolný parametr, avšak je zvlášť důležité jej nastavit pro číselná data, údaje s uvedením měny nebo kalendářní data a časy. Zadáte-li pro parametr přijímaný datový typ, zobrazí se uživatelům užitečnější chybová zpráva v případě, že zadají chybný datový typ, například při zadání textu namísto očekávané částky s uvedením měny.

Poznámka : Pokud je parametr nastaven na příjem textových dat, bude jakýkoli vstup interpretován jako text a nezobrazí se žádná chybová zpráva.

Chcete-li pro parametry v dotazu zadat datový typ, postupujte následujícím způsobem:

  1. Při otevření dotazu v návrhovém zobrazení klepněte na kartě Návrh ve skupině Zobrazit či skrýt na možnost Parametry.

  2. V dialogovém okně Parametry dotazu zadejte ve sloupci Parametr výzvu pro každý parametr, pro který chcete zadat datový typ. Ověřte, zda každý parametr odpovídá výzvě použité na řádku Kritéria v návrhové mřížce dotazu.

  3. Ve sloupci Datový typ vyberte datový typ pro každý parametr.

Začátek stránky

Provádění výpočtů na základě dat

Tabulky se povětšinou nepoužívají k ukládání vypočtených hodnot, které jsou založeny na datech ve stejné databázi. Například tabulka Rozpis objednávek v databázi Northwind 2007 neobsahuje mezisoučty výrobků, protože mezisoučet pro libovolný daný výrobek se vypočítává na základě dat uložených v polích Množství, Cena za kus a Sleva v tabulce Rozpis objednávek.

V některých případech vypočtené hodnoty mohou zastarat, protože hodnoty, na kterých jsou založeny, se změní. Například není vhodné ukládat v tabulce věk osob, protože každý rok byste tuto hodnotu museli aktualizovat – místo toho uložíte datum narození dané osoby a potom pomocí výrazu v dotazu vypočtete věk.

Pomocí následujícího postupu vytvoříte dotaz, který vypočte mezisoučty výrobků na základě dat z tabulky Rozpis objednávek.

  1. Otevřete databázi Northwind, kterou jste dříve nastavili pomocí těchto kroků.

  2. Na kartě Vytvoření klikněte ve skupině Dotaz na tlačítko Návrh dotazu.

  3. V dialogovém okně Zobrazit tabulku poklepejte na kartě Tabulky na položku Rozpis objednávek.

  4. Zavřete dialogové okno Zobrazit tabulku.

  5. V tabulce Rozpis objednávek poklepejte na položku Kód výrobku, čímž toto pole přidáte do prvního sloupce návrhové mřížky dotazu.

  6. Ve druhém sloupci mřížky klepněte pravým tlačítkem myši na řádek Pole a potom klepněte na příkaz Lupa v místní nabídce.

  7. Do pole Lupa zadejte nebo vložte následující řetězec:

    Mezisoučet: ([Množství]*[Cena za kus])-([Množství]*[Cena za kus]*[Sleva])

    Klikněte na OK.

    Toto je počítané pole. Vynásobí množství každého počítaného pole produkt jednotkovou cenou pro tento výrobek vynásobí množství každý produkt Jednotková cena a sleva pro tento výrobek a potom odečtením hodnoty Celková sleva z celkové Jednotková cena.

  8. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

    Dotaz se spustí a následně zobrazí seznam výrobků a mezisoučty pro jednotlivé objednávky.

  9. Stisknutím kombinace kláves CTRL + S uložte dotaz a pojmenujte jej mezisoučty Výrobků.

Začátek stránky

Zobrazení souhrnných neboli agregovaných dat

Při použití tabulek pro zaznamenávání transakcí nebo ukládání pravidelně se vyskytujících číselných dat je užitečné mít možnost prohlížet tato data v agregované podobě, například jako součty nebo průměry.

Access umožňuje zkontrolovat simple agregace dat v libovolné Datový list přidáním řádek Součet. Řádek souhrnů tvoří jeden řádek v dolní části datového listu, který lze zobrazit mezisoučet nebo jiné agregace hodnoty.

Poznámka : Řádek Celkem nelze přidat do datového listu webového dotazu.

Řádek Celkem můžete následujícím způsobem přidat do dotazu Mezisoučty výrobků vytvořeného v předchozím příkladu:

  1. Spusťte dotaz Mezisoučty výrobků a ponechejte výsledky otevřené v Zobrazení Datový list.

  2. Na kartě Domů klepněte ve skupině Záznamy na položku Souhrny.

    Na dolním okraji datového listu se zobrazí nový řádek se slovem Součet v prvním sloupci.

  3. Klepněte na buňku v posledním řádku datového listu s názvem Součet.

    Všimněte si, že se v buňce objeví šipka.

  4. Klepnutím na šipku zobrazíte dostupné agregační funkce.

    Protože sloupec obsahuje textová data, jsou k dispozici jen dvě možnosti: Žádný a Počet.

  5. Klepněte na položku Počet.

    Obsah buňky se změní z textu Součet na počet hodnot ve sloupci.

  6. Klepněte na vedlejší buňku (druhý sloupec).

    Všimněte si, že se v buňce objeví šipka.

  7. Klepněte na šipku a potom na položku Součet.

    Pole zobrazí součet hodnot ve sloupci.

  8. Ponechejte dotaz otevřený ve zobrazení datového listu.

Vytvoření souhrnného dotazu pro získání složitějších souhrnů

Řádek Součet v datovém listu je velmi užitečný, avšak v případě složitějších otázek se používá souhrnný dotaz. Souhrnný dotaz představuje výběrový dotaz, který umožňuje seskupit a shrnout data. Předpokládejme například, že chcete zobrazit celkový prodej pro jednotlivé výrobky. V souhrnném dotazu můžete ke zobrazení celkového prodeje pro jednotlivé výrobky použít funkci Součet, což je Agregační funkce.

Poznámka : Agregační funkce nelze používat ve webovém dotazu.

Provedením následujícího postupu upravíte dotaz Mezisoučty výrobků tak, aby mezisoučty jednotlivých výrobků shrnoval.

  1. Na kartě Domů klikněte ve skupině Zobrazení na položku Zobrazení a potom na položku Návrhové zobrazení.

    Dotaz Mezisoučty výrobků se otevře v návrhovém zobrazení.

  2. Na kartě Návrh klepněte ve skupině Zobrazit/Skrýt na položku Souhrny.

    V návrhové mřížce dotazu se zobrazí řádek Součty.

    Poznámka : Řádek Součty v návrhové mřížce není totéž co řádek Součet v datovém listu, ačkoli mají podobný název:

    • Pomocí řádku Součty v návrhové mřížce můžete seskupovat data podle hodnot polí.

    • Řádek Součet v datovém listu můžete přidat do výsledků souhrnného dotazu.

    • Pokud použijete řádek Součty v návrhové mřížce, je třeba zvolit agregační funkci pro každé pole. Nechcete-li u pole provést výpočet, můžete podle něj provést seskupení.

  3. Ve druhém sloupci návrhové mřížky vyberte na řádku Celkem z rozevíracího seznamu funkci Součet.

  4. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

    Dotaz se spustí a následně zobrazí seznam výrobků s mezisoučty.

  5. Stisknutím kombinace kláves CTRL+S dotaz uložte. Ponechejte dotaz otevřený.

Vytvoření křížového dotazu pro přidání další úrovně seskupení

Nyní předpokládejme, že chcete prohlížet mezisoučty výrobků, avšak zároveň chcete provést agregaci podle měsíců, aby každý řádek zobrazoval mezisoučty pro výrobky a každý sloupec mezisoučty výrobků za měsíc. Mezisoučty pro výrobky a mezisoučty výrobků za měsíc zobrazíte pomocí Křížový dotaz.

Poznámka : Křížový dotaz nelze ve webovém prohlížeči.

Dotaz Mezisoučty výrobků můžete znovu upravit tak, aby vracel řádky s mezisoučty výrobků a sloupce s měsíčními mezisoučty.

  1. Na kartě Domů klikněte ve skupině Zobrazení na položku Zobrazení a potom na položku Návrhové zobrazení.

  2. Ve skupině Nastavení dotazu klepněte na tlačítko Zobrazit tabulku.

  3. V dialogovém okně Zobrazit tabulku poklepejte na položku Objednávky a potom klepněte na tlačítko Zavřít.

  4. Na kartě Návrh klikněte ve skupině Typ dotazu na položku Křížový.

    V návrhové mřížce je řádek Zobrazit skrytý a řádek Křížová tabulka zobrazený.

  5. Ve třetím sloupci návrhové mřížky klepněte pravým tlačítkem myši na řádek Pole a potom klepněte na příkaz Lupa v místní nabídce. Otevře se okno Lupa.

  6. Do pole Lupa zadejte nebo vložte následující řetězec:

    Měsíc: "Měsíc " & DatePart("m", [Datum objednávky])

  7. Klikněte na tlačítko OK.

  8. Na řádku Křížová tabulka vyberte z rozevíracího seznamu následující hodnoty: Záhlaví řádku pro první sloupec, Hodnota pro druhý sloupec a Záhlaví sloupce pro třetí sloupec.

  9. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

    Dotaz se spustí a následně zobrazí mezisoučty výrobků agregované podle měsíců.

  10. Stisknutím kombinace kláves CTRL+S dotaz uložte.

Začátek stránky

Vytvoření nové tabulky z dat z jiných tabulek

K vytvoření nové tabulky z dat uložených v jiných tabulkách můžete použít vytvářecí dotaz.

Poznámka : Vytvářecí dotaz nejde spustit ve webovém prohlížeči.

Pokud například chcete odeslat data týkající se objednávek uskutečněných v Chicagu svému obchodnímu partnerovi z Chicaga, který používá aplikaci Access k vytváření sestav, nebudete pravděpodobně odesílat veškerá data objednávek, ale pouze data objednávek z Chicaga.

Provedením následujícího postupu můžete sestavit výběrový dotaz, který shromáždí data týkající se objednávek pro Chicago, a potom na základě tohoto dotazu vytvořit novou tabulku:

  1. Otevřete databázi Northwind, kterou jste dříve nastavili pomocí těchto kroků.

  2. Pokud chcete spustit vytvářecí dotaz a otevřená databáze nepochází z důvěryhodného umístění, bude pravděpodobně nutné povolit obsah databáze pomocí panelu zpráv, který se zobrazí pod pásem karet.

    Ukázat postup povolení databáze

    • Na panelu zpráv klikněte na tlačítko Povolit obsah.

    Pokud je databáze v důvěryhodném umístění, panel zpráv se nezobrazí a povolení obsahu není nutné.

  3. Zavřete formulář Přihlašovací dialogové okno.

  4. Na kartě Vytvoření klikněte ve skupině Dotaz na tlačítko Návrh dotazu.

  5. V dialogovém okně Zobrazit tabulku poklepejte na položku Rozpis objednávek a Objednávky.

  6. Zavřete dialogové okno Zobrazit tabulku.

  7. V tabulce Objednávky poklepejte na položku Kód zákazníka a Město příjemce, čímž tato pole přidáte do návrhové mřížky.

  8. V tabulce Rozpis objednávek poklepejte na položky Kód objednávky, Kód výrobku, Množství, Cena za kus a Sleva, čímž tato pole přidáte do návrhové mřížky.

  9. Ve sloupci Město příjemce návrhové mřížky zrušte zaškrtnutí políčka na řádku Zobrazit. Na řádku Kritéria zadejte text 'Chicago' (včetně jednoduchých uvozovek).

    Ověřte výsledky dotazu dříve, než je použijete k vytvoření tabulky.

  10. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

  11. Stisknutím kombinace kláves CTRL+S dotaz uložte.

    Zobrazí se dialogové okno Uložit jako.

  12. Do pole Název dotazu zadejte text Dotaz na objednávky pro Chicago a klepněte na tlačítko OK.

  13. Na kartě Domů klepněte ve skupině Zobrazení na položku Zobrazení a potom na položku Návrhové zobrazení.

  14. Na kartě Návrh klepněte ve skupinovém rámečku Typ dotazu na položku Vytvořit tabulku.

    Zobrazí se dialogové okno Vytvořit tabulku.

  15. V dialogovém okně Vytvořit tabulku zadejte v poli Název tabulky text Objednávky pro Chicago a potom klikněte na tlačítko OK.

  16. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

  17. V dialogovém okně pro potvrzení potvrďte zadání kliknutím na tlačítko Ano.

    Vytvoří se nová tabulka a zobrazí se v navigačním podokně.

    Poznámka : Pokud již existuje tabulka se zadaným názvem, bude tato tabulka před spuštěním dotazu odstraněna.

  18. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

    Protože tabulka Objednávky pro Chicago existuje, zobrazí se dialogové okno s upozorněním.

  19. Klepnutím na tlačítko Ne akci zrušíte a dialogové okno zavřete.

Začátek stránky

Přidání dat z jiných tabulek do tabulky

K načtení dat z jedné nebo více tabulek a jejich přidání do jiné tabulky se používá přidávací dotaz.

Poznámka : Přidávací dotaz nejde spustit ve webovém prohlížeči.

Předpokládejme, že jste vytvořili tabulku, kterou budete sdílet s obchodním partnerem v Chicagu, avšak uvědomíte si, že tento partner pracuje rovněž s klienty v oblasti Milwaukee. Před sdílením tabulky s partnerem chcete do tabulky přidat řádky obsahující data pro oblast Milwaukee.

Data týkající se oblasti Milwaukee můžete do tabulky Objednávky pro Chicago, kterou jste vytvořili v předchozím příkladu, přidat provedením následujícího postupu:

  1. Otevřete dotaz s názvem Dotaz na objednávky pro Chicago v návrhovém zobrazení.

  2. Na kartě Návrh klikněte ve skupině Typ dotazu na položku přidávací. Otevře se dialogové okno Přidat.

  3. V dialogovém okně Přidat klepněte na šipku v poli Název tabulky a potom z rozevíracího seznamu vyberte položku Objednávky pro Chicago.

  4. Klikněte na tlačítko OK.

    Dialogové okno Přidat se zavře. V návrhové mřížce zmizí řádek Zobrazit a objeví se řádek Přidat do.

  5. V návrhové mřížce odstraňte na řádku Kritéria sloupce Město příjemce řetězec 'Chicago' a potom zadejte řetězec 'Milwaukee'.

  6. Na řádku Přidat do vyberte odpovídající pole pro každý sloupec.

    V tomto příkladu by hodnoty řádku Přidat do měly odpovídat hodnotám na řádku Pole, není to však nutné pro fungování přidávacích dotazů.

  7. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

Poznámka :  Při spuštění dotazu, který vrací velké množství dat, se může zobrazit chybová zpráva s informací, že dotaz nebude možné vrátit zpět. Chcete-li aby se dotaz provedl, zkuste zvýšit limit segmentu paměti na 3 MB.

Začátek stránky

Automatizované změny dat

Data v tabulkách můžete změnit pomocí aktualizačního dotazu. V tomto dotazu můžete zadat kritéria určující, které řádky by měly být aktualizovány. Aktualizační dotaz nabízí možnost prohlédnout aktualizovaná data před provedením aktualizace.

Důležité : Akční dotaz nelze vrátit zpět. Měli byste zvážit vytvoření zálohy všech tabulek, které budete pomocí aktualizačního dotazu aktualizovat.

Poznámka : Aktualizační dotaz nelze spustit ve webovém prohlížeči.

V předchozím příkladu jste k tabulce Objednávky pro Chicago přidali řádky. Pole Kód výrobku v tabulce Objednávky pro Chicago zobrazuje číselný kód výrobku. Aby byla data užitečnější pro sestavy, může být vhodné nahradit kódy výrobků jejich názvy. Chcete-li kódy nahradit, je třeba nejprve změnit datový typ pole Kód výrobku v tabulce Objednávky pro Chicago z číselného na textový, aby pole Kód výrobku mohlo přijmout názvy výrobků.

Hodnoty v tabulce Objednávky pro Chicago můžete aktualizovat pomocí následujícího postupu:

  1. Otevřete tabulku Objednávky pro Chicago v návrhovém zobrazení.

  2. Na řádku Kód výrobku změňte datový typ z hodnoty Číslo na Text.

  3. Uložte a uzavřete tabulku Objednávky pro Chicago.

  4. Na kartě Vytvoření klikněte ve skupině Dotaz na tlačítko Návrh dotazu.

  5. V dialogovém okně Zobrazit tabulku poklepejte na položku Objednávky pro Chicago a Výrobky.

  6. Zavřete dialogové okno Zobrazit tabulku.

  7. Na kartě Návrh klikněte ve skupině Typ dotazu na položku Aktualizovat.

    V návrhové mřížce zmizí řádky Seřadit a Zobrazit a objeví se řádek Aktualizovat do.

  8. V tabulce Objednávky pro Chicago poklepejte na položku Kód výrobku, čímž toto pole přidáte do návrhové mřížky.

  9. V návrhové mřížce v řádku Aktualizovat do ve sloupci ID výrobku, zadejte nebo vložte následující:

    [Výrobky].[Název výrobku]

    Tip : Pomocí aktualizačního dotazu můžete hodnoty polí odstranit, a to použitím prázdného řetězce ("") neboli hodnoty NULL na řádku Aktualizovat do.

  10. Na řádku Kritéria zadejte nebo vložte následující řetězec:

    [Kód výrobku] Like ([Výrobky].[Kód])

    Klíčové slovo jako je nutné, protože pole, která jsou porovnání obsahovat různé datové typy (ID výrobku je textová data, ID číselná data).

  11. Zobrazením dotazu v zobrazení datového listu můžete zkontrolovat, které hodnoty budou aktualizačním dotazem změněny.

    Na kartě Návrh klepněte ve skupině Výsledky na položku Zobrazení a potom na položku Zobrazení datového listu.

    Dotaz vrátí seznam kódů výrobků, které budou aktualizovány.

  12. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

    Když otevřete tabulku Objednávky pro Chicago, uvidíte, že číselné hodnoty v poli Kód výrobku byly nahrazeny názvy výrobků z tabulky Výrobky.

Začátek stránky

Automatizované odstranění dat

K odstranění dat z tabulek můžete použít odstraňovací dotaz. V tomto dotazu můžete zadat kritéria určující, které řádky mají být odstraněny. Odstraňovací dotaz nabízí možnost zkontrolovat řádky, které budou odstraněny, před jejich odstraněním.

Poznámka : Odstraňovací dotaz nejde spustit ve webovém prohlížeči.

Předpokládejme, že připravujete odeslání tabulky Objednávky pro Chicago (aktualizované v předchozím příkladu) obchodnímu partnerovi v Chicagu a všimnete si, že některé řádky obsahují mnoho prázdných polí. Před odesláním tabulky byste chtěli tyto řádky odstranit. Mohli byste jednoduše otevřít tabulku a odstranit řádky ručně, avšak pokud se jedná o více než jen několik řádků a existují jasná kritéria, podle kterých můžete řádky odstranit, mohl by být užitečný odstraňovací dotaz.

Provedením následujícího postupu můžete z tabulky Objednávky pro Chicago pomocí dotazu odstranit řádky, které neobsahují hodnotu kódu objednávky:

  1. Na kartě Vytvoření klikněte ve skupině Dotaz na tlačítko Návrh dotazu.

  2. V dialogovém okně Zobrazit tabulku poklepejte na položku Objednávky pro Chicago.

  3. Zavřete dialogové okno Zobrazit tabulku.

  4. Na kartě Návrh klikněte ve skupině Typ dotazu na položku Odstranit.

    V návrhové mřížce zmizí řádky Seřadit a Zobrazit a objeví se řádek Odstranit.

  5. V tabulce Objednávky pro Chicago poklepejte na položku Kód objednávky, čímž ji přidáte do mřížky.

  6. V návrhové mřížce zadejte na řádku Kritéria sloupce ID objednávky hodnotu Is Null.

  7. Na kartě Návrh klepněte ve skupině Výsledky na tlačítko Spustit.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×