Řešení potíží s vyhledáváním v Outlooku

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Vyberte scénář, který nejlépe vystihuje váš problém s hledáním v Outlooku:

Hledání v Outlooku nevrátí žádné výsledky.

Když nebudete pomocí aplikace Outlook hledat žádné výsledky, postupujte v uvedeném pořadí:

  • Ve Windows 10: vyberte tlačítko Start , vyberte Nastavení > aktualizovat zabezpečení &a pak vyberte Poradce při potížích. Vyhledejte a klikněte na Hledat a indexovánía potom klikněte na spustit Poradce při potížích.

  • Ve Windows 8,1: od spuštěnívyhledejte Nastavení. V Nastavenívyhledejte možnosti odstraňování potížía vyberte Poradce při potížích ve výsledcích hledání. Vyhledání a spuštění Poradce při potížích s vyhledáváním a indexováním

  • Ve Windows 7: od startuvyberte Ovládací panelya pak vyberte Poradce při potížích. Vyhledání a spuštění Poradce při potížích s vyhledáváním a indexováním

  1. Spusťte Outlook a klikněte na pole Hledat.

  2. V nabídce Hledání vyberte Nástroje hledání > Stav indexování.

  3. Když se zobrazí dialogové okno Stav indexování , měli byste vidět toto:

    Stav indexování pro vyhledávání v Outlooku

Pokud Outlook indexování nedokončil, všimněte si položek, které zbývá indexovat, počkejte pět minut a pak údaje znovu zkontrolujte. Pokud se počet položek nesnížil, pokračujte dalším krokem.

  1. Spusťte Outlook a klikněte na pole Hledat.

  2. V nabídce Hledání vyberte Nástroje hledání > Prohledávaná umístění.

  3. Zkontrolujte, že jsou vybrané všechny datové soubory a všechna úložiště.

  1. V nabídce Start systému Windows klikněte do vyhledávacího pole.

  2. Zadejte Services. msc a stiskněte ENTER.

  3. Pod sloupcem název Najděte a poklikejte na Windows Search.

  4. Nastavte Typ spouštění na automaticky (zpožděné spuštění) , pokud ještě nebyl.

  5. Pokud se stav služby nezobrazuje, klikněte na tlačítko Start pod ním a spusťte tak službu.

  1. Ukončete Outlook.

  2. V Ovládacích panelech Windows otevřete Možnosti indexování.

  3. V dialogovém okně Možnosti indexování ověřte, že ve sloupci Zahrnutá umístění je Microsoft Outlook.

  4. Pokud tam Microsoft Outlook není, vyberte Změnit a kliknutím zaškrtněte políčko Microsoft Outlook.

  5. Vyberte OK a pak vyberte Zavřít.

K ověření správné konfigurace možností indexování použijte tento postup:

  1. Ukončete Outlook.

  2. V Ovládacích panelech Windows otevřete Možnosti indexování.

  3. V dialogovém okně Možnosti indexování vyberte Upřesnit.

  4. Vyberte kartu Typy souborů.

  5. Ve sloupci Přípona se posuňte dolů, až najdete položku msg a pak ji vyberte.

  6. Zkontrolujte, že je vybraná možnost Indexovat vlastnosti a obsah souboru.

  7. Vyberte OK a pak vyberte Zavřít.

Poznámka: Zkontrolujte, že se ve sloupci Popis filtru zobrazuje Office Outlook MSG IFilter. Pokud se nezobrazuje, nefunguje správně služba Windows Search nebo Microsoft Outlook správně nenainstaloval filtry. V obou případech byste měli kontaktovat podporu Microsoftu a požádat ji, aby vám pomohla problém vyřešit.

  1. Ukončete Outlook.

  2. V Ovládacích panelech Windows otevřete Možnosti indexování.

  3. V dialogovém okně Možnosti Indexování vyberte Změnit, zrušte zaškrtnutí políčka vedle Outlooku a vyberte OK.

  4. V dialogovém okně Možnosti indexování vyberte Upřesnit.

  5. V dialogovém okně Upřesnit možnosti vyberte Znovu sestavit.

  6. Vyberte OK a pak vyberte Zavřít.

Pokud indexování skončí bez zahrnutí datových souborů Outlooku, obraťte se na podporu Microsoftu a požádejte o pomoc s outlookovou funkcí Okamžité hledání.

Pokud se indexování nedokončí, obraťte se na podporu Microsoftu a požádejte o pomoc s programem Windows Desktop Search.

K vytvoření nového profilu a testování hledání použijte tento postup:

  1. V Outlooku vyberte Soubor > Nastavení účtu > Správa profilů. Nebo můžete ukončit Outlook a v Ovládacích panelech Windows otevřít Poštu.

  2. V dialogovém okně Nastavení pošty – Outlook vyberte Zobrazit profily. Potom na kartě Obecné vyberte Přidat.

  3. Do pole Název profilu napište název nového profilu a vyberte OK.

  4. Pokud se zobrazí výzva, zadejte informace o účtu, jako je e-mailová adresa a heslo, a vyberte Další.

  5. Vyberte Dokončit. Název nového přidaného profilu se v dialogovém okně Pošta zobrazí na kartě Obecné.

  6. V nabídce Při spuštění aplikace Microsoft Outlook použít profil zvolte Nabídnout výběr profilu a pak vyberte OK.

  7. Restartujte Outlook.

  8. V rozevíracím seznamu v dialogovém okně Zvolit profil zvolte název nového profilu, který jste vytvořili, a vyberte OK.

  9. Klikněte na políčko Hledat a vyzkoušejte hledání.

Pokud hledání funguje, mohl potíže způsobovat váš starý profil. Pravděpodobně budete chtít z tohoto profilu udělat nový výchozí profil a pak přenést informace ze starého profilu do nového.

Postup, jak získat přístup k nástroji pro opravu, se liší v závislosti na vašem operačním systému. Z možností dole vyberte svůj operační systém.

  1. Klikněte pravým tlačítkem na tlačítko Start Tlačítko Start ve Windows 8 a Windows 10 (v levém dolním rohu) a v místní nabídce vyberte Aplikace a funkce.

    Snímek obrazovky s nabídkou Start se zobrazenými aplikacemi a funkcemi
  2. Vyberte produkt Microsoft Office, který chcete opravit, a pak vyberte Změnit.

    Poznámka: I když chcete opravit jenom jednu aplikaci, například Word nebo Excel, opravíte celou sadu Office. Pokud máte nainstalovanou samostatnou aplikaci, vyhledejte ji podle názvu.

  3. Podle toho, jestli je vaše kopie Office nainstalovaná pomocí Klikni a spusť, nebo pomocí Instalační služby MSI, se vám zobrazí následující možnosti, jak pokračovat v opravě. Postupujte podle pokynů pro typ vaší instalace.

    Klikni a spusť

    V části Jak chcete aplikace Office opravit vyberte Online oprava, aby proběhly všechny potřebné opravy, a pak vyberte Opravit. (K dispozici je také možnost Rychlá oprava, která ale jenom rozpozná a nahradí poškozené soubory.)

    Instalační služba MSI

    V části pro změnu instalace produktu vyberte Opravit a pak klikněte na Pokračovat.

  4. Opravu dokončete podle pokynů na obrazovce.

  1. Klikněte pravým tlačítkem na tlačítko Start Tlačítko Start ve Windows 8 a Windows 10 (v levém dolním rohu) a v místní nabídce zvolte Ovládací panely.

    Seznam možností a příkazů zobrazený po stisknutí klávesy s logem Windows + X
  2. V zobrazení Kategorie zvolte v části Programy možnost Odinstalovat program.

  3. Klikněte pravým tlačítkem na aplikaci Microsoft Office, kterou chcete opravit, a v rozevírací nabídce vyberte Změnit.

    Poznámka: Pokud máte sadu, jako je například Office 365 pro domácnosti nebo Office 2013 nebo 2016 pro domácnosti, vyhledejte název sady, i když chcete opravit jenom konkrétní aplikaci, například Word nebo Excel. Pokud máte jenom samostatnou aplikaci, například Word nebo Excel, vyhledejte název této aplikace.

  4. Podle toho, jestli je vaše kopie Office nainstalovaná pomocí Klikni a spusť, nebo pomocí Instalační služby MSI, proveďte následující postup pro příslušný typ instalace Office:

    Typ instalace Klikni a spusť:

    V části Jak chcete aplikace Office opravit vyberte Online oprava, aby proběhly všechny potřebné opravy, a pak vyberte Opravit. (K dispozici je také možnost Rychlá oprava, která ale jenom rozpozná a nahradí poškozené soubory.)

    Typ instalace založené na Instalační službě MSI:

    V části pro změnu instalace produktu vyberte Opravit a pak klikněte na Pokračovat.

  5. Opravu dokončete podle zbývajících pokynů na obrazovce.

  1. Klikněte na tlačítko Start Tlačítko Start ve Windows 7 > Ovládací panely.

  2. V zobrazení Kategorie zvolte v části Programy možnost Odinstalovat program.

  3. Klikněte na produkt Office, který chcete opravit, a pak klikněte na Změnit.

    Poznámka: Pokud máte sadu, jako je například Office 365 pro domácnosti nebo Office 2013 nebo 2016 pro domácnosti, vyhledejte název sady, i když chcete opravit jenom konkrétní aplikaci, například Word nebo Excel. Pokud máte jenom samostatnou aplikaci, například Word nebo Excel, vyhledejte název této aplikace.

  4. Podle toho, jestli je vaše kopie Office nainstalovaná pomocí Klikni a spusť, nebo pomocí Instalační služby MSI, proveďte následující postup pro příslušný typ instalace Office:

    Typ instalace Klikni a spusť:

    V části Jak chcete aplikace Office opravit vyberte Online oprava, aby proběhly všechny potřebné opravy, a pak vyberte Opravit. (K dispozici je také možnost Rychlá oprava, která ale jenom rozpozná a nahradí poškozené soubory.)

    Typ instalace založené na Instalační službě MSI:

    V části pro změnu instalace produktu vyberte Opravit a pak klikněte na Pokračovat.

  5. Opravu dokončete podle zbývajících pokynů na obrazovce.

  1. Kliknutím na tlačítko níže stáhněte a nainstalujte nástroj pro odinstalaci Office.

    Tlačítko Stáhnout nástroje Easy Fix označující, že je k dispozici automatická oprava
  2. Podle níže uvedených kroků pro svůj prohlížeč stáhněte nástroj pro odinstalaci.

    Tip: Stažení a instalace nástroje může trvat několik minut. Po dokončení instalace se otevře okno pro odinstalaci produktů Office.

    Microsoft Edge nebo Internet Explorer

    V dolní části okna prohlížeče výběrem tlačítka Spustit spusťte soubor SetupProd_OffScrub.exe.

    Kde najít a odkud otevřít stažený soubor asistenta podpory ve webovém prohlížeči Microsoft Edge nebo Internet Explorer

    Chrome

    V levém dolním rohu klikněte pravým tlačítkem na SetupProd_OffScrub.exe > Otevřít.

    Kde najít a odkud otevřít stažený soubor asistenta podpory ve webovém prohlížeči Chrome

    Firefox

    V automaticky otevíraném okně vyberte Uložit soubor.

    Pak v pravém horním rohu okna prohlížeče Firefox vyberte šipku a v seznamu stažených souborů vyberte SetupProd_OffScrub.exe.

    Kde najít a odkud otevřít stažený soubor asistenta podpory ve webovém prohlížeči Chrome
  3. Vyberte verzi, kterou chcete odinstalovat, a potom vyberte Další.

  4. Postupujte podle pokynů na zbývajících obrazovkách a po zobrazení výzvy restartujte počítač.

    Po restartování počítače se nástroj pro odinstalaci automaticky znovu otevře, aby dokončil poslední krok procesu odinstalace. Postupujte podle zbývajících pokynů.

  5. Vyberte kroky pro verzi Office, kterou chcete nainstalovat nebo přeinstalovat. Zavřete nástroj pro odinstalaci.

    Office 365 | Office 2019 | Office 2016 | Office 2013 | Office 2010 | Office 2007

Poznámka: Pokud tyto kroky nevidíte, vyzkoušejte rozšířené kroky v tomto článku: žádné výsledky hledání pro účty POP, IMAP nebo Exchange

Hledání v Outlooku vrátí neúplné výsledky.

Když dostanete neúplné výsledky pomocí vyhledávání Outlooku, postupujte v uvedeném pořadí:

Pokud jsou chybějící výsledky hledání ve složce Odstraněná pošta, můžete tuto složku přidat do výsledků hledání:

  1. Spusťte Outlook.

  2. Klikněte na Možnosti> souborů a pak vyberte Hledat.

  3. Vyberte zahrnout zprávy ze složky Odstraněná pošta v každém datovém souboru při hledání ve všech položkách a klikněte na OK.

  4. Restartujte Outlook.

Čas v offline nastavení e-mailového účtu můžete prodloužit tak, aby se víc nebo všechny e-maily ukládaly místně do mezipaměti. Postupujte takto:

  1. Spusťte Outlook.

  2. Klikněte na Soubor > Nastavení účtu > Nastavení účtu.

  3. Na kartě e-mail vyberte svůj e-mailový účet a klikněte na změnit.

  4. Přetáhněte stažený e-mail pro dřívější období do požadovaného časového úseku nebo úplně vpravo.

  5. Klikněte na Dalšía pak na Hotovo. Zavřete okno a restartujte Outlook.

V Outlooku se ve výchozím nastavení zobrazí 250 výsledky hledání. Můžete to zvětšit tak, aby se zobrazily všechny výsledky, ale hledání bude pomalejší. Postupujte takto:

  1. Spusťte Outlook.

  2. Klikněte na Možnosti> souborů a pak vyberte Hledat.

  3. Zrušte zaškrtnutí políčka zrychlit vyhledávání omezením počtu zobrazených výsledků a klikněte na tlačítko OK.

  4. Restartujte Outlook.

Když v Outlooku prohledáváte všechny poštovní schránky nebo všechny položky Outlooku , nebudou pro archivní poštovní schránku vráceny žádné výsledky. Položky, které byly přesunuty na automaticky rozbalenou poštovní schránku, můžete hledat pouze prohledáním samotné složky. V seznamu složek vyberte složku archiv a vyberte možnost aktuální složka jako obor hledání. Pokud složka v oblasti automatického rozbaleného úložiště obsahuje podsložky, musíte prohledat každou podsložku zvlášť. Další informace najdete v tématu Přehled neomezené archivace v Office 365.

Hledání v Outlooku nemůže najít starší e-maily

Když nemůžete najít e-maily starší než 6 měsíců pomocí vyhledávání Outlooku, postupujte v uvedeném pořadí:

Pokud jsou chybějící výsledky hledání ve složce Odstraněná pošta, můžete tuto složku přidat do výsledků hledání:

  1. Spusťte Outlook.

  2. Klikněte na Možnosti> souborů a pak vyberte Hledat.

  3. Vyberte zahrnout zprávy ze složky Odstraněná pošta v každém datovém souboru při hledání ve všech položkách a klikněte na OK.

  4. Restartujte Outlook.

Čas v offline nastavení e-mailového účtu můžete prodloužit tak, aby se víc nebo všechny e-maily ukládaly místně do mezipaměti. Postupujte takto:

  1. Spusťte Outlook.

  2. Klikněte na Soubor > Nastavení účtu > Nastavení účtu.

  3. Na kartě e-mail vyberte svůj e-mailový účet a klikněte na změnit.

  4. Přetáhněte stažený e-mail pro dřívější období do požadovaného časového úseku nebo úplně vpravo.

  5. Klikněte na Dalšía pak na Hotovo. Zavřete okno a restartujte Outlook.

V Outlooku se ve výchozím nastavení zobrazí 250 výsledky hledání. Můžete to zvětšit tak, aby se zobrazily všechny výsledky, ale hledání bude pomalejší. Postupujte takto:

  1. Spusťte Outlook.

  2. Klikněte na Možnosti> souborů a pak vyberte Hledat.

  3. Zrušte zaškrtnutí políčka zrychlit vyhledávání omezením počtu zobrazených výsledků a klikněte na tlačítko OK.

  4. Restartujte Outlook.

Karta hledání je šedá (jenom Outlook 2016)

Tato situace může nastat po upgradu na Windows 10 verze 1709 a starší. Problém byl opraven ve Windows 10 verze 1803 a novějším. Tento problém můžete vyřešit takto:

Postup, jak získat přístup k nástroji pro opravu, se liší v závislosti na vašem operačním systému. Z možností dole vyberte svůj operační systém.

  1. Klikněte pravým tlačítkem na tlačítko Start Tlačítko Start ve Windows 8 a Windows 10 (v levém dolním rohu) a v místní nabídce vyberte Aplikace a funkce.

    Snímek obrazovky s nabídkou Start se zobrazenými aplikacemi a funkcemi
  2. Vyberte produkt Microsoft Office, který chcete opravit, a pak vyberte Změnit.

    Poznámka: I když chcete opravit jenom jednu aplikaci, například Word nebo Excel, opravíte celou sadu Office. Pokud máte nainstalovanou samostatnou aplikaci, vyhledejte ji podle názvu.

  3. Podle toho, jestli je vaše kopie Office nainstalovaná pomocí Klikni a spusť, nebo pomocí Instalační služby MSI, se vám zobrazí následující možnosti, jak pokračovat v opravě. Postupujte podle pokynů pro typ vaší instalace.

    Klikni a spusť

    V části Jak chcete aplikace Office opravit vyberte Online oprava, aby proběhly všechny potřebné opravy, a pak vyberte Opravit. (K dispozici je také možnost Rychlá oprava, která ale jenom rozpozná a nahradí poškozené soubory.)

    Instalační služba MSI

    V části pro změnu instalace produktu vyberte Opravit a pak klikněte na Pokračovat.

  4. Opravu dokončete podle pokynů na obrazovce.

  1. Klikněte pravým tlačítkem na tlačítko Start Tlačítko Start ve Windows 8 a Windows 10 (v levém dolním rohu) a v místní nabídce zvolte Ovládací panely.

    Seznam možností a příkazů zobrazený po stisknutí klávesy s logem Windows + X
  2. V zobrazení Kategorie zvolte v části Programy možnost Odinstalovat program.

  3. Klikněte pravým tlačítkem na aplikaci Microsoft Office, kterou chcete opravit, a v rozevírací nabídce vyberte Změnit.

    Poznámka: Pokud máte sadu, jako je například Office 365 pro domácnosti nebo Office 2013 nebo 2016 pro domácnosti, vyhledejte název sady, i když chcete opravit jenom konkrétní aplikaci, například Word nebo Excel. Pokud máte jenom samostatnou aplikaci, například Word nebo Excel, vyhledejte název této aplikace.

  4. Podle toho, jestli je vaše kopie Office nainstalovaná pomocí Klikni a spusť, nebo pomocí Instalační služby MSI, proveďte následující postup pro příslušný typ instalace Office:

    Typ instalace Klikni a spusť:

    V části Jak chcete aplikace Office opravit vyberte Online oprava, aby proběhly všechny potřebné opravy, a pak vyberte Opravit. (K dispozici je také možnost Rychlá oprava, která ale jenom rozpozná a nahradí poškozené soubory.)

    Typ instalace založené na Instalační službě MSI:

    V části pro změnu instalace produktu vyberte Opravit a pak klikněte na Pokračovat.

  5. Opravu dokončete podle zbývajících pokynů na obrazovce.

  1. Klikněte na tlačítko Start Tlačítko Start ve Windows 7 > Ovládací panely.

  2. V zobrazení Kategorie zvolte v části Programy možnost Odinstalovat program.

  3. Klikněte na produkt Office, který chcete opravit, a pak klikněte na Změnit.

    Poznámka: Pokud máte sadu, jako je například Office 365 pro domácnosti nebo Office 2013 nebo 2016 pro domácnosti, vyhledejte název sady, i když chcete opravit jenom konkrétní aplikaci, například Word nebo Excel. Pokud máte jenom samostatnou aplikaci, například Word nebo Excel, vyhledejte název této aplikace.

  4. Podle toho, jestli je vaše kopie Office nainstalovaná pomocí Klikni a spusť, nebo pomocí Instalační služby MSI, proveďte následující postup pro příslušný typ instalace Office:

    Typ instalace Klikni a spusť:

    V části Jak chcete aplikace Office opravit vyberte Online oprava, aby proběhly všechny potřebné opravy, a pak vyberte Opravit. (K dispozici je také možnost Rychlá oprava, která ale jenom rozpozná a nahradí poškozené soubory.)

    Typ instalace založené na Instalační službě MSI:

    V části pro změnu instalace produktu vyberte Opravit a pak klikněte na Pokračovat.

  5. Opravu dokončete podle zbývajících pokynů na obrazovce.

Sdílená poštovní schránka: problémy s výsledky hledání

Pokud se vám nezobrazuje očekávané výsledky ze sdíleného poštovní schránky nebo se zobrazí chybová zpráva, postupujte podle těchto kroků:

Zakažte vyhledávání serveru jako krátkodobé řešení. Postupujte takto:

Důležité informace: Následující postup ukazuje, jak upravit registr. Pokud byste ale registr upravili nesprávně, mohlo by dojít k vážným problémům. Provádějte proto prosím tento postup pečlivě. Před úpravami registru si pro zvýšení ochrany udělejte jeho zálohu. V případě problému ho pak můžete obnovit. Další informace o tom, jak zálohovat a obnovit registr, najdete v článku Postup zálohování a obnovení registru v systému Windows.

  1. Ve Windows klikněte pravým tlačítkem myši na Start a potom vyberte Spustit. Do pole Otevřít zadejte regedit a potom klikněte na OK. Tím otevřete editor registru.

  2. V dialogovém okně Editor registru Najděte podklíč registru a klikněte na něj:

    • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Search

  3. Klikněte na Úpravy > Nový > Hodnota DWORD.

  4. Jako název hodnoty DWORD zadejte DisableServerAssistedSearch a pak stiskněte ENTER.

  5. Klikněte pravým tlačítkem myši na DisableServerAssistedSearch a potom klikněte na změnit.

  6. Do pole údaj hodnoty zadejte 1 pro povolení položky registru a klikněte na OK.

  7. Zavřete Editor registru a restartujte Windows.

Poznámka: Tato zásada a další důležité úvahy jsou dokumentovány na blogu vyhledávání.

Pokud chcete vyhledat sdílenou poštovní schránku, klikněte na ni a použijte aktuální rozsah složky . Toto je limit návrhu, který se právě zpracovává pro budoucí aktualizace. Další informace o tom, jaké obory jsou podporovány, najdete v tomto článku v blogu obory hledání .

Když prohledáte sdílenou poštovní schránku přidanou jako další poštovní schránku, může se zobrazit tato chyba:

Máme potíže s načtením výsledků ze serveru. Je možné, že některé položky nebudou ve výsledcích hledání zahrnuty.

K tomu dojde, pokud používáte verzi Outlooku s trvalou multilicenční licencí (MSI). V současné době je to omezení u verzí Office s trvalou platností. Řešení: Tento problém zakáže hledání serveru.

Viz také

Jak zpřesnit kritéria hledání a zlepšit vyhledávání v Outlooku

Hledání zprávy nebo položky pomocí funkce Okamžité hledání

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×