Řízení, kdy mají být aktualizovány externí odkazy (propojení)

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Po vytvoření externích odkazů (označovaných také jako propojení) můžete určit, zda budou externí připojení aktualizována a kdy bude k aktualizaci docházet. Jestliže jiný uživatel změnil hodnotu v buňce, aplikace Microsoft Excel tuto novou hodnotu nevyhledá, pokud k tomu nedostane pokyn.

Co chcete udělat?

Získání dalších informací o externích odkazech

Určování propojení na jiné sešity

Nastavení úvodní výzvy k aktualizaci všech propojení

Rozhodnutí o aktualizaci propojení při zobrazení úvodní výzvy

Další informace o externích odkazech

Sešit, který obsahuje odkazy, se označuje jako cílový sešit, a sešit, na který se odkazuje, se označuje jako zdrojový sešit. Pokud sešit, který jste otevřeli (říkáme mu Cílový soubor) obsahuje odkazy na další sešity nebo soubory (říkáme jim zdrojové soubory), a zdrojové soubory se změnily, můžou odkazy v sešitě, který otevíráte, obsahovat informace, které jsou zastaralé.

Sešit obsahuje propojení.

1. Cílový sešit obsahuje externí odkaz.

2. Externí odkaz (propojení) je odkazem na oblast buněk ve zdrojovém sešitě.

3. Zdrojový sešit obsahuje buňku a skutečnou hodnotu načtenou a umístěnou v cílovém sešitě.

Začátek stránky

Určování propojení na jiné sešity

Pokud jsou zdrojový i cílový sešit otevřeny ve stejném počítači, jsou propojení aktualizována automaticky. Jestliže otevřete cílový sešit a zdrojový sešit otevřen není, je možné, že se na panelu s informacemi o blokování zobrazí výstraha s dotazem, zda chcete propojení aktualizovat. Můžete určit, zda má být výstraha zobrazena a zda mají být aktualizována všechna propojení, pokud se výstraha nezobrazí. Jestliže sešit obsahuje více než jedno propojení, lze aktualizovat pouze některá z nich.

Ruční aktualizace všech nebo žádných propojení v sešitu

  1. Zavřete všechny sešity. Pokud je otevřen jeden zdrojový sešit a ostatní jsou zavřeny, nebude aktualizace úplná.

  2. Otevřete sešit obsahující propojení.

  3. Chcete-li propojení aktualizovat, klikněte na panelu s informacemi o blokování na tlačítko Možnosti a potom klikněte na možnost Povolit tento obsah.

Začátek stránky

Ruční aktualizace pouze některých propojení s jinými sešity

  1. Zavřete všechny sešity.

  2. Otevřete sešit obsahující propojení.

  3. Na kartě Data klikněte ve skupině Spravovat připojení na položku Upravit odkazy.

    Datová připojení

  4. Ve sloupci Zdroj klikněte na propojený objekt, který chcete aktualizovat.

    Jestliže chcete vybrat více propojení, podržte při klikání na jednotlivé objekty klávesu Ctrl.

    Chcete-li vybrat všechna propojení, stiskněte klávesy Ctrl+A.

  5. Klikněte na tlačítko Aktualizovat hodnoty.

Začátek stránky

Nastavení úvodní výzvy k aktualizaci všech propojení

Můžete rozhodnout, zda chcete aktualizovat propojení automaticky při spuštění nebo po spuštění.

Nepožadovat potvrzení aktualizace propojení v sešitu a zkontrolovat aktualizaci propojení automaticky

Upozornění : Tato možnost ovlivňuje všechny uživatele sešitu. Jestliže se rozhodnete neaktualizovat propojení a nezobrazovat výzvy, nebudou uživatelé sešitu vědět, že data jsou zastaralá.

  1. Na kartě Data klikněte ve skupině Spravovat připojení na položku Upravit odkazy.

  2. Klikněte na tlačítko Výzva při spuštění.

  3. Vyberte požadovanou možnost.

Poznámka : Přestože zadáte, že aplikace Excel nemá zobrazit dotaz na to, zda mají být aktualizovány odkazy, zobrazí se oznámení, pokud existují nějaké přerušené odkazy.

Začátek stránky

Rozhodnutí o aktualizaci propojení při zobrazení úvodní výzvy

V dialogovém okně Výzva při spuštění lze provést několik rozhodnutí.

Domníváte se, že jste propojení nevytvářeli

  1. Na kartě Data klikněte ve skupině Spravovat připojení na položku Upravit odkazy.

  2. Klikněte na tlačítko Výzva při spuštění.

  3. Klikněte na možnost Nezobrazovat výzvu a neaktualizovat automaticky propojení.

Propojení je možné vytvořit náhodou přesunutím nebo zkopírováním oblasti, listu nebo grafu mezi sešity. Otevřete sešit, vyhledejte vytvořená propojení a potom propojení zrušte nebo ho nahraďte hodnotou.

Zrušení propojení ke zdroji

Důležité : Jestliže zrušíte propojení ke zdroji, budou všechny vzorce používající tento zdroj převedeny na své aktuální hodnoty. Například propojení =SUMA([Rozpočet.xls]Roční!C10:C25) by bylo převedeno na hodnotu =45. Tuto akci nelze vrátit zpět, proto doporučujeme soubor uložit.

  1. Na kartě Data klikněte ve skupině Spravovat připojení na položku Upravit odkazy.

  2. V seznamu Zdroj klikněte na propojení, které chcete zrušit.

    • Jestliže chcete vybrat více propojených objektů, podržte při klikání na jednotlivé objekty klávesu CTRL.

    • Chcete-li vybrat všechna propojení, stiskněte klávesy CTRL+A.

  3. Klikněte na tlačítko Zrušit propojení.

  4. Pokud propojení používalo definovaný Název, nebude název automaticky odebrán. Můžete také odstranit název.

    Odstranění názvu

  5. Na kartě Vzorce ve skupině Definované názvy klikněte na Správce názvů.

  6. Ve sloupci Název klikněte na název, který chcete odstranit, a klikněte na možnost Odstranit.

  7. Pokud používáte Oblast externích dat, může parametr dotazu také používat data z jiného sešitu. Doporučujeme vyhledat libovolný z těchto typů propojení a odstranit jej.

Nahrazení jednoho vzorce jeho vypočtenou hodnotou

Pokud nahradíte vzorec jeho hodnotou, aplikace Excel vzorec trvale odebere. Jestliže nahradíte vzorec hodnotou náhodně a chcete jej obnovit, klikněte ihned po zadání nebo vložení hodnoty na tlačítko Zpět Obrázek tlačítka .

  1. Vyberte buňku, která obsahuje vzorec.
    Jestliže se jedná o Maticový vzorec, vyberte oblast, která ho obsahuje.
    Výběr oblasti obsahující pole   

    1. Klikněte na libovolnou buňku v rozsahu Matice.

    2. Na kartě Domů ve skupině Úpravy klikněte na položku Najít a vybrat a poté klikněte na příkaz Přejít na.

    3. V dialogovém okně Přejít na klikněte na možnost Aktuální matice.

  2. Na kartě Domů klikněte ve skupině Schránka na Kopírovat Obrázek tlačítka .

  3. Klikněte na Vložit Obrázek tlačítka .

  4. Klikněte na šipku vedle tlačítka Možnosti vložení Obrázek tlačítka a poté klikněte na tlačítko Hodnoty Obrázek tlačítka .

Začátek stránky

Víte, že nejste připojeni ke zdroji

Klikněte na tlačítko Neaktualizovat. Aplikace Excel nemůže data aktualizovat ze zdroje, který není připojen. Zdroj může být například v síti, ke které nejste momentálně připojeni.

Začátek stránky

Chcete použít data v aktuálním stavu a nechcete je nahrazovat novými daty

Klikněte na tlačítko Neaktualizovat.

Začátek stránky

Poslední aktualizace dat trvala příliš dlouho

Klikněte na tlačítko Neaktualizovat. Pokud není nutné mít nejaktuálnější data, můžete ušetřit čas, jestliže nebudete aktualizovat všechna propojení. Po otevření sešitu klikněte na kartě Data ve skupině Připojení na tlačítko Upravit odkazy a potom aktualizujte pouze propojení na požadované zdroje.

Začátek stránky

Sešit vytvořil jiný uživatel a vy nevíte, proč se výzva zobrazila

Klikněte na Neaktualizovat. Kontaktujte vlastníka sešitu. Můžete taky zjistit, jaká propojení v sešitě jsou. Na kartě Data klikněte ve skupině Připojení na Upravit odkazy.

Začátek stránky

Odpovídáte na výzvu pokaždé stejně a nechcete, aby se znovu zobrazovala

Na úvodní výzvu můžete odpovědět pokaždé stejně a nemusí se u tohoto sešitu zobrazovat.

Při otevírání sešitů nezobrazovat výzvu a aktualizovat propojení automaticky:   

Tato možnost má vliv na každý sešit otevřený v počítači. Nemá vliv na uživatele, kteří tento sešit otevřou v jiném počítači.

  1. Klikněte na kartu Soubor, na položku Možnosti a poté na kategorii Upřesnit.

  2. V části Obecné zrušte zaškrtnutí políčka Potvrdit aktualizaci automatických propojení. Pokud toto políčko není zaškrtnuto, budou propojení aktualizována automaticky a výzva se nezobrazí.

Zobrazovat stejnou výzvu všem uživatelům tohoto sešitu:   

Upozornění    Tato možnost ovlivňuje všechny uživatele sešitu. Jestliže se rozhodnete neaktualizovat propojení a nezobrazovat výzvy, nebudou uživatelé sešitu vědět, že data jsou zastaralá.

  1. Na kartě Data, ve skupině Připojení, klikněte na možnost Upravit propojení.

  2. Klikněte na tlačítko Výzva při spuštění.

  3. Vyberte požadovanou možnost.

Poznámka:    Při přerušení propojení se vám přesto zobrazí upozornění.

Začátek stránky

Víte, že sešit, ke kterému se aplikace Excel pokouší připojit, je k dispozici

Klikněte na tlačítko Aktualizovat. Tak zajistíte, že budete pracovat s posledními daty.

Začátek stránky

Používáte parametrický dotaz

Propojení na parametrický dotaz nelze aktualizovat, pokud není zdrojový sešit otevřen.

  1. Klikněte na tlačítko Neaktualizovat.

  2. Zavřete cílový sešit.

  3. Otevřete zdrojový sešit.

  4. Otevřete cílový sešit.

  5. Klikněte na tlačítko Aktualizovat.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×