Úvod k zabezpečení aplikace Access 2010

Tento článek uvádí základní informace o funkcích zabezpečení, které nabízí Access 2010, a vysvětluje, jak používat nástroje Accessu určené k lepšímu zabezpečení databáze. Obsahuje taky odkazy na podrobnější obsah věnovaný různým funkcím zabezpečení.

Tento článek se nezabývá funkcemi zabezpečení SharePointu, které můžete používat při publikování svojí databáze na webu pomocí služeb Access Services. Další informace najdete v nápovědě pro Microsoft SharePoint Server 2010.

V tomto článku

Novinky v zabezpečení Accessu

Použití accessové databáze v důvěryhodném umístění

Zabalení, podepsání a distribuce databáze Accessu 2010

Povolení zakázaného obsahu při otevření databáze

Šifrování accessové databáze pomocí hesla databáze

Jak funguje zabezpečení u databází ze starších verzí Accessu otevřených v Accessu 2010

Spouštění nebezpečných výrazů (zakázání režimu izolovaného prostoru)

Novinky v zabezpečení Accessu

Access nabízí vylepšený model zabezpečení, který pomáhá zjednodušit procesy zabezpečení databáze a otevření databáze s povoleným zabezpečením.

Poznámka: I když model a postupy popsané v tomto článku zabezpečení zlepšují, tím nejbezpečnějším způsobem, jak zajistiti ochranu accessových dat, je ukládat tabulky na server, třeba na počítač, na kterém běží Windows SharePoint Services 3.0 nebo Microsoft Office SharePoint Server 2010.

Tady jsou novinky v zabezpečení Accessu:

Novinky ve verzi 2010

  • Nová technologie šifrování:     Office 2010 nabízí novou technologii šifrování, která je silnější než technologie nabízená v Office 2007.

  • Podpora produktů pro šifrování od jiných výrobců:     Pokud chcete, můžete v Accessu 2010 používat technologii šifrování od jiných výrobců. Tento článek se ale používáním produktů pro šifrování od jiných výrobců nezabývá.

Novinky ve verzi 2007

  • Možnost zobrazovat data i v případě, že nechcete povolit obsah databáze:     Když jste v Microsoft Office Accessu 2003 nastavili zabezpečení na úroveň Vysoké, museli jste před zobrazením dat podepsat kód databáze a označit ji jako důvěryhodnou. Teď si můžete data prohlédnout, aniž byste se museli rozhodnout, jestli databázi důvěřujete.

  • Mnohem snadnější používání:     Pokud soubory databáze (v novém nebo starším formátu souborů Accessu) uložíte do důvěryhodného umístění, třeba do složky souborů nebo sdílené síťové složky, která je označená jako zabezpečená, budou se tyto soubory otevírat a spouštět bez zobrazování zpráv upozornění nebo žádostí o povolení zakázaného obsahu. A když budete chtít v Accessu 2010 otevřít digitálně podepsané databáze ze starších verzí Accessu (třeba soubory .mdb nebo .mde), jejichž vydavatele jste označili za důvěryhodného, spustí se tyto soubory bez toho, abyste museli rozhodovat o důvěryhodnosti. Pokud ale vydavatele neoznačíte jako důvěryhodného, nespustí se v podepsané databázi kód VBA. Nespustí se ani v případě, že už bude digitální podpis neplatný. Podpis ztratí platnost, když obsah databáze změní někdo, kdo ji nepodepsal.

    Pokud nevíte jistě, jestli máte certifikátu důvěřovat, přečtěte si článek Jak zjistit, zda je digitální podpis důvěryhodný, který obsahuje obecné informace o kontrole kalendářních dat a dalších položek v certifikátu, abyste měli jistotu, že je certifikát platný.

  • Centrum zabezpečení:     Centrum zabezpečení je dialog, kde můžete na jednom místě zadat a změnit nastavení zabezpečení pro Access. Centrum zabezpečení se používá k vytváření nebo změnám důvěryhodných umístění a k nastavení možností zabezpečení pro Access. Tato nastavení ovlivňují chování nových a existujících databází při otevírání v příslušné instanci Accessu. Centrum zabezpečení obsahuje taky logiku, která umí vyhodnotit komponenty v databázi a zjistit, jestli je bezpečné databázi otevřít nebo jestli by ji mělo Centrum zabezpečení zakázat a umožnit vám, abyste mohli o jejím povolení rozhodnout sami.

    Obecné informace o používání Centra zabezpečení najdete v článku Zobrazení nastavení zabezpečení a ochrany osobních údajů v Centru zabezpečení.

  • Míň zpráv upozornění:     Ve starších verzích Accessu se vám zobrazovala celá řada různých upozornění. Za všechny uveďme třeba zprávy týkající se zabezpečení maker nebo režimu izolovaného prostoru. Když ve výchozím nastavení otevřete soubor .accdb, který jste ještě neoznačili jako důvěryhodný, zobrazí se jediný nástroj označovaný jako panel zpráv.

    Panel zpráv

    Pokud chcete databázi důvěřovat, můžete při jejím otevření na panelu zpráv povolit veškerý zakázaný obsah, který obsahuje – akční dotazy (dotazy, které přidávají, odstraňují nebo mění data), makra, ovládací prvky ActiveX, výrazy (funkce, které se vyhodnocují jako jedna hodnota) a kód VBA.

  • Nové způsoby podepisování a distribuce souborů databází:     Ve verzích Accessu starších než 2007 jste certifikát zabezpečení u jednotlivých komponent databáze aplikovali pomocí programu Visual Basic Editor. Teď databázi zabalíte a pak podepíšete a distribuujete tento balíček.

    Pokud databázi z podepsaného balíčku extrahujete do důvěryhodného umístění, databáze se otevře bez zobrazení panelu zpráv. Když databázi z podepsaného balíčku extrahujete do nedůvěryhodného umístění, ale certifikát balíčku jste označili jako důvěryhodný a podpis je platný, databáze se otevře bez zobrazení panelu zpráv.

    Poznámka: Když zabalíte a podepíšete databázi, která je nedůvěryhodná nebo obsahuje neplatný digitální podpis, musíte takovou databázi při každém otevření označit na panelu zpráv jako důvěryhodnou (pokud jste ji neuložili do důvěryhodného umístění).

  • Silnější algoritmus pro šifrování databází ve formátu souborů .accdb, které využívají funkci hesla databáze:     Šifrováním databáze se zakódují data ve vašich tabulkách a líp se tím zabrání tomu, aby si vaše data četli nežádoucí uživatelé.

    Poznámka: Při šifrování databáze pomocí hesla bude šifrovaná databáze bez ohledu na nastavení aplikace používat zamykání na úrovni stránky. To může ovlivnit dostupnost dat ve sdíleném prostředí.

  • Nová podtřída akcí maker, které se spouští, když je databáze zakázaná:     Tato bezpečnější makra taky obsahují funkce pro zpracování chyb. Makra (i taková, která obsahují akce zakázané Accessem) se taky dají vložit přímo do formuláře, sestavy nebo vlastnosti ovládacího prvku, které by měly logicky pracovat s modulem kódu VBA nebo s makrem ze starší verze Accessu.

Dál je potřeba pamatovat na tato pravidla:

  • Pokud otevřete databázi v důvěryhodném umístění, všechny komponenty se spustí, aniž by bylo potřeba rozhodovat o důvěryhodnosti.

  • Pokud zabalíte, podepíšete a nasadíte databázi se starším formátem souborů (soubor .mdb nebo .mde), všechny komponenty se spustí, aniž by bylo potřeba rozhodovat o důvěryhodnosti. Databáze ale musí obsahovat platný digitální podpis od důvěryhodného vydavatele a vy musíte příslušnému certifikátu důvěřovat.

  • Pokud podepíšete a nasadíte nedůvěryhodnou databázi do nedůvěryhodného umístění, Centrum zabezpečení ve výchozím nastavení tuto databázi zakáže a vy ji budete muset při každém otevření povolit.

Access a uživatelská úroveň zabezpečení

Access nepodporuje u databází vytvořených v novém formátu souborů (soubory .accdb a .accde) uživatelskou úroveň zabezpečení. Když ale v Accessu 2010 otevřete databázi ze starší verze Accessu, u které je uživatelská úroveň zabezpečení použitá, budou tato nastavení dál fungovat.

Důležité informace: Oprávnění vytvořená pomocí funkce uživatelské úrovně zabezpečení nechrání vaši databázi před kyberzločinci a neslouží jako bezpečnostní bariéra. Tato funkce by měla přispět ke zvýšení použitelnosti databáze pro důvěryhodné uživatele. Jestli chcete zajistit lepší zabezpečení dat, použijte oprávnění systému souborů Windows a povolte přístup ke svému souboru databáze nebo přidruženým souborům uživatelské úrovně zabezpečení jenom důvěryhodným uživatelům.

Když převedete databázi ze starší verze Accessu s uživatelskou úrovní zabezpečení na nový formát souborů, Access automaticky odebere všechna nastavení zabezpečení a budou platit pravidla pro zabezpečení souboru .accdb nebo .accde.

Hlavně nezapomeňte, že vždycky, když otevřete databáze s novým formátem souborů, budou moct všichni uživatelé zobrazit všechny databázové objekty.

Architektura zabezpečení Accessu

Abyste pochopili architekturu zabezpečení Accessu, je potřeba si uvědomit, že accessová databáze není stejný soubor jako excelový sešit nebo wordový dokument. Accessová databáze je sada objektů (tabulek, formulářů, dotazů, maker, sestav atd.), jejichž funkce na sobě často závisejí. Když třeba vytvoříte formulář pro zadávání dat, nemůžete data zadávat nebo ukládat s formulářem, pokud nevytvoříte vazbu (propojení) ovládacích prvků ve formuláři s tabulkou.

Některé komponenty Accessu můžou být z hlediska zabezpečení rizikové, a proto jsou v nedůvěryhodné databázi zakázané:

  • Akční dotazy (dotazy, které vkládají, odstraňují nebo mění data)

  • Makra

  • Některé výrazy (funkce,které vrací jedinou hodnotu)

  • Kód VBA

Access a Centrum zabezpečení při každém otevření databáze udělají kvůli lepšímu zabezpečení vašich dat sadu kontrol zabezpečení. Probíhá to takto:

  • Když otevřete soubor .accdb nebo .accde, odešle Access informace o umístění databáze do Centra zabezpečení. Pokud Centrum zabezpečení určí, že je umístění důvěryhodné, databáze se spustí se všemi funkcemi. Když otevřete databázi se starším formátem souborů, odešle Access do Centra zabezpečení informace o umístění souboru a podrobnosti o jeho digitálním podpisu (pokud existuje).

    Centrum zabezpečení zkontroluje tuto „legitimaci“ pro vyhodnocení důvěryhodnosti databáze a pak dá Accessu informace, jak databázi otevřít. Access databázi buď zakáže, nebo ji otevře tak, že bude plně funkční.

    Poznámka: Rozhodování o důvěryhodnosti při otevírání databáze v Accessu se děje na základě nastavení, která si vy nebo váš správce zvolíte v Centru zabezpečení.

    Další informace o použití Centra zabezpečení najdete pod odkazy v části Viz taky.

  • Když Centrum zabezpečení obsah databáze zakáže, objeví se při otevření databáze panel zpráv.

    Panel zpráv

    Pokud chcete obsah databáze povolit, klikněte na Možnosti a v dialogu, který se zobrazí, potom zvolte příslušné možnosti. Access zakázaný obsah povolí a databáze se znova otevře se všemi funkcemi. Když to neuděláte, nebudou zakázané komponenty fungovat.

  • Pokud otevřete databázi vytvořenou ve starším formátu souborů (soubory .mdb nebo .mde), která není podepsaná a důvěryhodná, Access ve výchozím nastavení zakáže všechen spustitelný obsah.

Režim vypnutí

Když Centrum zabezpečení vyhodnotí databázi jako nedůvěryhodnou, Access ji otevře v režimu vypnutí, to znamená, že bez ohledu na formát souboru databáze vypne všechen spustitelný obsah.

Access v režimu vypnutí zakáže tyto komponenty:

  • Kód VBA a všechny odkazy v kódu VBA a taky všechny nebezpečné výrazy.

  • Nebezpečné akce ve všech makrech. Nebezpečné jsou všechny akce, které by uživateli mohly umožnit měnit databázi nebo získat přístup k prostředkům mimo databázi. Akce, které Access zakáže, se ale někdy za bezpečné považovat můžou. Když třeba důvěřujete osobě, která databázi vytvořila, můžete všechny nebezpečné akce maker považovat za důvěryhodné.

  • Některé typy dotazů:

    • Akční dotazy:    Tyto dotazy přidávají, aktualizují a odstraňují data.

    • Dotazy DDL(Data Definition Language):    Tyto dotazy slouží k vytváření nebo úpravám objektů v databázi, třeba tabulek a procedur.

    • Předávací dotazy SQL:    Tyto dotazy odesílají příkazy přímo na databázový server, který podporuje standard ODBC (Open Database Connectivity). Předávací dotazy pracují s tabulkami na serveru a nevyžadují databázový stroj Accessu.

  • Ovládací prvky ActiveX

Je možné, že Access při otevření databáze zkusí načíst doplňky (programy, které rozšíří funkčnost Accessu nebo otevřené databáze). Možná taky budete chtít spustit průvodce, kteří v otevřené databázi vytvoří objekty. Při načtení doplňku nebo spuštění průvodce předá Access legitimaci Centru zabezpečení, které dál rozhodne o důvěryhodnosti a objekt nebo akci buď povolí, nebo zakáže. Když Centrum zabezpečení databázi zakáže a vy s tím nesouhlasíte, máte skoro vždycky možnost příslušný obsah povolit pomocí panelu zpráv. Výjimkou jsou doplňky. Když v Centru zabezpečení (v podokně Doplňky) zaškrtnete políčko Vyžadovat podepsání doplňků aplikací důvěryhodným vydavatelem, vyzve vás Access k povolení doplňku, ale panel zpráv se nezobrazí.

Začátek stránky

Použití accessové databáze v důvěryhodném umístění

Když dáte accessovou databázi do důvěryhodného umístění, spustí se při jejím otevření veškerý kód VBA, makra a bezpečné výrazy. Při otevírání takové databáze nemusíte rozhodovat o důvěryhodnosti.

Proces používání accessové databáze v důvěryhodném umístění spočívá v těchto obecných krocích:

  1. Pomocí Centra zabezpečení najděte nebo vytvořte důvěryhodné umístění.

  2. Do tohoto důvěryhodného umístění uložte, přesuňte nebo zkopírujte accessovou databázi.

  3. Otevřete databázi a používejte ji.

To, jak najít nebo vytvořit důvěryhodné umístění a pak do něj přidat databázi, vysvětlují následující postupy.

Otevření Centra zabezpečení

  1. Na kartě Soubor klikněte na Možnosti.

    Zobrazí se dialog Možnosti aplikace Access.

  2. Klikněte na Centrum zabezpečení a v části Centrum zabezpečení aplikace Microsoft Office Access klikněte na Nastavení Centra zabezpečení.

  3. Klikněte na Důvěryhodná umístění a pak udělejte jednu z těchto věcí:

    • Poznamenejte si cestu k jednomu nebo několika důvěryhodným umístěním.

    • Vytvořte nové důvěryhodné umístění. Uděláte to tak, že kliknete na Přidat nové umístění a potom vyplníte možnosti v dialogu Důvěryhodné umístění Microsoft Office.

Umístění databáze do důvěryhodného umístění

  • Soubor databáze můžete do důvěryhodného umístění přesunout nebo zkopírovat svojí oblíbenou metodou. Soubor můžete třeba zkopírovat nebo přesunout v Průzkumníkovi Windows nebo ho můžete otevřít v Accessu a uložit do důvěryhodného umístění.

Otevření databáze v důvěryhodném umístění

  • K otevření souboru můžete použít svůj oblíbený postup. Můžete třeba poklikat na soubor databáze v Průzkumníkovi Windows, nebo když máte spuštěný Access, můžete kliknout na Otevřít na kartě Soubor a pak soubor najít a otevřít.

Začátek stránky

Zabalení, podepsání a distribuce databáze Accessu 2010

Access umožňuje databázi snadno a rychle podepsat a distribuovat. Když vytvoříte soubor .accdb nebo .accde, můžete ho zabalit a digitálně podepsat a podepsaný balíček pak distribuovat ostatním uživatelům. Nástroj Zabalit a podepsat uloží databázi do accessového souboru pro nasazení (.accdc), soubor podepíše a podepsaný balíček pak uloží na místo, které určíte. Ostatní pak můžou databázi z balíčku extrahovat a pracovat přímo s ní (a ne se souborem balíčku).

Je ale potřeba pamatovat na tyto skutečnosti:

  • Zabalením databáze a podpisem balíčku se potvrzuje důvěryhodnost. Když databázi zabalíte a podepíšete, tak svým digitálním podpisem potvrdíte, že se databáze po vytvoření balíčku nezměnila.

  • Po extrakci databáze z balíčku už neexistuje žádné propojení mezi podepsaným balíčkem a extrahovanou databází.

  • Nástroj Zabalit a podepsat můžete používat jenom s databázemi uloženými ve formátu souborů .accdb, .accdc nebo .accde. Access nabízí taky nástroje, které slouží k podepsání a distribuci databází vytvořených ve starším formátu souborů. Je potřeba použít nástroj pro digitální podpis určený pro formát souboru databáze, který používáte.

  • Do balíčku můžete přidat jenom jednu databázi.

  • Tento proces digitálně podepíše balíček, který obsahuje celou databázi, a ne jenom makra nebo moduly.

  • Tento proces soubor balíčku zkomprimuje, aby jeho stahování netrvalo tak dlouho.

  • Databáze se dají extrahovat ze souborů balíčků umístěných na serverech Windows SharePoint Services 3.0.

To, jak vytvořit podepsaný soubor balíčku a jak extrahovat a používat databázi obsaženou v podepsaném souboru balíčku, se vysvětluje v postupech v následujících částech.

Vytvoření podepsaného balíčku

  1. Otevřete databázi, kterou chcete zabalit a podepsat.

  2. Na kartě Soubor klikněte na Uložit a publikovat a v části Upřesnit pak klikněte na Zabalit a podepsat.

    Zobrazí se dialog Vybrat certifikát.

  3. Vyberte digitální certifikát a potom klikněte na OK.

    Zobrazí se dialog Vytvořit podepsaný balíček aplikace Microsoft Office Access.

  4. V seznamu Uložit do vyberte umístění podepsaného balíčku databáze.

  5. Do pole Název souboru zadejte název podepsaného balíčku a potom klikněte na Vytvořit.

    Access vytvoří soubor .accd a umístí ho tam, kam jste si zvolili.

Extrahování a použití podepsaného balíčku

  1. Na kartě Soubor klikněte na Otevřít.

    Zobrazí se dialog Otevřít.

  2. Jako typ souboru vyberte Podepsané balíčky aplikace Microsoft Office Access (*.accdc).

  3. V seznamu Oblast hledání najděte složku, která obsahuje váš soubor .accdc, vyberte ho a pak klikněte na Otevřít.

  4. Udělejte jednu z těchto věcí:

    • Pokud se rozhodnete považovat certifikát zabezpečení použitý k podepsání balíčku pro nasazení za důvěryhodný, zobrazí se dialog Extrahovat databázi do. Přejděte k dalšímu kroku.

    • Pokud jste se ještě nerozhodli, jestli budete certifikátu zabezpečení důvěřovat, zobrazí se tato zpráva.

      Doporučující zpráva

      Jestli databázi důvěřujete, klikněte na Otevřít. Když důvěřujete všem certifikátům od tohoto poskytovatele, klikněte na Veškerý obsah od tohoto vydavatele považovat za důvěryhodný. Zobrazí se dialog Extrahovat databázi do.

      Poznámka: Pokud použijete k podepsání balíčku databáze certifikát podepsaný svým držitelem a potom při otevření tohoto balíčku kliknete na Veškerý obsah od tohoto vydavatele považovat za důvěryhodný, budou se balíčky podepsané certifikáty podepsanými svým držitelem vždycky považovat za důvěryhodné.

  5. Jestli chcete, můžete v seznamu Uložit do vybrat umístění pro extrahovanou databázi a pak do pole Název souboru zadat jiný název extrahované databáze.

    Tip: Když databázi extrahujete do důvěryhodného umístění, bude její obsah při otevření pokaždé automaticky povolený. Pokud si vyberete nedůvěryhodné umístění, může být určitý obsah databáze ve výchozím nastavení zakázaný.

  6. Klikněte na tlačítko OK.

Pokud nevíte jistě, jestli máte certifikátu důvěřovat, přečtěte si článek Jak zjistit, zda je digitální podpis důvěryhodný, který obsahuje obecné informace o kontrole kalendářních dat a dalších položek v certifikátu, abyste měli jistotu, že je certifikát platný.

Začátek stránky

Povolení zakázaného obsahu při otevření databáze

Pokud se nejedná o důvěryhodnou databázi nebo o databázi, která se nachází v důvěryhodném umístění, Access ve výchozím nastavení zakáže všechen spustitelný obsah databáze. Když databázi otevřete, Access zakáže obsah a zobrazí panel zpráv.

Panel zpráv

Access taky ve výchozím nastavení při otevření databáze už nezobrazuje sadu modálních dialogů (dialogy, kde jste museli o něčem rozhodnout a teprve potom jste mohli udělat další věc), jak tomu bylo v Accessu 2003. Jestli dáváte takovému chování přednost, můžete přidat klíč registru a zobrazit starší modální dialog.

Nastavení databáze jako důvěryhodné

Bez ohledu na chování Accessu při otevírání databáze platí, že pokud databáze pochází od spolehlivého vydavatele, můžete povolit spustitelné komponenty v souboru, neboli ji označit za důvěryhodnou.

  • Na panelu zpráv klikněte na Povolit obsah.

Důležité informace: Po kliknutí na Povolit obsah Access povolí všechen zakázaný obsah včetně potenciálně škodlivého kódu. V případě poškození dat nebo počítače škodlivým kódem nemůže Access tyto škody vrátit zpět.

Skrytí panelu zpráv

  • V pravém horním rohu panelu zpráv klikněte na tlačítko Zavřít (X).

    Panel zpráv se zavře. Pokud databázi nepřesunete do důvěryhodného umístění, zobrazí se při dalším otevření databáze tento panel znova.

Přidání klíče registru pro zobrazení modálních dialogů

Upozornění: Nesprávné úpravy registru můžou způsobit vážné poškození operačního systému, a to až takové, že se bude muset přeinstalovat. Microsoft nezaručuje, že potíže způsobené nesprávnou úpravou registru půjdou odstranit. Před úpravami registru si zazálohujte všechna cenná data. Nejnovější informace o použití a ochraně registru počítače najdete v nápovědě k Microsoft Windows.

  1. V Microsoft Windows klikněte na tlačítko Start a potom na Spustit.

  2. Do pole Otevřít zadejte regedit a stiskněte ENTER.

    Spustí se Editor registru.

  3. Rozbalte složku HKEY_CURRENT_USER a přejděte k tomuto klíči registru:

    Software\Microsoft\Office\14.0\Access\Security

  4. V pravém podokně Editoru registru klikněte pravým tlačítkem na prázdnou plochu, přejděte na Nový a klikněte na Hodnota DWORD. Zobrazí se nová, prázdná hodnota DWORD.

  5. Zadejte pro hodnotu tento název: ModalTrustDecisionOnly.

  6. Poklikejte na novou hodnotu.

    Zobrazí se dialog Upravit hodnotu DWORD.

  7. V poli Údaj hodnoty změňte hodnotu 0 na 1 a potom klikněte na OK.

  8. Zavřete Editor registru.

Když teď otevřete databázi obsahující nebezpečný obsah, zobrazí se vám místo panelu zpráv posloupnost dialogů. Jestli se chcete vrátit k původnímu chování, opakujte tyto kroky a změňte hodnotu 1 na 0.

Začátek stránky

Šifrování accessové databáze pomocí hesla databáze

Nástroj pro šifrování v Accessu je kombinací a zlepšením dvou starších nástrojů – kódování a hesla databáze. Když k šifrování databáze použijete heslo databáze, nebudou žádná data čitelná v jiných nástrojích, a aby mohli uživatelé databázi používat, budou muset zadat heslo. Šifrování v Accessu 2010 používá silnější algoritmus než starší verze Accessu.

Poznámka: Pokud jste k šifrování databáze v Accessu 2007 použili heslo databáze, můžete přepnout na novou technologii šifrování, která zajišťuje lepší zabezpečení.

Přepnutí šifrované databáze Accessu 2007 na novou technologii šifrování

Když chcete přepnout na novou technologii šifrování, odeberte aktuální heslo databáze a pak ho zase přidejte.

Šifrování pomocí hesla databáze

  1. Otevřete databázi, kterou chcete šifrovat, ve výhradním režimu.

    Otevření databáze ve výhradním režimu

    1. Na kartě Soubor klikněte na možnost Otevřít.

    2. V dialogovém okně Otevřít vyhledejte soubor, který chcete otevřít, a pak soubor vyberte.

    3. Klikněte na šipku vedle tlačítka Otevřít a potom klikněte na Výhradní přístup.

      Otevření souboru ve výhradním režimu

  2. Na kartě Soubor klikněte na položku Informace a potom na položku Zašifrovat pomocí hesla.

    Zobrazí se dialogové okno Nastavit heslo databáze.

  3. Do pole Heslo zadejte heslo a pak ho zadejte znova do pole Ověření.

    Poznámky: 

    • Používejte silná hesla kombinující malá a velká písmena, čísla a symboly. Slabá hesla obsahují jenom některé z těchto znaků. Příklad silného hesla: Y6dh!et5. Příklad slabého hesla: Domek27. Hesla by měla obsahovat minimálně 8 znaků. Ještě vhodnější jsou hesla obsahující 14 nebo víc znaků.

    • Je velice důležité, abyste si své heslo zapamatovali. Pokud je zapomenete, společnost Microsoft je nemůže odnikud načíst. Pokud si heslo zapíšete, uložte je na bezpečném místě odlišném od místa uložení informací, které heslo pomáhá chránit.

  4. Klikněte na OK.

Dešifrování a otevření databáze

  1. Otevřete šifrovanou databázi stejným způsobem, jakým obvykle otvíráte jakékoli jiné databáze.

    Zobrazí se dialogové okno Zadání hesla.

  2. Zadejte heslo do pole Zadejte heslo databáze a klikněte na tlačítko OK.

Odebrání hesla

  1. Na kartě Soubor klikněte na položku Informace a potom na položku Dešifrovat databázi.

    Zobrazí se dialogové okno Zrušit heslo databáze.

  2. Zadejte heslo do pole Heslo a klikněte na tlačítko OK.

Začátek stránky

Jak funguje zabezpečení u databází ze starších verzí Accessu otevřených v Accessu 2010

Při otevření databáze vytvořené ve starší verzi Accessu budou všechny funkce zabezpečení použité v databázi pořád fungovat. Když jste třeba u databáze použili uživatelskou úroveň zabezpečení, bude tato funkce v Accessu 2010 dál fungovat.

Access ve výchozím nastavení otevírá všechny starší nedůvěryhodné databáze v režimu vypnutí a nechává je v tomto stavu. Vždycky, když otevíráte starší databázi, můžete se rozhodnout povolit všechen zakázaný obsah nebo můžete použít digitální podpis s využitím certifikátu od důvěryhodného vydavatele, případně můžete dát databázi do důvěryhodného umístění.

Důležité informace: Kroky v této části neplatí pro databáze, které používají některý z nových formátů souborů (*.accd?).

V případě databází ve starším formátu souborů můžete u komponent v databázi použít Digitální podpis. Digitální podpis potvrzuje, že všechna makra, moduly kódu a další spustitelné komponenty v databázi pocházejí od toho, kdo databázi podepsal, a že je od okamžiku podpisu databáze nikdo nezměnil.

Abyste mohli databázi podepsat, potřebujete nejdřív digitální certifikát. Pokud vytváříte databáze ke komerční distribuci, musíte certifikát získat od komerční certifikační autority (CA). Certifikační autority na základě kontrol původu ověřují, jestli jsou osoby vytvářející obsah (třeba databáze) seriózní.

Další informace o certifikačních autoritách, které nabízejí služby pro produkty Microsoftu, najdete pod odkazy v části Viz taky.

Pokud chcete používat databázi pro osobní potřebu nebo pro malou pracovní skupinu, poskytuje Microsoft Office Professional 2007 nástroj k vytvoření certifikátu podepsaného svým držitelem. To, jak nainstalovat nástroj s názvem SelfCert.exe a použít ho k vytvoření certifikátu podepsaného svým držitelem, vysvětlují kroky v dalších částech.

Vytvoření certifikátu podepsaného svým držitelem

  1. Přejděte do složky obsahující soubory aplikací Office 2010. Výchozí složka je tato: Jednotka:\Program Files\Microsoft Office\Office14. V této složce najděte soubor SelfCert.exe a poklikejte na něj.

    Zobrazí se dialog Vytvořit digitální certifikát.

  2. Do pole Název vašeho certifikátu zadejte název nového testovacího certifikátu.

  3. Klikněte dvakrát na OK.

Poznámka: Pokud nevidíte příkaz Digitální certifikát pro projekty v jazyce VBA nebo nemůžete najít soubor SelfCert.exe, budete nejspíš muset nainstalovat nástroj SelfCert.

Podepsání kódu databáze

Poznámka: Myslete na to, že tento postup se dá použít jenom u databází ve starším formátu souborů databází, jako je třeba soubor .mdb.

  1. Otevřete databázi, kterou chcete podepsat.

  2. Na kartě Databázové nástroje ve skupině Makro klikněte na Visual Basic. Tím spustíte Visual Basic Editor.

    Klávesová zkratka: Stiskněte ALT+F11.

  3. V okně průzkumníka projektu vyberte databázi nebo projekt VBA (Visual Basic for Applications), který chcete podepsat.

  4. V nabídce Tools (Nástroje) klikněte na Digital Signature (Digitální podpis).

    Zobrazí se dialog Digitální podpis.

  5. Klikněte na Zvolit a vyberte svůj testovací certifikát.

    Zobrazí se dialog Vybrat certifikát.

  6. Vyberte certifikát, který chcete použít.

    Pokud jste postupovali podle kroků v předchozí části, vyberte certifikát, který jste vytvořili pomocí nástroje SelfCert.

  7. Kliknutím na OK zavřete dialog Vlastní certifikát a potom klikněte na OK znova, aby se zavřel dialog Digitální podpis.

Tipy pro podepisování starších verzí databází

  • Pokud chcete uživatelům vašeho řešení zabránit v tom, aby projekt VBA omylem upravili a zrušili platnost vašeho podpisu, tak projekt VBA před podepsáním zamkněte.

    Poznámka: Zamknutí projektu VBA nezabrání jinému uživateli nahradit digitální podpis jiným podpisem. Správci podnikové sítě můžou třeba znova podepsat šablony a doplňky, aby mohli přesně určovat, co budou moct uživatelé na svých počítačích spouštět.

  • Při digitálním podepisování projektu VBA je dobré použít časové razítko, aby mohli ostatní uživatelé ověřit váš podpis i po vypršení platnosti certifikátu použitého k podpisu. Další informace o zabezpečení projektů VBA a časových razítkách najde v dokumentaci pro Microsoft Office Online.

Poznámka: Myslete na to, že tento postup se dá použít jenom v případě, že v Accessu 2010 používáte databáze se starším formátem souborů.

Instalace nástroje SelfCert.exe

  1. Spusťte instalační disk CD nebo jiné instalační médium s Office 2010.

  2. V instalačním programu klikněte na Přidat či odebrat součásti a pak klikněte na Pokračovat.

    Pokud pracujete v prostředí, kde se Microsoft Office na jednotlivé počítače neinstaluje z disku CD, ale instalují ho správci IT, postupujte takto:

    1. V Microsoft Windows, otevřete Ovládací panely.

    2. Poklikejte na Programy a funkce.

    3. Vyberte Microsoft Office 2010 a potom klikněte na Změnit.

      Spustí se instalační program.

    4. Klikněte na Přidat či odebrat součásti a pak klikněte na Pokračovat.

    5. Pokračujte dalšími kroky.

  3. Kliknutím na symboly plus (+) vedle uzlů Microsoft Office a Sdílené součásti systému Office tyto uzly rozbalte.

  4. Klikněte na Digitální certifikát pro projekty v jazyce VBA.

  5. Klikněte na Spouštět z tohoto počítače.

  6. Kliknutím na Pokračovat komponentu nainstalujte.

  7. Po dokončení instalace klikněte na Zavřít a pak se vraťte k první sadě kroků v této části.

Začátek stránky

Spouštění nebezpečných výrazů (zakázání režimu izolovaného prostoru)

Když přidáte do databáze výraz a potom ji označíte za důvěryhodnou nebo ji dáte do důvěryhodného umístění, spustí Access tento výraz v operačním prostředí označovaném jako režim izolovaného prostoru (sandbox). Access to dělá u databází vytvořených v Accessu nebo ve starších formátech souborů Accessu. Režim izolovaného prostoru je v Accessu povolený ve výchozím nastavení a v tomto režimu jsou nebezpečné výrazy vždycky zakázané, a to i v případě, že jste databázi označili za důvěryhodnou. Další informace o výrazech, které režim izolovaného prostoru zakazuje, najdete v článku Režim izolovaného prostoru výrazové služby Microsoft Jet na webu Microsoft Office.com.

Pokud databázi považujete za důvěryhodnou a chcete spustit výraz, který režim izolovaného prostoru zakazuje, můžete ho spustit, když změníte klíč registru a zakážete režim izolovaného prostoru. Nezapomeňte, že tyto kroky můžete udělat, až když databázi označíte za důvěryhodnou.

Rozhodovací proces, kterým musíte při spouštění nebezpečných výrazů projít, znázorňuje tento diagram.

Rozhodovací proces pro režim izolovaného prostoru

Upozornění: Nesprávné úpravy registru můžou způsobit vážné poškození operačního systému, a to až takové, že se bude muset přeinstalovat. Microsoft nezaručuje, že potíže způsobené nesprávnou úpravou registru půjdou odstranit. Před úpravami registru si zazálohujte všechna cenná data. Nejnovější informace o použití a ochraně registru počítače najdete v nápovědě k Microsoft Windows.

Pokud nemáte s prací s registrem zkušenosti nebo se nechcete do změn klíčů registru pouštět, kontaktujte někoho, kdo to umí, případně zvažte převod databáze ze starší verze Accessu na novější formát souboru. Ke změně hodnot registru je taky nutné, abyste na počítači měli oprávnění správce.

Změna klíče registru

Důležité informace: Následujícím postupem povolíte spuštění nebezpečných výrazů ve všech instancích Accessu pro všechny uživatele v počítači.

  1. V Microsoft Windows klikněte na tlačítko Start a potom na Spustit.

  2. Do pole Otevřít zadejte regedit a stiskněte ENTER.

    Spustí se Editor registru.

  3. Rozbalte složku HKEY_LOCAL_MACHINE a přejděte k následujícímu klíči registru:

    \Software\Microsoft\Office\14.0\Access Connectivity Engine\Engines

  4. V pravém podokně Editoru registru poklikejte na hodnotu SandboxMode.

    Zobrazí se dialogové okno Upravit hodnotu DWORD.

  5. V poli Údaj hodnoty změňte hodnotu 3 na 2 a poté klikněte na tlačítko OK.

  6. Zavřete Editor registru.

Důležité:    Pamatujte na to, že pokud databázi nejdřív neoznačíte jako důvěryhodnou, Access všechny nebezpečné výrazy zakáže bez ohledu na to, jestli jste toto nastavení registru změnili nebo ne.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×