Úvod k dotazům

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Použití dotazu umožňuje prohlížet, přidávat, odstraňovat nebo měnit data ve vaší accessové databázi. Některé další důvody pro používání dotazů:

  • Rychlé nalezení dat pomocí filtrování na základě konkrétních kritérií (podmínky)

  • Výpočty nebo souhrny dat

  • Automatizace úkolů správy dat, jako je například opakovaná kontrola nejaktuálnějších dat

Poznámka: Pokud chcete vyzkoušet dotazy v příkladech, použijte desktopovou databázi Accessu.

Dotazy pomáhají najít data a pracovat s nimi

Vytvoření výběrového dotazu

Vytvoření parametrického dotazu

Vytvoření souhrnného dotazu

Vytvoření křížového dotazu

Vytvoření vytvářecího dotazu

Vytvoření přidávacího dotazu

Vytvoření aktualizačního dotazu

Vytvoření odstraňovacího dotazu

Dotazy pomáhají najít data a pracovat s nimi

V dobře navržené databázi se data, která chcete prezentovat prostřednictvím formuláře nebo sestavy, obvykle nacházejí ve více tabulkách. Dotaz může načíst informace z různých tabulek a sestavit je pro zobrazení ve formuláři nebo sestavě. Dotaz může představovat požadavek na zobrazení výsledků dat z databáze, na provedení akce s daty nebo na kombinaci obou dvou operací. Dotaz může poskytnout odpověď na jednoduchou otázku, provádět výpočty, slučovat data z různých tabulek nebo dokonce přidávat, měnit či odstraňovat data z databáze. Protože jsou dotazy velmi univerzální, existuje jich mnoho typů, které při vytváření volíte podle dané úlohy.

Hlavní typy dotazů

Použití

Výběrový

Načtení dat z tabulky nebo provádění výpočtů

Akční

Přidání, změna nebo odstranění data. Každý úkol má určitý typ akčního dotazu. Akční dotazy nejsou k dispozici ve webových aplikacích pro Access.

Vytvoření výběrového dotazu

Pokud budete chtít prohlížení dat z jenom určitých polí v tabulce, nebo současné prohlížení dat z více tabulek nebo možná zobrazit pouze data v závislosti na určitá kritéria, by typu výběrový dotaz svého výběru. Další informace najdete v tématu vytvořit jednoduchý výběrový dotaz.

Prohlížení dat z vybraných polí

Pokud například vaše databáze obsahuje tabulku s velkým množstvím informací o produktech a chcete si prohlédnout seznam produktů a jejich ceny, následujícím způsobem vytvoříte výběrový dotaz, který vrátí pouze názvy produktů a jejich odpovídající ceny:

  1. Otevřete databázi a na kartě Vytvoření klikněte na Návrh dotazu.

  2. V okně Zobrazit tabulku na kartě Tabulky poklikejte na tabulku Výrobky a potom dialogové okno zavřete.

  3. Dejme tomu, že máte v tabulce Produkty pole Název produktu a Ceníková cena. Poklikejte na položku Název výrobku a Ceníková cena, čímž tato pole přidáte do Návrhová mřížka dotazu.

  4. Na kartě Návrh klikněte na Spustit. Dotaz se spustí a zobrazí seznam výrobků a jejich ceny.

Začátek stránky

Současné prohlížení dat z více tabulek spojených relacemi

Předpokládejme, že máte databázi obchodu, který prodává potraviny, a chcete si prohlédnout objednávky zákazníků, kteří bydlí v konkrétním městě. Řekněme, že data o objednávkách a data o zákaznících jsou uložena ve dvou tabulkách pojmenovaných Zákazníci a Objednávky. Každá tabulka má pole ID zákazníka, které tvoří základ Relace 1:N mezi oběma tabulkami. Dotaz vracející objednávky pro zákazníky v konkrétním městě, například v Las Vegas, můžete vytvořit pomocí následujícího postupu:

  1. Otevřete databázi. Na kartě Vytvoření klikněte ve skupině Dotaz na tlačítko Návrh dotazu.

  2. V dialogovém okně Zobrazit tabulku poklikejte na kartě Tabulky na položku Zákazníci a Objednávky.

  3. Zavřete dialogové okno Zobrazit tabulku. Povšimněte si čáry (nazývané spojení), která spojuje pole ID v tabulce Zákazníci a pole ID zákazníka v tabulce Objednávky. Tato čára zobrazuje relaci mezi oběma tabulkami.

  4. V tabulce Zákazníci poklikejte na položky Společnost a Město, čímž tato pole přidáte do návrhové mřížky dotazu.

  5. V návrhové mřížce dotazu zrušte ve sloupci Město zaškrtnutí políčka na řádku Zobrazit.

  6. Na řádku Kritéria ve sloupci Město zadejte Las Vegas.

    Jestliže zrušíte zaškrtnutí políčka Zobrazit, zabráníte zobrazení města ve výsledcích dotazu, a pokud zadáte hodnotu Las Vegas do řádku Kritéria, určíte, že chcete zobrazit pouze záznamy, v nichž pole Město obsahuje hodnotu Las Vegas. V tomto případě dotaz vrátí pouze zákazníky se sídlem v Las Vegas. Pole, která chcete použít v kritériu, nemusíte zobrazit.

  7. V tabulce Objednávky poklikejte na položku ID objednávky a Datum objednávky, čímž tato pole přidáte do dalších dvou sloupců návrhové mřížky dotazu.

  8. Na kartě Návrh, ve skupině Výsledky, klikněte na příkaz Spustit. Dotaz se spustí a následně zobrazí seznam objednávek pro zákazníky v Las Vegas.

  9. Stisknutím kombinace kláves CTRL+S dotaz uložte.

Začátek stránky

Vytvoření parametrického dotazu

Pokud chcete často spouštět varianty určitého dotazu, zvažte použití parametrického dotazu. Když spustíte parametrický dotaz, zobrazí se výzva k zadání hodnot polí a vámi zadané hodnoty se následně použijí k vytvoření kritérií pro daný dotaz.

Poznámka: Parametrický dotaz nelze vytvořit ve webové aplikaci pro Access.

V předchozím příkladu jste se naučili, jak vytvořit výběrový dotaz vracející objednávky pro zákazníky se sídlem v Las Vegas. Dotaz nyní můžete změnit tak, aby při každém spuštění zobrazoval výzvu k zadání města. Pro pokračování otevřete databázi, kterou jste vytvořili v předchozím příkladu:

  1. V navigačním podokně klikněte pravým tlačítkem myši na dotaz s názvem Objednávky podle města (vytvořený v předchozí části) a potom klikněte na příkaz Návrhové zobrazení v místní nabídce.

  2. V návrhové mřížce dotazu na řádku Kritéria ve sloupci Město odstraňte hodnotu Las Vegas a zadejte řetězec [Zadejte město:].

    Řetězec [Zadejte město:] je výzvou k zadání parametru. Hranaté závorky označují, že dotaz má vyzvat k zadání hodnoty, a obsahují text (v tomto případě Zadejte město:), který se má ve výzvě k zadání parametru zobrazit.

    Poznámka: Text ve výzvě k zadání parametru nesmí obsahovat tečku (.) ani vykřičník (!).

  3. Zaškrtněte políčko na řádku Zobrazit sloupce Město, aby se ve výsledcích dotazu zobrazilo město.

  4. Na kartě Návrh, ve skupině Výsledky, klikněte na příkaz Spustit. Dotaz zobrazí výzvu k zadání hodnoty pro pole Město.

  5. Zadejte New York a potom stisknutím klávesy ENTER si zobrazte objednávky pro zákazníky v New Yorku.

    Ale co v případě, že nevíte, jaké hodnoty lze zadat? Jako součást výzvy můžete použít zástupné znaky:

  6. Na kartě Domů klikněte ve skupině Zobrazení na položku Zobrazení a potom na položku Návrhové zobrazení.

  7. V návrhové mřížce dotazu zadejte na řádku Kritéria ve sloupci Město řetězec Like [Zadejte město:]&"*".

    Klíčové slovo Like, znak ampersand (&) a hvězdička (*) uzavřená v uvozovkách umožňují uživateli zadat ve výzvě k zadání parametru kombinaci znaků, včetně zástupných znaků, která bude vracet nejrůznější výsledky. Pokud například uživatel zadá znak *, dotaz vrátí všechna města, pokud zadá písmeno L, dotaz vrátí všechna města začínající tímto písmenem, a pokud zadá řetězec *s*, dotaz vrátí všechna města obsahující písmeno „s“.

  8. Na kartě Návrh ve skupině Výsledky klikněte na Spustit, do výzvy dotazu zadejte New a stiskněte ENTER.

    Dotaz se spustí a následně zobrazí objednávky pro zákazníky v New Yorku.

Zadání datových typů parametrů

Měli byste rovněž zadat, jaký datový typ by měl parametr přijímat. Datový typ můžete nastavit pro libovolný parametr, avšak je zvlášť důležité jej nastavit pro číselná data, údaje s uvedením měny nebo kalendářní data a časy. Zadáte-li pro parametr přijímaný datový typ, zobrazí se uživatelům užitečnější chybová zpráva v případě, že zadají chybný datový typ, například při zadání textu namísto očekávané částky s uvedením měny.

Pokud je parametr nastaven na příjem textových dat, bude jakýkoli vstup interpretován jako text a nezobrazí se žádná chybová zpráva.

Chcete-li pro parametry v dotazu zadat datový typ, postupujte následujícím způsobem:

  1. Při otevření dotazu v návrhovém zobrazení klikněte na kartě Návrh ve skupině Zobrazit či skrýt na položku Parametry.

  2. V dialogovém okně Parametry dotazu zadejte ve sloupci Parametr výzvu pro každý parametr, pro který chcete zadat datový typ. Ověřte, zda každý parametr odpovídá výzvě použité na řádku Kritéria v návrhové mřížce dotazu.

  3. Ve sloupci Datový typ vyberte datový typ pro každý parametr.

Další informace najdete v tématu Použití parametrů uživatele o zadání kritérií při spuštění dotazu.

Začátek stránky

Vytvoření souhrnného dotazu

Řádek Součet v datovém listu je velmi užitečný, avšak v případě složitějších otázek se používá souhrnný dotaz. Souhrnný dotaz představuje výběrový dotaz, který umožňuje seskupit a shrnout data – například když chcete zobrazit celkový prodej pro jednotlivé výrobky. V souhrnném dotazu můžete k zobrazení celkového prodeje pro jednotlivé výrobky použít funkci Součet, což je agregační funkce.

Poznámka: Agregační funkce nelze použít ve webové aplikaci pro Access.

Pomocí následujícího postupu upravte dotaz Mezisoučty výrobků, který jste vytvořili v předchozím příkladu, aby vytvořil souhrn mezisoučtů výrobků podle produktu.

  1. Na kartě Domů klikněte na Zobrazení > Návrhové zobrazení.

    Dotaz Mezisoučty výrobků se otevře v návrhovém zobrazení.

  2. Na kartě Návrh ve skupině Zobrazit nebo skrýt klikněte na Součty.

    V návrhové mřížce dotazu se zobrazí řádek Součty.

Poznámka: Řádek Součty v návrhové mřížce není totéž co řádek Součet v datovém listu, ačkoli mají podobný název:

  • Pomocí řádku Součty v návrhové mřížce můžete seskupovat data podle hodnot polí.

  • Řádek Součet v datovém listu můžete přidat do výsledků souhrnného dotazu.

  • Pokud použijete řádek Součty v návrhové mřížce, je třeba zvolit agregační funkci pro každé pole. Nechcete-li u pole provést výpočet, můžete podle něj provést seskupení.

  • Ve druhém sloupci návrhové mřížky vyberte na řádku Celkem z rozevíracího seznamu funkci Součet.

  • Na kartě Návrh, ve skupině Výsledky, klikněte na příkaz Spustit. Dotaz se spustí a následně zobrazí seznam výrobků s mezisoučty.

  • Stisknutím kombinace kláves CTRL+S dotaz uložte. Ponechejte dotaz otevřený.

Další informace najdete v článku Zobrazení součtů sloupců v datovém listu pomocí řádku souhrnů.

Začátek stránky

Provádění výpočtů na základě dat

Tabulky většinou nebudete používat k ukládání vypočtených hodnot, jako jsou mezisoučty, a to i když jsou založeny na datech ve stejné databázi, protože vypočítané hodnoty mohou při změně hodnot, na kterých jsou založeny, přestat být aktuální. Například není vhodné ukládat v tabulce věk osob, protože každý rok byste tuto hodnotu museli aktualizovat – místo toho uložíte datum narození dané osoby a potom pomocí dotazu vypočtete věk.

Máte například databázi produktů, které chcete prodat. Tato databáze obsahuje tabulku nazvanou Rozpis objednávek, která obsahuje informace o produktech v polích, jako je cena a množství jednotlivých produktů. Mezisoučet můžete vypočítat použitím dotazu, který množství každého výrobku vynásobí příslušnou jednotkovou cenou, potom množství každého výrobku vynásobí příslušnou jednotkovou cenou a slevou a následně od celkové ceny odečte celkovou slevu. Pokud jste v předchozím příkladu vytvořili ukázkovou databázi, otevřete ji a pokračujte podle pokynů:

  1. Na kartě Vytvoření klikněte na Návrh dotazu.

  2. V dialogovém okně Zobrazit tabulku na kartě Tabulky poklikejte na Rozpis objednávek.

  3. Zavřete dialogové okno Zobrazit tabulku.

  4. V tabulce Rozpis objednávek poklikáním na pole ID výrobku ho přidejte do prvního sloupce návrhové mřížky dotazu.

  5. Ve druhém sloupci mřížky klikněte pravým tlačítkem myši na řádek Pole a potom v místní nabídce klikněte na Lupa.

  6. Do pole Lupa zadejte nebo vložte následující řetězec: Mezisoučet: ([Množství]*[Jednotková cena])-([Množství]*[Jednotková cena]*[Sleva]).

  7. Klikněte na OK.

  8. Na kartě Návrh klikněte na Spustit. Dotaz se spustí a zobrazí seznam výrobků a mezisoučty pro jednotlivé objednávky.

  9. Stisknutím kombinace kláves CTRL+S uložte dotaz a pojmenujte jej Mezisoučty výrobků.

Další informace najdete v článku Zobrazení součtů sloupců v datovém listu pomocí řádku souhrnů.

Začátek stránky

Zobrazení souhrnů nebo agregačních dat

Při použití tabulek pro zaznamenávání transakcí nebo ukládání pravidelně se vyskytujících číselných dat je užitečné mít možnost prohlížet tato data v agregované podobě, například jako součty nebo průměry. V aplikaci Access můžete do Datový list přidat řádek Celkem. Řádek Celkem je umístěn v dolní části datového listu a umožňuje zobrazit aktuální součet nebo jinou agregovanou hodnotu.

  1. Spusťte dotaz mezisoučty výrobků, které jste dříve vytvořili a ponechejte výsledky otevřené v Zobrazení Datový list.

  2. Na kartě Domů klikněte na Součty. Na novém řádku se zobrazí v dolní části datový list se slovo celkové v prvním sloupci.

  3. Klikněte na buňku v posledním řádku datového listu s názvem Celkem.

  4. Kliknutím na šipku zobrazíte dostupné agregační funkce. Protože sloupec obsahuje textová data, jsou k dispozici jen dvě možnosti: Žádný a Počet.

  5. Klikněte na položku Počet. Obsah buňky se změní z textu Celkem na počet hodnot ve sloupci.

  6. Klikněte na vedlejší buňku (druhý sloupec). Všimněte si, že se v buňce objeví šipka.

  7. Klikněte na šipku a potom na položku Součet. Pole zobrazí součet hodnot ve sloupci.

  8. Ponechejte dotaz otevřený v zobrazení Datový list.

Začátek stránky

Vytvoření křížového dotazu

Nyní předpokládejme, že chcete prohlížet mezisoučty výrobků, avšak zároveň chcete provést agregaci podle měsíců, aby každý řádek zobrazoval mezisoučty pro výrobky a každý sloupec mezisoučty výrobků za měsíc. Mezisoučty pro výrobky a mezisoučty výrobků za měsíc zobrazíte pomocí Křížový dotaz.

Poznámka: Křížový dotaz nelze zobrazit ve webové aplikaci pro Access.

Dotaz Mezisoučty výrobků můžete znovu upravit tak, aby vracel řádky s mezisoučty výrobků a sloupce s měsíčními mezisoučty.

  1. Na kartě Domů klikněte ve skupině Zobrazení na položku Zobrazení a potom na položku Návrhové zobrazení.

  2. Ve skupině Nastavení dotazu klikněte na tlačítko Zobrazit tabulku.

  3. V dialogovém okně Zobrazit tabulku poklikejte na položku Objednávky a potom klikněte na tlačítko Zavřít.

  4. Na kartě Návrh klikněte ve skupině Typ dotazu na Křížový. V návrhové mřížce je řádek Zobrazit skrytý a řádek Křížový zobrazený.

  5. Ve třetím sloupci návrhové mřížky klikněte pravým tlačítkem myši na řádek Pole a potom v místní nabídce klikněte na příkaz Lupa. Otevře se okno Lupa.

  6. Do pole Lupa zadejte nebo vložte následující řetězec: Měsíc: "Měsíc " & DatePart("m", [Datum objednávky]).

  7. Klikněte na tlačítko OK.

  8. Na řádku Křížová tabulka vyberte z rozevíracího seznamu tyto hodnoty: Záhlaví řádku pro první sloupec, Hodnota pro druhý sloupec a Záhlaví sloupce pro třetí sloupec.

  9. Na kartě Návrh, ve skupině Výsledky, klikněte na příkaz Spustit. Dotaz se spustí a následně zobrazí mezisoučty výrobků agregované podle měsíců.

  10. Stisknutím kombinace kláves CTRL+S dotaz uložte.

    Další informace o křížových dotazů najdete v tématu vytvoření souhrnných dat snadněji číst pomocí křížového dotazu.

Začátek stránky

Vytvoření vytvářecího dotazu

K vytvoření nové tabulky z dat uložených v jiných tabulkách můžete použít vytvářecí dotaz.

Poznámka: Vytvářecí dotaz není k dispozici ve webových aplikacích pro Access.

Pokud například chcete odeslat data týkající se objednávek uskutečněných v Chicagu svému obchodnímu partnerovi z Chicaga, který používá aplikaci Access k vytváření sestav, nebudete pravděpodobně odesílat veškerá data objednávek, ale pouze data objednávek z Chicaga.

Provedením následujícího postupu můžete sestavit výběrový dotaz, který shromáždí data týkající se objednávek pro Chicago, a potom na základě tohoto dotazu vytvořit novou tabulku:

  1. Otevřete ukázkovou databázi z předchozího příkladu.

    Ke spuštění vytvářecího dotazu může být potřeba povolit obsah databáze.

    Poznámka:  Pokud se pod pásem karet zobrazí zpráva o povolení databáze, klikněte na Povolit obsah. Pokud se už databáze nachází v důvěryhodném umístění, panel zpráv se nezobrazí.

  2. Na kartě Vytvoření klikněte ve skupině Dotazy na tlačítko Návrh dotazu.

  3. V dialogovém okně Zobrazit tabulku poklikejte na položky Rozpis objednávek a Objednávky a zavřete dialogové okno Zobrazit tabulku.

  4. V tabulce Objednávky poklikejte na položku ID zákazníka a Město příjemce, čímž tato pole přidáte do návrhové mřížky.

  5. V tabulce Rozpis objednávek poklikejte na položky ID objednávky, ID výrobku, Množství, Jednotková cena a Sleva, čímž tato pole přidáte do návrhové mřížky.

  6. Ve sloupci Město příjemce návrhové mřížky zrušte zaškrtnutí políčka na řádku Zobrazit. Na řádku Kritéria zadejte text 'Chicago' (včetně jednoduchých uvozovek). Ověřte výsledky dotazu dříve, než je použijete k vytvoření tabulky.

  7. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

  8. Stisknutím kombinace kláves CTRL+S dotaz uložte.

  9. Do pole Název dotazu zadejte Dotaz na objednávky pro Chicago a potom klikněte na OK.

  10. Na kartě Domů klikněte ve skupině Zobrazení na Zobrazení a potom klikněte na Návrhové zobrazení.

  11. Na kartě Návrh klikněte ve skupině Typ dotazu na položku Vytvářecí.

  12. V dialogovém okně Vytvářecí zadejte v poli Název tabulky text Objednávky pro Chicago a potom klikněte na OK.

  13. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

  14. V potvrzovacím dialogovém okně klikněte na tlačítko Anoa v navigačním podokně se zobrazí nová tabulka.

    Poznámka: Pokud již existuje tabulka se stejným názvem, který jste zadali, aplikace Access tuto tabulku před spuštěním dotazu odstraní.

Další informace o používání vytvářecí dotazy najdete v článku Vytvoření vytvářecího dotazu.

Začátek stránky

Vytvoření přidávacího dotazu

K načtení dat z jedné nebo více tabulek a jejich přidání do jiné tabulky se používá přidávací dotaz.

Poznámka: Přidávací dotaz není k dispozici ve webových aplikacích pro Access.

Předpokládejme například, že jste vytvořili tabulku, kterou budete sdílet s obchodním partnerem v Chicagu, avšak uvědomíte si, že tento partner pracuje rovněž s klienty v oblasti Milwaukee. Před sdílením tabulky s partnerem chcete do tabulky přidat řádky obsahující data pro oblast Milwaukee. Data týkající se oblasti Milwaukee můžete do tabulky Objednávky pro Chicago přidat provedením následujícího postupu:

  1. Otevřete dotaz s názvem "Dotaz na objednávky pro Chicago", že kterou jste vytvořili dříve v návrhovém zobrazení.

  2. Na kartě Návrh klikněte ve skupině Typ dotazu na Přidávací. Otevře se dialogové okno Přidat.

  3. V dialogovém okně Přidat klikněte na šipku v poli Název tabulky, z rozevíracího seznamu vyberte položku Objednávky pro Chicago a klikněte na tlačítko OK.

  4. V návrhové mřížce odstraňte na řádku Kritéria ve sloupci Město příjemce řetězec 'Chicago' a potom zadejte řetězec 'Milwaukee'.

  5. Na řádku Přidat do vyberte odpovídající pole pro každý sloupec.

    V tomto příkladu by hodnoty řádku Přidat do měly odpovídat hodnotám na řádku Pole, není to však nutné pro fungování přidávacích dotazů.

  6. Na kartě Návrh klikněte ve skupině Výsledky na tlačítko Spustit.

Poznámka:  Při spuštění dotazu, který vrací velké množství dat, se může zobrazit chybová zpráva s informací, že dotaz nebude možné vrátit zpět. Chcete-li aby se dotaz provedl, zkuste zvýšit limit segmentu paměti na 3 MB.

Další informace o přidávacích dotazech najdete v tématu Přidání záznamů do tabulky pomocí přidávacího dotazu.

Začátek stránky

Vytvoření aktualizačního dotazu

Data v tabulkách můžete změnit pomocí aktualizačního dotazu. V tomto dotazu můžete zadat kritéria určující, které řádky by měly být aktualizovány. Aktualizační dotaz nabízí možnost prohlédnout aktualizovaná data před provedením aktualizace.

Důležité informace: Akční dotaz nelze vzít zpět. Zvažte vytvoření zálohy všech tabulek, které se aktualizuje pomocí aktualizačního dotazu. Aktualizační dotaz není k dispozici ve webových aplikacích pro Access.

V předchozím příkladu jste k tabulce Objednávky pro Chicago přidali řádky. Pole ID výrobku v tabulce Objednávky pro Chicago zobrazuje číselné ID výrobku. Aby byla data užitečnější pro sestavy, můžete ID výrobků nahradit názvy produktů podle následujícího postupu:

  1. Otevřete tabulku Objednávky pro Chicago v návrhovém zobrazení.

  2. Na řádku ID výrobku změňte datový typ z hodnoty Číslo na Text.

  3. Uložte a zavřete tabulku Objednávky pro Chicago.

  4. Na kartě Vytvoření klikněte ve skupině Dotaz na tlačítko Návrh dotazu.

  5. V dialogovém okně Zobrazit tabulku poklikejte na položky Objednávky pro Chicago a Produkty a zavřete dialogové okno Zobrazit tabulku.

  6. Na kartě Návrh klikněte ve skupině Typ dotazu na položku Aktualizační.

  7. V návrhové mřížce zmizí řádky Seřadit a Zobrazit a objeví se řádek Aktualizovat do.

  8. V tabulce Objednávky pro Chicago poklikejte na položku ID výrobku, čímž toto pole přidáte do návrhové mřížky.

  9. V návrhové mřížce zadejte nebo vložte na řádku Aktualizovat do ve sloupci ID výrobku toto: [Výrobky].[Název výrobku].

    Tip: Pomocí aktualizačního dotazu můžete hodnoty polí odstranit, a to použitím prázdného řetězce ("") nebo hodnoty NULL na řádku Aktualizovat do.

  10. Na řádku Kritéria zadejte nebo vložte toto: [ID výrobku] Like ([Výrobky].[ID]).

  11. Zobrazením dotazu v zobrazení Datový list můžete zkontrolovat, které hodnoty se aktualizačním dotazem změní.

  12. Na kartě Návrh klikněte na Zobrazení > Datový list. Dotaz vrátí aktualizovaný seznam ID výrobků.

  13. Na kartě Návrh klikněte na Spustit.

    Když otevřete tabulku objednávky pro Chicago, zobrazí se, že číselné hodnoty v poli Kód výrobku byly nahrazeny názvy produktů z tabulky produkty.

Další informace o aktualizačních dotazech najdete v tématu Vytvoření a spuštění aktualizačního dotazu.

Začátek stránky

Vytvoření odstraňovacího dotazu

K odstranění dat z tabulek můžete použít odstraňovací dotaz. V tomto dotazu můžete zadat kritéria určující, které řádky mají být odstraněny. Odstraňovací dotaz nabízí možnost zkontrolovat řádky, které budou odstraněny, před jejich odstraněním.

Poznámka: Možnost odstraňovacího dotazu není k dispozici ve webových aplikacích pro Access.

Předpokládejme například, že připravujete odeslání tabulky Objednávky pro Chicago z předchozího příkladu obchodnímu partnerovi v Chicagu a všimnete si, že některé řádky obsahují mnoho prázdných polí. Rozhodli jste se před odesláním tabulky tyto řádky odebrat. Mohli byste jednoduše otevřít tabulku a odstranit řádky ručně, ovšem pokud potřebujete odstranit hodně řádků a máte jasná kritéria, podle kterých by měly být řádky odstraněny, mohlo by být užitečné použít odstraňovací dotaz.

Provedením následujícího postupu můžete z tabulky Objednávky pro Chicago pomocí dotazu odstranit řádky, které neobsahují hodnotu ID objednávky:

  1. Na kartě Vytvoření klikněte na Návrh dotazu.

  2. V okně Zobrazit tabulku poklikejte na Objednávky pro Chicago a okno Zobrazit tabulku zase zavřete.

  3. Na kartě Návrh ve skupině Typ dotazu klikněte na Odstraňovací. V návrhové mřížce zmizí řádky Seřadit a Zobrazit a objeví se řádek Odstranit.

  4. V tabulce Objednávky pro Chicago poklikejte na položku ID objednávky, čímž ji přidáte do mřížky.

  5. V návrhové mřížce zadejte na řádku Kritéria ve sloupci ID objednávky hodnotu IsNull.

  6. Na kartě Návrh ve skupině Výsledky klikněte na Spustit.

Další informace o dotazech najdete v tématu Vytvoření a spuštění odstraňovacího dotazu.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×