Преминаване към основното съдържание
Office
×
Английски
Съжаляваме. Тази статия не е налична на вашия език.

Beginner tutorial for Visio

Visio lets you transform complicated text and tables that are hard to understand into visual diagrams that communicate information at a glance. There are many kinds of Visio diagrams, including organization charts, network diagrams, workflows, and home or office plans. Getting started with Visio can be summarized into three basic steps: using a template, arranging and connecting shapes, and modifying shapes with text.

Note: If you have Visio Plan 2, you have access to both the installed app and the web version of Visio. With Visio Plan 1, you don't get the installed Visio app. Not sure which license you have? You can check what version you have.

Note: See Install Visio if you haven't installed the Visio app yet.

Tutorial: 3 basic steps to create a Visio diagram:

  1. Choose and open a template

  2. Arrange and connect shapes

  3. Add text to shapes and connectors

Choose and open a template

Templates include stencils, shapes, and grid measurements to help you get started quickly and easily when making your diagram.

  • Templates come with stencils that are full of the shapes needed to create a particular kind of drawing.

    The Home Plan template, for example, opens with stencils full of shapes such as walls, furniture, appliances, cabinets, and so on.

    The Organization Chart template includes distinct shapes for executives, managers, assistants, positions, consultants, vacancies, and more.

  • Appropriate grid size and ruler measurements

    Some drawings require a special scale. For example, the Site Plan template opens with an engineering scale, where 1 inch represents 10 feet. Templates come ready with appropriate settings for the drawing type.

  • Special tabs

    Some templates have unique features that you can find on special tabs in the ribbon. For example, when you open the Office Layout template, a Plan tab appears. You can use the Plan tab to configure display options that are specific to office layout diagrams.

  • Wizards to help you with special types of drawings

    In some cases when you open a Visio template, a wizard helps you get started. For example, the Space Plan template opens with a wizard that helps you set up your space and room information.

  1. Start the Visio app or open Visio on the web. If Visio is already open, select File > New.

    Note: Haven't installed Visio yet? If you have Visio Plan 2, you can download and install the Visio desktop app.

  2. Select the template you want, or select Basic Diagram to start from scratch.

    You can also browse for more templates by clicking Categories, and you can enter terms to search for templates.

    Template gallery

  3. If you're using the desktop link, you may have to specify a specific type of that template and then select Create.

Arrange and connect shapes

To create your diagram, you drag shapes from the stencil in the Shapes window to the canvas and connect them. There are several ways to connect shapes, but the simplest way is with AutoConnect arrows.

Note: AutoConnect is available by default when your drawing is based on a template for a type that typically requires connections, like a flowchart. If do not see the AutoConnect arrows Button image when you hover the mouse pointer over a shape, AutoConnect is not active. To activate AutoConnect, click Connector in the Tools area on the Home tab.

Visio shapes are ready-made objects that you drag onto your drawing page — they are the building blocks of your diagram.

When you drag a shape from the Shapes window onto your drawing page, the original shape remains on the stencil. That original is called a master shape. The shape that you put on your drawing is a copy — also called an instance — of that master. You can drag as many instances of the same shape onto your drawing as you want.

Instead of static pictures, you can create data-connected Visio diagrams that display data, are easy to refresh, and dramatically increase your productivity. You can use the wide variety of diagram templates and stencils in Visio to understand, act on, and share information about organizational systems, resources, and processes throughout your enterprise.

Rotating and resizing shapes

  • Rotation handles

    The round handle Rotation handle located above a selected shape is called a rotation handle. Drag it right or left to rotate the shape.

  • Connection arrows for AutoConnect

    The connection arrows Button image help you easily connect shapes to one another, as you saw in the previous section.

  • Selection handles for resizing shapes

    You can use the square selection handles to change the height and width of your shape. Click and drag a selection handle on the corner of a shape to enlarge the shape without changing its proportions, or click and drag a selection handle on the side of a shape to make the shape taller or wider.

Visio shapes can hold data

You can add data to each shape by typing it in the Shape Data window – on the View tab, in the Show group, click Task Panes, and then click Shape Data. With Visio Professional Edition, you can also import data from an external data source.

Data is not displayed in the drawing by default. To see the data for an individual shape, open the Shape Data window at Data > Show/Hide > Shape Data Window, then select the shape.

If you want to display the data for lots of shapes at once, you can use a feature called data graphics, also on the Data tab. The following illustration shows the data for two trees at once.

Data graphics shows the data for two shapes at one time.

Visio shapes with special behavior

Many Visio shapes have special behavior that you can find by stretching, right-clicking, or moving the yellow control handle on the shape.

For example, you can stretch a People shape to show more people, or stretch the Growing flower shape to indicate growth.

People shape displays up to four people if stretched horizontally   Growing flower shape grows taller if stretched vertically

Tip: A great way to find out what a shape can do is to right-click it to see if there are any special commands on its shortcut menu.

If you’re building an organization chart, shapes can automatically build the reporting structure. Drag each person’s shape to the chart and drop it on top of their manager’s shape. The shapes automatically connect to show the hierarchy.

  1. In the Shapes window, select a shape and drag it onto the canvas.

    Drag a shape to add

  2. Hold your mouse over one of the arrows and a mini toolbar appears with the top four shapes in the Quick Shapes area.
    AutoConnect mini toolbar
    Select the shape you want and it'll automatically connect to the arrow you selected.

  3. You can also drag all your shapes onto the canvas. Then hold the mouse over a shape until the arrows appear. Then grab an arrow and drag it to a shape you want to connect to.

    Drop on autoconnect arrow
  4. If you're using the Visio desktop app, you can also drag a new shape directly from the Shapes window to an existing shape's arrows and connect them automatically.

    Drop shape on autoconnect arrow

Add text to shapes and connectors

Now it's time to add details to your diagram by adding text. For more details about working with text, see Add, edit, move, or rotate text on shapes and Add text to a page.

  1. Select a shape.

  2. Type your text. When you start typing, Visio switches the selected shape to text editing mode.

    Select a shape and type

  3. Click an empty area of the page, or press Esc when you’re finished.

    Note: To move text on a shape, go to Home > Tools > Text Block Text Block , and go to a shape that has text on it. Drag the text around and then go back and click Home > Tools > Pointer Tool Select Objects when you’re done.

Add text to a connector the same way. After you press ESC or click away, select the connector again and you’ll see a tiny box on the text – this is a handle for moving the text block. Click and drag it up, down, or beside the connector.

Customize your Visio diagram

Once you've created your Visio diagram, there's more you can do to make it your own:

  1. On the Design tab, hover the mouse pointer over the various themes.

    Visio temporarily applies each theme as you hover the mouse pointer over them.

    Theme gallery in Visio

  2. To see other available themes, click More The More button .

  3. Click the theme that you want to apply to the diagram.

  1. Click Design and then click Backgrounds.

  2. Click a background.

    Your diagram gets a new background, and, a new background page called VBackground-1. This page you can see in the page tabs along the bottom of the canvas.

    Background tab in Visio

  1. Click Design > Borders & Titles and click the title style that you want.

  2. Click a title style.

    The title and border appear on the background page.

  3. At the bottom of the diagramming area, click the VBackground-1 tab.

  4. Click the title text.

    The entire border is selected, but when you start typing it changes the title text.

  5. Type your title, then press ESC.

  6. To edit other text in the border, first select the entire border, and then click the text you want to change and start typing. You may have to click more than once to get the text selected.

  7. Click Page-1 in the lower-right corner of the page to return to the drawing.

Tutorial: 3 basic steps to create a Visio diagram:

  1. Choose and open a template

  2. Arrange and connect shapes

  3. Add text to shapes and connectors

Choose and open a template

Templates include stencils, shapes, and grid measurements to help you get started quickly and easily when making your diagram.

  • Templates come with stencils that are full of the shapes needed to create a particular kind of drawing.

    The Home Plan template, for example, opens with stencils full of shapes such as walls, furniture, appliances, cabinets, and so on.

    The Organization Chart template includes distinct shapes for executives, managers, assistants, positions, consultants, vacancies, and more.

  • Appropriate grid size and ruler measurements

    Some drawings require a special scale. For example, the Site Plan template opens with an engineering scale, where 1 inch represents 10 feet. Templates come ready with appropriate settings for the drawing type.

  • Special tabs

    Some templates have unique features that you can find on special tabs in the ribbon. For example, when you open the Office Layout template, a Plan tab appears. You can use the Plan tab to configure display options that are specific to office layout diagrams.

  • Wizards to help you with special types of drawings

    In some cases when you open a Visio template, a wizard helps you get started. For example, the Space Plan template opens with a wizard that helps you set up your space and room information.

  1. Open Visio on the web. If Visio is already open, select File > New.

    Note: If you have Visio Plan 2, you can also download and install the Visio desktop app.

  2. Select Create under the template you want, or select Create under Basic Diagram to start from scratch.

Arrange and connect shapes

To create your diagram, you drag shapes from the stencil in the Shapes pane to the canvas and connect them. There are several ways to connect shapes, but the simplest way is by auto-connecting them.

  1. In the Shapes window, select a shape and drag it onto the canvas.

    Drag a shape to add

  2. Hold your mouse over one of the arrows and a mini toolbar appears with the top four shapes in the Quick Shapes area.
    AutoConnect mini toolbar
    Select the shape you want and it'll automatically connect to the arrow you selected.

  3. You can also drag all your shapes onto the canvas. Then hold the mouse over a shape until the arrows appear. Then grab an arrow and drag it to a shape you want to connect to.

    Drop on autoconnect arrow
  4. If you're using the Visio desktop app, you can also drag a new shape directly from the Shapes window to an existing shape's arrows and connect them automatically.

    Drop shape on autoconnect arrow

Add text to shapes and connectors

Now it's time to add details to your diagram by adding text. For more details about working with text, see Add and format text in Visio for the web.

  1. Select a shape.

  2. Type your text. When you start typing, Visio switches the selected shape to text editing mode.

    Select a shape and type

  3. Click an empty area of the page, or press Esc when you’re finished.

    Note: To move text on a shape, go to Home > Tools > Text Block Text Block , and go to a shape that has text on it. Drag the text around and then go back and click Home > Tools > Pointer Tool Select Objects when you’re done.

Add text to a connector the same way. After you press ESC or click away, select the connector again and you’ll see a tiny box on the text – this is a handle for moving the text block. Click and drag it up, down, or beside the connector.

Customize your Visio diagram

Once you've created your Visio diagram, there's more you can do to make it your own:

  1. On the Design tab, hover the mouse pointer over the various themes.

    Visio temporarily applies each theme as you hover the mouse pointer over them.

  2. To see other available themes, click More.

  3. Click the theme that you want to apply to the diagram.

  1. Click Design and then click Backgrounds.

  2. Click a background.

    Your diagram gets a new background, and, a new background page called VBackground-1. This page you can see in the page tabs along the bottom of the canvas.

  1. Click Design > Borders & Titles and click the title style that you want.

  2. Click a title style.

    The title and border appear on the background page.

  3. At the bottom of the diagramming area, click the VBackground-1 tab.

  4. Click the title text.

    The entire border is selected, but when you start typing it changes the title text.

  5. Type your title, then press ESC.

  6. To edit other text in the border, first select the entire border, and then click the text you want to change and start typing. You may have to click more than once to get the text selected.

  7. Click Page-1 in the lower-right corner of the page to return to the drawing.

Create a simple diagram

Drag a shape from the Shapes window and drop it on the page. Leave the mouse pointer over the shape until four arrows Button image appear around the sides. These are AutoConnect arrows, which give you several ways to automatically connect shapes.

  • Hold the mouse pointer over one of the arrows and a mini toolbar appears, holding the top four shapes in the Quick Shapes area.
    AutoConnect mini toolbar
    Move the pointer over each to see a preview of that shape on your diagram. Click the one that you want, and that shape appears with a connector between it and your first shape.

  • Drag a shape from the Shapes window and hold it over a shape on the page until the arrows appear, then drop the shape on top of one of the arrows.

    Drop shape on autoconnect arrow
Drop on autoconnect arrow
  • Hold the pointer over a shape until the arrows appear, then grab an arrow, drag it to a shape you want to connect to, and drop it in the middle of the second shape.

Note: Some templates have other handy ways to add and connect shapes. For example, the organization chart template lets you drop subordinates’ shapes on top of a manager’s shape, automatically forming that manager’s reporting structure.

Add text to the shapes

Click a shape once and start typing. Press ESC or click an empty area of the page when you’re done typing.
Add text to a shape

Add text to a connector the same way. After you press ESC or click away, select the connector again and you’ll see a tiny box on the text – this is a handle for moving the text block. Click and drag it up, down, or beside the connector.

Move text on a shape

Click Home > Tools > Text Block Text Block , go to a shape that has text on it, and drag the text around. Go back and click Home > Tools > Pointer Tool Select Objects when you’re done moving text.

Change the font, size, and other formatting

Select a shape that has text. Click Home and use tools in the Font and Paragraph groups to format the text.

Make the diagram look better

Once you've created your Visio diagram, there's more you can do to change its look:

Add color and other formatting

On the Design tab, in the Themes group, move the pointer slowly over the different themes. Each theme adds different colors and effects to the diagram. Click the one you want to apply.

Add a background to a Visio diagram

Click Design > Backgrounds > Backgrounds. Click one of the background designs.

Now look down at the bottom of Visio, just under the drawing page. There are two tabs: Page-1 and VBackground-1. Page-1 is the page with the shapes on it, and VBackground-1 is a background page you just added. Click VBackground-1 to see just the background page, and then click Page-1 to go back to the diagram.

Background tab in Visio

Apply a border or title to a Visio diagram

Click Design > Backgrounds > Borders & Titles. Click one of the options to add it to the diagram.

Notice the border and title are added to the background page, so if you want to add the title, click the tab for the background page. Now click Title once and start typing. The title changes to your new text. When you’re done, click the Page-1 tab to go back to your diagram.

Find and apply a template

Visio 2010 allows you to apply built-in templates, to apply your own custom templates, and to search from a variety of templates available on Office.com. Office.com provides a wide selection of popular Excel templates.

To find and apply a template in Visio, do the following:

  1. On the File tab, click New.

  2. Under Choose a Template, do one of the following:

    • To use one of the built-in templates, under Template Categories, click the category that you want, and then click the template that you want and click Create.

    • To reuse a template that you’ve recently used, under Recently Used Templates, click the template that you want and then click Create.

    • To use your own template that you previously created, under Other Ways to Get Started, click New from existing, navigate to the file that you want and click Create New.

    • To find a template on Office.com, under Other Ways to Get Started, click Office.com templates, select the template that you want, and then click Download to download the template from Office.com to your computer.

Note: You can also search for templates on Office.com from within Visio. To search for templates on Office.com, under Other Ways to Get Started, click Office.com templates. In the Search Office.com for templates box, type one or more search terms, and then click the arrow button to search.

Create a new diagram

  1. Click the File tab. This opens up the Backstage view.

    Note: You are in the Backstage view when you first open Visio. If you have just opened Visio, proceed to the next step.

  2. Click New.

  3. Under Choose a Template, below Other Ways to Get Started, click Blank drawing.

  4. Click Create.

When the diagram template opens, most of the space is taken up with a blank diagramming page. Along the side is the Shapes window, which contains several stencils full of shapes.

The Department stencil in the Shapes window

The stencils are identified by title bars at the top of the Shapes window; you might need to scroll the title bar pane to see them all. When you click a stencil title bar, the shapes appear in the pane below.

Open a diagram

  1. Click the File tab, and then click Open.

  2. In the left pane of the Open dialog box, click the drive or folder that contains the drawing.

  3. In the right pane of the Open dialog box, open the folder that contains the drawing that you want.

  4. Click the drawing and then click Open.

Save a diagram

You can save your diagram as a standard Visio file that you can share with other people who have Visio. In addition, there are many different formats that you can save your diagram in directly from the Save As dialog box.

  1. Click the File tab.

  2. Click Save As, and then select a format in the Save as type list.

The different formats are useful for different ways of using or sharing your diagram.

  • Standard image file    including JPG, PNG, and BMP formats.

  • Web page    in HTM format. Image files and other resource files are saved in a subfolder of the location where you save the HTM file.

  • PDF or XPS file   

  • AutoCAD drawing     in DWG or DXF format.

Add a shape

  1. From the Shapes window, click and hold the shape that you want.

  2. Drag the shape onto the diagram page.

For more information about how to add shapes, see Use the Shapes window to organize and find shapes and Find more shapes and stencils.

Add a connector between two shapes

To add a shape to the drawing page so that it is automatically connected when it is added to the page, do the following:

  1. Drag a first shape onto the drawing page.

  2. Hold your pointer over the shape that is already on the page. Notice that small blue arrows appear on the four sides of the shape. These are AutoConnect arrows that you can use to connect shapes.

    Shape with AutoConnect arrows

    The Service Request shape with the AutoConnect arrows shown.

  3. Move the pointer to cover one of the arrows.

    A mini toolbar that contains four shapes appears, and a preview shape might also appear on the page. As you move the pointer over the shapes in the mini toolbar, previews of the shapes appear. The shapes on the toolbar are the top four shapes from the Quick Shapes area.

  4. Click one of the shapes in the mini toolbar to add it to the page.

To automatically connect two shapes when you drag the second shape onto the page, do the following:

  1. Drag one shape onto the drawing page.

  2. Drag a second shape onto the drawing page and hold it so it covers the first shape, but do not drop it yet. Notice that the AutoConnect arrows appear.

    Connect shapes by dropping one on another's AutoConnect arrow

    The Analyze shape is placed on the bottom AutoConnect arrow on the Service Request shape.

  3. Move the second shape down over the AutoConnect arrow that points in the direction that you want, and drop it on the arrow.

    Two connected shapes

    The Analyze shape is spaced a standard distance from the Service Request shape, and is connected automatically.

To connect two shapes that are already on the page, do the following:

  1. Hold the pointer over one of the shapes that you want to connect.

  2. When the AutoConnect arrows appear, move the pointer over an arrow that is pointing toward the other shape that you want to connect to.

  3. Click and hold the AutoConnect arrow, and then drag a connector from it to the center of the other shape.

    When the arrow is over the center of the other shape, a red border appears around the shape. Drop the connector to attach it, or "glue" it, to the shape.

For more information about how to connect shapes, see Add connectors between shapes in Visio.

Add text to shapes or to the page

Add text to a shape

  1. Select the shape that you want to add text to.

  2. Type the text that you want.

    When you start typing, Visio switches the selected shape to text editing mode. To add another line of text, press ENTER.

  3. Click an empty area of the page, or press ESC when you are finished.

  4. Select the shape again. A small yellow control handle appears in the text area. Drag the yellow control handle to move the text.

Add text to the page

  1. On the Home tab, in the Tools group, click the Text tool.

  2. Click an empty area of the page. A text box appears.

  3. Type the text that you want.

  4. On the Home tab, in the Tools group, click Pointer Tool to stop using the Text tool.

The text box now has the characteristics of other shapes. You can select it and type to change the text, you can drag it to another part of the page, and you can format the text by using the Font and Paragraph groups on the Home tab. In addition, when you hold the pointer over the text, AutoConnect arrows appear so you can connect the text to other shapes.

For more information about how to add text blocks, see Add, edit, move, or rotate text and text blocks.

Add data to a shape

To enter data into a data property or field that a shape already has, do the following:

  1. Select a shape on the drawing page.

  2. Right-click the shape and click Shape Data.

  3. In the Shape Data window, in the property row that you want, enter the data that you want.

To define a new data property or field for a shape, do the following:

  1. Select a shape on the drawing page.

  2. Right-click the shape and click Define Shape Data.

  3. In the Define Shape Data dialog box, click New

  4. In the Label box, delete the default text and type a name for the property.

  5. In the Type list, select the type of data that you want to be entered into that property.

    Tip: If you want the property to accept text (like a person’s name) as the type of data, select String.

  6. In the Value box, type the value of the data that you want.

  7. Click OK.

  8. Right-click the shape again, point to Data, and this time click Shape Data.

The Shape Data window opens and displays all the data that has been defined for the shape. If all of the shapes have specific information, you can leave the Shape Data window open and click the shapes you are interested in to see the data that they contain.

Connect data sources to shapes

Adding shape data manually can add a lot of value to your diagram, but if your data is in a database or an Excel workbook, you can pull that data into your diagram automatically and connect the rows of data with specific shapes.

Use the Data Selector wizard to import your data into the External Data window.

The data that appears in the External Data window is a snapshot of your source data at the time of import. You can update the data in your drawing to match the changes in your source data by clicking Refresh All on the Data tab.

  1. On the Data tab, in the External Data group, click Link Data to Shapes.

  2. On the first page of the Data Selector wizard, choose which of the following types of data sources have the data you're using:

    • Microsoft Office Excel workbook

    • Microsoft Office Access database

    • Microsoft Windows SharePoint Services list

    • Microsoft SQL Server database

    • Other OLEDB or ODBC data source

  3. Complete the remainder of the wizard.

After you click Finish on the last page of the Data Connection wizard, the External Data window appears with your imported data shown in a grid. Drag a row of data onto a shape to add automatically the data to the Shape Data for that shape. Or, in the Shapes window, select a shape that you want to hold the data, and then drag a row of data and drop it on an empty area of the page. The selected shape is added to the page, connected to the data.

Format your diagram

To apply a background to your drawing:

  1. Click the Design tab.

  2. In the Backgrounds group, click Backgrounds.

  3. Click the background that you want. A new background page is added to the diagram, which you can see in the page tabs along the bottom of the diagramming area.

To apply a border or title to your drawing:

  1. On the Design tab, click Borders & Titles.

  2. Click the title that you want.

    The title and border are added to the background page (named VBackground-1 by default). To change the title and other text, you must make the changes on the background page; you can't change the title on any other pages.

  3. At the bottom of the diagramming area, click the VBackground-1 tab.

    Pages tabs with VBackground page

  4. Click the title text. The entire border is selected, but if you start typing it changes the default title text.

  5. Enter the title that you want.

  6. To edit other text in the border, first select the entire border, and then click the text you want to change and start typing.

To apply a unified color scheme and other formatting effects:

  1. On the Design tab, in the Themes group, hold your pointer over the various themes. A preview of the theme shows up on the page.

    To see other available themes, click More The More button .

  2. Click the theme you want to apply to the diagram.

Разширете уменията си в Office
Преглед на обучението
Получавайте първи новите функции
Присъединете се към участниците в Office Insider

Беше ли полезна тази информация?

Благодарим ви за обратната връзка!

Благодарим ви за вашата обратна връзка. Изглежда, че ще бъде полезно да ви свържем с един от нашите агенти по поддръжката на Office.

×