Share schedule and task details with a Visio Gantt chart

Share schedule and task details with a Visio Gantt chart

ملاحظة:  نرغب في تزويدك بأحدث محتوى تعليمات لدينا بأسرع ما يمكن وبلغتك الخاصة. وقد تمت ترجمة هذه الصفحة آلياً وقد تحتوي على أخطاء نحوية أو أخطاء تتعلق بالدقة. كما نهدف إلى أن يكون هذا المحتوى مفيداً لك. هل يمكنك إخبارنا إذا كانت المعلومات مفيدة لك في أسفل هذه الصفحة؟ إليك المقالة بالغة الإنجليزية لسهولة الرجوع إليها.

A Gantt chart helps you schedule your project tasks and then helps you track your progress. To communicate detailed task and schedule information to managers or other team members, you can create a Gantt chart in Microsoft Visio. You can also use a Gantt chart to manage the project's schedule at the task level.

Set up a Gantt chart

  1. In the Categories list, click the Schedule category.

  2. انقر فوق مخطط جانت، ثم انقر فوق إنشاء.

  3. في مربع الحوار خيارات مخطط جانت، قم بإعداد التواريخ لمقياس الوقت:

    • انقر فوق علامة تبويب التاريخ، ثم حدد الخيارات التي تريدها.
      الوحدات الرئيسية هي أكبر وحدة وقت (كالسنوات أو الأشهر) تريد استخدامها في المخطط، أما الوحدات الثانوية فهي الأصغر (كالأيام أو الساعات).

    • على علامة التبويب تنسيق، انقر فوق الأشكال والتسميات التي تريد استخدامها على أشرطة المهام والأحداث الرئيسية والأشرطة التلخيصية، ثم انقر فوق موافق.
      إذا لم تكن متأكداً من التنسيق الذي يجب اختياره، ما عليك سوى قبول الاختيارات الافتراضية. ويمكنك تغيير التنسيق لاحقاً.

إضافة بيانات إلى مخطط جانت

المهام

تشغل كل مهمة في أي مخطط جانت صفاً في إطار المخطط. عند كتابة أسماء المهام في الخلايا الموجودة في عمود اسم المهمة، يتم تمثيل مدد المهام كأشرطة مهام في المنطقة أسفل مقياس الوقت.

الهدف

الإجراء المطلوب

تغيير اسم مهمة

  • انقر فوق الخلية الموجودة في العمود اسم المهمة الذي يحتوي على المهمة، ثم اكتب اسماً جديداً.

تعيين مدة مهمة أو تغييرها

  • انقر فوق الخلية الموجودة في إطار مخطط جانت الذي يحتوي على المدة أو التاريخ الذي تريد تغييره، ثم اكتب المعلومات الجديدة.

اكتب المدة كالتالي:

  • 1h for 1 hour

  • 1d for 1 day

  • 1w for 1 week

  • 1m for 1 month

إضافة صفوف مهام جديدة

  • اسحب شكل صف من نافذة الأشكال وأفلته في المخطط في المكان حيث تريد الصف الجديد.

إضافة مؤشرات النسبة المئوية للاكتمال إلى المهام

  1. حدد العمود إلى يمين الموقع حيث تريد ظهور عمود النسبة المئوية للإكمال.

  2. على علامة التبويب مخطط جانت في مجموعة الأعمدة، انقر فوق إدراج.

  3. ضمن نوع العمود، انقر فوق تم إكمال %، ثم انقر فوق موافق.

بينما تحرز تقدماً في مهمة ما، اكتب النسبة المئوية للمهمة المكتملة في العمود الجديد. يظهر مؤشر النسبة المئوية للاكتمال في شريط المهام.

حذف مهمة

  • حدد أي خلية في الصف الذي يمثل المهمة التي تريد حذفها، ثم على علامة التبويب مخطط جانت في المجموعة مهام، انقر فوق حذف.

الأحداث الرئيسية

قم بتعيين مدة الحدث الرئيسي إلى صفر، لأنه يمثل حدثاً مميزاً في جدول بدلاً من مهمة.

الهدف

الإجراء المطلوب

إضافة حدث رئيسي جديد

  1. اسحب شكل حدث رئيسي من نافذة الأشكال وقم بإفلاته على المخطط في المكان حيث تريد إنشاء صف حدث رئيسي جديد.

  2. انقر بزر الماوس الأيمن فوق الخلية الموجودة في العمود بدء للصف الذي يمثل الحدث الرئيسي، ثم انقر فوق تحرير التاريخ من القائمة المختصرة.

  3. عيّن التاريخ، وانقر فوق موافق. يتغير التاريخ الموجود في العمود انتهاء لمطابقة التاريخ الموجود في العمود بدء، ويتم تعيين المدة إلى صفر (0).

تحويل مهمة موجودة إلى حدثٍ رئيسي

  • Type a duration of zero (0) in the Duration column of the row representing the task that you want to convert to a milestone.

تغيير مظهر علامة الحدث الرئيسي

  • انقر بزر الماوس الأيمن فوق علامة الحدث الرئيسي، ثم انقر فوق خيارات المهام على القائمة المختصرة. حدد الخيارات التي تريدها، ثم انقر فوق موافق.

حذف حدث رئيسي

  • حدد أي خلية في الصف الذي يمثل الحدث الرئيسي الذي تريد حذفه، ثم على علامة التبويب مخطط جانت في المجموعة مهام، انقر فوق حذف.

المهام الموجزة

يمكنك استخدام مهمة موجزة عندما تريد تجميع عدة مهام تابعة ضمن مظلة مهمة واحدة.

الهدف

الإجراء المطلوب

إنشاء مهام تابعة تحت مهمة موجزة

المهمة الموجزة عبارة عن صف مهمة عادية. إنها تلخّص المهام التابعة التي تم تحريكها إلى مستوى أدنى. لإنشاء مهام تابعة:

  1. حدد خلية تحتوي على اسم مهمة. لتحديد عدة مهام، اضغط باستمرار على SHIFT أثناء النقر.

  2. على علامة التبويب مخطط جانت في المجموعة مهام، انقر فوق تحريك إلى مستوى أدنى.

تُعتبر الآن المهمة التي تم تحريكها إلى مستوى أدنى مهمة تابعة للمهمة الموجزة أعلاها.

تعيين المدة لمهمة موجزة

  1. في صف المهمة التابعة الأولى، انقر فوق الخلية الموجودة في العمود بدء، ثم اكتب تاريخ بدء هذه المهمة.

  2. للمهمة التابعة نفسها، انقر فوق الخلية الموجودة في العمود انتهاء، ثم اكتب تاريخ انتهاء هذه المهمة.

  3. كرر الخطوات 1 و2 لكل مهمة تابعة.

تتم تعبئة مدة المهمة الموجزة بشكلٍ تلقائي بعد إضافة معلومات مدة المهمة إلى كافة المهام التابعة.

ترقية (التحريك إلى مستوى أعلى) مهمة

  • انقر بزر الماوس الأيمن فوق اسم المهمة التي تريد ترقيتها، ثم انقر فوق تحريك إلى مستوى أعلى من القائمة المختصرة.

تغيير مظهر شريط مهمة موجزة

  1. انقر بزر الماوس الأيمن فوق شريط الوقت الخاص بمهمة موجزة تريد تغييرها، ثم انقر فوق خيارات المهام من القائمة المختصرة.

  2. ضمن الأشرطة التلخيصية، حدد الرموز التي تريدها لبدء وانتهاء الأشرطة، ثم انقر فوق موافق.

التبعيات (مهمات مرتبطة)

عند جعل مهمة واحدة في مخطط جانت تابعة لأخرى، يربط سهم بين شريطي المهام. إذا قمت بتغيير تاريخ أو مدة المهمة التي تتبعها مهمة أخرى، فستتغير تواريخ المهمة التابعة أيضاً.

الهدف

الإجراء المطلوب

تعيين التبعيات بين المهام

  1. حدد خلايا الأسماء الخاصة بالمهام والأحداث الرئيسية التي تريد ربطها. لتحديد عدة مهام، اضغط باستمرار على Ctrl أثناء التحديد.

  2. على علامة التبويب مخطط جانت في المجموعة مهام، انقر فوق ارتباط.

قطع التبعيات بين المهام

  1. حدد المهام ذات التبعيات التي تريد قطعها عن طريق النقر في الخلايا التي تحتوي على أسماء المهام. لتحديد عدة مهام، اضغط باستمرار على Ctrl أثناء التحديد.

  2. على علامة التبويب مخطط جانت في المجموعة مهام، انقر فوق إلغاء الارتباط.

تغيير نمط أسهم التبعية

  • انقر بزر الماوس الأيمن فوق صفحة الرسم أثناء فتح مخطط جانت، ثم انقر فوق موصلات على شكل S‏.

إضافة أعمدة

الهدف

الإجراء المطلوب

إعادة تسمية عمود موجود

  • انقر فوق عنوان العمود الذي تريد إعادة تسميته، ثم اكتب اسماً جديداً.

إضافة عمود بيانات مصمم مسبقاً

  1. حدد عنوان العمود الذي تريد ظهور العمود الجديد إلى يمينه.

  2. على علامة التبويب مخطط جانت في مجموعة الأعمدة، انقر فوق إدراج.

  3. في القائمة نوع العمود، انقر فوق اسم العمود الذي يتطابق مع نوع البيانات الذي تريد إضافته، ثم انقر فوق موافق.

إضافة عمود بيانات جديد قمت بنفسك بتصميمه

  1. حدد عنوان العمود الذي تريد ظهور العمود الجديد إلى يمينه.

  2. على علامة التبويب مخطط جانت في مجموعة الأعمدة، انقر فوق إدراج.

  3. في القائمة نوع العمود، انقر فوق أحد الأعمدة المعرفة من قِبل المستخدم التي تتطابق مع التنسيق الذي ستكون عليه البيانات (على سبيل المثال، الرقم العشري المعرف من قبل المستخدم أو النص المعرف من قبل المستخدم أو الوقت المعرف من قِبل المستخدم)، ثم انقر فوق موافق.

  4. اكتب اسماً جديداً للعمود.

ملاحظة: إذا أضفت أكثر من عمود نص، فانقر في كل مرة فوق خيار نص مختلف معرف من قِبل المستخدم. على سبيل المثال، انقر فوق النص 1 المعرف من قبل المستخدم للعمود الأول، والنص 2 المعرف من قبل المستخدم للعمود الثاني، وما إلى ذلك.

حذف (إخفاء) عمود بيانات

  • حدد عنوان العمود الذي تريد حذفه (أو إخفاءه).

  • على علامة التبويب مخطط جانت في مجموعة الأعمدة، انقر فوق إخفاء.

ملاحظة: عند حذف عمود أو إخفائه من المخطط، يتم الاحتفاظ ببيانات العمود في ملف. لإظهار العمود مرة أخرى لاحقاً، انقر بزر الماوس الأيمن فوق عنوان عمود، ثم انقر فوق إدراج عمود. من القائمة، حدد العمود الذي تريد إظهاره مرة أخرى، ثم انقر فوق موافق.

نقل عمود بيانات

  1. انقر فوق عنوان العمود الذي تريد نقله.

  2. اسحب العمود إلى موقع جديد.

  3. قم بواحد مما يلي:

    • لنقل عمود إلى يسار عمود آخر، ضع نقطة وسط العمود الذي تقوم بنقله إلى يسار نقطة وسط العمود الآخر.

    • لنقل عمود إلى يمين عمود آخر، ضع نقطة وسط العمود الذي تقوم بنقله إلى يمين نقطة وسط العمود الآخر.

    • لنقل عمود إلى يمين منطقة مقياس الوقت، ضع نقطة وسط العمود الذي تقوم بنقله إلى يمين نقطة وسط منطقة مقياس الوقت.

مقياس الوقت

مقياس الوقت هو مقياس وحدات الوقت الرئيسية والثانوية التي تمتد من تاريخ بدء المشروع حتى تاريخ انتهائه. يمكنك تعريف وحدات الوقت لمقياس الوقت، وتاريخي بدئه وانتهائه، والأيام التي تعتبرها من غير أيام العمل.

الهدف

الإجراء المطلوب

تغيير تاريخ البدء أو الانتهاء، أو كليهما

  1. على علامة التبويب مخطط جانت، في المجموعة إدارة، انقر فوق خيارات المخطط.

  2. في مربع الحوار خيارات مخطط جانت، ضمن نطاق مقياس الوقت، عيّن نطاق التاريخ.

تغيير وحدات الوقت

  1. على علامة التبويب مخطط جانت، في المجموعة إدارة، انقر فوق خيارات المخطط.

  2. في مربع الحوار خيارات مخطط جانت، ضمن وحدات الوقت، حدد الوحدات الرئيسية والوحدات الثانوية التي تريدها، ثم انقر فوق موافق.

تحديد أيام غير العمل

  1. على علامة التبويب مخطط جانت، في المجموعة إدارة، انقر فوق تكوين وقت العمل.

  2. في مربع حوار تكوين وقت العمل، حدد خيارات أيام العمل ووقت العمل، ثم انقر فوق موافق.

التمرير إلى مهمة معينة أو حدث رئيسي معين

  1. حدد المهمة أو الحدث الرئيسي الذي تريد التمرير إليه بالنقر في الخلية التي تحتوي على اسم المهمة.

  2. على علامة التبويب مخطط جانت، في مجموعة التنقل، انقر فوق التمرير إلى المهمة.

التمرير إلى تاريخ معين

  • To scroll to the end of the timescale, on the Gantt Chart tab, in the Navigation group, click Go to Finish.

  • To scroll one minor unit to the left, on the Gantt Chart tab, in the Navigation group, click Next.

  • To scroll one minor unit to the right, on the Gantt Chart tab, in the Navigation group, click Previous.

  • To scroll to the beginning of the timescale, on the Gantt Chart tab, in the Navigation group, click Go to Start.

تغيير عرض منطقة مقياس الوقت

  1. حدد عمود مقياس الوقت.

  2. اسحب مقبض التحديد الموجود على الجانب الأيسر من العمود إلى أي اتجاه حتى يصبح عرض المنطقة كما تريد.

عرض المزيد من وحدات الوقت

  1. انقر فوق الخط المتصل الذي يحيط بإطار مخطط جانت لتحديد الإطار.

  2. اسحب مقبض التحديد الموجود في الجزء المتوسط الأيسر من الإطار إلى اليسار.

ملاحظة: عند توسيع مقياس الوقت لعرض المزيد من وحدات الوقت، فإنك تقوم أيضاً بتغيير تاريخ الانتهاء المقترن بمشروعك.

ماذا تريد أن تفعل؟

Use a Gantt chart as a communication tool

Set up a Gantt chart

Add data to a Gantt chart

Print a large Gantt chart

Use a Gantt chart as a communication tool

In a Gantt chart, graphical elements such as bars and arrows represent tasks and the dependencies between them so you can track how the changes in one task affect the others.

You can also group several subordinate tasks under one summary task and add descriptions, required resources, and completion percentages to each task.

Tasks are displayed as bars on a timescale.

مخطط جانب مع أشرطة المهام

You can quickly produce a visually appealing annotated schedule for a presentation by applying a color scheme and adding text labels to a Gantt chart.

If you start a schedule for a complex project as a Visio Gantt chart, you can easily export the schedule data to Microsoft Project 2010, and then use Project to plan and manage the project in detail.

Product

Use when

Visio

  • You want to prepare a visually appealing annotated schedule for a presentation.

  • You want to define the basic tasks in a schedule in the early stages of a project.

  • Your schedule includes fewer than 30 tasks.

Project

  • You want to use a full-featured project management tool for planning and scheduling a project.

  • Your schedule includes dozens of tasks.

  • You need to assign multiple resources to tasks or connect schedules for different projects.

Top of Page

Set up a Gantt chart

  1. في علامة تبويب ملف، انقر فوق جديد.

  2. Under Choose a Template, click Schedule, and then double-click Gantt Chart.

  3. In the Gantt Chart Options dialog box, set up the dates for the timescale. You can also choose how you want to format the task bars, milestones, and other chart elements:

    • Click the Date tab, and then choose the options that you want.

      ملاحظة: Major units are the longest unit of time (such as years or months) that you want to use in the chart, and Minor units are the smallest (such as days or hours).

    • On the Format tab, click the shapes and labels that you want to use on the task bars, milestones, and summary bars, and then click OK.
      مربع الحوار "خيارات مخطط جانت"

ملاحظة:  If you aren't sure what formatting to choose, just accept the default choices. You can change the formatting later.

A chart frame up close

After you set up a Gantt chart, a generic chart frame appears.

The frame is like a blank canvas on which you can paint the details of your schedule:

  • In the Task Name column, click a cell, and then type to replace the generic text with a specific task name. You can add more tasks as your project progresses.

  • Initially, the dates in the Start and Finish columns reflect the start date that you specified for the project. To change the date, click a cell, and then type.

  • The Duration column updates automatically as you type new start and finish dates. You can also type one of the dates and the duration to indicate the length of a task.

  • In the Timescale (the area labeled 2000 with months shown below), Major units are on top, and Minor units are on the bottom. The timescale starts and ends with the start and finish dates that you specified. As you add task start and end dates or durations, task bars appear in the area below the timescale, and the area expands.

تلميح: To record additional data about each task, you can add more columns. For example, you can add a Resource column so your Gantt chart reflects who is responsible for each task.

Top of Page

إضافة بيانات إلى مخطط جانت

You can fill the frame with data that reflects the details of your project schedule. You can add and refine the following schedule elements:

Tasks

Milestones

Summary tasks

Dependencies (Linked tasks)

Data columns

Timescale

المهام

مخطط جانب مع أشرطة المهام

تشغل كل مهمة في أي مخطط جانت صفاً في إطار المخطط. عند كتابة أسماء المهام في الخلايا الموجودة في عمود اسم المهمة، يتم تمثيل مدد المهام كأشرطة مهام في المنطقة أسفل مقياس الوقت.

الهدف

الإجراء المطلوب

تغيير اسم مهمة

  • انقر فوق الخلية الموجودة في العمود اسم المهمة الذي يحتوي على المهمة، ثم اكتب اسماً جديداً.

تعيين مدة مهمة أو تغييرها

  • انقر فوق الخلية الموجودة في إطار مخطط جانت الذي يحتوي على المدة أو التاريخ الذي تريد تغييره، ثم اكتب المعلومات الجديدة.

ملاحظة: اكتب المدة كالتالي:

  • 1h for 1 hour

  • 1d for 1 day

  • 1w for 1 week

  • 1m for 1 month

Add new tasks at the bottom of the Gantt chart

  • Select the Gantt chart frame by clicking the solid line that surrounds the chart. To create a new task row, on the Gantt Chart tab, in the Tasks group, click New.
    المجموعة "مهام"

Add a new task between two existing tasks

  • Select any cell in the row that you want a new task row to appear above, and then on the Gantt Chart tab, in the Tasks group, click New.
    المجموعة "مهام"

إضافة مؤشرات النسبة المئوية للاكتمال إلى المهام

  1. Select the shaded portion at the top of the column to the left of where you want a percent complete column to appear, and then on the Gantt Chart tab, in the Columns group, click Insert.
    مجموعة الأعمدة

  2. ضمن نوع العمود، انقر فوق تم إكمال %، ثم انقر فوق موافق.

  3. بينما تحرز تقدماً في مهمة ما، اكتب النسبة المئوية للمهمة المكتملة في العمود الجديد. يظهر مؤشر النسبة المئوية للاكتمال في شريط المهام.

حذف مهمة

  • Select any cell in the row that represents the task you want to delete, and then on the Gantt Chart tab, in the Tasks group, click Delete.
    المجموعة "مهام"

الأحداث الرئيسية

حدث رئيسي على مخطط جانت

قم بتعيين مدة الحدث الرئيسي إلى صفر، لأنه يمثل حدثاً مميزاً في جدول بدلاً من مهمة.

الهدف

الإجراء المطلوب

إضافة حدث رئيسي جديد

  1. Drag a Milestone shape from the Gantt Chart Shapes stencil onto the Gantt chart frame, and drop it between the cells containing the task names for the tasks that you want the milestone to follow and precede.

  2. انقر بزر الماوس الأيمن فوق الخلية الموجودة في العمود بدء للصف الذي يمثل الحدث الرئيسي، ثم انقر فوق تحرير التاريخ من القائمة المختصرة.

  3. Type the date that you want, and then click OK. The date in the Finish column changes to match the date in the Start column, and the Duration is set to zero (0).

تحويل مهمة موجودة إلى حدثٍ رئيسي

  • Type a duration of zero (0) in the Duration column of the row representing the task that you want to convert to a milestone.

تغيير مظهر علامة الحدث الرئيسي

  • انقر بزر الماوس الأيمن فوق علامة الحدث الرئيسي، ثم انقر فوق خيارات المهام على القائمة المختصرة. حدد الخيارات التي تريدها، ثم انقر فوق موافق.

حذف حدث رئيسي

  • Select any cell in the row that represents the milestone that you want to delete, and then on the Gantt Chart tab, in the Tasks group, click Delete.
    المجموعة "مهام"

المهام الموجزة

مخطط جانت مع ملخص ومهام تابعة

يمكنك استخدام مهمة موجزة عندما تريد تجميع عدة مهام تابعة ضمن مظلة مهمة واحدة.

الهدف

الإجراء المطلوب

Create a summary task with subordinate tasks

  1. Add a summary task and subordinate tasks or milestones to the Gantt chart.

  2. To select a subordinate task, select a cell containing the task name. To select multiple tasks, hold down SHIFT while you click.

  3. On the Gantt Chart tab, in the Tasks group, click Indent.
    المجموعة "مهام"

تعيين المدة لمهمة موجزة

  1. في صف المهمة التابعة الأولى، انقر فوق الخلية الموجودة في العمود بدء، ثم اكتب تاريخ بدء هذه المهمة.

  2. للمهمة التابعة نفسها، انقر فوق الخلية الموجودة في العمود انتهاء، ثم اكتب تاريخ انتهاء هذه المهمة.

  3. كرر الخطوات 1 و2 لكل مهمة تابعة.

ملاحظة: تتم تعبئة مدة المهمة الموجزة بشكلٍ تلقائي بعد إضافة معلومات مدة المهمة إلى كافة المهام التابعة.

Demote (Indent) a task

  • Select the name of the task that you want to demote, and then on the Gantt Chart tab, in the Tasks group, click Indent.
    المجموعة "مهام"

ترقية (التحريك إلى مستوى أعلى) مهمة

  • Right-click the name of the task that you want to promote, and then on the Gantt Chart tab, in the Tasks group, click Oudent.
    المجموعة "مهام"

تغيير مظهر شريط مهمة موجزة

  1. Right-click the task bar of a summary task that you want to change, and then click Task Options on the shortcut menu.

  2. ضمن الأشرطة التلخيصية، حدد الرموز التي تريدها لبدء وانتهاء الأشرطة، ثم انقر فوق موافق.

التبعيات (مهمات مرتبطة)

حدث رئيسي على مخطط جانت

عند جعل مهمة واحدة في مخطط جانت تابعة لأخرى، يربط سهم بين شريطي المهام. إذا قمت بتغيير تاريخ أو مدة المهمة التي تتبعها مهمة أخرى، فستتغير تواريخ المهمة التابعة أيضاً.

الهدف

الإجراء المطلوب

تعيين التبعيات بين المهام

  1. Select the tasks and milestones between which you want to set dependencies by clicking in the cells containing the task names. To select multiple tasks, hold down SHIFT while you select.

  2. On the Gantt Chart tab, in the Tasks group, click Link.
    المجموعة "مهام"

قطع التبعيات بين المهام

  1. Select the tasks with dependencies that you want to break by clicking in the cells containing the task names. To select multiple tasks, hold down SHIFT while you select.

  2. On the Gantt Chart tab, in the Tasks group, click Unlink.
    المجموعة "مهام"

تغيير نمط أسهم التبعية

  • انقر بزر الماوس الأيمن فوق صفحة الرسم أثناء فتح مخطط جانت، ثم انقر فوق موصلات على شكل S‏.

Data columns

A project schedule is built from task-specific data. The accumulation of task start dates and durations determines the finish date for the project. In a Visio Gantt chart, you store task data in data columns.

If you want to record and display additional task data in a Gantt chart, you can add new columns. For example, you may want to add a column for task notes in which you can describe complex or unique tasks, a column for resources to list the people responsible for completing each task, or a column for percent complete to track what percentage of each task is completed.


مخطط جانب مع أشرطة المهام

By default, when you create a new Gantt chart, the chart contains Task Name, Start, Finish, and Duration columns. You can rearrange the existing columns, add new columns, and delete columns that you no longer need.

الهدف

الإجراء المطلوب

إعادة تسمية عمود موجود

  • انقر فوق عنوان العمود الذي تريد إعادة تسميته، ثم اكتب اسماً جديداً.

إضافة عمود بيانات مصمم مسبقاً

  1. حدد عنوان العمود الذي تريد ظهور العمود الجديد إلى يمينه.

  2. On the Gantt Chart tab, in the Columns group, click Insert.
    مجموعة الأعمدة

  3. في القائمة نوع العمود، انقر فوق اسم العمود الذي يتطابق مع نوع البيانات الذي تريد إضافته، ثم انقر فوق موافق.

إضافة عمود بيانات جديد قمت بنفسك بتصميمه

  1. حدد عنوان العمود الذي تريد ظهور العمود الجديد إلى يمينه.

  2. On the Gantt Chart tab, in the Columns group, click Insert.
    مجموعة الأعمدة

  3. في القائمة نوع العمود، انقر فوق أحد الأعمدة المعرفة من قِبل المستخدم التي تتطابق مع التنسيق الذي ستكون عليه البيانات (على سبيل المثال، الرقم العشري المعرف من قبل المستخدم أو النص المعرف من قبل المستخدم أو الوقت المعرف من قِبل المستخدم)، ثم انقر فوق موافق.

  4. اكتب اسماً جديداً للعمود.

ملاحظة: إذا أضفت أكثر من عمود نص، فانقر في كل مرة فوق خيار نص مختلف معرف من قِبل المستخدم. على سبيل المثال، انقر فوق النص 1 المعرف من قبل المستخدم للعمود الأول، والنص 2 المعرف من قبل المستخدم للعمود الثاني، وما إلى ذلك.

حذف (إخفاء) عمود بيانات

  • حدد عنوان العمود الذي تريد حذفه (أو إخفاءه).

  • On the Gantt Chart tab, in the Columns group, click Hide.
    مجموعة الأعمدة

ملاحظة: عند حذف عمود أو إخفائه من المخطط، يتم الاحتفاظ ببيانات العمود في ملف. لإظهار العمود مرة أخرى لاحقاً، انقر بزر الماوس الأيمن فوق عنوان عمود، ثم انقر فوق إدراج عمود. من القائمة، حدد العمود الذي تريد إظهاره مرة أخرى، ثم انقر فوق موافق.

نقل عمود بيانات

  1. انقر فوق عنوان العمود الذي تريد نقله.

  2. اسحب العمود إلى موقع جديد.

  3. قم بواحد مما يلي:

    • لنقل عمود إلى يسار عمود آخر، ضع نقطة وسط العمود الذي تقوم بنقله إلى يسار نقطة وسط العمود الآخر.

    • لنقل عمود إلى يمين عمود آخر، ضع نقطة وسط العمود الذي تقوم بنقله إلى يمين نقطة وسط العمود الآخر.

    • لنقل عمود إلى يمين منطقة مقياس الوقت، ضع نقطة وسط العمود الذي تقوم بنقله إلى يمين نقطة وسط منطقة مقياس الوقت.

ملاحظة: If the timescale region is long, you may have to zoom out to move the column past the region's midpoint. To zoom out, on the View menu, point to Zoom, and then click the zoom level that you want.

مقياس الوقت

مقياس الوقت هو مقياس وحدات الوقت الرئيسية والثانوية التي تمتد من تاريخ بدء المشروع حتى تاريخ انتهائه. يمكنك تعريف وحدات الوقت لمقياس الوقت، وتاريخي بدئه وانتهائه، والأيام التي تعتبرها من غير أيام العمل.

مخطط جانب مع أشرطة المهام

You can scroll to a particular date or task on the timescale, and you can change the width of the timescale region and display more dates.

الهدف

الإجراء المطلوب

تغيير تاريخ البدء أو الانتهاء، أو كليهما

  1. On the Gantt Chart tab, in the Manage group, click Chart Options.
    المجموعة "إدارة"

  2. In the Gantt Chart Options dialog box, under Timescale range, change the click the date that you want to change.

تغيير وحدات الوقت

  1. On the Gantt Chart tab, in the Manage group, click Chart Options.
    المجموعة "إدارة"

  2. في مربع الحوار خيارات مخطط جانت، ضمن وحدات الوقت، حدد الوحدات الرئيسية والوحدات الثانوية التي تريدها، ثم انقر فوق موافق.

تحديد أيام غير العمل

  1. On the Gantt Chart tab, in the Manage group, click Configure Working Time.
    المجموعة "إدارة"

  2. في مربع حوار تكوين وقت العمل، حدد خيارات أيام العمل ووقت العمل، ثم انقر فوق موافق.

التمرير إلى مهمة معينة أو حدث رئيسي معين

  1. حدد المهمة أو الحدث الرئيسي الذي تريد التمرير إليه بالنقر في الخلية التي تحتوي على اسم المهمة.

  2. On the Gantt Chart tab, in the Navigation group, click Scroll To Task.
    مجموعة التنقل

التمرير إلى تاريخ معين

  • To scroll to the end of the timescale, on the Gantt Chart tab, in the Navigation group, click Go to Finish.

  • To scroll one minor unit to the left, on the Gantt Chart tab, in the Navigation group, click Next.

  • To scroll one minor unit to the right, on the Gantt Chart tab, in the Navigation group, click Previous.

  • To scroll to the beginning of the timescale, on the Gantt Chart tab, in the Navigation group, click Go to Start.
    مجموعة التنقل

تغيير عرض منطقة مقياس الوقت

  1. Click once in the gray area at the top of the timescale region, and then click again to select the timescale column.

  2. Drag the blue selection handle on the right side of the column in either direction until the region is the width that you want.

عرض المزيد من وحدات الوقت

  1. انقر فوق الخط المتصل الذي يحيط بإطار مخطط جانت لتحديد الإطار.

  2. Drag the blue selection handle at the right-center of the frame toward the right.

ملاحظة: عند توسيع مقياس الوقت لعرض المزيد من وحدات الوقت، فإنك تقوم أيضاً بتغيير تاريخ الانتهاء المقترن بمشروعك.

Top of Page

Print a large Gantt chart

Unless you are creating a schedule for a small project, your Gantt chart is likely to extend beyond the boundaries of one standard printer page. The following table describes some printing problems that you may encounter and steps that you can take before you print that will help you get the results that you expect.

Problem

Solution

الإجراء المطلوب

Only part of the Gantt chart is printed.

Make sure the whole chart fits on a drawing page.

  1. On the Design tab, in the Page Setup group, click Page Setup dialog box launcher.

  2. In the Page Setup dialog box, click the Page Size tab, under Print zoom, select Fit to.

  3. Next to Fit to, type “1” in the sheet(s) across box and type “1” in the sheet(s) down box.

  4. انقر فوق تطبيق ثم فوق موافق.

The printed page and drawing page orientations are not the same.

Change the printer page orientation.

  • On the Design tab, in the Page Setup group, click Orientation, and then click the orientation that you want.

You don't know how many pages the chart will be printed across.

Preview how the drawing will be printed before you print it.

  • On the File tab, click Print, and then click Print Preview.

You don't know where the page breaks will occur.

Turn on page breaks to see how many pages the chart will tile across.

  • On the View tab, in the Show group, select Page Breaks. Gray lines on the chart indicate where the page breaks will occur.

The breaks between the printed pages occur at awkward positions.

Change the margin settings to control the overlap between pages. The larger the margins, the larger the overlap between pages.

  1. On the Design tab, in the Page Setup group, click Page Setup dialog box launcher.

  2. On the Print Setup tab, under Printer paper, click Setup.

  3. Type the margin settings that you want, and then click OK two times.

Top of Page

ماذا تريد أن تفعل؟

Use a Gantt chart as a communication tool

Set up a Gantt chart

Add data to a Gantt chart

Print a large Gantt chart

Use a Gantt chart as a communication tool

In a Gantt chart, graphical elements such as bars and arrows represent tasks and the dependencies between them so you can track how the changes in one task affect the others.

You can also group several subordinate tasks under one summary task and add descriptions, required resources, and completion percentages to each task.

Tasks are displayed as bars on a timescale.

مثال مخطط جانت

You can quickly produce a visually appealing annotated schedule for a presentation by applying a color scheme and adding text labels to a Gantt chart.

If you start a schedule for a complex project as a Visio Gantt chart, you can easily export the schedule data to Microsoft Office Project, and then use Office Project to plan and manage the project in detail. For more information about exporting Gantt charts from Office Visio, see Help in Microsoft Office Visio.

Product

Use when

Office Visio

  • You want to prepare a visually appealing annotated schedule for a presentation.

  • You want to define the basic tasks in a schedule in the early stages of a project.

  • Your schedule includes fewer than 30 tasks.

Office Project

  • You want to use a full-featured project management tool for planning and scheduling a project.

  • Your schedule includes dozens of tasks.

  • You need to assign multiple resources to tasks or connect schedules for different projects.

Top of Page

Set up a Gantt chart

First set up the basic chart frame and the dates for the timescale. You can also choose how you want to format the task bars, milestones, and other chart elements.

Later you can change the dates, add or delete tasks and milestones, and create dependencies between tasks. You can also apply a color scheme and add a title and legend.

  1. In Visio, on the File menu, point to New, point to Schedule, and then click Gantt Chart.

  2. Click the Date tab, and then choose the options that you want.

    Major units are the longest unit of time (such as years or months) that you want to use in the chart, and Minor units are the smallest (such as days or hours).

  3. On the Format tab, click the shapes and labels that you want to use on the task bars, milestones, and summary bars, and then click OK.

If you aren't sure what formatting to choose, just accept the default choices. You can change the formatting later.

A chart frame up close

After you set up a Gantt chart, a generic chart frame appears.

The frame is like a blank canvas on which you can paint the details of your schedule:

  • In the Task Name column, click a cell, and then type to replace the generic text with a specific task name. You can add more tasks as your project progresses.

  • Initially, the dates in the Start and Finish columns reflect the start date that you specified for the project. To change the date, click a cell, and then type.

  • The Duration column updates automatically as you type new start and finish dates. You can also type one of the dates and the duration to indicate the length of a task.

  • In the Timescale (the area labeled 2000 with months shown below), Major units are on top, and Minor units are on the bottom. The timescale starts and ends with the start and finish dates that you specified. As you add task start and end dates or durations, task bars appear in the area below the timescale, and the area expands.

To record additional data about each task, you can add more columns. For example, you can add a Resource column so your Gantt chart reflects who is responsible for each task.

Top of Page

إضافة بيانات إلى مخطط جانت

You can fill the frame with data that reflects the details of your project schedule. You can add and refine the following schedule elements:

Tasks

Milestones

Summary tasks

Dependencies (Linked tasks)

Data columns

Timescale

المهام

مخطط جانب مع أشرطة المهام

تشغل كل مهمة في أي مخطط جانت صفاً في إطار المخطط. عند كتابة أسماء المهام في الخلايا الموجودة في عمود اسم المهمة، يتم تمثيل مدد المهام كأشرطة مهام في المنطقة أسفل مقياس الوقت.

الهدف

الإجراء المطلوب

تغيير اسم مهمة

  • انقر فوق الخلية الموجودة في العمود اسم المهمة الذي يحتوي على المهمة، ثم اكتب اسماً جديداً.

تعيين مدة مهمة أو تغييرها

  • انقر فوق الخلية الموجودة في إطار مخطط جانت الذي يحتوي على المدة أو التاريخ الذي تريد تغييره، ثم اكتب المعلومات الجديدة.

اكتب المدة كالتالي:

  • 1h for 1 hour

  • 1d for 1 day

  • 1w for 1 week

  • 1m for 1 month

Add new tasks at the bottom of the Gantt chart

  • Select the Gantt chart frame by clicking the solid line that surrounds the chart. To create new task rows, drag the green selection handle at the lower center of the frame.

Add a new task between two existing tasks

  • Right-click any cell in the row that you want a new task row to appear above, and then click New Task on the shortcut menu.

إضافة مؤشرات النسبة المئوية للاكتمال إلى المهام

  1. Right-click the shaded portion at the top of the column to the left of where you want a percent complete column to appear, and then click Insert Column on the shortcut menu.

  2. ضمن نوع العمود، انقر فوق تم إكمال %، ثم انقر فوق موافق.

  3. بينما تحرز تقدماً في مهمة ما، اكتب النسبة المئوية للمهمة المكتملة في العمود الجديد. يظهر مؤشر النسبة المئوية للاكتمال في شريط المهام.

حذف مهمة

  • Right-click any cell in the row that represents the task you want to delete, and then click Delete Task on the shortcut menu.

Change the way a task bar looks

  • Right-click the task bar, and then click Task Options on the shortcut menu. From the list, click the options you want, and then click OK.

الأحداث الرئيسية

حدث رئيسي على مخطط جانت

قم بتعيين مدة الحدث الرئيسي إلى صفر، لأنه يمثل حدثاً مميزاً في جدول بدلاً من مهمة.

الهدف

الإجراء المطلوب

إضافة حدث رئيسي جديد

  1. Drag a Milestone shape from the Gantt Chart Shapes stencil onto the Gantt chart frame, and drop it between the cells containing the task names for the tasks that you want the milestone to follow and precede.

  2. انقر بزر الماوس الأيمن فوق الخلية الموجودة في العمود بدء للصف الذي يمثل الحدث الرئيسي، ثم انقر فوق تحرير التاريخ من القائمة المختصرة.

  3. Type the date that you want, and then click OK. The date in the Finish column changes to match the date in the Start column, and the Duration is set to zero (0).

تحويل مهمة موجودة إلى حدثٍ رئيسي

  • Type a duration of zero (0) in the Duration column of the row representing the task that you want to convert to a milestone.

تغيير مظهر علامة الحدث الرئيسي

  • انقر بزر الماوس الأيمن فوق علامة الحدث الرئيسي، ثم انقر فوق خيارات المهام على القائمة المختصرة. حدد الخيارات التي تريدها، ثم انقر فوق موافق.

حذف حدث رئيسي

  • Right-click any cell in the row that represents the milestone that you want to delete, and then click Delete Task on the shortcut menu.

المهام الموجزة

مخطط جانت مع ملخص ومهام تابعة

يمكنك استخدام مهمة موجزة عندما تريد تجميع عدة مهام تابعة ضمن مظلة مهمة واحدة.

الهدف

الإجراء المطلوب

Create a summary task with subordinate tasks

  1. Add a summary task and subordinate tasks or milestones to the Gantt chart.

  2. To select a subordinate task, click a cell containing the task name. To select multiple tasks, hold down SHIFT while you click.

  3. Right-click one of the selected tasks, and then click Indent on the shortcut menu.

تعيين المدة لمهمة موجزة

  1. في صف المهمة التابعة الأولى، انقر فوق الخلية الموجودة في العمود بدء، ثم اكتب تاريخ بدء هذه المهمة.

  2. للمهمة التابعة نفسها، انقر فوق الخلية الموجودة في العمود انتهاء، ثم اكتب تاريخ انتهاء هذه المهمة.

  3. كرر الخطوات 1 و2 لكل مهمة تابعة.

تتم تعبئة مدة المهمة الموجزة بشكلٍ تلقائي بعد إضافة معلومات مدة المهمة إلى كافة المهام التابعة.

Demote (Indent) a task

  • Right-click the name of the task that you want to demote, and then click Indent on the shortcut menu.

ترقية (التحريك إلى مستوى أعلى) مهمة

  • Right-click the name of the task that you want to promote, and then click Outdent on the shortcut menu.

تغيير مظهر شريط مهمة موجزة

  1. Right-click the task bar of a summary task that you want to change, and then click Task Options on the shortcut menu.

  2. ضمن الأشرطة التلخيصية، حدد الرموز التي تريدها لبدء وانتهاء الأشرطة، ثم انقر فوق موافق.

التبعيات (مهمات مرتبطة)

حدث رئيسي على مخطط جانت

عند جعل مهمة واحدة في مخطط جانت تابعة لأخرى، يربط سهم بين شريطي المهام. إذا قمت بتغيير تاريخ أو مدة المهمة التي تتبعها مهمة أخرى، فستتغير تواريخ المهمة التابعة أيضاً.

الهدف

الإجراء المطلوب

تعيين التبعيات بين المهام

  1. Select the tasks and milestones between which you want to set dependencies by clicking in the cells containing the task names. To select multiple tasks, hold down SHIFT while you select.

  2. Right-click one of the selected tasks, and then click Link Tasks on the shortcut menu.

قطع التبعيات بين المهام

  1. Select the tasks with dependencies that you want to break by clicking in the cells containing the task names. To select multiple tasks, hold down SHIFT while you select.

  2. Right-click one of the selected tasks, and then click Unlink Tasks on the shortcut menu.

تغيير نمط أسهم التبعية

  • With the Gantt chart open, right-click the drawing page, and then click S Type Connectors on the shortcut menu.

Data columns

A project schedule is built from task-specific data. The accumulation of task start dates and durations determines the finish date for the project. In a Visio Gantt chart, you store task data in data columns.

If you want to record and display additional task data in a Gantt chart, you can add new columns. For example, you may want to add a column for task notes in which you can describe complex or unique tasks, a column for resources to list the people responsible for completing each task, or a column for percent complete to track what percentage of each task has been completed.


مخطط جانب مع أشرطة المهام

By default, when you create a new Gantt chart, the chart contains Task Name, Start, Finish, and Duration columns. You can rearrange the existing columns, add new ones, and delete columns you no longer need.

الهدف

الإجراء المطلوب

إعادة تسمية عمود موجود

  • انقر فوق عنوان العمود الذي تريد إعادة تسميته، ثم اكتب اسماً جديداً.

إضافة عمود بيانات مصمم مسبقاً

  1. Right-click the heading of the column to the left of where you want the new column to appear, and then click Insert Column on the shortcut menu.

  2. في القائمة نوع العمود، انقر فوق اسم العمود الذي يتطابق مع نوع البيانات الذي تريد إضافته، ثم انقر فوق موافق.

إضافة عمود بيانات جديد قمت بنفسك بتصميمه

  1. Right-click the heading of the column to the left of where you want the new column to appear, and then Click Insert Column on the shortcut menu.

  2. في القائمة نوع العمود، انقر فوق أحد الأعمدة المعرفة من قِبل المستخدم التي تتطابق مع التنسيق الذي ستكون عليه البيانات (على سبيل المثال، الرقم العشري المعرف من قبل المستخدم أو النص المعرف من قبل المستخدم أو الوقت المعرف من قِبل المستخدم)، ثم انقر فوق موافق.

  3. اكتب اسماً جديداً للعمود.

ملاحظة: إذا أضفت أكثر من عمود نص، فانقر في كل مرة فوق خيار نص مختلف معرف من قِبل المستخدم. على سبيل المثال، انقر فوق النص 1 المعرف من قبل المستخدم للعمود الأول، والنص 2 المعرف من قبل المستخدم للعمود الثاني، وما إلى ذلك.

حذف (إخفاء) عمود بيانات

  • Right-click the heading of the column that you want to delete (hide), and then click Hide Column on the shortcut menu.

ملاحظة:  When you delete, or hide, a column from the chart, the data from the column is preserved in a file. To show the column again later, right-click a column heading, and then click Insert Column on the shortcut menu. From the list, select the column that you want to show again, and then click OK.

نقل عمود بيانات

  1. انقر فوق عنوان العمود الذي تريد نقله.

  2. اسحب العمود إلى موقع جديد.

  3. قم بواحد مما يلي:

    • لنقل عمود إلى يسار عمود آخر، ضع نقطة وسط العمود الذي تقوم بنقله إلى يسار نقطة وسط العمود الآخر.

    • لنقل عمود إلى يمين عمود آخر، ضع نقطة وسط العمود الذي تقوم بنقله إلى يمين نقطة وسط العمود الآخر.

    • لنقل عمود إلى يمين منطقة مقياس الوقت، ضع نقطة وسط العمود الذي تقوم بنقله إلى يمين نقطة وسط منطقة مقياس الوقت.

ملاحظة: If the timescale region is long, you may have to zoom out to move the column past the region's midpoint. To zoom out, on the View menu, point to Zoom, and then click the zoom level that you want.

مقياس الوقت

مقياس الوقت هو مقياس وحدات الوقت الرئيسية والثانوية التي تمتد من تاريخ بدء المشروع حتى تاريخ انتهائه. يمكنك تعريف وحدات الوقت لمقياس الوقت، وتاريخي بدئه وانتهائه، والأيام التي تعتبرها من غير أيام العمل.

مخطط جانب مع أشرطة المهام

You can scroll to a particular date or task on the timescale, and you can change the width of the timescale region and display more dates.

الهدف

Action to take

تغيير تاريخ البدء أو الانتهاء، أو كليهما

  1. In your Gantt chart, right-click anywhere in the timescale, and then click Date Options on the shortcut menu.

  2. Under Timescale range, select a new start or end date or time, and then click OK.

تغيير وحدات الوقت

  1. In your Gantt chart, right-click anywhere in the timescale, and then click Date Options on the shortcut menu.

  2. Under Time units, select the Major units and Minor units that you want, and then click OK.

تحديد أيام غير العمل

  1. In your Gantt chart, right-click anywhere in the timescale, and then click Configure Working Time on the shortcut menu.

  2. Select the options that you want for Working days and Working time, and then click OK.

التمرير إلى مهمة معينة أو حدث رئيسي معين

  1. Select the task or milestone that you want to scroll to by clicking in the cell containing the task name.

  2. On the Gantt Chart toolbar, click the Scroll To Task button.

ملاحظة:  If you don't see the Gantt Chart toolbar, on the View menu, point to Toolbars, and then click Gantt Chart.

التمرير إلى تاريخ معين

In your Gantt chart, right-click anywhere in the timescale, and then click one of the following on the shortcut menu:

  • Scroll to Finish Date, to scroll to the end of the timescale.

  • Scroll One Unit Left, to scroll one minor unit to the left.

  • Scroll One Unit Right, to scroll one minor unit to the right.

  • Scroll to Start Date, to scroll to the beginning of the timescale.

تغيير عرض منطقة مقياس الوقت

  1. Click once in the gray area at the top of the timescale region, and then click again to select the timescale column.

  2. Drag the green selection handle on the right side of the column in either direction until the region is the width that you want.

عرض المزيد من وحدات الوقت

  1. انقر فوق الخط المتصل الذي يحيط بإطار مخطط جانت لتحديد الإطار.

  2. Drag the green selection handle at the right-center of the frame toward the right.

ملاحظة: عند توسيع مقياس الوقت لعرض المزيد من وحدات الوقت، فإنك تقوم أيضاً بتغيير تاريخ الانتهاء المقترن بمشروعك.

Top of Page

Print a large Gantt chart

Unless you are creating a schedule for a small project, your Gantt chart is likely to extend beyond the boundaries of one standard printer page. The following table describes some printing problems you may encounter and steps you can take before you print that will help you get the results you expect.

Problem

Sol ution

الإجراء المطلوب

Only part of the Gantt chart is printed.

Make sure the entire chart fits on a drawing page.

  1. في القائمة ملف، انقر فوق إعداد الصفحة.

  2. Click the Page Size tab, click Size to fit drawing contents, and then click OK.

The printed page and drawing page orientations are not the same.

Change the printer page orientation.

  1. في القائمة ملف، انقر فوق إعداد الصفحة.

  2. Click the Print Setup tab, click the orientation you want, and then click OK.

You don't know how many pages the chart will be printed across.

Preview how the drawing will be printed before you print it.

  • On the File menu, click Print Preview.

You don't know where the page breaks will occur.

Turn on page breaks to see how many pages the chart will tile across.

  • On the View menu, click Page Breaks. Gray lines on the chart indicate where the page breaks will occur.

The breaks between the printed pages occur at awkward places.

Change the margin settings to control the overlap between pages. The larger the margins, the larger the overlap between pages.

  1. في القائمة ملف، انقر فوق إعداد الصفحة.

  2. On the Print Setup tab, click Setup.

  3. Type the margin settings that you want, and then click OK twice.

Top of Page

تعزيز مهارات Office
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×