المهام الأساسية في Access 2010

هام: تمت ترجمة هذه المقالة ترجمة آلية، راجع إقرار إخلاء المسؤولية. يرجى الاطلاع على النسخة الإنجليزية من هذه المقالة. هنا للرجوع إليها.

فيما يلي بعض المهام الاساسيه في قاعده البيانات التي يمكنك القيام بها ل# مساعدتك علي تعلم كيفيه استخدام Microsoft Access 2010.

 

في هذه المقالة

ما المقصود بـ Access؟

قواعد البيانات الارتباطية في Access

عند فتح Access

البحث عن قالب وتطبيقه

إنشاء قاعدة بيانات من البداية

فتح قاعدة بيانات Access موجودة

بدء استخدام قاعدة البيانات الجديدة

إضافة جدول

لصق بيانات من مصدر آخر إلى جدول في Access

استيراد بيانات من مصدر آخر أو الارتباط بها

الخطوات التالية

استيراد بيانات من جدول بيانات أو برنامج آخر

استيراد ورقة عمل Excel إلى Access

استيراد ورقة عمل Excel كجدول في قاعدة بيانات جديدة

استخدام معالج محلل الجداول لتنظيم البيانات

العمل على بيانات من برامج أخرى

استخدام قاعدة بيانات مُنشأة في إصدار سابق في إصدارات متعددة من Access

استخدام ملف قاعدة بيانات Access في إصدارات متعددة من Access

الخطوة 1: إنشاء نسخة من قاعدة البيانات الموجودة، وحفظها بتنسيق جديد

الخطوة 2: تقسيم نسخة قاعدة البيانات، واستخدام الملف الأصلي باعتباره قاعدة البيانات الموجودة على الخادم

الخطوة 3: اتصال قاعدة البيانات الجديدة الموجودة على الكمبيوتر العميل بقاعدة البيانات الأصلية

استخدام التطبيق الموجود على الكمبيوتر العميل/الخادم في إصدارات متعددة من Access

ما المقصود بـ Access؟

Access 2010 قاعده بيانات تطبيق التصميم و# النشر اداه التي يمكنك استخدامها ل# تعقب المعلومات الهامه. يمكنك المحافظه علي البيانات علي الكمبيوتر، او يمكنك نشره الي الويب — حيث يمكن ل# الاخرين استخدام قاعده البيانات ب# استخدام مستعرض ويب.

يبدأ العديد من الأشخاص في استخدام Access عندما يصبح البرنامج الذي يستخدمونه لتعقب شيء ما أقل ملاءمة لهذه المهمة بشكلٍ تدريجي. على سبيل المثال، لنفترض أنك مخطط أحداث، وتريد تعقب كافة التفاصيل التي تحتاج إلى إدارتها لإتمام الأحداث بنجاح. فإذا استخدمت معالج كلمات أو برنامج جداول بيانات لإجراء ذلك، يمكنك بسهولة مواجهة مشاكل فيما يتعلق بالبيانات المكررة وغير المتوافقة. يمكنك استخدام برنامج تقويم، ولكن لا يعتبر تعقب المعلومات المالية في تقويم أمرًا ملائمًا بشكلٍ جيد.

قواعد البيانات الارتباطية في Access

تحتاج في بعض الاحيان قاعده بيانات ارتباطيه ل# تعقب هذه المعلومات — مخزن البيانات التي تم فصلها في مجموعات اصغر من البيانات (و# تسمي جداول) ازاله التكرار، و# ثم ذات الصله معا استنادا الي مجموعه عامه من المعلومات (تسمي حقول). علي سبيل المثال، قد يحتوي علي قاعده بيانات ارتباطيه ل# تخطيط احداث جدول يتضمن معلومات العميل و# جدول يتضمن معلومات المورد، و# جدول يتضمن معلومات الاحداث. قد الجدول الذي يتضمن معلومات الاحداث حقل ل# ربطه ب# جدول العملاء، و# حقل ل# ربطه ب# جدول المورد. ب# هذه الطريقه، علي سبيل المثال، اذا تم تغيير رقم هاتف المورد، يمكن ان يمكن تغيير المعلومات مره واحده في جدول الموردين، بدلا من كل الاحداث التي تشتمل المورد.

يعتبر Access أداةً يمكنك استخدامها لتطوير تطبيقات قواعد البيانات الارتباطية سريعًا وبسهولة مما يساعدك على إدارة المعلومات. فبإمكانك إنشاء قاعدة بيانات لمساعدتك على تعقب أي نوع تقريبًا من المعلومات، مثل المخزون أو جهات الاتصال الاحترافية أو دورات الأعمال. وفي الواقع، يحتوي Access على قوالب تستطيع استخدامها على الفور لتعقب مجموعة منوعة من المعلومات، مما يسهل إجراء الأعمال حتى للمبتدئين.

عند فتح Access

عند بدء تشغيل Access 2010، ستشاهد عرض Microsoft Office Backstage، حيث يمكنك الحصول علي معلومات حول قاعده البيانات الحاليه، و# انشاء قاعده بيانات جديده، و# فتح قاعده بيانات موجوده، و# طريقه عرض المحتوي من Office.com المتميزه.

طريقة عرض Backstage في Access 2010

تحتوي أيضًا طريقة عرض Backstage على العديد من الأوامر الأخرى التي يمكنك استخدامها لضبط قواعد البيانات أو صيانتها أو مشاركتها. تنطبق بشكلٍ عام الأوامر الموجودة في طريقة عرض Backstage على قواعد البيانات بالكامل، وليس على الكائنات الموجودة داخل قاعدة البيانات.

ملاحظة: يمكنك الانتقال إلى طريقة عرض Backstage في أي وقت بواسطة النقر فوق علامة التبويب ملف.

أعلى الصفحة

البحث عن قالب وتطبيقه

يوفر Access مجموعة كبيرة ومنوعة من القوالب التي يمكنك استخدامها لزيادة سرعة عملية إنشاء قاعدة البيانات. القالب هو قاعدة بيانات جاهزة للاستخدام وتحتوي على كافة الجداول والاستعلامات والنماذج والتقارير التي تحتاج إليها لتنفيذ مهمة معينة. على سبيل المثال، توجد قوالب يمكن استخدامها لتعقب المشاكل أو إدارة جهات الاتصال أو الاحتفاظ بسجل المصاريف. وتحتوي بعض القوالب على عدد من نماذج السجلات لتساعد في توضيح كيفية استخدامها. يمكن استخدام قواعد بيانات القوالب كما هي، أو يمكنك تخصيصها لتناسب احتياجاتك بشكلٍ أفضل.

للبحث عن قالب وتطبيقه على قاعدة البيانات، قم بما يلي:

  1. من علامة التبويب ملف، انقر فوق جديد.

  2. ضمن القوالب المتوفرة، قم بأي مما يلي:

    • لإعادة استخدام قالب قمت باستخدامه مؤخرًا، انقر فوق القوالب الأخيرة، ثم حدد القالب الذي تريده.

    • لاستخدام قالب قمت بتثبيته مسبقًا، انقر فوق القوالب، ثم حدد القالب الذي تريده.

    • ل# البحث عن قالب علي Office.com، ضمن قوالب Office.com، انقر فوق فئه قالب و# حدد القالب الذي تريده، و# ثم انقر فوق تنزيل ل# تنزيل القالب من Office .com مع الكمبيوتر.

      يمكنك أيضًا البحث عن قوالب في موقع Office.com من داخل Access. في المربع البحث في Office.com عن قوالب، اكتب مصطلح بحث واحد أو أكثر، ثم انقر فوق زر السهم لبدء البحث.

  3. اختياريًا، انقر فوق أيقونة المجلد المجاورة لمربع اسم الملف لتستعرض للوصول إلى الموقع الذي تريد إنشاء قاعدة البيانات فيه. إذا لم تقم بالإشارة إلى موقع معين، يقوم Access بإنشاء قاعدة البيانات في الموقع الافتراضي الذي يتم عرضه أسفل المربع اسم الملف.

  4. انقر فوق إنشاء.

يقوم Access بإنشاء قاعدة البيانات ويفتحها للاستخدام.

أعلى الصفحة

إنشاء قاعدة بيانات من البداية

إذا كنت في حاجة إلى مقدمة أكثر شمولاً حول المفاهيم التي يدور حولها استخدام Access لإنشاء قاعدة بيانات، راجع المقالة أساسيات تصميم قواعد البيانات.

إذا لم يتناسب أحد القوالب مع احتياجاتك، أو إذا كانت لديك بيانات في برنامج آخر وتريد استخدامها في Access، قد تقرر أنه من الأفضل إنشاء قاعدة بيانات من البداية. في Access 2010، يمكنك اختيار: قاعدة بيانات سطح مكتب قياسية أو قاعدة بيانات ويب.

لمزيد من المعلومات حول قواعد بيانات ويب، راجع المقالة إنشاء قاعدة بيانات لمشاركتها على ويب.

لإنشاء قاعدة بيانات جديدة، قم بما يلي:

  1. قم ببدء تشغيل Access.

  2. ضمن علامة التبويب جديد في طريقة عرض Backstage، انقر فوق قاعدة بيانات فارغة أو قاعدة بيانات فارغة على ويب.

    هام: سيحدد الخيار الذي تجريه هنا الميزات المتوفرة في قاعدة البيانات. فلا يمكن نشر قواعد بيانات سطح المكتب على ويب، ولا تعتمد قواعد بيانات ويب بعض ميزات سطح المكتب مثل استعلامات الإجماليات.

  3. على الجانب الأيسر، اكتب اسمًا لقاعدة البيانات في المربع اسم الملف.

    ل# تغيير الموقع حيث تقوم ب# انشاء الملف، انقر فوق استعراض شكل الزر الموجود ب# جانب المربع اسم الملف، و# استعرض وصولا الي و# حدد الموقع الجديد، و# من ثم انقر فوق موافق.

  4. انقر فوق إنشاء.

    يقوم ب# انشاء قاعده بيانات access، و# ثم يقوم ب# فتح جدول فارغ (المسمي جدول 1) في طريقة عرض ورقة البيانات.

  5. يضع Access المؤشر في الخلية الفارغة الأولى في العمود انقر للإضافة بالجدول الجديد.

    ل# اضافه بيانات، ابدا ب# الكتابه، او يمكنك لصق البيانات من مصدر اخر، كما هو موضح في القسم لصق بيانات من مصدر اخر الي جدول Access، لاحقا في هذه المقاله.

    ملاحظات: 

    • تم تصميم إدخال البيانات في طريقة عرض "ورقة البيانات" ليماثل بدرجة كبيرة إدخال البيانات في ورقة عمل Excel. والقيد الأساسي هو أنه يجب إدخال البيانات في صفوف وأعمدة متقاربة، بدايةً من الزاوية العلوية اليمنى من ورقة البيانات. كما أنه لا يجب محاولة تنسيق البيانات بواسطة تضمين صفوف أو أعمدة فارغة كما كنت تفعل في ورقة عمل Excel، لأن ذلك سيؤدى إلى وجود مسافات مهملة في الجدول. حيث سيتضمن الجدول البيانات فقط. وسيكون التمثيل المرئي بالكامل لهذه البيانات من خلال النماذج والتقارير التي ستقوم بتصميمها لاحقًا.

    • يتم انشاء بنيه الجدول اثناء ادخال البيانات. اي وقت اضافه عمود جديد الي ورقه البيانات، يتم تعريف حقل جديد في الجدول. يقوم access ب# تعيين نوع البيانات الحقل استنادا الي نوع البيانات التي تقوم ب# ادخالها. علي سبيل المثال، اذا كان لديك عمود فيه ادخال قيم التاريخ فقط، سيتم تعيين الوصول الي نوع البيانات ل# هذا الحقل الي التاريخ / الوقت. اذا حاولت لاحقا ادخال قيمه غير التاريخ (علي سبيل المثال، اسم او رقم هاتف) في هذا الحقل، يعرض Access رساله تخبرك ان القيمه لا تتطابق مع نوع بيانات العمود. اذا امكن، يجب عليك التخطيط الجدول حيث ان كل عمود يحتوي علي نفس نوع البيانات، سواء كان النص، و# التواريخ او الارقام او اي نوع اخر. يؤدي ذلك من السهل انشاء الاستعلامات و# النماذج و# التقارير التي حدد البيانات التي تريدها فقط.

اذا كنت لا تريد ادخال بيانات بعد، ف# انقر فوق اغلاق شكل الزر .

ملاحظة: سيحذف Access "الجدول1" إذا قمت بإغلاقه دون حفظه.

أعلى الصفحة

فتح قاعدة بيانات موجودة في Access

تلميح: لفتح إحدى قواعد البيانات المتعددة الأخيرة التي سبق لها فتحها سريعًا، ضمن علامة التبويب ملف، انقر فوق أخير، ثم انقر فوق اسم الملف.

  1. ضمن علامة التبويب ملف، انقر فوق فتح.

  2. انقر فوق اختصار في مربع الحوار فتح — او، في المربع بحث في، انقر فوق محرك الاقراص او المجلد الذي يحتوي علي قاعده البيانات التي تريدها.

  3. في قائمة المجلدات، انقر نقرًا مزدوجًا فوق المجلدات حتى يتم فتح المجلد الذي يحتوي على قاعدة البيانات.

  4. عند العثور على قاعدة البيانات، قم بأي مما يلي:

    • لفتح قاعدة البيانات في وضع الفتح الافتراضي، انقر نقرًا مزدوجًا فوقها.

    • لفتح قاعدة البيانات لتمكين الوصول المشترك إليها في بيئة متعددة المستخدمين، بحيث يمكنك أنت والمستخدمين الآخرين قراءة قاعدة البيانات والكتابة إليها في نفس الوقت، انقر فوق فتح.

    • لفتح قاعدة البيانات في وضع الوصول للقراءة فقط، بحيث يمكنك عرضها دون تحريرها، انقر فوق السهم الموجود بجانب الزر فتح، ثم انقر فوق فتح للقراءة فقط.

    • لفتح قاعدة البيانات في وضع الوصول الخاص، بحيث لا يتمكن أي أحد آخر من فتحها أثناء فتحك لها، انقر فوق السهم الموجود بجانب الزر فتح، ثم انقر فوق فتح خاص.

    • لفتح قاعدة البيانات في وضع الوصول للقراءة فقط، انقر فوق السهم الموجود بجانب الزر فتح، ثم انقر فوق فتح خاص للقراءة فقط سيتمكن المستخدمون الآخرون أيضًا من فتح قاعدة البيانات، ولكن في وضع الوصول للقراءة فقط.

إذا لم تتمكن من العثور على قاعدة البيانات التي تريد فتحها   

  1. في مربع الحوار فتح، انقر فوق اختصار جهاز الكمبيوتر — او، في المربع بحث في، انقر فوق جهاز الكمبيوتر.

  2. في قائمة محركات الأقراص، انقر بزر الماوس الأيمن فوق محرك الأقراص الذي قد تعتقد أنه يحتوي على قاعدة البيانات المطلوبة، ثم انقر فوق بحث.

  3. قم بإدخال معايير البحث، ثم اضغط على المفتاح ENTER للبحث عن قاعدة البيانات.

  4. إذا تم العثور على قاعدة البيانات، قم بفتحها بواسطة النقر المزدوج فوقها في مربع الحوار نتائج البحث.

    بما أنه تم بدء البحث من مربع الحوار فتح، يجب النقر فوق إلغاء الأمر في مربع الحوار هذا قبل فتح قاعدة البيانات.

يمكنك فتح ملف بيانات مباشره ب# تنسيق ملف خارجي (علي سبيل المثال، dBASE او Paradox، Microsoft Exchange او Excel). يمكنك ايضا مباشره فتح اي مصدر بيانات ODBC، مثل Microsoft SQL Server او Microsoft FoxPro. Access تلقائيا ب# انشاء قاعده بيانات Access جديده في المجلد نفسه ك# ملف البيانات، و# اضافه ارتباطات الي كل جدول في قاعده البيانات الخارجيه.

أعلى الصفحة

بدء استخدام قاعدة البيانات الجديدة

وفقًا للقالب الذي تستخدمه، قد تحتاج إلى القيام بإجراء أو أكثر من الإجراءات التالية لبدء استخدام قاعدة البيانات الجديدة:

  • إذا كان Access يعرض مربع الحوار تسجيل الدخول مع قائمة فارغة للمستخدمين، استخدم الإجراء التالي للبدء:

    1. انقر فوق مستخدم جديد.

    2. قم بملء نموذج تفاصيل المستخدم.

    3. انقر فوق حفظ وإغلاق.

    4. قم بتحديد اسم المستخدم الذي قمت بإدخاله، ثم انقر فوق تسجيل الدخول.

  • إذا قام Access بعرض ورقة بيانات فارغة، فيمكنك البدء بكتابة البيانات مباشرةً في ورقة البيانات هذه، أو انقر فوق الأزرار الأخرى وعلامات التبويب لاستكشاف قاعدة البيانات.

  • إذا قام Access بعرض صفحة الشروع في العمل، يمكنك النقر فوق الارتباطات الموجودة على تلك الصفحة للتعرف على المزيد حول قاعدة البيانات، أو النقر فوق الأزرار الأخرى وعلامات التبويب لاستكشاف قاعدة البيانات.

  • إذا قام Access بعرض رسالة تحذير أمان في شريط الرسائل، مع ثقتك في مصدر القالب، انقر فوق تمكين المحتوى. إذا كانت قاعدة البيانات تتطلب تسجيل الدخول، يجب تسجيل الدخول مرة أخرى.

بالنسبة لقواعد بيانات سطح المكتب وقواعد بيانات ويب، ستحتاج أيضًا إلى البدء بإحدى الخطوتين التاليتين:

أعلى الصفحة

إضافة جدول

يمكنك إضافة جدول جديد إلى قاعدة بيانات موجودة باستخدام الأدوات الموجودة في المجموعة جداول ضمن علامة التبويب إنشاء.

المجموعة "جداول" ضمن علامة التبويب "إنشاء"

ملاحظة: في قاعدة بيانات ويب، يتوفر الأمر جدول فقط في المجموعة جداول.

بغض النظر عن طريقة العرض التي تبدأ بها، يمكنك دومًا التبديل إلى طرق العرض الأخرى باستخدام أزرار طرق العرض الموجودة على شريط المعلومات في نافذة Access.

انشاء جدول فارغ في طريقه عرض ورقه البيانات    في طريقه عرض ورقه البيانات، يمكنك ادخال البيانات مباشره، و# السماح ل# الوصول الي انشاء بنيه الجدول الخلفيه. يتم تعيين اسماء الحقول رقميا (Field1, Field2، و# ما الي ذلك)، و# يقوم Access ب# تعيين نوع بيانات الحقل، استنادا الي نوع البيانات التي تقوم ب# ادخالها.

  1. علي علامه التبويب انشاء، في المجموعه جداول، انقر فوق جدول شكل الزر .

  2. ينشىء Access الجدول، ثم يضع المؤشر في الخلية الفارغة الأولى بالعمود انقر للإضافة.

  3. ل# اضافه بيانات، ابدا ب# الكتابه في اول خليه فارغه، او يمكنك لصق البيانات من مصدر اخر، كما هو موضح لاحقا في هذه المقاله.

    • لإعادة تسمية عمود (حقل)، انقر نقرًا مزدوجًا فوق عنوان العمود، ثم اكتب الاسم الجديد.

      تلميح: قم بتعيين اسم ذي معنى لكل حقل، حتى تتمكن من معرفة محتوياته دون الحاجة إلى فحص البيانات.

    • لنقل عمود، حدده بواسطة النقر فوق عنوانه، ثم اسحبه إلى المكان الذي تريده. يمكنك أيضًا تحديد العديد من الأعمدة المتقاربة وسحبها بأكملها إلى موقع جديد معًا.

      لإضافة المزيد من الحقول إلى الجدول، يمكنك إما بدء الكتابة في العمود انقر للإضافة في طريقة عرض "ورقة البيانات"، أو إضافة حقول جديدة باستخدام الأوامر الموجودة في المجموعة إضافة وحذف ضمن علامة التبويب الحقول.

بدء انشاء جدول في طريقه عرض التصميم    في طريقه عرض "التصميم"، يجب اولا انشاء بنيه الجدول الجديد. ثم اما التبديل الي طريقه عرض ورقه البيانات ل# ادخال بيانات، او قم ب# ادخال البيانات ب# استخدام اساليب اخري، مثل ب# استخدام نموذج.

طريقة عرض "التصميم" ليست متوفرة للجداول في قاعدة بيانات ويب.

  1. من علامة التبويب إنشاء، ضمن المجموعة جداول، انقر فوق تصميم الجدول. شكل الزر

  2. قم بكتابة اسم لكل حقل موجود في الجدول في العمود اسم الحقل ثم حدد نوع البيانات من قائمة نوع البيانات.

  3. يمكنك إدخال معلومات إضافية لكل حقل في عمود الوصف. يتم عرض الوصف الذي تقوم بإدخاله على شريط المعلومات عندما تكون نقطة الإدراج في هذا الحقل، ويتم استخدام هذا الوصف كنص شريط المعلومات لأي عنصر من عناصر التحكم التي يتم إنشاؤها عن طريق سحب الحقل من جزء قائمة الحقول إلى نموذج أو تقرير، وكذلك عناصر التحكم التي يتم إنشاؤها لهذا الحقل بواسطة "معالج النماذج" أو "معالج التقارير".

  4. بعد إضافة كافة الحقول, احفظ الجدول:

    • ضمن علامة التبويب ملف، انقر فوق حفظ.

  5. يمكنك بدء إدخال البيانات في الجدول في أي وقت بواسطة التبديل إلى طريقة عرض "ورقة البيانات"، والنقر في الخلية الفارغة الأولى، ثم الكتابة. يمكنك أيضًا لصق بيانات من مصدر آخر، كما هو موضح في المقطع التالي.

انشاء جدول ب# الاستناد الي قائمه SharePoint    قائمه SharePoint، يمكن استخدام بياناتك ب# الاشخاص الذين ليس لديهم حق الوصول. فضلا عن ذلك، يتم تخزين بيانات القائمه علي خادم، الذي يوفر حمايه افضل من فقدان البيانات من الملفات المخزنه علي كمبيوتر سطح مكتب ب# شكل عام. يمكنك اما ابدا ب# استخدام قائمه جديده، او يمكنك انشاء ارتباط ب# قائمه موجوده. يجب ان يكون لديك اذونات كافيه علي موقع SharePoint حيث تريد انشاء القائمه; يمكن ان يختلف هذا ب# مسؤول SharePoint ل# الحصول علي تفاصيل حول الخيارات المتاحه لك موقع ذا جهه الاتصال.

هذه الميزه غير متوفره في قاعده بيانات ويب.

  1. ضمن علامة التبويب "إنشاء"، في المجموعة "جداول"، انقر فوق "قوائم SharePoint".

  2. يمكنك استخدام أحد قوالب القوائم لإنشاء قائمة قياسية لـ SharePoint، مثل "جهات الاتصال" أو "الأحداث".

    يمكنك أيضًا اختيار إنشاء قائمة مخصصة، أو الارتباط بقائمة موجودة أو استيرادها. انقر فوق الخيار الذي تريده.

  3. في حالة اختيار أي قالب من قوالب القوائم أو عند إنشاء قائمة مخصصة، يتم فتح مربع الحوار إنشاء قائمة جديدة لإرشادك طوال العملية. أما في حالة اختيار استخدام قائمة موجودة، يتم فتح مربع الحوار إحضار بيانات خارجية لمساعدتك.

لمزيد من المعلومات حول الجداول، راجع المقالة مقدمة حول الجداول.

أعلى الصفحة

لصق بيانات من مصدر آخر إلى جدول في Access

إذا كانت البيانات مُخزنة حاليًا في برنامج آخر، مثل Excel، يمكنك نسخ هذه البيانات ولصقها في جدول Access. وبشكلٍ عام، يُفضل فصل البيانات مسبقًا في أعمدة، كما هو الحال في ورقة عمل Excel. فإذا كانت البيانات موجودة في برنامج معالجة الكلمات، يجب فصل أعمدة البيانات أولاً باستخدام أحرف جدولة، أو تحويل البيانات إلى جدول في برنامج معالجة الكلمات، ثم نسخ هذه البيانات. وإذا كانت البيانات في حاجة لأي تحرير أو معالجة (مثل فصل الأسماء الكاملة إلى الأسماء الأولى وأسماء العائلة)، قد تحتاج إلى عمل ذلك قبل نسخ البيانات، خاصةً إذا كنت غير متمرس على استخدام Access.

عند لصق بيانات في جدول فارغ، يُعين Access نوع بيانات كل حقل وفقًا لنوع البيانات الموجود. على سبيل المثال، إذا لم يحتوي الحقل الذي تم لصقه إلا على قيم تواريخ، سيطبق Access نوع البيانات "تاريخ/وقت" على هذا الحقل. وإذا كان الحقل يحتوي على الكلمتين "نعم" و"لا" فقط، سيطبق Access نوع البيانات "نعم/لا" على هذا الحقل.

يقوم Access بتسمية الحقول استنادًا إلى ما يجده في الصف الأول من البيانات التي تم لصقها. فإذا كان الصف الأول من البيانات التي تم لصقها مماثلاً في النوع للصفوف التالية، سيعتبر Access أن الصف الأول هذا هو جزء من البيانات وسيعيّن أسماء الحقول العامة (الحقل1، الحقل2، وهكذا). وإذا لم يكن الصف الأول هذا مماثلاً للصفوف التالية، فإن Access سيستخدمه كأسماء حقول، وسيستبعده في البيانات الفعلية.

إذا قام Access بتعيين أسماء الحقول العامة، يجب أن تعيد تسمية الحقول بأسرع ما يمكن لتجنب تداخل البيانات. استخدم الإجراء التالي:

  1. ضمن علامة التبويب ملف، انقر فوق حفظ لحفظ الجدول.

  2. في طريقة عرض "ورقة البيانات"، انقر نقرًا مزدوجًا فوق عنوان كل عمود، ثم اكتب اسمًا للعمود.

  3. احفظ الجدول مرة أخرى.

أعلى الصفحة

استيراد بيانات من مصدر آخر أو الارتباط بها

قد تكون لديك بيانات تم تجميعها في برنامج آخر وتريد استخدامها في Access. ومن المحتمل أنك تعمل مع أشخاص يقومون بتخزين البيانات في برامج أخرى، وترغب أنت في العمل باستخدام هذه البيانات في Access. أو قد تكون لديك العديد من مصادر البيانات المتباينة، وتحتاج إلى "نقطة مركزية" يمكنك فيها تجميع هذه البيانات معًا لإجراء تحليل أعمق.

يسهل Access عملية استيراد البيانات أو الارتباط بها من برامج أخرى. حيث يمكنك إحضار بيانات من ورقة عمل Excel أو من جدول في قاعدة بيانات أخرى في Access أو من قائمة SharePoint أو من أية مجموعة منوعة من المصادر الأخرى. تختلف العملية اختلافًا بسيطًا وفقًا لمصدر البيانات، ولكن ستمكنك هذه الإرشادات من الشروع في العمل:

  1. ضمن علامة التبويب بيانات خارجية، في المجموعة استيراد وارتباط، انقر فوق الأمر الخاص بنوع الملف الذي تقوم بالاستيراد منه.

    على سبيل المثال، إذا كنت تستورد بيانات من ورقة عمل Excel، انقر فوق Excel. وإذا لم تشاهد نوع البرنامج الصحيح، انقر فوق أكثر.

    ملاحظة: اذا لم تعثر علي نوع التنسيق الصحيح في المجموعه استيراد و# ارتباط، قد تحتاج الي بدء تشغيل البرنامج الذي الذي انشاه في الاصل البيانات، و# ثم استخدام هذا البرنامج ل# حفظ البيانات ب# تنسيق ملف يعتمده Access (مثل ملف نص محدد )، و# ثم استيراده او انشاء ارتباط ب# البيانات.

  2. في مربع الحوار إحضار بيانات خارجية، إما أن تنقر فوق استعراض للاستعراض وصولاً إلى ملف البيانات المصدر، أو كتابة المسار الكامل لملف البيانات المصدر في المربع اسم الملف.

  3. انقر فوق الخيار المطلوب تحت تحديد كيفية والمكان المراد فيه تخزين البيانات في قاعدة البيانات الحالية. يمكنك إنشاء جدول جديد باستخدام البيانات التي تم استيرادها، أو إنشاء جدول مرتبط يحتفظ بارتباط إلى مصدر البيانات.

  4. انقر فوق موافق.

    استنادًا إلى اختيارك، يتم فتح مربع الحوار ربط كائنات أو مربع الحوار استيراد كائنات.

  5. استخدم مربع الحوار لإنهاء العملية. حيث يعتمد الإجراء الفعلي الذي تتبعه على خيار الاستيراد أو الارتباط الذي اخترته.

  6. في صفحة المعالج الأخيرة، انقر فوق إنهاء.

    إذا اخترت الاستيراد، سيستفسر Access عما إذا كنت ترغب في حفظ تفاصيل عملية الاستيراد التي تمت الآن.

  7. إذا كنت تعتقد أنك ستعيد إجراء نفس عملية الاستيراد هذه مرة أخرى، انقر فوق حفظ خطوات الاستيراد، ثم أدخل التفاصيل.

    بعد ذلك، يمكنك بسهولة إعادة تنفيذ عملية الاستيراد عن طريق النقر فوق عمليات الاستيراد المحفوظة في المجموعة استيراد ضمن علامة التبويب بيانات خارجية، ثم النقر فوق مواصفة الاستيراد، والنقر فوق تشغيل.

  8. وفي حالة عدم الرغبة في حفظ تفاصيل العملية، انقر فوق إغلاق.

يستورد Access البيانات إلى جدول جديد، ثم يعرض هذا الجدول ضمن جداول في "جزء التنقل".

لمعرفة المزيد حول كيفية استيراد بيانات إلى Access، اتبع الارتباطات في المقطع راجع أيضًا في هذه المقالة.

أعلى الصفحة

الخطوات التالية

يختلف الجزء المتبقي من عملية التصميم استنادًا إلى أهدافك، ولكنك قد تحتاج إلى وضع عملية إنشاء الاستعلامات والنماذج والتقارير ووحدات الماكرو في الاعتبار. لا توفر هذه المقالة أية معلومات حول إنشاء الكائنات الإضافية بقاعدة البيانات.

لمزيد من المعلومات، راجع المقالات التالية:

أعلى الصفحة

استيراد بيانات من جدول بيانات أو برنامج آخر

إذا كنت متمرسًا على استخدام البرامج الأخرى لقواعد البيانات أو جداول البيانات، فربما تعرف أساسيات عمل هذه التطبيقات والمجالات التي يتم فيها استخدام قواعد البيانات. يختلف Access عن العديد من تطبيقات قواعد البيانات الأخرى من خلال السماح لك بإنشاء قواعد بيانات ارتباطية، كما أنه يختلف عن معظم برامج جداول البيانات من خلال توفير أدوات لتطوير استعلامات ونماذج وتقارير متطورة. يوفر Access أيضًا خيارات عديدة للعمل في برامج قواعد البيانات الأخرى، مثل SQL Server.

استيراد ورقة عمل Excel إلى Access

يبدأ العديد من الأشخاص في استكشاف Access بعد إنشاء أول قائمة في Excel. حيث يعد Excel مكانًا رائعًا يمكنك البدء منه في إنشاء قائمة، ولكن كلما كبر حجم القائمة، يصبح من الصعب تنظيمها والاحتفاظ بحداثتها. لذلك، يعتبر عادةً نقل القائمة المُنشأة في Excel إلى Access الخطوة المنطقية التالية.

يشبه جدول قاعدة البيانات ورقة العمل من ناحية البنية، حيث يتم تخزين البيانات في صفوف وأعمدة. ولذلك، يكون من السهل عادةً استيراد ورقة عمل إلى جدول قاعدة بيانات. أما نقطة الاختلاف الأساسية بين تخزين البيانات في ورقة عمل وتخزينها في جدول قاعدة بيانات تكمن في كيفية تنظيم البيانات. حيث لن يؤدي ببساطة استيراد ورقة العمل بأكملها كجدول جديد في قاعدة البيانات إلى حل المشاكل المقترنة بتنظيم البيانات وتحديثها، خاصةً إذا كانت ورقة العمل تحتوي على بيانات متكررة. لحل هذه المشاكل، يجب تقسيم جدول البيانات إلى جداول منفصلة، يحتوي كل منها على بيانات مرتبطة. لمزيد من المعلومات حول كيفية تنظيم البيانات في الجداول، راجع المقالة أساسيات تصميم قواعد البيانات.

يحتوي Access على ميزة "معالج محلل الجداول"، الذي يمكن أن يساعدك في إتمام هذه العملية. فبعد استيراد بياناتك إلى أحد الجداول، يساعدك المعالج في تقسيم هذا الجدول إلى جداول منفصلة، يحتوي كل منها على بيانات لا تتكرر في أي من الجداول الأخرى. ينشئ المعالج أيضًا العلاقات الضرورية بين الجداول.

أعلى الصفحة

استيراد ورقة عمل Excel كجدول في قاعدة بيانات جديدة

  1. ضمن علامة التبويب ملف، انقر فوق جديد، ثم فوق قاعدة بيانات فارغة.

  2. اكتب اسمًا لقاعدة البيانات الجديدة في المربع اسم الملف، ثم انقر فوق إنشاء.

    يتم فتح قاعدة البيانات الجديدة، ويقوم Access بإنشاء جدول فارغ جديد، يسمى "الجدول1".

  3. أغلق "الجدول1".

    عند الاستفسار عما إذا كنت ترغب في حفظ التغييرات على تصميم "الجدول1"، انقر فوق لا.

  4. علي علامه التبويب بيانات خارجيه، في المجموعه استيراد و# ارتباط، انقر فوق Excel. شكل الزر

  5. في مربع الحوار إحضار بيانات خارجية، انقر فوق استعراض.

  6. استخدم مربع الحوار فتح ملف لتحديد موقع الملف.

  7. حدد الملف، ثم انقر فوق فتح.

  8. في مربع الحوار إحضار بيانات خارجية، تأكد من تحديد الخيار استيراد البيانات المصدر إلى جدول جديد في قاعدة البيانات الحالية.

  9. انقر فوق موافق.

    يتم بدء تشغيل "معالج استيراد جدول بيانات"، ويسألك بعض الأسئلة عن بياناتك.

  10. اتبع الإرشادات، بالنقر فوق التالي أو السابق للتنقل بين الصفحات. في صفحة المعالج الأخيرة، انقر فوق إنهاء.

    ملاحظة: يستفسر Access عما إذا كنت ترغب في حفظ تفاصيل عملية الاستيراد التي تمت الآن. إذا كنت تعتقد أنك ستعيد إجراء نفس عملية الاستيراد هذه مرة أخرى، انقر فوق نعم، ثم أدخل التفاصيل. بعد ذلك، يمكنك بسهولة إعادة تنفيذ العملية في المستقبل عن طريق النقر فوق عمليات الاستيراد المحفوظة في المجموعة استيراد ضمن علامة التبويب بيانات خارجية. وفي حالة عدم الرغبة في حفظ تفاصيل العملية، انقر فوق إغلاق.

يستورد Access البيانات إلى جدول جديد، ثم يعرضه ضمن كافة الجداول في "جزء التنقل" .

أعلى الصفحة

استخدام معالج محلل الجداول لتنظيم البيانات

بعد استيراد البيانات إلى جدول Access، يمكنك استخدام "معالج محلل الجداول" لتعريف البيانات المتكررة سريعًا. يوفر المعالج بعد ذلك طريقة بسيطة لتنظيم البيانات في جداول منفصلة، وبذلك يتم تخزينها بالطريقة الأكثر فعالية. حيث يحتفظ Access بالجدول الأصلي كنسخة احتياطية، ثم ينشئ جداول جديدة يمكنك استخدامها كأساس لتطبيق قاعدة البيانات.

  1. افتح قاعدة بيانات Access التي تحتوي على الجدول الذي تريد تحليله.

  2. ضمن علامة التبويب أدوات قاعدة البيانات، في المجموعة تحليل، انقر فوق تحليل الجدول.

    يتم بدء تشغيل "معالج محلل الجداول".

    برنامج تعليمي قصير تحتوي علي صفحات الاولي و# الثانيه من المعالج — كامله مع الازرار التي يمكنك النقر فوق ل# الاطلاع علي امثله. اذا لم يظهر الصفحات تمهيديه، و# لكنك بدلا من ذلك مشاهده خانه الاختيار المعنونه اظهار صفحات تمهيديه؟ و# حدد خانه الاختيار، و# ثم انقر فوق السابق مرتين ل# رؤيه المقدمه. اذا كنت لا تريد رؤيه الصفحات تمهيديه مره اخري بعد قراءه المقدمه، يمكنك مسح اظهار صفحات تمهيديه؟ خانه الاختيار.

  3. في الصفحة ما هو الجدول الذي يحتوي على حقول تتضمن قيم مكررة في العديد من السجلات؟ ، حدد الجدول الذي تريد تحليله، ثم انقر فوق التالي.

  4. يمكنك السماح للمعالج بتحديد الحقول المراد تضمينها في الجداول كلٍ على حده، أو يمكنك اتخاذ هذا القرار بنفسك. إذا قمت باتباع اقتراحات المعالج، سيظل بإمكانك إجراء تغييرات على تخطيط الجدول في الصفحة التالية من المعالج.

    ملاحظة: إذا تركت المعالج يحدد الحقول المراد تضمينها في الجداول كلٍ على حده، فقد لا تتلاءم دومًا اختياراته مع بياناتك، خاصةً إذا كانت هناك كمية قليلة من البيانات للعمل عليها. لذلك يجب التحقق من نتائج المعالج بعناية. على الجانب الآخر، قد يقترح المعالج تنظيمًا أكثر فاعلية من ذلك الذي تفكر فيه، ولهذا السبب قد تكون محاولة استخدام قرارات المعالج مرة واحدة على الأقل فكرة جيدة. وإذا لم تعجبك اقتراحات المعالج، سيظل بإمكانك إعادة ترتيب الحقول يدويًا، حيث يمكنك بشكلٍ دائم النقر فوق السابق وترتيب كافة الحقول بنفسك.

  5. انقر فوق التالي. في هذه الصفحة، ستقوم بتعيين أي الجداول تتضمن أي الحقول. إذا اخترت السماح للمعالج باتخاذ القرار، يجب مشاهدة جداول متعددة متصلة بواسطة خطوط العلاقات. وإلا، سينشئ Access جدولاً واحدًا فقط يحتوي على كافة الحقول. في كلتا الحالتين، يمكنك إجراء تغييرات على هذه الصفحة.

    • يمكنك سحب حقول من جدول إلى مساحة فارغة في الصفحة لإنشاء جدول جديد يحتوي على هذه الحقول. يطالبك Access بوضع اسم للجدول.

    • يمكنك سحب حقول من أحد الجداول إلى جدول آخر إذا كنت تعتقد أن تخزينها سيكون بصورة أكثر فاعلية هناك.

    • سيتم إعطاء معظم الجداول الحقل معرف أو معرف فريد مولد. لمعرفة المزيد حول حقول "المعرف"، انقر فوق تلميحات في الزاوية العلوية اليسرى من المعالج.

    • للتراجع عن أي تغيير، انقر فوق الزر تراجع.

    • لإعادة تسمية جدول، انقر نقرًا مزدوجًا فوق شريط عنوانه، واكتب الاسم الجديد، ثم انقر فوق موافق.

  6. عندما تصبح الحقول مرتبة كما تريدها، انقر فوق التالي.

  7. عندما يعثر المعالج على سجلات تحتوي على قيم متشابهة إلى حدٍ كبير، فإنه سيعرّف هذه القيم كأخطاء مطبعية محتملة وسيعرض شاشة يمكنك فيها تأكيد ما ستقوم به تجاه تلك الأخطاء. قم بالمرور خلال القوائم للبحث عن تلك التي تتضمن قيمًا في العمود تصحيح، ثم انقر فوق العنصر المناسب في القائمة المنسدلة. حدد (اتركه كما هو) لمنع المعالج من إجراء أي تغييرات على القيمة. وعند الانتهاء، انقر فوق التالي.

  8. يسألك المعالج عما إذا كنت ترغب في إنشاء استعلام يشبه الجدول الأصلي. إذا قمت مسبقًا بإنشاء نماذج وتقارير تستند إلى الجدول الأصلي، فمن الأفضل إنشاء ذلك الاستعلام. وإذا قمت باختيار نعم، أريد إنشاء الاستعلام، سيعيد المعالج تسمية الجدول الأصلي بواسطة إلحاق "OLD_" باسم الجدول، وبعد ذلك سيقوم بتسمية الاستعلام الجديد باستخدام اسم الجدول الأصلي. تستخدم الآن النماذج والتقارير التي كانت تستند إلى الجدول الاستعلام لبياناتها، مع استمرارها في العمل كالسابق.

  9. انقر فوق إنهاء.

    ينشئ المعالج الجداول الجديدة كما هو محدد، ثم يفتحها. بعد الانتهاء من تفحص النتائج، قم بإغلاق الجداول.

أعلى الصفحة

العمل على بيانات من برامج أخرى

يوفر Access 2010 ميزات للعمل على البيانات المخزنة في برامج أخرى.

انشاء قاعده بيانات Access جديده يرتبط ب# البيانات ب# تنسيق ملف اخر    يمكنك استخدام Access ل# فتح ملف ب# تنسيق ملف اخر مثل نص او dBASE او جدول بيانات. Access تلقائيا ب# انشاء قاعده بيانات Access و# ارتباطات الملف ب# النيابه عنك.

  1. قم ببدء تشغيل Access.

  2. ضمن علامة التبويب ملف، انقر فوق فتح.

  3. في مربع الحوار فتح، انقر فوق نوع الملف الذي تريد فتحه في القائمة. في حالة عدم التأكد من نوع الملف، انقر فوق All Files (*.*)‎.

  4. حسب الحاجة، قم بالاستعراض للوصول إلى المجلد الذي يحتوي على الملف الذي تريد فتحه. وعند العثور على الملف، انقر نقرًا مزدوجًا فوقه لفتحه.

  5. اتبع الإرشادات الموجودة في المعالج. وفي صفحة المعالج الأخيرة، انقر فوق إنهاء.

بيانات الاستيراد او الارتباط ب# قاعده بيانات Access    يمكنك اما استيراد البيانات من مصادر و# البرامج الاخري الي جداول Access حيث البيانات المضمنه داخل ملف Access، او يمكنك الارتباط ب# البيانات من Access حيث يظل البيانات الموجوده في الملف الاصلي (خارج ملف Access).

  1. ضمن علامة التبويب بيانات خارجية، في المجموعة استيراد وارتباط، انقر فوق التنسيق الذي تم تخزين البيانات به.

    يمكنك استيراد البيانات أو الارتباط بها من المصادر التالية:

    • Excel    يمكنك احضار البيانات من ورقه عمل او نطاق مسمي في مصنف Excel. يجب ان تكون استيراد كل ورقه العمل او النطاق المسمي او مرتبطا ب# شكل منفصل.

    • Access    هذا مفيدا ل# فصل عمليه الخاصه بك من البيانات، انشاء قاعده بيانات منقسمه. ب# معني، استخدم قاعده بيانات واحده ل# تضمين كافه النماذج و# التقارير و# وحدات الماكرو، و# المحافظه علي البيانات في قاعده بيانات اخري. يمكنك ثم تطوير تحسينات دون مقاطعه العمل ل# اي شخص. يمكنك ايضا دمج البيانات من العديد من الوصول الي قواعد بيانات مختلفه في واحد، مما يسهل ل# تلخيص البيانات عبر الاقسام او بين شركاء العمل.

    • قاعده بيانات ODBC    تدعم برامج العديد من هذا التنسيق، ب# ما في ذلك العديد من منتجات خادم قاعده البيانات. يساعدك هذا في انشاء قواعد بيانات "المنتقل اليها لوحه"، حيث يمكنك دمج البيانات من انظمه اخري.

    • ملف نصي    يمكنك الاتصال ب# ملف نصي بسيطه، و# يمكنك استخدام Access ل# تغيير محتويات هذا الملف. يمكن ان يساعد هذا تسهيل استهلاكه عبر مجموعه واسعه من برامج بيانات Access.

    • ملف XML    يوفر هذا التنسيق ايضا التوافق مع العديد من برامج اخري، ب# ما في ذلك بعض خوادم ويب.

    • قائمه SharePoint    يؤدي هذا الي جعل البيانات الخاصه بك قابله ل# الاستخدام ب# استخدام مستعرض ويب، طريقه قياسيه ل# استخدام قائمه SharePoint.

    • خدمات البيانات    يمكنك الاتصال ب# خدمات البيانات ويب داخل المؤسسه الخاصه بك.

    • مستند HTML   

    • مجلد outlook    يمكنك الاتصال ب# مجلدات Outlook، حيث يمكنك دمج معلومات الاتصال الخاصه بك ب# سهوله اكبر مع الجزء المتبقي البيانات.

    • dBase ملف dBase    عباره عن نظام ل# قواعد بيانات بديل شائعه التي يعتمدها Access

      يظهر مربع الحوار إحضار بيانات خارجية.

  2. اتبع الإرشادات الموجودة في مربع الحوار.

    سيستورد Access البيانات إلى قاعدة بياناتك أو سيرتبط بها. يجب تحديد موقع البيانات في معظم التنسيقات، ثم اختيار كيفية تخزينها في قاعدة البيانات.

أعلى الصفحة

استخدام قاعدة بيانات مُنشأة في إصدار سابق في إصدارات متعددة من Access

اذا تم انشاء مشروع Access او قاعده بيانات Access الخاصه بك في Access 2000 او الاصدار الاحدث، يمكنك استخدام قاعده البيانات او المشروع في اصدار Access الذي تم فيه انشاء او في اي اصدار احدث — حتي اذا كان الملف تمكين الامان. علي سبيل المثال، يمكن استخدام ملفات Access 2000 في Access 2000 و Access 2002 Access 2003 Access 2007 و Access 2010.

قد يكون لديك موقف المكان الذي تريد الاحتفاظ ب# البيانات في اصدار سابق من Access، و# لكن لديك المستخدمين ب# استخدام اصدار احدث من Access التي تريد انشاء ارتباط الي تلك البيانات و# لكن ما زال الاستفاده من استخدام بعض الميزات في الاصدار الاحدث. الحل هو ل# انشاء قاعده جديده "الموجوده" في الاصدار الاحدث (التي تحتوي علي النماذج، تقارير، و# الاستعلامات، و# وحدات الماكرو، و# لكن لا الجداول)، و# ربطه ب# الجداول الموجوده في الملف اصدار سابق. استخدم احد الاجراءات التاليه، استنادا الي ما اذا كان قاعده البيانات الموجوده في ملف واحد، او الفعل تقسيم التطبيق الموجود على الكمبيوتر العميل/الخادم.

استخدام ملف قاعدة بيانات Access في إصدارات متعددة من Access

إذا كانت كافة الجداول والنماذج والكائنات الأخرى الخاصة بقاعدة بيانات Access المُنشأة في إصدار سابق موجودة في ملف واحد، وأردت استخدام قاعدة البيانات في إصدارات متعددة من Access، يمكنك إنشاء قاعدة بيانات جديدة على الكمبيوتر العميل باستخدام إصدار أحدث وربطها بالملف الأصلي. سيظل بإمكان مستخدمي الإصدار السابق من Access استخدام قاعدة البيانات الأصلية. كما يمكن لمستخدمي الإصدار الأحدث استخدام قاعدة البيانات الجديدة الموجودة على الكمبيوتر العميل للارتباط بنفس البيانات. يمكنك إنشاء العديد من إصدارات الكمبيوتر العميل إذا كنت في حاجة إلى إجراء توافق بين إصدارات متعددة من Access.

أعلى الصفحة

الخطوة 1: إنشاء نسخة من قاعدة البيانات الموجودة، وحفظها بتنسيق جديد

استخدم الإجراء التالي لتحويل قاعدة البيانات إلى أي من التنسيقات الثلاثة الحديثة التالية: Access 2000 أو Access2002-2003 أو Access 2007. يحافظ هذا الأمر على قاعدة البيانات الأصلية بتنسيقها الأصلي، وينشئ نسخة بالتنسيق الذي تحدده.

  1. قم بإغلاق ملف Access. وإذا كان الملف هو قاعدة بيانات Access متعددة المستخدمين وموجودة على خادم أو في مجلد مشترك، فتأكد من أنها غير مفتوحة من قِبل أي شخص آخر.

  2. قم ببدء تشغيل Access 2010.

  3. ضمن علامة التبويب ملف، انقر فوق فتح.

  4. قم بالاستعراض للوصول إلى موقع الملف المراد تحويله، ثم انقر نقرًا مزدوجًا فوقه لفتحه.

    في حالة ظهور مربع الحوار تحسين قاعدة بيانات، ليسألك عما إذا كنت تريد تحسين قاعدة البيانات أم لا، انقر فوق لا.

  5. في حالة فتح نموذج عند بدء تشغيل قاعدة البيانات، قم بإغلاقه.

  6. ضمن علامة التبويب ملف، انقر فوق حفظ قاعدة البيانات باسم.

  7. في مربع الحوار حفظ باسم، اكتب اسمًا لقاعدة البيانات الجديدة.

    ملاحظة: ما لم تقم بحفظ قاعدة البيانات الجديدة في موقع آخر، يجب أن يختلف اسمها عن اسم قاعدة البيانات الأصلية. في كلتا الحالتين، يُفضل عادةً استخدام اسم مختلف، لكي تتمكن بسهولة من التمييز بين قاعدة البيانات الموجودة على الكمبيوتر العميل وتلك الموجودة على الخادم. ومع ذلك، إذا قمت بالتحويل إلى تنسيق Access 2007، سيتغير ملحق اسم الملف من mdb. إلى accdb.، ولذلك يمكنك استخدام نفس اسم الملف.

  8. انقر فوق حفظ.

أعلى الصفحة

الخطوة 2: تقسيم نسخة قاعدة البيانات، واستخدام الملف الأصلي باعتباره قاعدة البيانات الموجودة على الخادم

قم بتقسيم قاعدة البيانات المحوّلة باستخدام الإجراء التالي:

  • علي علامه التبويب ادوات قاعده البيانات، في المجموعه نقل البيانات، انقر فوق قاعده بيانات Access. شكل الزر

  • في مربع الحوار مقسم قاعدة البيانات، انقر فوق تقسيم قاعدة البيانات.

    يمكنك إنشاء نسخة احتياطية إذا أردت، ولكن يمكنك أيضًا إعادة إنشاء النسخة باستخدام قاعدة البيانات الأصلية فقط.

  • اكتب اسمًا لقاعدة البيانات الموجودة على الخادم، ثم انقر فوق انقسام.

أعلى الصفحة

الخطوة 3: اتصال قاعدة البيانات الجديدة الموجودة على الكمبيوتر العميل بقاعدة البيانات الأصلية

  1. حذف قاعده البيانات الخادم التي تم انشاؤها اداه "تقسيم قاعده البيانات"، يتم الحذر حتي لا يتم حذف قاعده البيانات الاصليه.

  2. ربط قاعده البيانات الموجوده علي جديده ل# الجداول في قاعده البيانات الاصليه: علي علامه التبويب بيانات خارجيه، في المجموعه استيراد و# ارتباط، انقر فوق اداره الجداول المرتبطه. شكل الزر

  3. انقر فوق تحديد الكل، ثم حدد خانة الاختيار المطالبة دوماً بمكان جديد.

  4. انقر فوق موافق، وقم بالاستعراض للوصول إلى قاعدة البيانات المُنشأة في الإصدار السابق، ثم انقر نقرًا مزدوجًا فوقها.

    إذا تمت العملية بنجاح، سيعرض Access رسالة تبين أن كافة الجداول المرتبطة والمحددة قد تم تحديثها بنجاح.

يمكنك الآن تحسين قاعدة البيانات الجديدة الموجودة على الكمبيوتر العميل لاعتماد ميزات جديدة للمستخدمين الذين لديهم إصدارات أحدث من Access. وسيظل بإمكان المستخدمين الذين لديهم إصدارات سابقة متابعة استخدام قاعدة البيانات المُنشأة في الإصدار السابق.

أعلى الصفحة

استخدام التطبيق الموجود على الكمبيوتر العميل/الخادم في إصدارات متعددة من Access

اذا كان قاعده بيانات Access التطبيق الموجود على الكمبيوتر العميل/الخادم، يمكنك تحويل الاماميه الي تنسيق الملف الجديد. ليس تغييرات ضروريه ل# قاعده بيانات الخادم.

يوضح لك الإجراء التالي كيفية استخدام الأمر حفظ قاعدة البيانات باسم لتحويل قاعدة البيانات الموجودة على الكمبيوتر العميل إلى أي من التنسيقات الثلاثة الحديثة التالية: Access 2000 أو Access2002-2003 أو Access 2007. يحافظ هذا الأمر على قاعدة البيانات الأصلية بتنسيقها الأصلي، وينشئ نسخة بالتنسيق الذي تحدده.

  1. أغلق قاعدة البيانات الموجودة على الكمبيوتر العميل. وإذا كان الملف هو قاعدة بيانات Access متعددة المستخدمين وموجودة على خادم أو في مجلد مشترك، فتأكد من أنها غير مفتوحة من قِبل أي شخص آخر.

  2. قم ببدء تشغيل Access 2010.

  3. ضمن علامة التبويب ملف، انقر فوق فتح.

  4. قم بالاستعراض للوصول إلى موقع قاعدة البيانات الموجودة على الكمبيوتر العميل، ثم انقر نقرًا مزدوجًا فوقها لفتحها.

    في حالة ظهور مربع الحوار تحسين قاعدة بيانات، ليسألك عما إذا كنت تريد تحسين قاعدة البيانات أم لا، انقر فوق لا.

  5. إذا ظهر نموذج عند فتح قاعدة البيانات، قم بإغلاقه.

  6. ضمن علامة التبويب ملف، انقر فوق حفظ قاعدة البيانات باسم.

  7. في مربع الحوار حفظ باسم، اكتب اسمًا لقاعدة البيانات الجديدة.

  8. انقر فوق حفظ.

يمكنك الآن تحسين قاعدة البيانات الجديدة الموجودة على الكمبيوتر العميل لاعتماد ميزات جديدة.

أعلى الصفحة

ملاحظة: إقرار إخلاء المسؤولية للترجمة الآلية: تمت ترجمة هذه المقالة بواسطة نظام كمبيوتر دون تدخل العامل البشري. توفر Microsoft هذه الترجمات الآلية لمساعدة المستخدمين الذين لا يتحدثون الإنجليزية على استخدام منتجات Microsoft، وخدماتها، وتقنياتها والاستمتاع بها. قد تحتوي هذه المقالة على أخطاء في المفردات، أو بناء الجملة، أو القواعد نظرًا لترجمتها آليًا.

هل كانت المعلومات مفيدة؟

Great! Any other feedback?

How can we improve it?

نشكرك على ملاحظاتك!

×