نشر مصنف إلى موقع SharePoint في Excel for Windows

يمكنك نشر مصنف إلى مكتبة Microsoft SharePoint لتمكين الأشخاص الآخرين من عرضه أو تحريره في مستعرض ويب من دون تثبيت Excel على أجهزة الكمبيوتر لديهم. تُعد عملية النشر مماثلة لعملية الحفظ بشكل أساسي، ولكن مع بعض الخيارات المضمّنة التي تسمح لك بالتحكم في العناصر التي تريد تمكين الأشخاص من رؤيتها عندما يفتحون المصنف في المستعرض.

قد يؤدي اعتماد ممارسة حفظ المصنف أو نشره إلى موقع SharePoint مركزي على مستوى المؤسسة بكاملها إلى مساعدتك على ضمان عدم ظهور إصدارات مختلفة قليلاً من المصنف نفسه في كل مؤسستك عند إرساله بالبريد الإلكتروني.

من خلال تعيين بعض خيارات النشر، يمكنك التشديد على أجزاء معينة في مصنفك، مثل المخططات، أو استثناء أجزاء أخرى ومنع ظهورها في المستعرض. على سبيل المثال، يمكنك إظهار مخطط دون إظهار بياناته الأساسية. أو، يمكنك إظهار بعض أوراق العمل فقط لأولئك الأشخاص الذين يحتاجون لرؤيتها، وإخفاء أوراق العمل الأخرى.

توضح لك هذه المقالة كيفيه نشر مصنف من Excel for Windows ولا يغطي توصيل مصنف أو بيانات مصنف بجزء ويب خاص ب Excel Web Access علي صفحه SharePoint.

عندما تنشر مصنفاً إلى موقع SharePoint، يُحفظ المصنف بكامله في SharePoint. بإمكان المستخدم الذي لديه أذونات SharePoint المطلوبة عرض المصنف بكامله واستخدامه سواء في المستعرض أو في برنامج Excel لسطح المكتب.

إذا تم نشر Office Online على SharePoint، فإن عرض البيانات والعمل عليها في المستعرض يمكن أن يشبه إلى حدٍ بعيدٍ العمل على البيانات في برنامج Excel لسطح المكتب. وفي الواقع، بخلاف برنامج Excel لسطح المكتب، بإمكان مستخدمين متعددين تحرير مصنف بشكلٍ متزامن في شبكة المستعرض. عندما تعرض مصنفاً في المستعرض، إذا كان الزر تحرير في Excel Online مرئياً، فهذا سيشير إلى أن Office Online بات جاهزاً للاستخدام.

"تحرير في Excel Online" على القائمة "تحرير مصنف"

تحضير المصنف

قبل نشر مصنف، يمكنك اختيار تحديد فقط أوراق العمل أو العناصر التي تريد ظهورها في المستعرض. تذكر فقط أنه على الرغم من إمكانية تحديد ما يمكن عرضه في هذا الوضع، إلا أن محتويات المصنف تبقى محفوظة بالكامل على خادم SharePoint.

إذا أردت تضمين أوراق عمل كاملة كعنصر بالإضافة إلى عناصر أخرى، مثل المخططات أو جداول PivotTable، فقم بتعريف ورقة العمل بالكامل كنطاق مسمى. حدد ورقة العمل بالكامل، ثم قم بتعريف نطاق مسمى. وسيظهر هذا النطاق المسمى بعد ذلك كعنصر متوفر في مربع الحوار خيارات النشر عندما تكون جاهزًا للنشر.

للسماح للمستخدمين بإدخال قيمة في خلية للعمل مع صيغة في خلية أخرى، عيّن تلك الخلية كاسم معرّف في Excel قبل نشر المصنف. ويمكنك بعد ذلك إضافة هذا الاسم المعرّف كمعلمة ضمن علامة التبويب معلماتفي الجزء خيارات عرض المستعرض.

على سبيل المثال، يعرض المثال التالي الخلية D2، التي تتضمّن الاسم المعرّف "السعر". في المستعرض، يدخل المستخدم القيمة 5.625 في المربع السعر في الجزء معلومات، ثم ينقر فوق تطبيق. فتظهر هذه القيمة في الخلية D2، وتستخدم الصيغة في A2 القيمة الموجودة في D2. تتم إعادة حساب نتيجة الصيغة، وتظهر في الخلية A2: ‏ 1,151.31 ر.س.

يؤدي إدخال معلمة في الجزء إلى استخدامها في الخلية D2

ملاحظة: إذا أنشأت مقسمات طرق عرض لجدول Excel، وقمت بتعريف اسم لنطاق الخلايا التي تحتوي على الجدول ومقسمات طرق العرض، فلن تتمكّن من استخدام مقسمات طرق العرض لتصفية الجدول في المستعرض إذا نشرت النطاق المعرّف. إذا نشرت الجدول أو ورقة العمل بكاملها أو مصنفها، فستعمل مقسمات طرق العرض كما هو متوقع لها أن تعمل في المستعرض.

نشر المصنف

  1. انقر فوق علامة التبويب ملف، وفوق حفظ باسم، ثم فوق SharePoint.

  2. إذا رايت مجلد SharePoint ضمن الحالي أو الأخيرأو الأقدم، فانقر فوق المجلد الذي تريده.

    يظهر مربع الحوار حفظ باسم.


    وبخلاف ذلك ، انقر فوق استعراض، وادخل عنوان ويب لموقع SharePoint ، ثم استعرض وصولا إلى المجلد الذي تريد نشر المصنف فيه.

    انقر فوق مجلد SharePoint أو انقر فوق «استعراض»
  3. لتحديد أوراق عمل أو عناصر فردية لنشرها من المصنف، انقر فوق خيارات عرض المستعرض.

    في مربع الحوار "حفظ باسم"، انقر فوق "خيارات عرض المستعرض"

    سترى علامة التبويب إظهار وعلامة التبويب معلمات.

  4. إذا أردت نشر المصنف بكامله، فانقر فوق حفظ. وإلا، فقم بواحد مما يلي:

    • لإظهار المصنف بالكامل في المستعرض، على علامة التبويب إظهار، حدد المصنف بأكمله في مربع القائمة.

    • لإظهار أوراق عمل معينة فقط في المستعرض، على علامة التبويب إظهار، حدد الأوراق في مربع القائمة، ثم قم بإلغاء تحديد المربعات الخاصة بالأوراق التي تريد إظهارها في المستعرض.

      بشكل افتراضي، تكون جميع الأوراق محددة. لجعل كافة الأوراق قابلة للعرض مرة أخرى سريعاً بعد إلغاء تحديد بعض المربعات، حدد خانة الاختيار كافة الأوراق.

    • لإظهار عناصر معينة فقط في المستعرض (كالنطاقات المسماة، أو المخططات، أو الجداول أو جداول PivotTable)، على علامة التبويب إظهار، حدد العناصر الموجودة في المصنف في مربع القائمة، ثم حدد المربعات الخاصة بالعناصر التي تريد إظهارها.

    • على علامة التبويب معلمات، أضف أي أسماء معرّفة تريد استخدامها لتعيين الخلايا التي يمكن تحريرها عندما يعرض المستخدمون المصنف في المستعرض. ثم انقر فوق موافق.

  5. احفظ المصنف.

ملاحظات: 

  • إذا حددت عناصر لها الاسم نفسه (كمخطط وجدول البيانات الأساسي فيه)، فسيتوفر عنصر واحد فقط من هذه العناصر في المستعرض. لعرض جميع العناصر، يجب التأكد من إعطاء اسم فريد لكل عنصر في المصنف.

  • يمكنك إعادة تسمية الجداول ضمن علامة التبويب تصميم في المجموعة خصائص، وإعادة تسمية PivotTables ضمن علامة التبويب خيارات في المجموعة PivotTable، وإعادة تسمية المخططات أو PivotCharts في علامة التبويب تخطيط في المجموعة خصائص. عاود تسمية العناصر المكررة الأخرى، مثل النطاقات المسماة، على علامة التبويب صيغ في المجموعة اسم معرّف.

إذا تم نشر Office Online على SharePoint، فإن عرض البيانات والعمل عليها في المستعرض يمكن أن يشبه إلى حدٍ بعيدٍ العمل على البيانات في برنامج Excel لسطح المكتب. وفي الواقع، بخلاف برنامج Excel لسطح المكتب، بإمكان مستخدمين متعددين تحرير مصنف بشكلٍ متزامن في شبكة المستعرض. عندما تعرض مصنفاً في المستعرض، إذا كان الزر تحرير في Excel Online مرئياً، فهذا سيشير إلى أن Office Online بات جاهزاً للاستخدام.

"تحرير في Excel Online" على القائمة "تحرير مصنف"

لمزيد من المعلومات ، راجع المقالة أوجه الاختلاف بين استخدام مصنف في excel و Excel Services.

تحضير المصنف

قبل نشر مصنف، يمكنك اختيار تحديد فقط أوراق العمل أو العناصر التي تريد ظهورها في المستعرض. تذكر فقط أنه على الرغم من إمكانية تحديد ما يمكن عرضه في هذا الوضع، إلا أن محتويات المصنف تبقى محفوظة بالكامل على خادم SharePoint.

إذا أردت تضمين أوراق عمل كاملة كعنصر بالإضافة إلى عناصر أخرى، مثل المخططات أو جداول PivotTable، فقم بتعريف ورقة العمل بالكامل كنطاق مسمى. حدد ورقة العمل بالكامل، ثم قم بتعريف نطاق مسمى. وسيظهر هذا النطاق المسمى بعد ذلك كعنصر متوفر في مربع الحوار خيارات النشر عندما تكون جاهزًا للنشر.

للسماح للمستخدمين بإدخال قيمة في خلية للعمل مع صيغة في خلية أخرى، عيّن تلك الخلية كاسم معرّف في Excel قبل نشر المصنف. ويمكنك بعد ذلك إضافة هذا الاسم المعرّف كمعلمة ضمن علامة التبويب معلماتفي الجزء خيارات عرض المستعرض.

على سبيل المثال، يعرض المثال التالي الخلية D2، التي تتضمّن الاسم المعرّف "السعر". في المستعرض ، يقوم مستخدم بإدخال قيمه ، 5.625 ، في المربع في جزء المعلمات والنقر فوق تطبيق. فتظهر هذه القيمة في الخلية D2، وتستخدم الصيغة في A2 القيمة الموجودة في D2. تتم إعادة حساب نتيجة الصيغة، وتظهر في الخلية A2: ‏ 1,151.31 ر.س.

راجع تعليمات Excel للحصول علي معلومات حول كيفيه تحديد النطاقات.

يؤدي إدخال معلمة في الجزء إلى استخدامها في الخلية D2

ملاحظة: إذا أنشأت مقسمات طرق عرض لجدول Excel، وقمت بتعريف اسم لنطاق الخلايا التي تحتوي على الجدول ومقسمات طرق العرض، فلن تتمكّن من استخدام مقسمات طرق العرض لتصفية الجدول في المستعرض إذا نشرت النطاق المعرّف. إذا نشرت الجدول أو ورقة العمل بكاملها أو مصنفها، فستعمل مقسمات طرق العرض كما هو متوقع لها أن تعمل في المستعرض.

نشر المصنف

  1. انقر فوق ملف > حفظ باسم >SharePoint.

  2. إذا رايت مجلد SharePoint ضمنالمجلد الحالي أو المجلدات الاخيره، فانقر فوق المجلد الذي تريده. وبخلاف ذلك ، انقر فوق استعراض وادخل عنوان ويب لموقع SharePoint. ثم استعرض وصولا إلى المجلد الذي تريد نشر المصنف فيه. يظهر مربع الحوار حفظ باسم.

  3. لتحديد أوراق عمل أو عناصر فردية لنشرها من المصنف، انقر فوق خيارات عرض المستعرض. ستري علامة التبويب إظهار وعلامة التبويب معلمات . إذا أردت نشر المصنف بكامله، فانقر فوق حفظ. وإلا، فقم بواحد مما يلي:

    • لإظهار المصنف بالكامل في المستعرض، على علامة التبويب إظهار، حدد المصنف بأكمله في مربع القائمة.

    • لإظهار أوراق عمل معينه فقط في المستعرض ، علي علامة التبويب إظهار ، حدد الأوراق في مربع القائمة ، ثم قم بإلغاء تحديد المربعات الخاصة بالأوراق التي لا تريد إخفاءها في المستعرض.

      بشكل افتراضي، تكون جميع الأوراق محددة. لتمكين عرض كل الأوراق مره أخرى بسرعة بعد إلغاء تحديد بعض المربعات ، حدد خانه الاختيار كافة الأوراق .

    • لإظهار عناصر معينه فقط في المستعرض (مثل النطاقات المسمية أو المخططات أو الجداول أو PivotTables) ، علي علامة التبويب إظهار ، حدد العناصر الموجودة في المصنف في مربع القائمة ، ثم اختر المربعات الخاصة بالعناصر التي تريد عرضها.

    • علي علامة التبويب المعلمات ، قم باضافه اي أسماء معرفه تريد استخدامها لتحديد الخلايا التي يمكن تحريرها عند قيام المستخدمين بعرض المصنف في المستعرض. ثم انقر فوق موافق لإغلاق مربع الحوار.

  4. احفظ المصنف.

ملاحظات: 

  • إذا حددت عناصر لها الاسم نفسه (كمخطط وجدول البيانات الأساسي فيه)، فسيتوفر عنصر واحد فقط من هذه العناصر في المستعرض. لعرض جميع العناصر، يجب التأكد من إعطاء اسم فريد لكل عنصر في المصنف.

  • إذا حددت عناصر لها الاسم نفسه (كمخطط وجدول البيانات الأساسي فيه)، فسيتوفر عنصر واحد فقط من هذه العناصر في المستعرض. لعرض جميع العناصر، يجب التأكد من إعطاء اسم فريد لكل عنصر في المصنف.

  • يمكنك إعادة تسمية الجداول ضمن علامة التبويب تصميم في المجموعة خصائص، وإعادة تسمية PivotTables ضمن علامة التبويب خيارات في المجموعة PivotTable، وإعادة تسمية المخططات أو PivotCharts في علامة التبويب تخطيط في المجموعة خصائص. عاود تسمية العناصر المكررة الأخرى، مثل النطاقات المسماة، على علامة التبويب صيغ في المجموعة اسم معرّف.

  • يمكنك إعادة تسمية الجداول ضمن علامة التبويب تصميم في المجموعة خصائص، وإعادة تسمية PivotTables ضمن علامة التبويب خيارات في المجموعة PivotTable، وإعادة تسمية المخططات أو PivotCharts في علامة التبويب تخطيط في المجموعة خصائص. عاود تسمية العناصر المكررة الأخرى، مثل النطاقات المسماة، على علامة التبويب صيغ في المجموعة اسم معرّف.

لمزيد من المعلومات حول أجزاء ويب الخاصة ب Excel Web Access ، راجع المقالة عرض مصنف في جزء ويب الخاص ب Excel Web access.

عند نشر مصنف إلى خادم SharePoint ، يتم حفظ محتويات المصنف بالبالكامل في الخادم ويمكن عرضه والعمل معه إذا فتحت المصنف في برنامج Excel لسطح المكتب. إذا تم نشر Office Web Apps علي خادم SharePoint ، فمن الممكن ان يكون عرض البيانات واستخدامها في مستعرض ويب أكثر سهوله مثل استخدام البيانات في برنامج Excel لسطح المكتب. في الواقع ، يمكن اجراء تحرير متزامن لمصنف في شبكه المستعرض عند نشر Office Web Apps. عند عرض مصنف في المستعرض ، إذا كان الزر تحرير في المستعرض مرئيا ، فهذا يعني توفر Office Web Apps.

الزر "التحرير في المستعرض"

لمزيد من المعلومات ، راجع المقالة أوجه الاختلاف بين استخدام مصنف في excel و Excel Services.

تحضير المصنف

قبل نشر المصنف ، تتوفر لديك الفرصة (في مربع الحوار خيارات النشر ) لتحديد أوراق العمل أو العناصر التي تريد رؤيتها في المستعرض عند عدم تمكين التحرير بالنقر فوق الزر تحرير في المستعرض . ما عليك سوي تذكر انه يمكنك تحديد العناصر القابلة للعرض في هذا الوضع ، ما زالت المحتويات الكاملة للمصنف محفوظه في SharePoint server.

إذا أردت تضمين أوراق عمل كاملة كعنصر بالإضافة إلى عناصر أخرى، مثل المخططات أو جداول PivotTable، فقم بتعريف ورقة العمل بالكامل كنطاق مسمى. حدد ورقة العمل بالكامل، ثم قم بتعريف نطاق مسمى. وسيظهر هذا النطاق المسمى بعد ذلك كعنصر متوفر في مربع الحوار خيارات النشر عندما تكون جاهزًا للنشر.

إذا كنت تريد السماح للمستخدمين بتوفير معلمه لصيغه عند عرض ورقه عمل في مستعرض ، فقم بتعيين الخلية كاسم معرف. يمكنك بعد ذلك أضافه الاسم المعرف كمعلمه في علامة التبويب معلمات في مربع الحوار خيارات النشر .

علي سبيل المثال ، في الرسم التالي الذي يعرض ورقه عمل في المستعرض ، تحتوي الخلية D2 علي معدل الاسم المعرف. في المستعرض ، قام مستخدم بإدخال قيمه ، 5.625 ، في المربع في جزء المعلمات ، ثم النقر فوق تطبيق. فتظهر هذه القيمة في الخلية D2، وتستخدم الصيغة في A2 القيمة الموجودة في D2. تتم إعادة حساب نتيجة الصيغة، وتظهر في الخلية A2: ‏ 1,151.31 ر.س.

استخدام معلمة في المستعرض

راجع تعليمات Excel للحصول علي معلومات حول كيفيه تحديد النطاقات.

نشر المصنف

  1. انقر فوق علامة التبويب ملف ثم فوق حفظ وإرسال.

  2. انقر فوق حفظ إلى SharePoint.
    ملاحظه    إذا كان الأمر حفظ إلى SharePoint غير متوفر ، فلا يزال بإمكانك حفظ المصنف إلى موقع SharePoint باستخدام الأمر " حفظ باسم ". لن يتوفر مربع الحوار " خيارات النشر ". يمكنك أيضا تحميل المصنف من مكتبه SharePoint مباشره. يمكن للمستخدمين عرض محتويات المصنف وتحريرها في المستعرض بالانتقال مباشره إلى الموقع حيث تم حفظ المصنف.

    الأمر "حفظ باسم"

  3. إذا أردت تحديد أوراق عمل أو عناصر فرديه لنشرها في المصنف ، فانقر فوق الزر خيارات النشر . وبخلاف ذلك ، إذا كنت تريد نشر المصنف بأكمله ، فانتقل مباشره إلى الخطوة 4.
    علي علامة التبويب إظهار ، قم بما يلي:

    • لإظهار المصنف بأكمله في المستعرض ، حدد المصنف بأكمله في مربع القائمة.

    • لإظهار أوراق عمل معينه فقط في المستعرض ، حدد الأوراق في مربع القائمة ، ثم قم بإلغاء تحديد خانات الاختيار الخاصة بالأوراق التي لا تريد جعلها مرئية.
      ملاحظه    بشكل افتراضي ، يتم تحديد كل الأوراق. لتمكين عرض كل الأوراق مره أخرى بسرعة بعد إلغاء تحديد بعض خانات الاختيار ، يمكنك تحديد خانه الاختيار كافة الأوراق .

    • لإظهار عناصر معينه فقط في المستعرض (مثل النطاقات المسمية أو المخططات أو الجداول أو PivotTables) ، حدد العناصر الموجودة في المصنف في مربع القائمة ، ثم حدد خانات الاختيار الخاصة بالعناصر التي تريد عرضها.
      ملاحظه إذا قمت بتحديد العناصر التي لها نفس الاسم (علي سبيل المثال ، المخطط وجدول البيانات الأساسي) ، سيتوفر واحد فقط من هذه العناصر في المستعرض. لإظهار كافة العناصر ، يجب التاكد من ان كل عنصر في المصنف يحمل اسما فريدا. يمكنك إعادة تسمية الجداول ضمن علامة التبويب تصميم في المجموعة خصائص، وإعادة تسمية PivotTables ضمن علامة التبويب خيارات في المجموعة PivotTable، وإعادة تسمية المخططات أو PivotCharts في علامة التبويب تخطيط في المجموعة خصائص. يمكن أعاده تسميه العناصر المكررة ، مثل النطاقات المسمية ، علي علامة التبويب صيغ في المجموعة الأسماء المعرفة.
      تحديد أوراق عمل أو عناصر

    • علي علامة التبويب المعلمات ، قم باضافه اي أسماء معرفه تريد استخدامها لتحديد الخلايا التي يمكن تحريرها عند قيام المستخدمين بعرض المصنف في المستعرض. ثم انقر فوق موافق لإغلاق مربع الحوار.
      تعيين معلمات

  4. اختر موقعا لنشر المصنف فيه.
    قد يتم حفظ مواقع الخادم بالفعل ضمن الموقع الحاليأو المواقع الاخيره أو المواقع التي يمكنك الاختيار من بينها. إذا لم تكن هناك هذه المواقع ، أو تريد الحفظ في موقع جديد ، ضمن المواقع، انقر نقرا مزدوجا فوق الاستعراض بحثا عن موقع.

  5. في مربع الحوار حفظ باسم ، ادخل عنوان ويب لموقع SharePoint ، ثم استعرض وصولا إلى الموقع أو المكتبة التي تريد حفظ المصنف فيها.

  6. إذا لم تقم بتحديد أوراق العمل أو العناصر الفردية أو تعيين معلمات ، فانقر فوق الزر خيارات النشر .

  7. في المربع اسم الملف ، اقبل الاسم المقترح للمصنف ، أو اكتب اسما جديدا إذا أردت ذلك.

  8. لعرض محتويات المصنف في نافذه مستعرض مباشره بعد اكتمال عمليه النشر ، تاكد من تحديد خانه الاختيار فتح بواسطة Excel في المستعرض .

  9. انقر فوق حفظ.

ملاحظة:  وقد تمت ترجمة هذه الصفحة آلياً وقد تحتوي على أخطاء نحوية أو أخطاء تتعلق بالدقة. إن هدفنا هو أن يكون هذا المحتوى مفيداً لك. هل يمكنك إعلامنا إذا ما كانت المعلومات مفيدة؟ فيما يلي المقالة باللغة الإنجليزية لتكون مرجعاً لك.

تعزيز مهارات Office
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×