معاينة قالب النموذج

هام: تمت ترجمة هذه المقالة ترجمة آلية، راجع إقرار إخلاء المسؤولية. يرجى الاطلاع على النسخة الإنجليزية من هذه المقالة. هنا للرجوع إليها.

ل# المساعده علي التاكد من ان النماذج التي تستند الي قالب النموذج الخاص بك سيعمل كما هو متوقع عند تعبئه المستخدمون مره اخري، يمكنك معاينه قالب النموذج الخاص بك ل# اختبار مظهره و# الوظائف. يمكنك معاينه قالب النموذج الخاص بك عندما تقوم ب# تصميم ل# اختبار عنصر تحكم معين او الاداء الوظيفي. انها فكره جيده ل# معاينه قالب النموذج الخاص بك قبل نشرها.

في هذا المقال

نظرة عامة

معاينة قالب النموذج

معاينة قالب نموذج ذو ثقة كاملة أو مع مستوى أمان مقيد

معاينة قالب نموذج مع مستوى الأمان"مجال"

معاينة قالب النموذج مع البيانات النموذجية

نظرة عامة

عندما تقوم ب# تصميم قالب نموذج، يمكنك استخدام ميزه معاينه ل# اختبار وظيفه و# مظهره قالب النموذج الخاص بك. معاينه و# اختبار قالب النموذج الخاص بك يسمح لك ب# رؤيه و# العمل ب# استخدام قالب النموذج الخاص بك من منظور الخاص ب# المستخدم. عند النقر فوق معاينه علي شريط الادوات قياسي، يفتح نموذج يستند الي قالب النموذج الخاص بك في نافذه منفصله في معاينه. يمكنك ثم اختبار قالب النموذج الخاص بك ب# ادخال البيانات في عناصر التحكم ل# التحقق من ميزات متنوعه، مثل تنسيق النص، تنسيق شرطي و# القواعد، و# الصيغ و التحقق من صحة البيانات. اذا كنت تستخدم مستويات امان او قمت ب# اضافه ادوار المستخدم ل# قالب النموذج الخاص بك، يمكنك ايضا تعيين هذه الميزات عند معاينه قالب النموذج الخاص بك. استخدام نافذه معاينه يسمح لك ب# تحديد الاخطاء عند تصميم قالب النموذج الخاص بك و# قم ب# سرعه ب# التبديل الي نافذه التصميم، حيث يمكنك تصحيح عليها. ل# المساعده في تحديد الاطار الذي كنت تعمل في معاينه او يظهر التصميم في شريط عنوان كل نافذه.

اذا كنت تستخدم متناسقه تعيين البيانات ل# اختبار قالب النموذج الخاص بك، يمكنك تحسين الفعاليه و# دقه الاختبارات الخاصه بك ب# استخدام نموذج ب# استخدام بيانات نموذجيه بدلا من ادخال البيانات يدويا في كل مره يتم معاينه قالب النموذج. بيانات نموذجيه يتم نص العنصر النائب الذي يظهر في عناصر التحكم علي النموذج الخاص بك و# يوفر مثال حول طريقه ظهور النص في عنصر التحكم عند مستخدم تعبئته. يمكن ان يشاهد نموذج البيانات فقط عند معاينه قالب النموذج.

اعلي الصفحه

معاينة قالب النموذج

  1. ل# اختبار دور مستخدم علي قالب النموذج الخاص بك، حدد دور المستخدم الذي تريد اختباره قالب النموذج ب# استخدام.

    كيف؟

    1. من القائمة أدوات، انقر فوق خيارات النموذج.

    2. في القائمة الفئة، انقر فوق المعاينة.

    3. في القائمه معاينه ب# اسم، ضمن دور المستخدم، انقر فوق دور المستخدم الذي تريد اختباره.

  2. لاختبار التغييرات، انقر فوق معاينة على شريط الأدوات قياسي، أو اضغط على CTRL+SHIFT+B.

أعلى الصفحة

معاينة قالب نموذج ذو ثقة كاملة أو مع مستوى أمان مقيد

  1. من القائمة أدوات، انقر فوق خيارات النموذج.

  2. في القائمة الفئة, انقر فوق الأمان والثقة.

  3. أسفل مستوى الأمان, قم بإلغاء خانة الاختيار تحديد مستوى الأمان تلقائياً (مستحسن), ثم انقر فوق مستوى الأمان الذي تريد تطبيقه على قالب النموذج.

  4. انقر فوق موافق.

  5. لاختبار التغييرات، انقر فوق معاينة على شريط الأدوات قياسي، أو اضغط على CTRL+SHIFT+B.

أعلى الصفحة

معاينة قالب نموذج مع مستوى الأمان"مجال"

  1. من القائمة أدوات، انقر فوق خيارات النموذج.

  2. من القائمة فئة, انقر فوق الأمان والثقة.

  3. أسفل مستوى الأمان, قم بإلغاء خانة الاختيار تحديد مستوى الأمان تلقائياً (مستحسن), ثم انقر فوق مجال (يستطيع النموذج الوصول إلى المحتوى من المجال الذي يقع فيه).

  4. في القائمة الفئة، انقر فوق المعاينة.

  5. في المربع مجال, اكتب اسم المجال في المكان الذي سيتم نشر قالب النموذج فيه.

  6. انقر فوق موافق.

  7. لاختبار التغييرات، انقر فوق معاينة على شريط الأدوات قياسي، أو اضغط على CTRL+SHIFT+B.

أعلى الصفحة

معاينة قالب نموذج مع البيانات النموذجية

اذا كنت تخطط ل# اختبار قالب نموذج شكل متكرر، يمكنك توفير الوقت ب# انشاء نموذج يستند الي قالب النموذج الذي يحتوي علي نموذج البيانات و# تكوين قالب النموذج الخاص بك ب# استخدام البيانات النموذجيه هذه كل مره ثم يمكنك معاينه قالب النموذج الخاص بك. ب# استخدام نموذج ب# استخدام بيانات نموذجيه، لا يجب ادخال البيانات نفسها في كل مره تقوم فيها ب# معاينه قالب النموذج.

  1. انقر فوق معاينه علي شريط الادوات قياسي، او اضغط علي CTRL + SHIFT + B.

  2. اكتب البيانات النموذجية في عناصر التحكم المناسبة.

  3. من القائمة ملف انقر فوق حفظ.

  4. في مربع الحوار حفظ باسم استعرض بحثاً عن الموقع الذي تريد حفظ النموذج بالبيانات النموذجية فيه, ثم انقر فوق حفظ.

  5. من شريط الأدوات قياسي، انقر فوق إغلاق المعاينة.

  6. من القائمة أدوات، انقر فوق خيارات النموذج.

  7. في القائمة الفئة، انقر فوق المعاينة.

  8. في المربع موقع الملف أسفل بيانات نموذجية, انقر فوق استعراض.

  9. في مربع الحوار استعراض , استعرض بحثاً عن الموقع الذي قمت بحفظ نموذح البيانات النموذجية عليه, انقر فوق النموذج, ثم انقر فوق فتح.

  10. انقر فوق موافق.

  11. لاختبار التغييرات، انقر فوق معاينة على شريط الأدوات قياسي، أو اضغط على CTRL+SHIFT+B.

أعلى الصفحة

ملاحظة: إقرار إخلاء المسؤولية للترجمة الآلية: تمت ترجمة هذه المقالة بواسطة نظام كمبيوتر دون تدخل العامل البشري. توفر Microsoft هذه الترجمات الآلية لمساعدة المستخدمين الذين لا يتحدثون الإنجليزية على استخدام منتجات Microsoft، وخدماتها، وتقنياتها والاستمتاع بها. قد تحتوي هذه المقالة على أخطاء في المفردات، أو بناء الجملة، أو القواعد نظرًا لترجمتها آليًا.

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×