سحب ملف من مكتبة SharePoint أو إيداعه

هام: تمت ترجمة هذه المقالة ترجمة آلية، راجع إقرار إخلاء المسؤولية. يرجى الاطلاع على النسخة الإنجليزية من هذه المقالة. هنا للرجوع إليها.

عندما تقوم بسحب ملف من مكتبة موجودة على موقع Microsoft Windows SharePoint Servicesلفحصه، يتعين عليك التأكد من عدم قدرة الآخرين على إحداث تغييرات في الملف أثناء قيامك بتحريره. أثناء فحص الملف يمكنك تحريره وإغلاقه وإعادة فتحه، بل واستخدامه على القرص الصلب الخاص بك. لا يستطيع الآخرون إحداث أية تغييرات على الملف أو الاطلاع على التغييرات حتى تقوم بإيداع الملف مرة ثانية.

في هذا المقال

نظره عامه

سحب ملف من مكتبه SharePoint

ايداع ملف الي مكتبه SharePoint

تغيير الموقع حيث يمكنك العمل علي الملفات المسحوبه

نظرة عامة

يساعدك سحب الملفات قبل العمل فيها على تجنب التعارضات والتداخل عندما يعمل أكثر من فرد على نفس مجموعة الملفات. لا يمكنك إجراء أية تغييرات على أي ملف إلا في حالة سحبه لك. يمكنك سحب أي ملف على موقع SharePoint الذي تمتلك إذناً له، كما يمكنك سحب ملفات مباشرة من برامج نظام ‎2007 Microsoft Office Word و Excel و PowerPoint و Visio.

عندما تقوم بإيداع ملف، يمكنك كتابة تعليقات حول التغييرات التي أجريتها على الملف. ويتيح ذلك للأفراد فهم التغييرات التي تمت داخل الملف من إصدار لآخر. وتتضح فائدة هذا الأمر على وجه الخصوص عند عمل أكثر من فرد في ملف واحد أفي حالة ما إذا كان الملف سيمر بأكثر من مراجعة. إذا كانت المكتبة الخاصة بك تقوم بتعقب إصدارات الملفات، تصبح هذه التعليقات جزءاً من تاريخ الإصدار الخاص بالملف، والذي يساعد الأفراد في عرض إصدار سابق أو إعادة تخزينه عند الحاجة.

ربما تطلب منك مؤسستك سحب ملف قبل أن تقوم بتحريره. عندئذ، يجب عليك إيداع ملف جديد عندما تقوم بإنشائه في أية مكتبة أو تحمليه على أية مكتبة.

لا تكون التغييرات التي تقوم بها مرئية للآخرين أثناء سحبك للملف حتى تقوم بإيداعه مرة ثانية. قد يكون هناك بعض المواقف التي تقوم فيها بإيداع الملف ليتمكن الآخرين من مشاهدة تغييراتك، ولكنك بحاجة إلى الاحتفاظ بالملف مسحوباً لتتمكن من مواصلة العمل فيه. عندما تقوم بإيداع ملف، يمكنك اختيار متابعة العمل فيه إلا إذا كانت المكتبة الخاصة بك تقوم بتعقب الإصدارات الرئيسية والثانوية وتقوم أنت بعملية الإيداع في إصدار رئيسي. يتغير الإصدار الرئيسي بشكل كبير نظراً للإصدار الرئيسي السابق، بينما يتغير الإصدار الثانوي نوعاً ما نظراً للإصدار السابق. على سبيل المثال، ربما يشتمل الإصدار الرئيسي على جزء من محتوى جديد، بينما قد يحتوي الإصدار الثانوي على تصحيحات للأخطاء الإملائية فقط.

عندما تقوم باستخدام برنامج Office لسحب ملف ضمن موقع Windows SharePoint Services 3.0 ، يتم تخزين الملف وفقاً للوضع الافتراضي على القرص الصلب الخاص بك في مجلد المسودّات الموجود في مجلد المستندات . يمكنك تغيير ذلك المكان إلى مكان آخر على القرص الصلب الخاص بك أو الشبكة، أو يمكنك تحديد الملفات المسحوبة المخزنة على خادم ويب أثناء العمل فيها. قد يقوم مسؤولك بتحديد مكان مخصص أو يقوم بمنع تغيير المكان استناداً على متطلبات مؤسستك.

عندما تقوم بسحب ملف من موقع Microsoft Windows SharePoint Services 2.0، يتم تخزين الملف على الخادم أثناء عملك فيه، لكن يجب عليك مواصلة إيداع الملف قبل أن يتمكن الآخرون من مشاهدة تغييراتك. في معظم الحالات، عندما تقوم بسحب ملف من موقع Windows SharePoint Services 3.0 ، فإنك تتلقى رسالة تخبرك بمكان تخزين الملف أثناء عملية سحبه. لكن لاحظ انك لن تتلقى مثل هذه الرسالة عند سحب الملف من Microsoft Windows SharePoint Services 2.0.

عند سحب مستند، يقوم جزء المهام إدارة المستندات في برنامج Office الخاص بك بتوفير أمرً لإيداع الملف ثانية.

من الممكن أن تتم مطالبتك في حالة تعقب كلاً من الإصدارين الرئيسي والثانوي أن تقوم باختيار إيداع إصدار رئيسي أو إصدار ثانوي.

اعلي الصفحه

سحب ملف من مكتبة SharePoint

قم بهذا الإجراء لسحب ملف مفتوح بالفعل في برنامج Office. كما يمكنك سحب ملف من المكتبة على موقع SharePoint.

قم بالإجراءات التالية في برامج إصدار Office 2007 :

Word أو Excel أو PowerPoint

  1. انقر فوق زر Microsoft Office صورة زر Office ، و# انقر فوق خادم، و# من ثم انقر فوق سحب.

    يتم فتح مستندات Word غالباً في طريقة العرض "قراءة شاشة كاملة" في الوضع الافتراضي. في هذه الحالة، قد تضطر للنقر فوق طباعة تخطيط ، للتبديل إلى طريقة العرض "طباعة تخطيط" قبل إتمام هذه الخطوة.

  2. إذا ظهرت رسالة تصف مكان تخزين الملف أثناء عملية السحب، فانقر فوق موافق.

    تظهر هذه الرسالة في معظم الحالات إذا كنت تقوم بسحب ملف من موقع Windows SharePoint Services 3.0 .

    تلميح: يمكنك تغيير الخيارات الخاصة باستخدام الملفات المسحوبة في الرسالة التي تصف مكان تخزين الملف الخاص بك أثناء عملية السحب.

Visio

  1. ضمن القائمة ملف ، انقر فوق سحب.

  2. إذا ظهرت رسالة تصف مكان تخزين الملف أثناء عملية السحب، فانقر فوق موافق.

    تظهر هذه الرسالة في معظم الحالات إذا كنت تقوم بسحب ملف من موقع Windows SharePoint Services 3.0 .

    تلميح: يمكنك تغيير الخيارات الخاصة باستخدام الملفات المسحوبة في الرسالة التي تصف مكان تخزين الملف الخاص بك أثناء عملية السحب.

اعلي الصفحه

إيداع ملف في مكتبة SharePoint

قم بهذا الإجراء لإيداع ملف أثناء فتحه في برنامج Office. كما يمكنك إيداع ملف من المكتبة على موقع SharePoint.

قم بالإجراءات التالية في برامج إصدار Office 2007 :

Word أو Excel أو PowerPoint

  1. انقر فوق زر Microsoft Office صورة زر Office ، و# انقر فوق الخادم و# من ثم انقر فوق ايداع.

    يتم فتح مستندات Word غالباً في طريقة العرض "قراءة شاشة كاملة" بشكل افتراضي. في هذه الحالة، قد تضطر للنقر فوق طباعة تخطيط ، للتبديل إلى طريقة العرض "طباعة تخطيط" قبل إتمام هذه الخطوة.

  2. عندما يُطلب منك إيداع إصدار رئيسي أو ثانوي، انقر فوق إصدار ثانوي إذا كنت تقوم بتغيير ثانوي أو انقر فوق إصدار رئيسي إذا كنت تقوم بتغيير رئيسي.

  3. في المربع تعليقات الإصدار ، قم بكتابة أية تعليقات تريد القيام بها حول التغييرات الخاصة بك.

    تظهر هذه التعليقات كجزء من تاريخ الإصدار الخاص بالملف في مكتبة SharePoint، والذي يمكن أن يكون مفيداً إذا احتجت أنت أو شخص آخر إلى القيام بعرض معلومات عن الإصدارات السابقة.

  4. إذا توفرت خانة الاختيار الاحتفاظ بالمستندات المسحوبة بعد الإيداع في هذا الإصدار ، يمكنك تحديدها إذا كنت تخطط لمواصلة العمل في هذا الملف.

    يتوفر هذا الخيار إذا كانت المكتبة الخاصة بك لا تقوم بتعقب الإصدارات، أو تتعقب كافة الإصدارات بنفس الطريقة أو إذا كنت تقوم بإيداع إصدار ثانوي. لا يتوفر هذا الخيار إذا كنت تقوم بإيداع إصدار رئيسي أو تقوم بنشر ملف.

Visio

  1. ضمن القائمة ملف ، انقر فوق إيداع.

  2. عندما يطلب منك إيداع إصدار رئيسي أو ثانوي، انقر فوق إصدار ثانوي إذا كنت تقوم بتغيير ثانوي أو انقر فوق إصدار رئيسي إذا كنت تقوم بتغيير رئيسي.

  3. في المربع تعليقات الإصدار ، قم بكتابة أية تعليقات تريد القيام بها حول التغييرات الخاصة بك.

    تظهر هذه التعليقات كجزء من تاريخ الإصدار الخاص بالملف في مكتبة SharePoint، والذي يمكن أن يكون مفيداً إذا احتجت أنت أو شخص آخر إلى القيام بعرض معلومات عن الإصدارات السابقة.

  4. إذا توفرت خانة الاختيار الاحتفاظ بالمستندات المسحوبة بعد الإيداع في هذا الإصدار ، يمكنك تحديدها إذا كنت تخطط لمواصلة العمل في هذا الملف.

    يتوفر هذا الخيار إذا كانت المكتبة الخاصة بك لا تقوم بتعقب الإصدارات أو تتعقب كافة الإصدارات بنفس الطريقة أو إذا كنت تقوم بإيداع إصدار ثانوي. لا يتوفر هذا الخيار إذا كنت تقوم بإيداع إصدار رئيسي أو تقوم بنشر ملف.

اعلي الصفحه

تغييرالموقع الذي تعمل فيه على الملفات المسحوبة

يقوم هذا الإعداد بتغيير الموقع الذي تعمل فيه على الملف التالي الذي قمت بسحبه. إذا كنت تعمل في ملفات مسحوبة، فلا يقوم هذا الإجراء بتغيير موقعه.

قم بالإجراءات التالية في برامج إصدار Office 2007 :

Word أو Excel أو PowerPoint

  1. انقر فوق زر Microsoft Office صورة زر Office ، و# من ثم انقر فوق خيارات ل# البرنامج: خيارات Word، او خيارات Excel، PowerPoint.

  2. في مربع الحوار الذي يظهر، انقر فوق حفظ.

  3. في المقطع خيارات التحرير بدون اتصال الخاصة بملفات خادم إدارة المستندات قم بأحد الإجراءات التالية:

    • قم بالإجراء التالي للعمل مع الملفات المسحوبة على القرص الصلب الخاص بك أو في مكان على الشبكة:

      1. ضمن حفظ الملفات المسحوبة إلى، انقر فوق موقع مسودّات الخادم على هذا الجهاز.

      2. في المربع موقع مسودّات الخادم ، قم بكتابة الموقع على الجهاز الخاص بك حيث تريد استخدام الملفات المسحوبة، أو انقر فوق استعراض للعثور على الموقع.

    • لاستخدام الملفات المسحوبة على خادم ويب، ضمن حفظ الملفات المسحوبة إلى، انقر فوق خادم ويب.

      عند اختيارك لهذا الخيار، فإنك تقوم باستخدام الملفات المسحوبة الخاصة بك على خادم ويب أو على الموقع الذي توجد عليه الملفات المخزنة. لا يمكنك تخصيص الموقع المحدد.

  4. انقر فوق موافق.

Visio

  1. ضمن القائمة أدوات ، انقر فوق خيارات.

  2. في مربع الحوار خيارات ، انقر فوق علامة التبويب عام ، ثم انقر فوق خيارات الخدمة .

  3. في مربع الحوار الذي يظهر، انقر فوق خيارات التحرير دون اتصال.

  4. في المقطع خيارات التحرير دون اتصال لملفات خادم إدارة المستندات قم بأحد الإجراءات التالية:

    • قم بالإجراء التالي لاستخدام الملفات المسحوبة على القرص الصلب الخاص بك أو في مكان على الشبكة:

      1. للعمل في الملفات المسحوبة على جهازك، ضمن حفظ الملفات المسحوبة إلى، انقر فوق موقع مسودّات الخادم على هذا الجهاز.

      2. ضمن موقع مسودّات الخادم، قم بكتابة الموقع على جهازك حيث تريد استخدام الملفات المسحوبة، أو انقر فوق استعراض للعثور على الموقع.

    • للعمل في الملفات المسحوبة على موقع خادم، ضمن حفظ الملفات المسحوبة إلى، انقر فوق خادم ويب.

      عند اختيارك لهذا الخيار، فإنك تقوم باستخدام الملفات المسحوبة الخاصة بك على خادم ويب أو على الموقع الذي توجد عليه ملفات الملفات المخزنة. لا يمكنك تخصيص الموقع المحدد.

  5. انقر فوق موافق.

اعلي الصفحه

ملاحظة: إقرار إخلاء المسؤولية للترجمة الآلية: تمت ترجمة هذه المقالة بواسطة نظام كمبيوتر دون تدخل العامل البشري. توفر Microsoft هذه الترجمات الآلية لمساعدة المستخدمين الذين لا يتحدثون الإنجليزية على استخدام منتجات Microsoft، وخدماتها، وتقنياتها والاستمتاع بها. قد تحتوي هذه المقالة على أخطاء في المفردات، أو بناء الجملة، أو القواعد نظرًا لترجمتها آليًا.

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×