توقيع مشروع الماكرو رقمياً

توضح هذه المقالة كيفية إضافة توقيع رقمي إلى مشروع ماكرو باستخدام شهادة. إذا لم تكن لديك شهادة رقمية في السابق، فيجب الحصول على شهادة. لاختبار مشاريع الماكرو على الكمبيوتر، تستطيع إنشاء شهادة التوقيع الذاتي الخاصة بك باستخدام الأداة Selfcert.exe.

يمكنك الحصول على شهادة رقمية من مرجع تجاري مصدق (CA‏) أو من مسؤول الأمان الداخلي أو محترف تكنولوجيا المعلومات (IT).

للتعرّف على المزيد حول المراجع المصدقة التي تقدم خدمات لمنتجات Microsoft، راجع قائمة أعضاء برنامج الشهادات الجذر من Microsoft.

تجاري أعلى الصفحة

بما أن الشهادة الرقمية التي تقوم بإنشائها لا يتم إصدارها من قِبل مرجع رسمي موثوق به، فإن مشاريع الماكرو التي يتم توقيعها باستخدام مثل هذه الشهادة تُعرف كـ مشاريع موقعّة ذاتياً. يثق Microsoft Office بالشهادة الموقعّة ذاتياً فقط على كمبيوتر يتضمن شهادة التوقيع الذاتي مضافةً إلى مجلد "الشهادات الجذر الموثوقة" في مخزن "الشهادات - المستخدم الحالي".

للتعرّف على كيفية إنشاء شهادة توقيع ذاتي، راجع القسم التالي.

  1. انتقل إلى ‏C:\ملفات البرامج (x86)\Microsoft Office\root\‏.

  2. انقر فوق SelfCert.exe. يظهر المربع إنشاء شهادة رقمية.

  3. اكتب اسماً وصفياً للشهادة في المربع اسم الشهادة.

  4. انقر فوق موافق.

  5. عند ظهور الرسالة "نجاح SelfCert"، انقر فوق موافق.

  1. انتقل إلى ‏C:\ملفات البرامج\Microsoft Office\<إصدار Office>\‏.

  2. انقر فوق SelfCert.exe. يظهر المربع إنشاء شهادة رقمية.

  3. اكتب اسماً وصفياً للشهادة في المربع اسم الشهادة.

  4. انقر فوق موافق.

  5. عند ظهور الرسالة "نجاح SelfCert"، انقر فوق موافق.

  1. انقر فوق بدء، ثم أشر إلى جميع البرامج، وانقر فوق Microsoft Office، ثم فوق أدوات Microsoft Office‏، ثم فوق شهادة رقمية لمشاريع VBA‏.
    يظهر المربع إنشاء شهادة رقمية.

  2. اكتب اسماً وصفياً للشهادة في المربع اسم الشهادة.

  3. انقر فوق موافق.

  4. عند ظهور الرسالة "نجاح SelfCert"، انقر فوق موافق.

مربع الحوار "إنشاء توقيع رقمي"

لعرض الشهادة في مخزن "الشهادات الشخصية"، قم بما يلي:

  1. افتح Internet Explorer.

  2. من القائمة أدوات، انقر فوق خيارات إنترنت ثم فوق علامة التبويب المحتوى.

  3. انقر فوق الشهادات ثم فوق علامة التبويب شخصي.

أعلى الصفحة

  1. افتح الملف الذي يحتوي على مشروع الماكرو الذي تريد توقيعه.

  2. ضمن علامة التبويب المطور، في المجموعة تعليمات برمجية، انقر فوق Visual Basic.

    ملاحظة: في حالة عدم توفر علامة التبويب "المطور": انقر فوق علامة التبويب ملف. وانقر فوق خيارات. انقر فوق تخصيص الشريط. ومن القائمة تخصيص الشريط، انقر فوق المطور ثم فوق موافق.

  3. في Visual Basic، من القائمة أدوات، انقر فوق التوقيع الرقمي.

  4. يظهر مربع الحوار التوقيع الرقمي.

  5. حدد شهادة ثم انقر فوق موافق.

    ملاحظة: إذا لم تحدد شهادة رقمية أو إذا أردت استخدام شهادة أخرى، فانقر فوق اختيار. حدد شهادة ثم انقر فوق موافق.

    ملاحظات: 

    • يوصى بتوقيع وحدات الماكرو فقط بعد أن يتم اختبار الحل ويصبح جاهزاً للتوزيع: عندما يتم تغيير التعليمات البرمجية الموجودة في مشروع ماكرو موقّع بأية طريقة، فإنه تتم إزالة توقيعه الرقمي. ومع ذلك، إذا كانت لديك الشهادة الرقمية الصحيحة التي تم استخدامها مسبقاً لتوقيع المشروع على الكمبيوتر، فإنه تتم إعادة توقيع مشروع الماكرو تلقائياً عند حفظه.

    • إذا أردت منع مستخدمي الحل الخاص بك من تغيير مشروع الماكرو وإبطال توقيعك من دون قصد، فقم بتأمين مشروع الماكرو قبل توقيعه. من خلال تضمين توقيع رقمي، تضمن عدم العبث بالمشروع بعد توقيعه. ولا يثبت توقيعك الرقمي أنك قمت بكتابة المشروع. لذلك، لا يمنع تأمين مشروع الماكرو أي مستخدم آخر من استبدال التوقيع الرقمي بتوقيع آخر. وباستطاعة مسؤولي الشركة إعادة توقيع القوالب والوظائف الإضافية بحيث يمكنهم التحكم في ما يمكن للمستخدمين تشغيله على أجهزة الكمبيوتر الخاصة بهم.

    • إذا أنشأت وظيفة إضافية تضيف تعليمات برمجية إلى مشروع ماكرو، فمن الضروري أن تحدد التعليمات البرمجية ما إذا تم توقيع المشروع رقمياً أم لا فضلاً عن إعلام المستخدمين بالنتائج الناجمة عن تغيير المشروع الموقّع قبل المتابعة.

    • عند توقيع وحدات الماكرو رقمياً، من المهم الحصول على طابع زمني بحيث يمكن للمستخدمين الآخرين التحقق من صحة التوقيع إذا انتهت مدة صلاحية الشهادة المُستخدمة للتوقيع أو تم إبطالها بعد التوقيع. وإذا قمت بتوقيع وحدات الماكرو بدون طابع زمني، فسيظل التوقيع صالحاً خلال فترة صلاحية الشهادة.

أعلى الصفحة

يمكنك الحصول على شهادة رقمية من مرجع تجاري مصدق (CA) أو من مسؤول الأمان لديك.

للتعرّف على المزيد حول المراجع المصدقة التي تقدم خدمات لمنتجات Microsoft، راجع قائمة أعضاء برنامج الشهادات الجذر من Microsoft.

أعلى الصفحة

بما أنه لا يتم إصدار الشهادة الرقمية التي تقوم بإنشائها من قِبل مرجع رسمي، فيشار إلى مشاريع الماكرو التي يتم توقيعها باستخدام مثل هذه الشهادة بمشاريع موقعّة ذاتياً. يثق Microsoft Office بالشهادة الموقعّة ذاتياً فقط على كمبيوتر يتضمن شهادة التوقيع الذاتي في مخزن "الشهادات الشخصية".

  1. انقر فوق زر بدء، ثم أشر إلى جميع البرامج، وانقر فوق Microsoft Office، ثم فوق أدوات Microsoft Office‏، ثم فوق شهادة رقمية لمشاريع VBA‏. اكتب اسماً وصفياً للشهادة في المربع اسم الشهادة.

  2. عند ظهور رسالة تأكيد الشهادة، انقر فوق موافق.

لعرض الشهادة في مخزن "الشهادات الشخصية"، قم بما يلي:

  1. افتح Internet Explorer.

  2. من القائمة أدوات، انقر فوق خيارات إنترنت ثم فوق علامة التبويب المحتوى.

  3. انقر فوق الشهادات ثم فوق علامة التبويب شخصي.

أعلى الصفحة

  1. انقر فوق الزر بدء، ثم أشر إلى جميع البرامج، أشر إلى Microsoft Office، وإلى أدوات Microsoft Office‏، ثم انقر فوق شهادة رقمية لمشاريع VBA‏. اكتب اسماً وصفياً للشهادة في المربع اسم الشهادة.

  2. عند ظهور رسالة تأكيد الشهادة، انقر فوق موافق.

لعرض الشهادة في مخزن "الشهادات الشخصية"، قم بما يلي:

  1. افتح Windows Internet Explorer.

  2. من القائمة أدوات، انقر فوق خيارات إنترنت ثم فوق علامة التبويب المحتوى.

  3. انقر فوق الشهادات ثم فوق علامة التبويب شخصي.

أعلى الصفحة

  1. افتح الملف الذي يحتوي على مشروع الماكرو الذي تريد توقيعه.

    • ضمن علامة تبويب المطور، في المجموعة تعليمات برمجية، انقر فوق Visual Basic.

      إذا كانت علامة تبويب المطور غير متوفرة، فانقر فوق زر Microsoft Office‏ صورة زر Office ، ثم انقر فوق خيارات Excel‏. بعد ذلك، انقر فوق شائع، ثم حدد خانة الاختيار إظهار علامة تبويب "المطور" في الشريط.

      ملاحظة: يشكل الشريط جزءاً من واجهة مستخدم Microsoft Office Fluent.

  2. في مستكشف مشاريع Visual Basic، حدد المشروع الذي تريد توقيعه.

  3. من القائمة أدوات، انقر فوق توقيع رقمي.

  4. قم بأحد الإجراءات التالية:

    • إذا لم تكن قد حددت مسبقاً شهادة رقمية أو ترغب في استخدام واحدة أخرى، فانقر فوق اختر، وحدد الشهادة، ثم انقر فوق موافق مرتين.

    • لاستخدام الشهادة الحالية، انقر فوق موافق.

      ملاحظات: 

      • قم بتوقيع وحدات الماكرو فقط بعد أن يتم اختبار الحل ويصبح جاهزاً للتوزيع: لأنه عندما يتم تغيير التعليمات البرمجية الموجودة في مشروع ماكرو موقّع بأية طريقة، فإنه تتم إزالة توقيعه الرقمي. ومع ذلك، إذا كانت لديك الشهادة الرقمية الصحيحة التي تم استخدامها مسبقاً لتوقيع المشروع على الكمبيوتر، فإنه تتم إعادة توقيع مشروع الماكرو تلقائياً عند حفظه.

      • إذا أردت منع مستخدمي الحل الخاص بك من تغيير مشروع الماكرو وإبطال توقيعك من دون قصد، فقم بتأمين مشروع الماكرو قبل توقيعه. وينص توقيعك الرقمي فقط بأنك تضمن عدم العبث بالمشروع بعد توقيعه. ولا يثبت توقيعك الرقمي أنك قمت بكتابة المشروع. لذلك، لا يمنع تأمين مشروع الماكرو أي مستخدم آخر من استبدال التوقيع الرقمي بتوقيع آخر. ويمكن لمسؤولي الشركة إعادة توقيع القوالب والوظائف الإضافية بحيث يمكنهم التحكم تحديداً في ما يمكن للمستخدمين تشغيله على أجهزة الكمبيوتر الخاصة بهم.

      • إذا أنشأت وظيفة إضافية تضيف تعليمات برمجية إلى مشروع ماكرو، فمن الضروري أن تحدد التعليمات البرمجية ما إذا تم توقيع المشروع رقمياً أم لا فضلاً عن إعلام المستخدمين بالنتائج الناجمة عن تغيير المشروع الموقّع قبل المتابعة.

      • عند توقيع وحدات الماكرو رقمياً، من المهم الحصول على طابع زمني بحيث يمكن للمستخدمين الآخرين التحقق من توقيعك حتى بعد انتهاء صلاحية الشهادة المستخدمة للتوقيع. إذا قمت بتوقيع وحدات الماكرو من دون طابع زمني، فإن التوقيع يظل صالحاً فقط طوال فترة صلاحية الشهادة.

  1. افتح الملف الذي يحتوي على مشروع الماكرو الذي تريد توقيعه.

    • من القائمة أدوات، أشر إلى ماكرو، ثم انقر فوق محرر Visual Basic‏.

  2. في مستكشف مشاريع Visual Basic، حدد المشروع الذي تريد توقيعه.

  3. من القائمة أدوات، انقر فوق توقيع رقمي.

  4. قم بأحد الإجراءات التالية:

    • إذا لم تكن قد حددت مسبقاً شهادة رقمية أو ترغب في استخدام واحدة أخرى، فانقر فوق اختر، وحدد الشهادة، ثم انقر فوق موافق مرتين.

    • لاستخدام الشهادة الحالية، انقر فوق موافق.

      ملاحظات: 

      • قم بتوقيع وحدات الماكرو فقط بعد أن يتم اختبار الحل ويصبح جاهزاً للتوزيع، لأنه عندما يتم تغيير التعليمات البرمجية الموجودة في مشروع ماكرو موقّع بأية طريقة، فإنه تتم إزالة توقيعه الرقمي. ومع ذلك، إذا كانت لديك الشهادة الرقمية الصحيحة التي تم استخدامها مسبقاً لتوقيع المشروع على الكمبيوتر، فإنه تتم إعادة توقيع مشروع الماكرو تلقائياً عند حفظه.

      • إذا أردت منع مستخدمي الحل الخاص بك من تغيير مشروع الماكرو وإبطال توقيعك من دون قصد، فقم بتأمين مشروع الماكرو قبل توقيعه. وينص توقيعك الرقمي فقط بأنك تضمن عدم العبث بالمشروع بعد توقيعه. ولا يثبت توقيعك الرقمي أنك قمت بكتابة المشروع. لذلك، لا يمنع تأمين مشروع الماكرو أي مستخدم آخر من استبدال التوقيع الرقمي بتوقيع آخر. ويمكن لمسؤولي الشركة إعادة توقيع القوالب والوظائف الإضافية بحيث يمكنهم التحكم تحديداً في ما يمكن للمستخدمين تشغيله على أجهزة الكمبيوتر الخاصة بهم.

      • إذا أنشأت وظيفة إضافية تضيف تعليمات برمجية إلى مشروع ماكرو، فمن الضروري أن تحدد التعليمات البرمجية ما إذا تم توقيع المشروع رقمياً أم لا فضلاً عن إعلام المستخدمين بالنتائج الناجمة عن تغيير المشروع الموقّع قبل المتابعة.

      • عند توقيع وحدات الماكرو رقمياً، من المهم الحصول على طابع زمني بحيث يمكن للمستخدمين الآخرين التحقق من توقيعك حتى بعد انتهاء صلاحية الشهادة المستخدمة للتوقيع. إذا قمت بتوقيع وحدات الماكرو من دون طابع زمني، فإن التوقيع يظل صالحاً فقط طوال فترة صلاحية الشهادة.

أعلى الصفحة

  1. افتح الملف الذي يحتوي على مشروع الماكرو الذي تريد توقيعه.

    • ضمن علامة التبويب المطور، في المجموعة تعليمات برمجية، انقر فوق Visual Basic.

      إذا كانت علامة تبويب المطور غير متوفرة، فانقر فوق زر Microsoft Office‏ صورة زر Office ، ثم انقر فوق خيارات PowerPoint‏. بعد ذلك، انقر فوق شائع، ثم حدد خانة الاختيار إظهار علامة تبويب "المطور" في الشريط.

      ملاحظة: يشكل الشريط جزءاً من واجهة مستخدم Microsoft Office Fluent.

  2. في مستكشف مشاريع Visual Basic، حدد المشروع الذي تريد توقيعه.

  3. من القائمة أدوات، انقر فوق توقيع رقمي.

  4. قم بأحد الإجراءات التالية:

    • إذا لم تكن قد حددت مسبقاً شهادة رقمية أو ترغب في استخدام واحدة أخرى، فانقر فوق اختر، وحدد الشهادة، ثم انقر فوق موافق مرتين.

    • لاستخدام الشهادة الحالية، انقر فوق موافق.

      ملاحظات: 

      • قم بتوقيع وحدات الماكرو فقط بعد أن يتم اختبار الحل ويصبح جاهزاً للتوزيع: لأنه عندما يتم تغيير التعليمات البرمجية الموجودة في مشروع ماكرو موقّع بأية طريقة، فإنه تتم إزالة توقيعه الرقمي. ومع ذلك، إذا كانت لديك الشهادة الرقمية الصحيحة التي تم استخدامها مسبقاً لتوقيع المشروع على الكمبيوتر، فإنه تتم إعادة توقيع مشروع الماكرو تلقائياً عند حفظه.

      • إذا أردت منع مستخدمي الحل الخاص بك من تغيير مشروع الماكرو وإبطال توقيعك من دون قصد، فقم بتأمين مشروع الماكرو قبل توقيعه. وينص توقيعك الرقمي فقط بأنك تضمن عدم العبث بالمشروع بعد توقيعه. ولا يثبت توقيعك الرقمي أنك قمت بكتابة المشروع. لذلك، لا يمنع تأمين مشروع الماكرو أي مستخدم آخر من استبدال التوقيع الرقمي بتوقيع آخر. ويمكن لمسؤولي الشركة إعادة توقيع القوالب والوظائف الإضافية بحيث يمكنهم التحكم تحديداً في ما يمكن للمستخدمين تشغيله على أجهزة الكمبيوتر الخاصة بهم.

      • إذا أنشأت وظيفة إضافية تضيف تعليمات برمجية إلى مشروع ماكرو، فمن الضروري أن تحدد التعليمات البرمجية ما إذا تم توقيع المشروع رقمياً أم لا فضلاً عن إعلام المستخدمين بالنتائج الناجمة عن تغيير المشروع الموقّع قبل المتابعة.

      • عند توقيع وحدات الماكرو رقمياً، من المهم الحصول على طابع زمني بحيث يمكن للمستخدمين الآخرين التحقق من توقيعك حتى بعد انتهاء صلاحية الشهادة المستخدمة للتوقيع. إذا قمت بتوقيع وحدات الماكرو من دون طابع زمني، فإن التوقيع يظل صالحاً فقط طوال فترة صلاحية الشهادة.

أعلى الصفحة

  1. افتح الملف الذي يحتوي على مشروع الماكرو الذي تريد توقيعه.

    • من القائمة أدوات، أشر إلى ماكرو، ثم انقر فوق محرر Visual Basic‏.

  2. في مستكشف مشاريع Visual Basic، حدد المشروع الذي تريد توقيعه.

  3. من القائمة أدوات، انقر فوق توقيع رقمي.

  4. قم بأحد الإجراءات التالية:

    • إذا لم تكن قد حددت مسبقاً شهادة رقمية أو ترغب في استخدام واحدة أخرى، فانقر فوق اختر، وحدد الشهادة، ثم انقر فوق موافق مرتين.

    • لاستخدام الشهادة الحالية، انقر فوق موافق.

      ملاحظات: 

      • قم بتوقيع وحدات الماكرو فقط بعد أن يتم اختبار الحل ويصبح جاهزاً للتوزيع: لأنه عندما يتم تغيير التعليمات البرمجية الموجودة في مشروع ماكرو موقّع بأية طريقة، فإنه تتم إزالة توقيعه الرقمي. ومع ذلك، إذا كانت لديك الشهادة الرقمية الصحيحة التي تم استخدامها مسبقاً لتوقيع المشروع على الكمبيوتر، فإنه تتم إعادة توقيع مشروع الماكرو تلقائياً عند حفظه.

      • إذا أردت منع مستخدمي الحل الخاص بك من تغيير مشروع الماكرو وإبطال توقيعك من دون قصد، فقم بتأمين مشروع الماكرو قبل توقيعه. وينص توقيعك الرقمي فقط بأنك تضمن عدم العبث بالمشروع بعد توقيعه. ولا يثبت توقيعك الرقمي أنك قمت بكتابة المشروع. لذلك، لا يمنع تأمين مشروع الماكرو أي مستخدم آخر من استبدال التوقيع الرقمي بتوقيع آخر. ويمكن لمسؤولي الشركة إعادة توقيع القوالب والوظائف الإضافية بحيث يمكنهم التحكم تحديداً في ما يمكن للمستخدمين تشغيله على أجهزة الكمبيوتر الخاصة بهم.

      • إذا أنشأت وظيفة إضافية تضيف تعليمات برمجية إلى مشروع ماكرو، فمن الضروري أن تحدد التعليمات البرمجية ما إذا تم توقيع المشروع رقمياً أم لا فضلاً عن إعلام المستخدمين بالنتائج الناجمة عن تغيير المشروع الموقّع قبل المتابعة.

      • عند توقيع وحدات الماكرو رقمياً، من المهم الحصول على طابع زمني بحيث يمكن للمستخدمين الآخرين التحقق من توقيعك حتى بعد انتهاء صلاحية الشهادة المستخدمة للتوقيع. إذا قمت بتوقيع وحدات الماكرو من دون طابع زمني، فإن التوقيع يظل صالحاً فقط طوال فترة صلاحية الشهادة.

أعلى الصفحة

  1. افتح الملف الذي يحتوي على مشروع الماكرو الذي تريد توقيعه.

    • من القائمة أدوات، أشر إلى ماكرو، ثم انقر فوق محرر Visual Basic‏.

  2. في مستكشف مشاريع Visual Basic، حدد المشروع الذي تريد توقيعه.

  3. من القائمة أدوات، انقر فوق توقيع رقمي.

  4. قم بأحد الإجراءات التالية:

    • إذا لم تكن قد حددت مسبقاً شهادة رقمية أو ترغب في استخدام واحدة أخرى، فانقر فوق اختر، وحدد الشهادة، ثم انقر فوق موافق مرتين.

    • لاستخدام الشهادة الحالية، انقر فوق موافق.

      ملاحظات: 

      • قم بتوقيع وحدات الماكرو فقط بعد أن يتم اختبار الحل ويصبح جاهزاً للتوزيع: لأنه عندما يتم تغيير التعليمات البرمجية الموجودة في مشروع ماكرو موقّع بأية طريقة، فإنه تتم إزالة توقيعه الرقمي. ومع ذلك، إذا كانت لديك الشهادة الرقمية الصحيحة التي تم استخدامها مسبقاً لتوقيع المشروع على الكمبيوتر، فإنه تتم إعادة توقيع مشروع الماكرو تلقائياً عند حفظه.

      • إذا أردت منع مستخدمي الحل الخاص بك من تغيير مشروع الماكرو وإبطال توقيعك من دون قصد، فقم بتأمين مشروع الماكرو قبل توقيعه. وينص توقيعك الرقمي فقط بأنك تضمن عدم العبث بالمشروع بعد توقيعه. ولا يثبت توقيعك الرقمي أنك قمت بكتابة المشروع. لذلك، لا يمنع تأمين مشروع الماكرو أي مستخدم آخر من استبدال التوقيع الرقمي بتوقيع آخر. ويمكن لمسؤولي الشركة إعادة توقيع القوالب والوظائف الإضافية بحيث يمكنهم التحكم تحديداً في ما يمكن للمستخدمين تشغيله على أجهزة الكمبيوتر الخاصة بهم.

      • إذا أنشأت وظيفة إضافية تضيف تعليمات برمجية إلى مشروع ماكرو، فمن الضروري أن تحدد التعليمات البرمجية ما إذا تم توقيع المشروع رقمياً أم لا فضلاً عن إعلام المستخدمين بالنتائج الناجمة عن تغيير المشروع الموقّع قبل المتابعة.

      • عند توقيع وحدات الماكرو رقمياً، من المهم الحصول على طابع زمني بحيث يمكن للمستخدمين الآخرين التحقق من توقيعك حتى بعد انتهاء صلاحية الشهادة المستخدمة للتوقيع. إذا قمت بتوقيع وحدات الماكرو من دون طابع زمني، فإن التوقيع يظل صالحاً فقط طوال فترة صلاحية الشهادة.

  1. افتح الملف الذي يحتوي على مشروع الماكرو الذي تريد توقيعه.

    • ضمن علامة التبويب المطور، في المجموعة تعليمات برمجية، انقر فوق Visual Basic.

      إذا كانت علامة تبويب المطور غير متوفرة، فانقر فوق زر Microsoft Office‏ صورة زر Office ، ثم انقر فوق خيارات Word‏. بعد ذلك، انقر فوق شائع، ثم حدد خانة الاختيار إظهار علامة تبويب "المطور" في الشريط.

      ملاحظة: يشكل الشريط جزءاً من واجهة مستخدم Microsoft Office Fluent.

  2. في مستكشف مشاريع Visual Basic، حدد المشروع الذي تريد توقيعه.

  3. من القائمة أدوات، انقر فوق توقيع رقمي.

  4. قم بأحد الإجراءات التالية:

    • إذا لم تكن قد حددت مسبقاً شهادة رقمية أو ترغب في استخدام واحدة أخرى، فانقر فوق اختر، وحدد الشهادة، ثم انقر فوق موافق مرتين.

    • لاستخدام الشهادة الحالية، انقر فوق موافق.

      ملاحظات: 

      • قم بتوقيع وحدات الماكرو فقط بعد أن يتم اختبار الحل ويصبح جاهزاً للتوزيع، لأنه عندما يتم تغيير التعليمات البرمجية الموجودة في مشروع ماكرو موقّع بأية طريقة، فإنه تتم إزالة توقيعه الرقمي. ومع ذلك، إذا كانت لديك الشهادة الرقمية الصحيحة التي تم استخدامها مسبقاً لتوقيع المشروع على الكمبيوتر، فإنه تتم إعادة توقيع مشروع الماكرو تلقائياً عند حفظه.

      • إذا أردت منع مستخدمي الحل الخاص بك من تغيير مشروع الماكرو وإبطال توقيعك من دون قصد، فقم بتأمين مشروع الماكرو قبل توقيعه. وينص توقيعك الرقمي فقط بأنك تضمن عدم العبث بالمشروع بعد توقيعه. ولا يثبت توقيعك الرقمي أنك قمت بكتابة المشروع. لذلك، لا يمنع تأمين مشروع الماكرو أي مستخدم آخر من استبدال التوقيع الرقمي بتوقيع آخر. ويمكن لمسؤولي الشركة إعادة توقيع القوالب والوظائف الإضافية بحيث يمكنهم التحكم تحديداً في ما يمكن للمستخدمين تشغيله على أجهزة الكمبيوتر الخاصة بهم.

      • إذا أنشأت وظيفة إضافية تضيف تعليمات برمجية إلى مشروع ماكرو، فمن الضروري أن تحدد التعليمات البرمجية ما إذا تم توقيع المشروع رقمياً أم لا فضلاً عن إعلام المستخدمين بالنتائج الناجمة عن تغيير المشروع الموقّع قبل المتابعة.

      • عند توقيع وحدات الماكرو رقمياً، من المهم الحصول على طابع زمني بحيث يمكن للمستخدمين الآخرين التحقق من توقيعك حتى بعد انتهاء صلاحية الشهادة المستخدمة للتوقيع. إذا قمت بتوقيع وحدات الماكرو من دون طابع زمني، فإن التوقيع يظل صالحاً فقط طوال فترة صلاحية الشهادة.

أعلى الصفحة

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×