تحرير سجلات في طريقة عرض البيانات أو حذفها أو إدراجها

هام: تمت ترجمة هذه المقالة ترجمة آلية، راجع إقرار إخلاء المسؤولية. يرجى الاطلاع على النسخة الإنجليزية من هذه المقالة. هنا للرجوع إليها.

بعد إنشاء "طريقة عرض البيانات" تتخذ من قائمة SharePoint ومكتبته مصدر بيانات لها، أو قاعدة بيانات SQl أو ملف XML، فيمكنك إضافة ارتباطات خاصة بتحرير سجلات أو حذفها أو إدراجها في مصدر البيانات باستخدام المستعرض.

على سبيل المثال، Northwind Traders، شركة توزيع أغذية متخصصة، تقوم بتعقب بيانات المخزون الخاص بها في ملف XML. عندما يقل المخزون، فإن عضو الفريق يطالب المورد بهذا المنتج ويقدم طلباً. قد تقترح إضافة ارتباطات خاصة بتحرير طريقة عرض البيانات لكي يتمكن عضو الفريق الذي يقوم بتقديم الطلب تحديث السجل الخاص بالعنصر في الحال. كما يمكنك إدراج طريقة ارتباطات في "طريقة عرض البيانات" أو حذفها ليتمكن أعضاء الفريق من إضافة منتجات أو إزالتها. بهذه الطريقة، سيكون لدى Northwind Traders أحدث معلومات تتعلق بمخزونها الحالي.

تشرح هذه المقاله كيفيه اضافه و# تحرير، و# حذفها و# ادراج الارتباطات الي طريقه "عرض بيانات" موجوده. ل# انشاء نموذج بيانات و# "طريقه عرض البيانات" التي يتم استخدامها في هذا المثال، او ل# معرفه المزيد حول "طرق عرض البيانات"، راجع المقاله انشاء طريقه "عرض البيانات".

في هذه المقالة

قبل البدء

اضافه ارتباطات الي تحرير او حذف او ادراج سجلات في طريقه "عرض البيانات"

تحرير او حذف او ادراج سجل من خلال المستعرض

تخصيص قوالب التحرير او ادراجها

قبل البدء

يحتوي Microsoft Office SharePoint Designer 2007 على ميزتين منفصلتين تمكّن المستخدمين من تحرير البيانات في "طريقة عرض البيانات" من خلال المستعرض.

  • إضافة ارتباطات إلى "طريقة عرض البيانات" موجودة     يمكنك إضافة ارتباطات إلى "طريقة عرض البيانات" موجودة لكي يتمكن المستخدمون من تحرير سجلات أو حذفها أو إدراجها في "طريقة عرض البيانات". يقوم المستخدمون بالنقر فوق الارتباط تحرير الخاص بسجل لوضع هذا العنصر في حالة التحرير. إذا كنت تضيف ارتباطات إلى "طريقة عرض البيانات" تم إدراجها كنموذج، فإن الارتباطات تتخطى أزرار النموذج. بالإضافة إلى ذلك، إذا كنت تضيف ارتباطات إلى "طريقة عرض البيانات" تم إدراجها كنموذج، فإن طريقة عرض البيانات لن تعد تعرض من حقول بشكل افتراضي، ولكن يتم عرض البيانات فقط في طريقة عرض بشكل افتراضي.

  • ادراج طريقه "عرض بيانات" ك# نموذج     عند انشاء طريقه "عرض البيانات"، يمكنك اختيار ل# ادراجها ك# نموذج متعدد العناصر او عنصر واحد. النموذج ب# شكل دائم في وضع التحرير و# يعرض اما سجل واحد او العديد من السجلات. يمكن ل# المستخدمين تعديل سجلات موجوده من خلال المستعرض، و# لكن لا يمكن ادراج او حذف السجلات. قد ترغب في اختيار نموذج متعدد العناصر اذا المستخدمين من المحتمل ان تريد تحرير البيانات الموجوده في العديد من السجلات في الوقت نفسه ب# شكل سريع. ل# مزيد من المعلومات، راجع المقاله ادراج طريقه "عرض بيانات" ك# نموذج.

تنسيق البيانات

يستخدم هذا النموذج ملف XML كمصدر بيانات. لأن ملف XML ملف نص عادي، فإنه ليس من السهل تحديد أنواع القيم التي يجب أن تشتمل عليها حقول مفردة. على سبيل المثال، ليس هناك شيءُُ يمنعك من إدخال نصوص وحفظها في حقل من المفترض أن يشتمل على أعداد، مثل "الوحدات _المطلوبة".

ومع ذلك، إذا كان مصدر البيانات الخاص بك هو قاعدة بيانات أو قائمة SharePoint أو مكتبته، فمن الممكن عند إنشاء قاعدة بيانات أو قائمة أو مكتبة أن تحدد أنواع القيم التي من الممكن أن تحتوي عليها حقول مفردة. في هذه الحالة، إذا قمت باستخدام النموذج لإدخال نصوص في حقل يتطلب عدداً، ثم قمت بالنقر فوق حفظ ستتلقى رسالة خطأ بأن عنصر تحكم مصدر بيانات الحقل فشل في تنفيذ أمر التحديث. يحدث ذلك لأنك تقوم بإدخال قيمة لا يقبلها الحقل داخل مصدر البيانات. إذا تلقيت رسالة خطأ، انقر فوق زر المستعرض الخلف. ثم انقر فوق إلغاء الأمر ضمن النموذج لتتخلص من تغييرات أو تقوم بإدخال قيمة يقبلها مصدر البيانات.

عندما تقوم بتصميم النموذج الخاص بك، قد تحتاج إلى تضمين ملاحظة على رأس كل عمود لتشير إلى نموذج البيانات الذي يتطلبه هذا الحقل.

اعلي الصفحه

إضافة ارتباطات لتحرير سجلات أو حذفها أو إدراجها في "طريقة عرض البيانات"

يمكن إضافة هذه الارتباطات لأية طريقة عرض، بصرف النظر عما إذا كانت هذه الارتباطات تم إدراجها كعرض أو نموذج. ومع ذلك، إذا كنت تضيف هذه الارتباطات إلى طريقة عرض تم إدراجها كنموذج، فإن العناصر المدرجة تتخطى أزرار النموذج. علاوة على ذلك، إذا كنت تضيف ارتباطات إلى طريقة عرض تم إدراجها كنموذج، فإن طريقة عرض البيانات لن يعد يتم عرضها من الحقول، بينما ستعرض البيانات في طريقة عرض فقط. يتعذر الحصول على "طريقة عرض البيانات" توفر كلاً من الأزرار والارتباطات باستخدام هذه الميزات.

  1. افتح الصفحة التي تحتوي على "طريقة عرض البيانات" التي ترغب في إضافة ارتباطات إليها.

    ل# متابعه هذا المثال، استخدم طريقه "عرض البيانات" التي تم انشاؤها في انشاء طريقه "عرض البيانات".

    Products.xml كما يظهر في طريقة عرض البيانات

  2. انقر فوق طريقه "عرض البيانات" و# انقر فوق السهم شكل الزر في الزاويه العلويه اليسري ل# اظهار قائمه المهام الشائعه في طريقه عرض البيانات و# ثم انقر فوق خصائص عرض البيانات. انقر فوق السهم مره اخري ل# اخفاء القائمه.

    تلميح: بشكل بديل، يمكنك النقر بزر الماوس الأيمن فوق طريقة عرض البيانات، ثم النقر فوق إظهار مهام عناصر التحكم المعتادة ضمن القائمة المختصرة.

  3. من مربع الحوار خصائص طرق عرض بيانات، انقر فوق علامة التبويب عام.

  4. ضمن علامة التبويب تحرير أسفل خيارات الارتباط، قم بإجراء أو أكثر من الإجراءات التالية

    • لإضافة ارتباط خاص بتحرير سجل، حدد خانة الاختيار إظهار ارتباطات تحرير العناصر.

    • لإضافة ارتباط خاص بحذف سجل، حدد خانة الاختيار إظهار ارتباطات حذف العناصر.

    • لإضافة ارتباط خاص بإدراج سجل جديد، حدد خانة الاختيار إظهار ارتباطات إدراج العناصر.

      في هذا المثال، حدد خانات الاختيارات الخاصة بكل من إظهار ارتباطات تحرير العناصر وإظهار ارتباطات حذف العناصر وإظهار ارتباطات إدراج العناصر.

      علامة التبويب "تحرير" في مربع الحوار "خصائص عرض البيانات"

      ملاحظة: هذا المثال السابق خاص بملفات XML. عندما تعمل بقاعدة بيانات SQL، فإن علامة التبويب تحرير في مربع الحوار خصائص طريقة عرض البيانات توفر أيضاً خياراً في المزامنة التلقائية لخيارات الأوامر. عندما يتم تحديد هذا الخيار، فإن تحديث الأوامر وحذفها وإدراجها من مصدر بيانات SQl يكون متزامناً مع تحرير عناصر التحكم وحذفها وإدراجها في طريقة العرض.

  5. انقر فوق موافق.

    كل سجل في طريقة عرض البيانات مسبوق الآن بكل من الارتباط تحرير والارتباط حذف. يوجد في الزاوية اليسرى السفلية من طريقة عرض البيانات الارتباط إدراج .

    طريقة عرض بيانات متعددة العناصر مع إدراج ارتباطات وتحريرها حذفها

  6. ضمن القائمة ملف، انقر فوق حفظ باسم.

  7. في مربع الحوار حفظ باسم، في المربع اسم الملف قم بكتابة اسماً للملف الخاص بك، ثم انقر فوق حفظ.

اعلي الصفحه

تحرير سجل أو حذفه أو إدراجه من خلال المستعرض

بعد حفظ الصفحة التي تتضمن نموذج، يمكنك معاينتها في المستعرض ومن ثم تعديل البيانات في النموذج.

معاينة طريقة عرض البيانات في المستعرض

  • في Office SharePoint Designer 2007, ضمن القائمة ملف، انقر فوق معاينة في المستعرض، ثم انقر فوق نوع المستعرض وحجمه الذي تريد استخدامه.

    اختصار لوحه المفاتيح انقر فوق الصفحه التي تريد معاينته في "قائمه المجلدات"، و# من ثم الضغط علي F12.

    تظهر" طريقة عرض البيانات" التي تحتوي على ارتباطات في المستعرض.

    "طريقة عرض البيانات" التي تحتوي على ارتباطات كما تظهر في المستعرض

تحرير سجل

  1. انقر فوق الارتباط تحرير الخاص بالسجل الذي تريد تحريره.

    ل# متابعه المثال، انقر فوق تحرير الارتباط Chai. طريقه "عرض بيانات" يتضمن نموذج بيانات ل# يظهر السجل Chai.

    سجل مفرد في عرض البيانات في وضع التحرير

    ملاحظات: 

    • عندما تعمل مع قوائم SharePoint ومكتباته، لا تكون عناصر التحكم الخاصة بالتحرير مربعات نصوص ولكن عناصر تحكم خاصة بحقول نماذج SharePoint.

    • عندما تعمل مع ملفات للقراءة فقط كما في المعرف الموجود في قائمة SharePoint أو قاعدة بيانات SQl، يتم عرض الحقل كنص فقط وليس كحقل قابل للتحرير.

    يمكنك الان تحرير اي من المعلومات التي تظهر في Chai السجل.

  2. قم بتحرير البيانات الخاصة بهذا السجل، ثم انقر إما فوق حفظ لحفظ التغيرات أو انقر فوق إلغاء الأمر لتتراجع عن التغييرات وتعود إلى طريقة عرض البيانات.

    ل# متابعه المثال، في المربع في العمود الوحدات _ المطلوبه ، اكتب 40، و# من ثم انقر فوق حفظ الي اليمين Chai السجل.

    تظهر "طريقة عرض البيانات" تحتوي على سجل تم تحديثه.

    سجل ذو القيمة UnitsOnOrder

حذف سجل

  • انقر فوق الارتباط حذف على يمين السجل الذي تريد حذفه.

    هام: عندما تقوم بحذف سجل من خلال المستعرض، فلن تتم مطالبتك بتأكيد ما تريد القيام به في هذا الإجراء، كما أنه يتعذر إرجاع سجل محذوف.

    ل# متابعه المثال، انقر فوق حذف الارتباط الي اليمين تغير في القائمه اسم المنتج . تظهر طريقه "عرض بيانات" يتضمن السجلات الاربعه فقط.

    تظهر 4 سجلات فقط في طريقة عرض البيانات

إدراج سجل

  1. انقر فوق الارتباط إدراج في الزاوية السفلية اليسرى لـ "طريقة عرض البيانات".

    يظهر سجل يحتوي على حقول نماذج فارغة.

    سجل ذو حقول نماذج فارغة يظهر عند النقر فوق الارتباط "إدراج"

    يمكنك الآن إدراج سجل جديد.

  2. قم بإدخال البيانات الخاصة بهذا السجل، ثم انقر إما فوق حفظ لحفظ التغيرات أو انقر فوق إلغاء الأمر لتتراجع عن التغييرات وتعود إلى طريقة عرض البيانات.

    ل# متابعه المثال، في المربع في العمود ProductName ، اكتب جراندما ل# مغادره. في المربع في العمود UnitsInStock ، اكتب 120. في المربع في العمود الوحدات _ المطلوبه ، اكتب 0. في المربع في العمود المهام تفاصيل مصدر البيانات ، اكتب 25. انقر فوق حفظ. تظهر طريقه "عرض البيانات" ب# السجل الجديد.

    يظهر السجل الجديد الذي أدرجته في "طريقة عرض البيانات"

اعلي الصفحه

تخصيص تحرير القوالب أو إدراجها

يعمل استخدام طريقة عرض البيانات في إدراج سجلات أو تحريرها بصورة مختلفة بعض الشيء عن استخدام نماذج قوائم كـ NewForm.aspx or EditForm.aspx في إضافة عناصر لموقع SharePoint أو تحريرها. تعرض القائمة أو المكتبة صفحة مختلفة للمستخدمين عندما يقومون بإضافة عناصر أو تحريرها، بينما تقوم طريقة عرض البيانات بعرض وضع مختلف. ومع ذلك، فإن كل وضع له قالب يمكنك تخصيصه بأكمله. على سبيل المثال، إذا قمت بتخصيص قالب التحرير، فإن المستخدمين لن يستطيعوا مشاهدة هذه التخصيصات إلا عندما تقوم بالنقر فوق ارتباط التحرير لوضع طريقة عرض البيانات في وضع التحرير.

على سبيل المثال، ربما تحتاج إلى تخصيص كل قالب وضع عندما تريد إمداد المستخدمين بتوضيحات معينة عندما يقومون بإدراج سجلات أو تحريرها. يمكنك إدراج صف جديد أسفل رؤوس الأعمدة بسهولة، ثم تقوم باستخدام الصف لإدخال نصوص تحدد نوع البيانات التي يجب إدخالها في كل عمود إضافة لنوع التنسيق الذي تتطلبه البيانات (نصوص وأرقام إلخ).

  1. انقر فوق طريقه "عرض البيانات" و# من ثم انقر فوق السهم شكل الزر في الزاويه العلويه اليسري ل# اظهار القائمه مهام طريقه عرض البيانات المشتركه.

    تلميح: بشكل بديل، يمكنك النقر بزر الماوس الأيمن فوق طريقة عرض البيانات، ثم النقر فوق مهام طريقة عرض البيانات المشتركة ضمن القائمة المختصرة.

  2. ضمن القائمة إظهار مهام عناصر التحكم العامة انقر فوق قالب تحرير أو قالب إدراج.

    يظهر القالب الخاص بهذا الوضع في طريقة عرض البيانات. يمكنك تخصيص شكل وأسلوب عرض القالب بتغيير خط النموذج أو تنسيقه أو تخطيطه.

  3. لحفظ التغيرات التي قمت بها، ضمن القائمة ملف، انقر فوق حفظ.

  4. لمعاينة القالب في المستعرض، ضمن القائمة ملف، انقر فوق معاينة في المستعرض، ثم انقر فوق نوع المستعرض وحجمه الذي تريد استخدامه.

    اختصار لوحه المفاتيح انقر فوق الصفحه التي تريد معاينته في "قائمه المجلدات"، و# من ثم الضغط علي F12.

عندما تفتح طريقة عرض البيانات في المستعرض، ثم النقر فوق تحرير أو إدراج يظهر القالب المخصص الذي قمت بإنشائه.

اعلي الصفحه

ملاحظة: إقرار إخلاء المسؤولية للترجمة الآلية: تمت ترجمة هذه المقالة بواسطة نظام كمبيوتر دون تدخل العامل البشري. توفر Microsoft هذه الترجمات الآلية لمساعدة المستخدمين الذين لا يتحدثون الإنجليزية على استخدام منتجات Microsoft، وخدماتها، وتقنياتها والاستمتاع بها. قد تحتوي هذه المقالة على أخطاء في المفردات، أو بناء الجملة، أو القواعد نظرًا لترجمتها آليًا.

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×