المهام الأساسية في Access 2010

ملاحظة: إننا نرغب في تزويدك بأحدث محتوى تعليمات لدينا بأسرع ما يمكن، وبلغتك الخاصة. وقد تمت ترجمة هذه الصفحة آلياً، وقد تحتوي على أخطاء نحوية أو أخطاء تتعلق بالدقة. إن هدفنا هو أن يكون هذا المحتوى مفيداً لك. هل يمكنك إخبارنا إذا ما كانت المعلومات مفيدة لك في أسفل هذه الصفحة؟ فيما يلي المقالة باللغة الإنجليزية لتكون مرجعاً سهلاً لك.

اليك بعض مهام قاعده البيانات الاساسيه التي يمكنك القيام بها لمساعدتك علي تعلم كيفيه استخدام Microsoft Access 2010.

 

في هذه المقالة

ما هو Access؟

قواعد البيانات العلائقية في Access

عند فتح Access

البحث عن قالب وتطبيقه

إنشاء قاعده بيانات من البداية

فتح قاعدة بيانات Access موجودة

بدء استخدام قاعده البيانات الجديدة

إضافة جدول

لصق بيانات من مصدر آخر في جدول Access

استيراد بيانات من مصدر آخر أو إنشاء ارتباط اليها

الخطوات التالية

استيراد بيانات من جدول بيانات أو برنامج آخر

استيراد ورقه عمل Excel إلى Access

استيراد ورقه عمل Excel كجدول في قاعده بيانات جديده

استخدام معالج محلل الجداول لتنظيم البيانات

استخدام البيانات من برامج أخرى

استخدام قاعده بيانات ذات إصدار سابق في عده إصدارات من Access

استخدام ملف قاعده بيانات access في إصدارات متعددة من Access

الخطوة 1: إنشاء نسخه عن قاعده البيانات الموجودة ، وحفظها بتنسيق جديد

الخطوة 2: تقسيم قاعده البيانات المنسوخة ، واستخدام الملف الأصلي كقاعده البيانات الموجودة علي الخادم

الخطوة 3: توصيل الطرف الامامي الجديد بقاعده البيانات الاصليه

استخدام تطبيق الاتصال الامامي/الخلفي في إصدارات متعددة من Access

ما هو Access؟

Access 2010 عبارة عن تصميم تطبيق قاعده بيانات وأداه نشر يمكنك استخدامها لتعقب المعلومات الهامه. يمكنك الاحتفاظ بالبيانات علي الكمبيوتر ، أو يمكنك نشرها علي ويب ، بحيث يتمكن الآخرون من استخدام قاعده بياناتك باستخدام مستعرض ويب.

يبدا الكثير من الأشخاص باستخدام Access عندما يصبح البرنامج الذي يستخدمونه لتعقب شيء ما بشكل تدريجي هو الاحتواء الأقل علي المهمة. علي سبيل المثال ، افترض انك مخطط حدث ، وتريد تعقب كل التفاصيل التي تحتاج إلى ادارتها لاجراء الاحداث بنجاح. إذا كنت تستخدم معالج الكلمات أو برنامج جداول بيانات للقيام بذلك ، فيمكنك بسهوله الوصول إلى المشاكل باستخدام البيانات المتكررة وغير المتناسقة. يمكنك استخدام برنامج تقويم ، ولكن تعقب المعلومات المالية في التقويم ليست مناسبه جيده.

قواعد البيانات العلائقية في Access

في بعض الأحيان ، تحتاج إلى قاعده بيانات علائقية لتعقب هذه المعلومات — مستودع البيانات التي تم تقسيمها إلى مجموعات أصغر من البيانات (تسمي الجداول) لأزاله التكرار ، ثم ربطها معا بالاستناد إلى بتات المعلومات الشائعة (تسمي الحقول) . علي سبيل المثال ، قد تحتوي قاعده البيانات العلائقية لتخطيط الحدث علي جدول يتضمن معلومات العميل وجدول بمعلومات المورد وجدول يحتوي علي معلومات الحدث. قد يحتوي الجدول الذي يحتوي علي معلومات الحدث علي حقل لربطه بجدول العملاء ، وحقل لربطه بجدول الموردين. بهذه الطريقة ، علي سبيل المثال ، إذا تم تغيير رقم هاتف المورد ، فيمكن تغيير المعلومات مره واحده في جدول المورد ، بدلا من كل حدث يشترك في المورد.

الوصول هو أداه يمكنك استخدامها لتطوير تطبيقات قواعد البيانات العلائقية بسرعة وسهوله تساعدك علي أداره المعلومات. يمكنك إنشاء قاعده بيانات لمساعدتك علي تعقب اي نوع من المعلومات فقط ، مثل المخزون أو جات الاتصال المهنية أو عمليات الاعمال. في الواقع ، ياتي Access مع القوالب التي يمكنك استخدامها مباشره لتعقب مجموعه متنوعة من المعلومات ، مما يجعل الأمر سهلا حتى علي مبتدئ.

عند فتح Access

عند بدء تشغيل Access 2010 ، يمكنك رؤية طريقه عرض Microsoft Office Backstage ، حيث يمكنك الحصول علي معلومات حول قاعده البيانات الحالية وإنشاء قاعده بيانات جديده وفتح قاعده بيانات موجودة وعرض المحتوي المميز من Office.com.

طريقة عرض Backstage في Access 2010

تحتوي طريقه عرض Backstage أيضا علي العديد من الأوامر الأخرى التي يمكنك استخدامها لضبط قواعد البيانات أو الاحتفاظ بها أو مشاركتها. تنطبق الأوامر الموجودة في طريقه عرض Backstage بشكل عام علي قواعد البيانات بأكملها ، وليس علي الكائنات داخل قاعده البيانات.

ملاحظة: يمكنك الوصول إلى طريقه عرض Backstage في اي وقت بالنقر فوق علامة التبويب ملف .

أعلى الصفحة

البحث عن قالب وتطبيقه

يوفر لك Access مجموعه كبيره من القوالب التي يمكنك استخدامها لزيادة سرعه عمليه إنشاء قاعده البيانات. القالب عبارة عن قاعده بيانات جاهزه للاستخدام تحتوي علي كل الجداول والاستعلامات والنماذج والتقارير المطلوبة لتنفيذ مهمة معينه. علي سبيل المثال ، تتوفر قوالب يمكن استخدامها لتعقب المشاكل أو أداره جات الاتصال أو الاحتفاظ بسجل للمصروفات. وتحتوي بعض القوالب على بضع نماذج سجلات للمساعدة على توضيح كيفية استخدامها. يمكن استخدام قواعد بيانات القوالب كما هي ، أو يمكنك تخصيصها لتناسب احتياجاتك بشكل أفضل.

للبحث عن قالب وتطبيقه علي قاعده البيانات ، قم بما يلي:

  1. في علامة تبويب ملف، انقر فوق جديد.

  2. ضمن القوالب المتاحة، قم بأحد الإجراءات التالية:

    • لأعاده استخدام قالب قمت باستخدامه مؤخرا ، انقر فوق القوالب الاخيره ، ثم حدد القالب الذي تريده.

    • لاستخدام قالب قمت بتثبيته بالفعل ، انقر فوق القوالب ، ثم حدد القالب الذي تريده.

    • للبحث عن قالب علي Office.com ، ضمن قوالب Office.com، انقر فوق فئة قالب ، وحدد القالب الذي تريده ، ثم انقر فوق تنزيل لتنزيل القالب من Office .com إلى الكمبيوتر.

      يمكنك أيضا البحث عن القوالب علي Office.com من داخل Access. في المربع البحث عن قوالب في Office.com، اكتب مصطلح بحث واحد أو أكثر، ثم انقر فوق زر السهم لبدء البحث.

  3. يمكنك بشكل اختياري النقر فوق أيقونه المجلد الموجودة إلى جانب المربع اسم الملف للاستعراض وصولا إلى الموقع الذي تريد إنشاء قاعده البيانات فيه. إذا لم تكن تريد الاشاره إلى موقع معين ، سيقوم Access بإنشاء قاعده البيانات في الموقع الافتراضي الذي يتم عرضه أسفل المربع اسم الملف .

  4. انقر فوق إنشاء.

يقوم Access بإنشاء قاعده البيانات وفتحها لاستخدامها.

أعلى الصفحة

إنشاء قاعده بيانات من البداية

إذا كنت تريد مقدمه أكثر شمولا إلى المفاهيم الموجودة خلف استخدام Access لإنشاء قاعده بيانات ، فراجع المقالة أساسيات تصميم قاعده البيانات.

إذا لم تناسب اي من القوالب احتياجاتك ، أو إذا كانت لديك بيانات في برنامج آخر تريد استخدامه في Access ، فقد تقرر انه من الأفضل إنشاء قاعده بيانات من البداية. في Access 2010 ، يتوفر لديك خيار: قاعده بيانات سطح المكتب القياسية ، أو قاعده بيانات ويب.

لمزيد من المعلومات حول قواعد بيانات ويب ، راجع المقالة إنشاء قاعده بيانات لمشاركتها علي ويب.

لإنشاء قاعده بيانات جديده ، قم بما يلي:

  1. بدء الوصول.

  2. علي علامة التبويب جديد في طريقه عرض Backstage ، انقر فوق قاعده بيانات فارغه أو قاعده بيانات فارغه علي ويب.

    هام: سيحدد الخيار الذي تقوم به هنا الميزات المتوفرة في قاعده البيانات. لا يمكن نشر قواعد بيانات سطح المكتب إلى ويب ، ولا تدعم قواعد بيانات ويب بعض ميزات سطح المكتب ، مثل استعلامات الإجماليات.

  3. في الجانب الأيسر ، اكتب اسما لقاعده البيانات في المربع اسم الملف .

    لتغيير الموقع الذي تقوم فيه بإنشاء الملف ، انقر فوق استعراض صورة الزر إلى جانب المربع اسم الملف ، واستعرض وصولا إلى الموقع الجديد وحدده ، ثم انقر فوق موافق.

  4. انقر فوق إنشاء.

    ينشئ Access قاعده البيانات ، ثم يفتح جدولا فارغا (يسمي جدول 1) في طريقة عرض ورقة البيانات.

  5. يضع Access المؤشر في الخلية الفارغة الاولي في العمود انقر للاضافه في الجدول الجديد.

    لأضافه بيانات ، أبدا الكتابة ، أو يمكنك لصق البيانات من مصدر آخر ، كما هو موضح في المقطع لصق البيانات من مصدر آخر إلى جدول Access، لاحقا في هذه المقالة.

    ملاحظات: 

    • تم تصميم إدخال البيانات في طريقه عرض "ورقه البيانات" بحيث تكون مماثله لإدخال البيانات في ورقه عمل Excel. التقييد الرئيسي هو انه يجب إدخال البيانات في الصفوف والاعمده المتجاورة ، بدءا من الزاوية العلوية اليمني من ورقه البيانات. لا يمكنك محاولة تنسيق البيانات عن طريق تضمين صفوف أو أعمده فارغه كما قد تفعل في ورقه عمل Excel ، لان ذلك سيؤدي إلى ترك مساحة في الجدول. يحتوي الجدول علي بياناتك فقط. سيتم تنفيذ كل العرض التقديمي المرئي لتلك البيانات في النماذج والتقارير التي تصممها لاحقا.

    • يتم إنشاء بنية الجدول أثناء إدخال البيانات. في اي وقت تقوم فيه باضافه عمود جديد إلى ورقه البيانات ، يتم تعريف حقل جديد في الجدول. يقوم Access بتعيين نوع البيانات الحقل استنادا إلى نوع البيانات التي تقوم بإدخالها. علي سبيل المثال ، إذا كان لديك عمود أدخلت فيه قيم التواريخ فقط ، سيقوم Access بتعيين نوع البيانات لهذا الحقل إلى التاريخ/الوقت. إذا حاولت لاحقا إدخال قيمه غير رقميه (مثل اسم أو رقم هاتف) في هذا الحقل ، سيعرض Access رسالة تعلمك بان القيمة لا تتطابق مع نوع بيانات العمود. إذا كان ذلك ممكنا ، يجب ان تخطط الجدول بحيث يحتوي كل عمود علي نوع البيانات نفسه ، سواء كان النص أو التواريخ أو الأرقام أو اي نوع آخر. يؤدي ذلك إلى تسهيل عمليه إنشاء الاستعلامات والنماذج والتقارير التي تحدد البيانات التي تريدها فقط.

إذا كنت لا تريد إدخال البيانات بعد ، فانقر فوق إغلاق صورة الزر .

ملاحظة: سيقوم Access بحذف جدول 1 إذا قمت بإغلاقه من دون حفظ.

أعلى الصفحة

فتح قاعدة بيانات Access موجودة

تلميح: لفتح أحدي قواعد البيانات المتعددة الاخيره التي قمت بفتحها ، علي علامة التبويب ملف ، انقر فوق الاخيره ، ثم انقر فوق اسم الملف.

  1. على علامة التبويب ملف، انقر فوق فتح.

  2. انقر فوق اختصار في مربع الحوار فتح ، أو في المربع بحث في ، انقر فوق محرك الاقراص أو المجلد الذي يحتوي علي قاعده البيانات التي تريدها.

  3. في قائمه المجلدات ، انقر نقرا مزدوجا فوق المجلدات حتى تفتح المجلد الذي يحتوي علي قاعده البيانات.

  4. عند العثور علي قاعده البيانات ، قم بأحد الإجراءات التالية:

    • لفتح قاعده البيانات في وضع الفتح الافتراضي ، انقر نقرا مزدوجا فوقها.

    • لفتح قاعده البيانات للوصول المشترك في بيئة متعددة المستخدمين ، التالي يمكنك وللمستخدمين الآخرين القراءة والكتابة إلى قاعده البيانات في الوقت نفسه ، انقر فوق فتح.

    • لفتح قاعده البيانات للوصول للقراءة فقط ، التالي يمكنك عرضها ولكن لا يمكنك تحريرها ، انقر فوق السهم الموجود بجانب الزر فتح ، ثم انقر فوق فتح للقراءة فقط.

    • لفتح قاعده البيانات للوصول الخاص ، التالي لا يستطيع اي شخص آخر فتحه اثناء فتحها ، انقر فوق السهم الموجود بجانب الزر فتح ، ثم انقر فوق فتح خاص.

    • لفتح قاعده البيانات للوصول للقراءة فقط ، انقر فوق السهم الموجود بجانب الزر فتح ، ثم انقر فوق فتح خاص للقراءة فقط يمكن للمستخدمين الآخرين فتح قاعده البيانات ، ولكن لديهم امكانيه الوصول للقراءة فقط.

في حالة تعذر العثور على قاعدة البيانات المطلوب فتحها    

  1. في مربع الحوار فتح ، انقر فوق اختصار جهاز الكمبيوتر ، أو في المربع بحث في ، انقر فوق جهاز الكمبيوتر.

  2. في قائمة محركات الأقراص، انقر بزر الماوس الأيمن فوق محرك الأقراص الذي قد يحتوي على قاعدة البيانات ثم انقر فوق البحث.

  3. ادخل معايير البحث ، ثم اضغط علي مفتاح الإدخال ENTER للبحث عن قاعده البيانات.

  4. إذا تم العثور علي قاعده البيانات ، فافتحها بالنقر نقرا مزدوجا فوقها في مربع الحوار نتائج البحث .

    بسبب بدء البحث من مربع الحوار فتح ، يجب النقر فوق إلغاء الأمر في مربع الحوار هذا قبل ان يتم فتح قاعده البيانات.

يمكنك فتح ملف بيانات مباشره بتنسيق ملف خارجي (مثل dBASE أو Paradox أو Microsoft Exchange أو Excel). يمكنك أيضاً فتح أي مصدر بيانات ODBC مباشرة، مثل Microsoft SQL Server أو Microsoft FoxPro. يتم إنشاء قاعدة بيانات تلقائياً في Access في نفس مجلد ملف البيانات وتتم إضافة ارتباطات لكل جدول في قاعدة البيانات الخارجية.

أعلى الصفحة

بدء استخدام قاعده البيانات الجديدة

استنادا إلى القالب الذي استخدمته ، قد تحتاج إلى تنفيذ اجراء واحد أو أكثر مما يلي لبدء استخدام قاعده البيانات الجديدة:

  • إذا قام Access بعرض مربع حوار تسجيل الدخول مع قائمه فارغه من المستخدمين ، فاستخدم الاجراء التالي للبدء:

    1. انقر فوق مستخدم جديد.

    2. قم بتعبئة نموذج تفاصيل المستخدم .

    3. انقر فوق حفظ وإغلاق.

    4. حدد اسم المستخدم الذي أدخلته للتو ، ثم انقر فوق تسجيل الدخول.

  • إذا عرض Access ورقه بيانات فارغه ، فيمكنك البدء بكتابه البيانات مباشره في ورقه البيانات هذه ، أو النقر فوق أزرار وعلامات تبويب أخرى لاستكشاف قاعده البيانات.

  • إذا كان Access يعرض صفحه بدء الاستخدام ، فيمكنك النقر فوق الارتباطات في هذه الصفحة لمعرفه المزيد حول قاعده البيانات ، أو النقر فوق أزرار وعلامات تبويب أخرى لاستكشاف قاعده البيانات.

  • إذا قام Access بعرض رسالة تحذير أمان في شريط الرسائل ، وكانت تثق في مصدر القالب ، فانقر فوق تمكين المحتوي. إذا كانت قاعده البيانات تتطلب تسجيل الدخول ، ستحتاج إلى تسجيل الدخول مره أخرى.

بالنسبة إلى قواعد بيانات سطح المكتب والويب ، يجب ان تبدا أيضا بأحدي الخطوات التالية:

أعلى الصفحة

إضافة جدول

يمكنك أضافه جدول جديد إلى قاعده بيانات موجودة باستخدام الاداات الموجودة في المجموعة جداول ضمن علامة التبويب إنشاء .

المجموعة "جداول" ضمن علامة التبويب "إنشاء"

ملاحظة: في قاعده بيانات ويب ، يتوفر الأمر " جدول " فقط في المجموعة " جداول ".

بصرف النظر عن طريقه العرض التي تبدا فيها ، يمكنك دائما التبديل إلى طريقه العرض الأخرى باستخدام أزرار طرق العرض علي شريط المعلومات في نافذه Access.

إنشاء جدول فارغ في طريقه عرض "ورقه البيانات"    في طريقه عرض ورقه البيانات ، يمكنك إدخال البيانات علي الفور ، والسماح ل Access بإنشاء بنيه الجدول خلف المشاهد. يتم تعيين أسماء الحقول رقميا (Field1 و Field2 وما إلى ذلك) ، ويقوم Access بتعيين نوع بيانات الحقل ، استنادا إلى نوع البيانات التي تقوم بإدخالها.

  1. علي علامة التبويب إنشاء ، في المجموعة جداول ، انقر فوق جدول صورة الزر .

  2. ينشئ Access الجدول ، ثم يضع المؤشر في الخلية الفارغة الاولي في العمود انقر للاضافه .

  3. لأضافه بيانات ، أبدا بالكتابة في الخلية الفارغة الاولي ، أو يمكنك لصق البيانات من مصدر آخر ، كما هو موضح لاحقا في هذه المقالة.

    • لإعادة تسمية عمود (حقل)، انقر نقراً مزدوجاً فوق رأس العمود، ثم اكتب الاسم الجديد.

      تلميح: قدم اسما ذا معني لكل حقل ، بحيث يمكنك معرفه ما يتضمنه من دون الحاجة إلى إلقاء نظره علي البيانات.

    • لنقل عمود ، حدده بالنقر فوق عنوان العمود الخاص به ، ثم اسحبه إلى المكان الذي تريده. يمكنك أيضا تحديد أعمده متعددة متجاورة وسحبها إلى موقع جديد معا.

      لأضافه المزيد من الحقول إلى الجدول ، يمكنك اما بدء الكتابة في العمود انقر للاضافه في طريقه عرض ورقه البيانات ، أو يمكنك أضافه حقول جديده باستخدام الأوامر الموجودة في المجموعة أضافه _amp_ Delete ضمن علامة التبويب حقول .

إنشاء جدول يبدا في طريقه عرض "التصميم"    في عرض "التصميم"، يجب عليك أولاً إنشاء بنية الجدول الجديد. ثم تقوم بالتبديل إلى طريقه عرض ورقه البيانات لإدخال البيانات ، أو تقوم بإدخال البيانات باستخدام طريقه أخرى ، مثل نموذج.

لا تتوفر طريقه عرض التصميم للجداول في قاعده بيانات ويب.

  1. في علامة التبويب إنشاء، في المجموعة جداول، انقر فوق تصميم جدول. صورة الزر

  2. اكتب اسماً لكل حقل في الجدول في العمود اسم الحقل، ثم حدد نوع بيانات من القائمة أنواع البيانات.

  3. يمكنك إدخال معلومات اضافيه لكل حقل في عمود الوصف. يتم عرض الوصف الذي تدخله في شريط المعلومات عندما تكون نقطه الادراج في هذا الحقل ، ويتم استخدامها كنص شريط المعلومات لأي عناصر تحكم تقوم بإنشاءها عن طريق سحب الحقل من جزء قائمه الحقول إلى نموذج أو تقرير ، النسبة إلى اي عناصر تحكم تم إنشاؤها لهذا الحقل بواسطة معالج النماذج أو معالج التقارير.

  4. وبعد إضافة جميع الحقول، احفظ الجدول:

    • في علامة التبويب ملف، انقر فوق حفظ.

  5. يمكنك البدء في إدخال البيانات في الجدول في اي وقت بالتبديل إلى طريقه عرض ورقه البيانات ، والنقر فوق الخلية الفارغة الاولي ، والكتابة. يمكنك أيضا لصق البيانات من مصدر آخر ، كما هو موضح في المقطع التالي.

إنشاء جدول استنادا إلى قائمه SharePoint    باستخدام قائمه SharePoint ، يمكن للأشخاص الذين لا يملكون حق الوصول إلى البيانات. بالاضافه إلى ذلك ، يتم تخزين بيانات القائمة علي خادم ، وهو يقدم بشكل عام حماية أفضل ضد فقدان البيانات من الملفات المخزنة علي كمبيوتر سطح المكتب. يمكنك اما البدء بقائمه جديده ، أو يمكنك إنشاء ارتباط إلى قائمه موجودة. يجب ان يكون لديك الأذونات الكافية علي موقع SharePoint الذي تريد إنشاء القائمة فيه ؛ قد يختلف هذا الأمر بحسب الموقع لذلك يمكنك الاتصال بمسؤول SharePoint للحصول علي التفاصيل المتعلقة بخياراتك.

لا تتوفر هذه الميزة في قاعده بيانات ويب.

  1. على علامة التبويب إنشاء، في المجموعة جداول، انقر فوق قوائم SharePoint.

  2. يمكنك استخدام أحد قوالب القوائم لإنشاء قائمه SharePoint قياسيه ، مثل جات الاتصال أو الاحداث.

    يمكنك أيضا اختيار إنشاء قائمه مخصصه أو الارتباط بقائمه موجودة أو استيرادها. انقر فوق الخيار الذي تريده.

  3. إذا اخترت أيا من قوالب القوائم أو لإنشاء قائمه مخصصه ، سيتم فتح مربع الحوار إنشاء قائمه جديده لإرشادك خلال العملية. إذا اخترت استخدام قائمه موجودة ، سيتم فتح مربع الحوار إحضار بيانات خارجيه لمساعدتك.

للحصول على مزيد من المعلومات حول الجداول، راجع المقالة مقدمة حول الجداول.

أعلى الصفحة

لصق بيانات من مصدر آخر في جدول Access

إذا كانت بياناتك مخزنه حاليا في برنامج آخر ، مثل Excel ، يمكنك نسخ البيانات ولصقها في جدول Access. بشكل عام، تعد هذه هي الطريقة الأفضل خاصة وإذا كانت البيانات مقسومة بالفعل إلى أعمدة، كما هو الحال في ورقة عمل Excel. إذا كانت البيانات موجودة في برنامج معالجه الكلمات ، فيجب أولا فصل أعمده البيانات باستخدام علامات الجدولة ، أو تحويل البيانات إلى جدول في برنامج معالجه الكلمات ، ثم نسخ البيانات. إذا كانت البيانات بحاجه إلى اي عمليه تحرير أو معالجه (علي سبيل المثال ، فصل الأسماء الكاملة في الاسم الأول وأسماء العائلة) ، فقد تحتاج إلى القيام بذلك قبل نسخ البيانات ، خاصه إذا لم تكن ملما باستخدام Access.

عند لصق البيانات في جدول فارغ، يتم تعيين نوع بيانات كل حقل في Access وفقاً لنوع البيانات التي يتم العثور عليه. على سبيل المثال، إذا كان أحد حقول الملصقة لا يحتوي إلا على قيم تواريخ، فسيتم تطبيق نوع البيانات التاريخ/الوقت على ذلك الحقل في Access. وإذا لم يتضمن الحقل الملصق سوى كلمتي "نعم" و"لا"، فسيتم تطبيق نوع البيانات "نعم/لا" على الحقل في Access.

تتم تسمية الحقول في Access بناءً على ما يتم العثور عليه في الصف الأول من البيانات الملصقة. إذا كان الصف الأول من البيانات الملصقة مماثلا للكتابة إلى الصفوف التي تليها ، فان Access يحدد ان الصف الأول جزء من البيانات ويعين الحقول الأسماء العامة (Field1 و Field2 وما إلى ذلك). إذا لم يكن الصف الأول من البيانات التي تم لصقها مماثلا للصفوف التي تليها ، سيستخدم Access الصف الأول كاسماء الحقول ، ويستبعد الصف الأول في البيانات الفعلية.

وفي حالة تم تعيين أسماء عامة للحقول في Access، يجب إعادة تسمية الحقول في أسرع وقت ممكن لتجنب حدوث أي إرباك. استخدم الإجراء التالي:

  1. علي علامة التبويب ملف ، انقر فوق حفظ لحفظ الجدول.

  2. في طريقه عرض ورقه البيانات ، انقر نقرا مزدوجا فوق عنوان العمود ، ثم اكتب اسما للعمود.

  3. احفظ الجدول مرة أخرى.

أعلى الصفحة

استيراد بيانات من مصدر آخر أو إنشاء ارتباط اليها

قد يكون لديك بيانات كنت تقوم بتجميعها في برنامج آخر ترغب في استخدامه في Access. ربما تعمل مع الأشخاص الذين يقومون بتخزين بياناتهم في برامج أخرى ، وتريد العمل علي البيانات الخاصة بهم في Access. أو ، قد يكون لديك عده مصادر مختلفه من البيانات ، وتحتاج إلى "لوحه الهبوط" حيث يمكنك الحصول عليها كلها معا لتحليل أعمق.

يسهل Access عمليه استيراد البيانات أو ربطها من برامج أخرى. يمكنك إحضار البيانات من ورقه عمل Excel ، من جدول في قاعده بيانات Access أخرى ، من قائمه SharePoint ، أو من اي مجموعه متنوعة من المصادر الأخرى. تختلف العملية قليلا استنادا إلى مصدر البيانات ، ولكن ستحصل هذه الإرشادات علي البدء:

  1. علي علامة التبويب بيانات خارجيه ، في المجموعة استيراد ارتباط _amp_ ، انقر فوق الأمر الخاص بنوع الملف الذي تقوم بالاستيراد منه.

    على سبيل المثال، إذا كنت تقوم باستيراد بيانات من ورقة عمل Excel، فانقر فوق Excel. إذا لم تتمكن من رؤية نوع البرنامج الصحيح ، فانقر فوق المزيد.

    ملاحظة: إذا لم تتمكن من العثور علي نوع التنسيق الصحيح في المجموعة استيراد ارتباط _amp_ ، فقد تحتاج إلى بدء تشغيل البرنامج الذي إنشات البيانات فيه في الأصل ، ثم استخدم هذا البرنامج لحفظ البيانات بتنسيق ملف يعتمده Access (مثل ملف نص محدد ) ، ثم قم باستيراد البيانات أو إنشاء ارتباط اليها.

  2. في مربع الحوار الحصول علي بيانات خارجيه ، انقر فوق استعراض للاستعراض وصولا إلى ملف البيانات المصدر ، أو اكتب المسار الكامل لملف البيانات المصدر في المربع اسم الملف .

  3. انقر فوق الخيار الذي تريده ضمن تحديد الطريقة والمكان الذي تريد تخزين البيانات فيه في قاعده البيانات الحالية. يمكنك إنشاء جدول جديد باستخدام البيانات المستوردة ، أو إنشاء جدول مرتبط يحتفظ بارتباط إلى مصدر البيانات.

  4. انقر فوق موافق.

    بحسب اختيارك ، يتم فتح مربع الحوار ارتباط الكائنات أو مربع الحوار استيراد كائنات .

  5. استخدم مربع الحوار لإنهاء العملية. يعتمد الاجراء الدقيق الذي تتابعه علي خيار الاستيراد أو الارتباط الذي اخترته.

  6. في صفحة المعالج الأخيرة، انقر فوق إنهاء.

    إذا اخترت استيراد ، سيسالك Access عما إذا كنت تريد حفظ تفاصيل عمليه الاستيراد التي أكملتها للتو.

  7. إذا كنت تعتقد انك ستقوم بتنفيذ نفس عمليه الاستيراد هذه مره أخرى ، فانقر فوق حفظ خطوات الاستيراد، ثم ادخل التفاصيل.

    يمكنك بعد ذلك أعاده إنشاء عمليه الاستيراد بسهوله بالنقر فوق الاستيرادات المحفوظة في المجموعة استيراد في علامة التبويب بيانات خارجيه ، النقر فوق مواصفة الاستيراد ، ثم النقر فوق تشغيل.

  8. إذا كنت لا ترغب في حفظ تفاصيل العملية، فانقر فوق إغلاق.

يدرج Access البيانات في جدول جديد ، ثم يعرض الجدول ضمن الجداول في جزء التنقل.

لمعرفه المزيد حول كيفيه استيراد البيانات إلى Access ، اتبع الارتباطات الموجودة في القسم انظر أيضا في هذه المقالة.

أعلى الصفحة

الخطوات التالية

تختلف بقية عمليه التصميم استنادا إلى أهدافك ، ولكن قد تحتاج إلى إنشاء استعلامات ونماذج وتقارير ووحدات ماكرو. لا توفر هذه المقالة معلومات حول إنشاء كائنات اضافيه لقاعده البيانات.

لمزيد من المعلومات ، راجع المقالات التالية:

أعلى الصفحة

استيراد بيانات من جدول بيانات أو برنامج آخر

إذا كنت ملما باستخدام برامج قواعد البيانات أو الجداول الأخرى ، فمن المحتمل ان تعرف أساسيات كيفيه عمل هذه التطبيقات والقواعد التي يتم استخدامها لها. يختلف Access عن العديد من تطبيقات قواعد البيانات الأخرى عن طريق السماح لك بإنشاء قواعد بيانات علائقية ، ويختلف الأمر أيضا عن معظم برامج جداول البيانات عن طريق عرض أدوات لتطوير الاستعلامات والنماذج والتقارير المتطورة. يوفر Access أيضا العديد من الخيارات لاستخدام برامج قواعد البيانات الأخرى ، مثل SQL server.

استيراد ورقه عمل Excel إلى Access

بدا العديد من الأشخاص في استكشاف Access بعد إنشاء قائمه أولا في Excel. يعتبر Excel مكانا رائعا لبدء قائمه ، ولكن كلما زاد حجم القائمة ، يصبح من الصعب تنظيمها والحفاظ علي تحديثها. عاده ما يكون نقل القائمة إلى Access هو الخطوة المنطقية التالية.

يشبه جدول قاعده البيانات البنية التي يتم تخزينها في ورقه البيانات في الصفوف والاعمده. نتيجة لذلك ، من السهل عاده استيراد ورقه عمل إلى جدول قاعده بيانات. الفرق الرئيسي بين تخزين البيانات في ورقه عمل وتخزينها في قاعده بيانات هو الطريقة التي يتم بها تنظيم البيانات. لن يؤدي استيراد ورقه العمل بأكملها كجدول جديد في قاعده البيانات إلى حل المشاكل المقترنة بتنظيم البيانات وتحديثها ، خاصه إذا كانت ورقه العمل تحتوي علي بيانات متكررة. لحل هذه المشاكل ، يجب تقسيم بيانات جدول البيانات إلى جداول منفصلة ، كل واحده تحتوي علي بيانات ذات صله. للحصول علي مزيد من المعلومات حول كيفيه ترتيب البيانات في الجداول ، راجع المقالة أساسيات تصميم قاعده البيانات.

ميزات Access الخاصة بمعالج محلل الجداول ، الذي يمكنه مساعدتك في إكمال هذه العملية. بعد استيراد بياناتك إلى جدول ، يساعدك المعالج في تقسيم الجدول إلى جداول منفصلة ، يحتوي كل منها علي بيانات غير مكرره في اي من الجداول الأخرى. ينشئ المعالج أيضا العلاقات الضرورية بين الجداول.

أعلى الصفحة

استيراد ورقه عمل Excel كجدول في قاعده بيانات جديده

  1. في علامة التبويب ملف، انقر فوق جديد، ثم انقر فوق قاعدة بيانات فارغة.

  2. اكتب اسما لقاعده البيانات الجديدة في المربع اسم الملف ، ثم انقر فوق إنشاء.

    يتم فتح قاعده البيانات الجديدة ، وينشئ Access جدولا فارغا جديدا ، جدول 1.

  3. اغلق جدول 1.

    عند سؤالك ما إذا كنت تريد حفظ التغييرات في تصميم جدول 1 ، انقر فوق لا.

  4. علي علامة التبويب بيانات خارجيه ، في المجموعة استيراد ارتباط _amp_ ، انقر فوق Excel. صورة الزر

  5. في مربع الحوار إحضار بيانات خارجيه ، انقر فوق استعراض.

  6. استخدم مربع الحوار " فتح ملف " لتحديد موقع الملف.

  7. حدد الملف، ثم انقر فوق فتح.

  8. في مربع الحوار الحصول علي بيانات خارجيه ، تاكد من تحديد الخيار استيراد البيانات المصدر إلى جدول جديد في قاعده البيانات الحالية .

  9. انقر فوق موافق.

    يبدا تشغيل معالج استيراد جدول البيانات ، سيطلب منك بعض الاسئله حول بياناتك.

  10. اتبع الإرشادات ، وانقر فوق التالي أو السابق للتنقل عبر الصفحات. في صفحة المعالج الأخيرة، انقر فوق إنهاء.

    ملاحظة: يسال Access عما إذا كنت تريد حفظ تفاصيل عمليه الاستيراد التي أكملتها للتو. إذا كنت تعتقد انك ستقوم بتنفيذ نفس عمليه الاستيراد هذه مره أخرى ، فانقر فوق نعم، ثم ادخل التفاصيل. يمكنك بعد ذلك أعاده إنشاء العملية في المستقبل بسهوله بالنقر فوق عمليات الاستيراد المحفوظة في المجموعة استيراد في علامة التبويب بيانات خارجيه . إذا كنت لا ترغب في حفظ تفاصيل العملية، فانقر فوق إغلاق.

يدرج Access البيانات في جدول جديد ، ثم يعرضها ضمن كل الجداول في جزء التنقل.

أعلى الصفحة

استخدام معالج محلل الجداول لتنظيم البيانات

بعد استيراد البيانات إلى جدول Access ، يمكنك استخدام معالج محلل الجداول لتحديد البيانات المكررة بسرعة. يوفر لك المعالج طريقه بسيطه لتنظيم البيانات في جداول منفصلة ، بحيث يتم تخزينها بالطريقة الأكثر فعاليه. يحافظ Access علي الجدول الأصلي كنسخه احتياطيه ، ثم ينشئ جداول جديده يمكنك استخدامها كاساس لتطبيق قاعده البيانات.

  1. افتح قاعده بيانات Access التي تحتوي علي الجدول الذي تريد تحليله.

  2. علي علامة التبويب أدوات قاعده البيانات ، في المجموعة تحليل ، انقر فوق تحليل الجدول.

    يبدا تشغيل "معالج محلل الجداول".

    تحتوي الصفحتان الاولي من المعالج علي برنامج تعليمي قصير — إكمال مع الأزرار التي يمكنك النقر فوقها للاطلاع علي الامثله. إذا لم تتمكن من رؤية الصفحات التمهيدية ، ولكن بدلا من ذلك ، فراجع خانه الاختيار إظهار الصفحات التمهيدية ؟، حدد خانه الاختيار ، ثم انقر فوق السابق مرتين للاطلاع علي المقدمة. إذا كنت لا تريد رؤية الصفحات التمهيدية مره أخرى بعد قراءه المقدمة ، فيمكنك إلغاء تحديد خانه الاختيار إظهار الصفحات التمهيدية ؟ .

  3. في الجدول الذي يحتوي علي حقول تحتوي علي قيم مكرره في العديد من السجلات ؟ ، حدد الجدول الذي تريد تحليله ، ثم انقر فوق التالي.

  4. يمكنك السماح للمعالج بتحديد الحقول التي تنقلها في اي جدول ، أو يمكنك اتخاذ هذه القرار بنفسك. إذا اتبعت اقتراحات المعالج ، فلا يزال بإمكانك اجراء تغييرات علي تخطيط الجدول في الصفحة التالية من المعالج.

    ملاحظة: إذا قمت بتحديد الحقول التي يجب وضعها في الجداول ، فقد لا تكون الخيارات المناسبة دائما لبياناتك ، خاصه إذا لم تكن هناك بيانات كثيره لاستخدامها. يجب ان تتحقق من نتائج المعالج بعناية. من الناحية الأخرى ، قد يقترح المعالج مؤسسه أكثر فعاليه من تلك التي تعتقد انها ، التالي من المستحسن علي الأقل تجربه قرارات المعالج مره واحده. إذا لم تعجبك الاقتراحات ، فلا يزال بإمكانك أعاده ترتيب الحقول يدويا ، ويمكنك دوما النقر فوق السابق وترتيب كل الحقول بنفسك.

  5. انقر فوق التالي. في هذه الصفحة ، يمكنك تحديد الجداول التي تحتوي علي الحقول. إذا اخترت السماح للمعالج بتحديده ، فيجب ان تري جداول متعددة متصلة بخطوط العلاقات. وبخلاف ذلك ، يقوم Access بإنشاء جدول واحد يحتوي علي كل الحقول. في كلتا الحالتين ، يمكنك اجراء تغييرات علي هذه الصفحة.

    • يمكنك سحب الحقول من جدول إلى منطقه فارغه علي الصفحة لإنشاء جدول جديد يحتوي علي هذه الحقول. يطالبك Access باسم جدول.

    • يمكنك سحب الحقول من جدول إلى آخر في حال كنت تعتقد انه سيتم تخزينها بشكل أكثر فعاليه هناك.

    • سيتم منح معظم الجداول معرفا أو حقل معرف فريد منشا . لمعرفه المزيد حول حقول المعرفات ، انقر فوق تلميحات في الزاوية العلوية اليسرى من المعالج.

    • للتراجع عن تغيير ما ، انقر فوق الزر تراجع .

    • لأعاده تسميه جدول ، انقر نقرا مزدوجا فوق شريط العنوان الخاص به ، واكتب الاسم الجديد ، ثم انقر فوق موافق.

  6. بعد ترتيب الحقول بالطريقة التي تريدها ، انقر فوق التالي.

  7. إذا عثر المعالج علي سجلات تحتوي علي قيم مماثله جدا ، سيتم تحديد هذه القيم كاخطاء مطبعية محتمله وتقديم الشاشة حيث يمكنك التحقق من الإجراءات التي يجب تنفيذها. قم بالتمرير عبر القائمة للعثور علي القيم الموجودة في عمود التصحيح ، ثم انقر فوق العنصر المناسب في القائمة المنسدلة. حدد (اتركه كما هو) لإبقاء المعالج من اجراء اي تغييرات علي القيمة. عند الانتهاء ، انقر فوق التالي.

  8. يسال المعالج عما إذا كنت تريد إنشاء استعلام يشبه الجدول الأصلي. إذا قمت بإنشاء النماذج والتقارير التي تستند إلى الجدول الأصلي ، فان إنشاء هذا الاستعلام يعتبر فكره جيده. إذا اخترت نعم ، فقم بإنشاء الاستعلام، يعيد المعالج تسميه الجدول الأصلي عن طريق إلحاق "_ OLD" إلى اسم الجدول ، ثم يقوم بتسميه الاستعلام الجديد باستخدام اسم الجدول الأصلي. تستخدم النماذج والتقارير التي تستند إلى الجدول الآن الاستعلام الخاص ببياناتها ، وتستمر العمل كما هو الحال.

  9. انقر فوق إنهاء.

    ينشئ المعالج الجداول الجديدة كما هو محدد ، ثم يفتحها. اغلقها عند الانتهاء من فحص النتائج.

أعلى الصفحة

استخدام البيانات من برامج أخرى

يوفر Access 2010 ميزات لاستخدام البيانات المخزنة في برامج أخرى.

إنشاء قاعده بيانات Access جديده ترتبط ببيانات بتنسيق ملف آخر    يمكنك استخدام Access لفتح ملف بتنسيق ملف آخر مثل text أو dBASE أو جدول بيانات. ينشئ Access تلقائيا قاعده بيانات Access ويربط الملف بالنيابة عنك.

  1. بدء الوصول.

  2. على علامة التبويب ملف، انقر فوق فتح.

  3. في مربع الحوار فتح ، انقر فوق نوع الملف الذي تريد فتحه في القائمة. إذا لم تكن متاكدا من نوع الملف ، فانقر فوق كافة الملفات (*. *).

  4. إذا لزم الاجراء ، استعرض وصولا إلى المجلد الذي يحتوي علي الملف الذي تريد فتحه. عند العثور علي الملف ، انقر نقرا مزدوجا فوقه لفتحه.

  5. اتبع التعليمات الواردة في المعالج. في صفحة المعالج الأخيرة، انقر فوق إنهاء.

استيراد بيانات إلى قاعده بيانات Access موجودة أو ربطها    يمكنك اما استيراد البيانات من مصادر وبرامج أخرى إلى جداول Access بحيث يتم تضمين البيانات في ملف access ، أو يمكنك إنشاء ارتباط إلى البيانات من Access بحيث تبقي البيانات في الملف الأصلي (خارج ملف Access).

  1. علي علامة التبويب بيانات خارجيه ، في المجموعة استيراد ارتباط _amp_ ، انقر فوق التنسيق الذي تم فيه تخزين البيانات.

    يمكنك استيراد البيانات أو إنشاء ارتباط اليها من المصادر التالية:

    • Excel    يمكنك إحضار البيانات من ورقه عمل أو نطاق مسمي في مصنف Excel. يجب استيراد كل ورقه عمل أو نطاق مسمي أو ربطها بشكل منفصل.

    • Access    يعتبر هذا الأمر مفيدا لفصل العملية عن البيانات ، مما يؤدي إلى إنشاء قاعده بيانات منقسمة. يمكنك استخدام قاعده بيانات واحده لتحتوي علي كل النماذج والتقارير ووحدات الماكرو والاحتفاظ بالبيانات في قاعده بيانات أخرى. يمكنك بعد ذلك تطوير التحسينات من دون مقاطعه عمل اي شخص. يمكنك أيضا دمج البيانات من قواعد بيانات Access مختلفه في واحد ، مما يسهل تلخيص البيانات عبر الأقسام أو بين شركاء العمل.

    • قاعدة بيانات ODBC    تدعم العديد من البرامج هذا التنسيق ، بما في ذلك العديد من منتجات خوادم قاعده البيانات. يساعدك هذا في إنشاء قواعد بيانات "لوحه الهبوط" ، حيث يمكنك دمج البيانات من أنظمه مختلفه.

    • ملف نصي    يمكنك الاتصال بملف نصي بسيط ، ويمكنك أيضا استخدام Access لتغيير محتويات هذا الملف. يمكن ان يساعد هذا في جعل بيانات Access سهله الاستخدام بواسطة مجموعه كبيره من البرامج.

    • ملف XML    يوفر لك هذا التنسيق أيضا التوافق مع مجموعه متنوعة من البرامج الأخرى ، بما في ذلك بعض خوادم الويب.

    • قائمة SharePoint    يؤدي ذلك إلى جعل البيانات الخاصة بك قابله للاستخدام باستخدام مستعرض ويب ، وهي الطريقة القياسية لاستخدام قائمه SharePoint.

    • Data Services    يمكنك الاتصال بخدمات بيانات ويب داخل المؤسسة.

    • مستند HTML    

    • مجلد Outlook    يمكنك الاتصال بمجلدات Outlook ، لكي تتمكن من دمج معلومات جات الاتصال الخاصة بك بسهوله مع باقي بياناتك.

    • ملف dBase    dBase هو نظام قاعده بيانات بديل شائع الدعم بواسطة Access

      يظهر مربع الحوار إحضار بيانات خارجيه .

  2. اتبع الإرشادات الموجودة في مربع الحوار.

    سيقوم Access باستيراد البيانات أو ربطها بقاعده بياناتك. بالنسبة إلى معظم التنسيقات ، يجب تحديد موقع البيانات ، ثم اختيار الطريقة التي تريد بها تخزين البيانات في قاعده البيانات.

أعلى الصفحة

استخدام قاعده بيانات ذات إصدار سابق في عده إصدارات من Access

إذا تم إنشاء قاعده بيانات access أو مشروع access في access 2000 أو الإصدارات الأحدث ، فيمكنك استخدام قاعده البيانات أو المشروع في إصدار access الذي تم إنشاؤه فيه أو في اي إصدار لاحق ، حتى لو كان الملف ممكنا أمانا. علي سبيل المثال ، يمكن استخدام ملفات access 2000 في access 2000 و access 2002 و access 2003 و access 2007 و access 2010.

قد يكون لديك موقف ترغب في الاحتفاظ بالبيانات فيه في إصدار سابق من access ، ولكن لديك المستخدمون الذين لديهم إصدارات أحدث من access التي تريد ربطها بتلك البيانات ولكن لا تزال تستفيد من بعض ميزات الإصدار الأحدث. الحل هو إنشاء قاعده بيانات "النهاية الاماميه" جديده في الإصدار الأحدث (التي تحتوي علي النماذج والتقارير والاستعلامات ووحدات الماكرو ولكن بدون جداول) ، وربطها بالجداول الموجودة في ملف الإصدارات السابق. استخدم أحد الإجراءات التالية ، استنادا إلى ما إذا كانت قاعده البيانات الخاصة بك مضمنه في ملف واحد أو تم تقسيمها بالفعل إلى التطبيق الموجود على الكمبيوتر العميل/الخادم.

استخدام ملف قاعده بيانات access في إصدارات متعددة من Access

إذا كانت كل الجداول والنماذج والعناصر الأخرى الخاصة بقاعده بيانات access الإصدارات السابقة مضمنه في ملف واحد ، وكانت تريد استخدام قاعده البيانات في إصدارات متعددة من Access ، فيمكنك إنشاء قاعده بيانات جديده للجهة الاماميه في إصدار لاحق وربطها بالملف الأصلي. لا يزال بإمكان المستخدمين الذين لديهم الإصدار السابق من Access استخدام قاعده البيانات الاصليه. يمكن للمستخدمين الذين لديهم الإصدار الأحدث استخدام قاعده البيانات الاماميه الجديدة لإنشاء ارتباط إلى البيانات نفسها. يمكنك إنشاء العديد من الإصدارات الاماميه إذا كنت بحاجه إلى استيعاب إصدارات متعددة من Access.

أعلى الصفحة

الخطوة 1: إنشاء نسخه عن قاعده البيانات الموجودة ، وحفظها بتنسيق جديد

استخدم الاجراء التالي لتحويل قاعده البيانات إلى اي من التنسيقات الثلاثة الأحدث: Access 2000 أو access 2002-2003 أو access 2007. يحافظ هذا الأمر علي قاعده البيانات الاصليه بتنسيقها الأصلي ، وينشئ نسخه بالتنسيق الذي تحدده.

  1. اغلق ملف Access. إذا كان الملف عبارة عن قاعده بيانات Access متعددة الوصول موجودة علي خادم أو في مجلد مشترك ، فتاكد من انه لم يتم فتحه من قبل اي شخص آخر.

  2. أبدا الوصول إلى 2010.

  3. على علامة التبويب ملف، انقر فوق فتح.

  4. استعرض وصولا إلى موقع الملف الذي تريد تحويله ، ثم انقر نقرا مزدوجا فوقه لفتحه.

    إذا ظهر مربع الحوار تحسين قاعده البيانات ، فأسال ما إذا كنت تريد تحسين قاعده البيانات ، انقر فوق لا.

  5. إذا تم فتح نموذج عند بدء تشغيل قاعده البيانات ، فاغلق النموذج.

  6. علي علامة التبويب ملف ، انقر فوق حفظ قاعده البيانات باسم.

  7. في مربع الحوار حفظ باسم ، اكتب اسما لقاعده البيانات الجديدة.

    ملاحظة: إذا لم تحفظ قاعده البيانات الجديدة في موقع مختلف ، فيجب ان يكون اسمها مختلفا عن تلك الموجودة في قاعده البيانات الاصليه. في كلتا الحالتين ، يفضل عاده استخدام اسم مختلف ، بحيث يمكنك التمييز بسهوله بين قاعده البيانات الموجودة علي الجانب الامامي وقاعده البيانات الموجودة علي الخادم. ومع ذلك ، إذا كنت تقوم بالتحويل إلى تنسيق Access 2007 ، سيتغير ملحق اسم الملف من .mdb إلى accdb ، بحيث يمكنك استخدام اسم الملف نفسه.

  8. انقر فوق حفظ.

أعلى الصفحة

الخطوة 2: تقسيم قاعده البيانات المنسوخة ، واستخدام الملف الأصلي كقاعده البيانات الموجودة علي الخادم

تقسيم قاعده البيانات المحولة باستخدام الاجراء التالي:

  • علي علامة التبويب أدوات قاعده البيانات ، في المجموعة نقل البيانات ، انقر فوق قاعده بيانات Access. صورة الزر

  • في مربع الحوار تقسيم قاعده البيانات ، انقر فوق تقسيم قاعده البيانات.

    يمكنك إنشاء نسخه احتياطيه إذا أردت ، ولكن يمكنك أيضا أعاده إنشاء النسخة باستخدام قاعده البيانات الاصليه.

  • اكتب اسما لقاعده البيانات الموجودة علي الخادم ، ثم انقر فوق انقسام.

أعلى الصفحة

الخطوة 3: توصيل الطرف الامامي الجديد بقاعده البيانات الاصليه

  1. احذف قاعده البيانات الموجودة علي الخادم التي انشاتها أداه تقسيم قاعده البيانات-انتبه إلى عدم حذف قاعده البيانات الاصليه.

  2. ربط قاعده البيانات الاماميه الجديدة بالجداول الموجودة في قاعده البيانات الاصليه: ضمن علامة التبويب بيانات خارجيه ، في المجموعة استيراد ارتباط _amp_ ، انقر فوق أداره الجداولالمرتبطة. صورة الزر

  3. انقر فوق تحديد الكل، ثم حدد خانه الاختيار المطالبة دوما بموقع جديد .

  4. انقر فوق موافق، واستعرض وصولا إلى قاعده بيانات الإصدارات السابقة ، ثم انقر نقرا مزدوجا فوقها.

    إذا كان كل شيء جيدا ، يعرض Access رسالة تفيد بأنه تم تحديث كل الجداول المرتبطة المحددة بنجاح.

يمكنك الآن تحسين قاعده البيانات الاماميه الجديدة لدعم الميزات الجديدة للمستخدمين الذين لديهم إصدارات أحدث من Access. يمكن للمستخدمين الذين لديهم إصدارات سابقه الاستمرار باستخدام قاعده بيانات الإصدارات السابقة.

أعلى الصفحة

استخدام تطبيق الاتصال الامامي/الخلفي في إصدارات متعددة من Access

إذا كانت قاعده بيانات Access الخاصة بك التطبيق الموجود على الكمبيوتر العميل/الخادم ه بالفعل ، فيمكنك تحويل الواجهة الاماميه إلى تنسيق الملف الجديد. لا توجد اي تغييرات ضرورية لقاعده البيانات الموجودة علي الخادم.

يوضح الاجراء التالي كيفيه استخدام الأمر " حفظ قاعده البيانات باسم " لتحويل قاعده البيانات الموجودة علي الجانب الامامي إلى أحدي التنسيقات الثلاثة الأحدث: Access 2000 أو access 2002-2003 أو access 2007. يحافظ هذا الأمر علي قاعده البيانات الاصليه بتنسيقها الأصلي وينشئ نسخه بالتنسيق الذي تحدده.

  1. اغلق قاعده البيانات الموجودة علي الجانب الامامي. إذا كان الملف عبارة عن قاعده بيانات Access متعددة الأشخاص موجودة علي خادم أو في مجلد مشترك ، فتاكد من عدم فتح اي شخص آخر.

  2. أبدا الوصول إلى 2010.

  3. على علامة التبويب ملف، انقر فوق فتح.

  4. استعرض وصولا إلى موقع قاعده البيانات الموجودة علي الخادم ، ثم انقر نقرا مزدوجا فوقه لفتحه.

    إذا ظهر مربع الحوار تحسين قاعده البيانات ، فأسال ما إذا كنت تريد تحسين قاعده البيانات ، انقر فوق لا.

  5. إذا ظهر نموذج عند فتح قاعده البيانات ، فاغلق النموذج.

  6. علي علامة التبويب ملف ، انقر فوق حفظ قاعده البيانات باسم.

  7. في مربع الحوار حفظ باسم ، اكتب اسما لقاعده البيانات الجديدة.

  8. انقر فوق حفظ.

يمكنك الآن تحسين قاعده البيانات الاماميه الجديدة لدعم الميزات الجديدة.

أعلى الصفحة

تعزيز مهارات Office
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×