الخطوة 4 - مشاركة الماكرو مع الآخرين

هام: تمت ترجمة هذه المقالة ترجمة آلية، راجع إقرار إخلاء المسؤولية. يرجى الاطلاع على النسخة الإنجليزية من هذه المقالة. هنا للرجوع إليها.

إن الشيء الهام الذي ينبغي فهمه حول مشاركة وحدات الماكرو هو أنه يتم تخزينها في ملف Office، لذلك ستحتاج إلى مشاركة هذا الملف مع الآخرين. إذا أنشأت ماكرو في Word، فستحتاج إلى مشاركة الملف كقالب Word به وحدات ماكرو ممكنة (dotm.) أو مستند Word به وحدات ماكرو ممكنة (docm.). وإذا أنشأت الماكرو في Excel، فستحتاج إلى مشاركة الملف كمصنف Excel به وحدات ماكرو ممكنة (xlsm.) أو قالب Excel به وحدات ماكرو ممكنة (xltm.).

إذا أنشأت ماكرو في Word، فهناك بضع خطوات إضافية ستحتاج إلى تنفيذها لمشاركة هذا الماكرو:

إنشاء قالب Word الفارغ

  1. افتح مستند Word جديداً.

  2. من القائمة ملف، انقر فوق حفظ باسم.

  3. قم بتعيين الاسم global_macros.dotm إلى الملف.

  4. من القائمة المنسدلة تنسيق، حدد قالب Word به وحدات ماكرو ممكنة (‎*.dotm) كـ تنسيق.

  5. اختر المكان الذي تريد تخزين الملف فيه على الشبكة.

  6. انقر فوق حفظ، ثم أغلق القالب.

تصدير ماكرو Word من المستند

باستخدام الماكرو الذي سجلته في الخطوة 1، اتبع الخطوات التالية هذه لتصدير الماكرو:

  1. افتح المستند أو القالب الذي يحتوي على الماكرو الذي تريد تصديره.

  2. من القائمة أدوات، أشر إلى ماكرو، ثم انقر فوق وحدات ماكرو.

  3. حدد الماكرو الذي تريد تصديره، ثم انقر فوق تحرير. تحديد ماكرو لتصديره

  4. في "محرر Visual Basic"، انقر فوق ملف > تصدير الملف.

  5. احفظ الماكرو في المجلد نفسه الذي حفظت القالب الذي به وحدات ماكرو ممكنة فيه وهو global_macros.dotm.

استيراد ماكرو Word إلى القالب الفارغ الجديد

  1. افتح global_macros.dotm ثم انقر فوق أدوات > ماكرو > محرر Visual Basic.

  2. لاستيراد الماكرو، انقر فوق ملف > استيراد الملف، وانتقل إلى المجلد الذي قمت بتصدير الماكرو إليه، ثم حدد الملف، وانقر فوق فتح.

  3. احفظ الوحدة النمطية، وقم بإنهاء "محرر Visual Basic" ثم إنهاء Word.

يمكنك الآن مشاركة الماكرو مع الآخرين، وإعلامهم باتباع الخطوات الموجودة أدناه لتثبيت هذا الماكرو على أجهزة الكمبيوتر المتوفرة لديهم.

تثبيت القالب: إعداد Word لاستخدام الماكرو

  1. ضع الملف global_macro.dotm في هذا الموقع:

    • Word for Mac 2011: Macintosh HD: Users: Username: Library: Application Support: Microsoft: Office: User Templates: My Templates

    • Word 2003 أو إصدار أحدث على Windows:‏ C:\Documents and Settings\Username\Application Data\Microsoft\Word\STARTUP

      ملاحظة:  يُعد اسم المستخدم اسم تسجيل الدخول الخاص بالمستخدم.

  2. في Word، انقر فوق Word > تفضيلات….

تفضيلات Word

  1. في القسم إعدادات شخصية، انقر فوق مواقع الملفات

  2. حدد بدء التشغيل من القائمة مواقع الملفات، ثم انقر فوق تعديل….

موقع الملف

  1. تحقق من أن Word يستخدم المجلد نفسه الذي وضعت الملف global_macro.dotm فيه كمجلد "بدء التشغيل".

  2. انقر فوق اختيار لإغلاق مربع الحوار اختيار مجلد، ثم انقر فوق موافق لإغلاق مربع الحوار "مواقع الملفات".

تتمثل خطوتك الأخيرة في إعلام Word باستخدام الملف global_macros.dotm عند بدء تشغيله.

  1. في Word، انقر فوق أدوات > قوالب ووظائف إضافية….

  2. حدد الملف global_macros.dotm من القائمة ثم انقر فوق موافق.

    تلميح:  إذا لم يظهر قالبك في القائمة، فهذا يعني أن الملف global_macros.dotm غير موجود في مجلد بدء التشغيل لـ Word. قم بالعودة إلى الخطوة 1 في هذا القسم ثم تحقق من أن مجلد بدء التشغيل هو المجلد نفسه الذي نسخت الملف global_macros.dotm إليه.

إعداد قالب عمومي في Word

 الخطوة 1 - البدء باستخدام مسجل الماكرو

الخطوة 2 - قراءة التعليمات البرمجية وفهمها

الخطوة 3 - التعرّف على أساسيات البرمجة

الخطوة 4 - مشاركة الماكرو مع الآخرين

الخطوة 5 - أمثلة من العالم الحقيقي

ملاحظة: إقرار إخلاء المسؤولية للترجمة الآلية: تمت ترجمة هذه المقالة بواسطة نظام كمبيوتر دون تدخل العامل البشري. توفر Microsoft هذه الترجمات الآلية لمساعدة المستخدمين الذين لا يتحدثون الإنجليزية على استخدام منتجات Microsoft، وخدماتها، وتقنياتها والاستمتاع بها. قد تحتوي هذه المقالة على أخطاء في المفردات، أو بناء الجملة، أو القواعد نظرًا لترجمتها آليًا.

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×