الحصول على تعليمات حول استخدام محرر Visual Basic

يقوم Microsoft Visual Basic for Applications (VBA) بتمكين غير المبرمجين لتسجيل وإنشاء وتحرير وحدات الماكرو التي يمكنها تنفيذ المهام في تطبيقات Office تلقائياً. توضح هذه المقالة المواقع التي يمكنك العثور فيها على تعليمات عند استخدامك محرر Visual Basic الوارد في تطبيق Office.

  1. في علامة التبويب إنشاء، في المجموعة ماكرو وتعليمات برمجية، انقر فوق Visual Basic

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. إذا لم تكن قد استخدمت تعليمات VBA Access من قبل، فستتم مطالبتك باختيار المستعرض الذي تريد عرض التعليمات فيه.

  4. في المستعرض، على الجزء الأيمن، ضمن Access، قم بتوسيع مرجع Access VBA.

  5. في الجزء الأيمن، استعرض بحثاً عن المفهوم أو الإجراء أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام في مربع البحث الموجود في الزاوية العلوية اليسرى من الشاشة.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. إذا لم تكن قد استخدمت تعليمات VBA Excel من قبل، فستتم مطالبتك باختيار المستعرض الذي تريد عرض التعليمات فيه.

  4. في المستعرض، على الجزء الأيمن، ضمن Excel، قم بتوسيع مرجع Excel VBA.

  5. في الجزء الأيمن، استعرض بحثاً عن المفهوم أو الإجراء أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام في مربع البحث الموجود في الزاوية العلوية اليسرى من الشاشة.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. إذا لم تكن قد استخدمت تعليمات VBA Outlook من قبل، فستتم مطالبتك باختيار المستعرض الذي تريد عرض التعليمات فيه.

  4. في المستعرض، على الجزء الأيمن، ضمن Outlook، قم بتوسيع مرجع Outlook VBA.

  5. في الجزء الأيمن، استعرض بحثاً عن المفهوم أو الإجراء أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام في مربع البحث الموجود في الزاوية العلوية اليسرى من الشاشة.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. إذا لم تكن قد استخدمت تعليمات VBA PowerPoint من قبل، فستتم مطالبتك باختيار المستعرض الذي تريد عرض التعليمات فيه.

  4. في المستعرض، على الجزء الأيمن، ضمن PowerPoint، قم بتوسيع مرجع PowerPoint VBA.

  5. في الجزء الأيمن، استعرض بحثاً عن المفهوم أو الإجراء أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام في مربع البحث الموجود في الزاوية العلوية اليسرى من الشاشة.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. إذا لم تكن قد استخدمت تعليمات VBA Visio من قبل، فستتم مطالبتك باختيار المستعرض الذي تريد عرض التعليمات فيه.

  4. في المستعرض، في الجزء الأيمن، ضمن Visio، قم بتوسيع مرجع Visio VBA.

  5. في الجزء الأيمن، استعرض بحثاً عن المفهوم أو الإجراء أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام في مربع البحث الموجود في الزاوية العلوية اليسرى من الشاشة.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. إذا لم تكن قد استخدمت تعليمات VBA Word من قبل، فستتم مطالبتك باختيار المستعرض الذي تريد عرض التعليمات فيه.

  4. في المستعرض، في الجزء الأيمن، ضمن Word، قم بتوسيع مرجع Word VBA.

  5. في الجزء الأيمن، استعرض بحثاً عن المفهوم أو الإجراء أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام في مربع البحث الموجود في الزاوية العلوية اليسرى من الشاشة.

  1. ضمن علامة التبويب أدوات قاعدة البيانات، في المجموعة ماكرو، انقر فوق Visual Basic.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. إذا لم تكن قد استخدمت تعليمات VBA Access من قبل، فستتم مطالبتك باختيار المستعرض الذي تريد عرض التعليمات فيه.

  4. في المستعرض، على الجزء الأيمن، ضمن Access، قم بتوسيع مرجع Access VBA.

  5. في الجزء الأيمن، استعرض بحثاً عن المفهوم أو الإجراء أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام في مربع البحث الموجود في الزاوية العلوية اليسرى من الشاشة.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. إذا لم تكن قد استخدمت تعليمات VBA Excel من قبل، فستتم مطالبتك باختيار المستعرض الذي تريد عرض التعليمات فيه.

  4. في المستعرض، على الجزء الأيمن، ضمن Excel، قم بتوسيع مرجع Excel VBA.

  5. في الجزء الأيمن، استعرض بحثاً عن المفهوم أو الإجراء أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام في مربع البحث الموجود في الزاوية العلوية اليسرى من الشاشة.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. إذا لم تكن قد استخدمت تعليمات VBA Outlook من قبل، فستتم مطالبتك باختيار المستعرض الذي تريد عرض التعليمات فيه.

  4. في المستعرض، على الجزء الأيمن، ضمن Outlook، قم بتوسيع مرجع Outlook VBA.

  5. في الجزء الأيمن، استعرض بحثاً عن المفهوم أو الإجراء أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام في مربع البحث الموجود في الزاوية العلوية اليسرى من الشاشة.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. إذا لم تكن قد استخدمت تعليمات VBA PowerPoint من قبل، فستتم مطالبتك باختيار المستعرض الذي تريد عرض التعليمات فيه.

  4. في المستعرض، على الجزء الأيمن، ضمن PowerPoint، قم بتوسيع مرجع PowerPoint VBA.

  5. في الجزء الأيمن، استعرض بحثاً عن المفهوم أو الإجراء أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام في مربع البحث الموجود في الزاوية العلوية اليسرى من الشاشة.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. إذا لم تكن قد استخدمت تعليمات VBA Visio من قبل، فستتم مطالبتك باختيار المستعرض الذي تريد عرض التعليمات فيه.

  4. في المستعرض، في الجزء الأيمن، ضمن Visio، قم بتوسيع مرجع Visio VBA.

  5. في الجزء الأيمن، استعرض بحثاً عن المفهوم أو الإجراء أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام في مربع البحث الموجود في الزاوية العلوية اليسرى من الشاشة.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. إذا لم تكن قد استخدمت تعليمات VBA Word من قبل، فستتم مطالبتك باختيار المستعرض الذي تريد عرض التعليمات فيه.

  4. في المستعرض، في الجزء الأيمن، ضمن Word، قم بتوسيع مرجع Word VBA.

  5. في الجزء الأيمن، استعرض بحثاً عن المفهوم أو الإجراء أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام في مربع البحث الموجود في الزاوية العلوية اليسرى من الشاشة.

  1. ضمن علامة التبويب أدوات قاعدة البيانات، في المجموعة ماكرو، انقر فوق Visual Basic.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. في مربع البحث، اكتب الأسلوب أو الخاصية أو الدالة أو البيان أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. في مربع البحث، اكتب الأسلوب أو الخاصية أو الدالة أو البيان أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Visual Basic Microsoft.

  3. في مربع البحث، اكتب الأسلوب أو الخاصية أو الدالة أو البيان أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. في مربع البحث، اكتب الأسلوب أو الخاصية أو الدالة أو البيان أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. في مربع البحث، اكتب الأسلوب أو الخاصية أو الدالة أو البيان أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    إذا لم تظهر علامة التبويب مطور:

    1. انقر فوق ملف > خيارات.

    2. انقر فوق تخصيص الشريط، وضمن علامات تبويب رئيسية، حدد خانة اختيار مطور.

    3. انقر فوق موافق.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Microsoft Visual Basic for Applications.

  3. في مربع البحث، اكتب الأسلوب أو الخاصية أو الدالة أو البيان أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه أو اكتب استعلام.

  1. ضمن علامة التبويب أدوات قاعدة البيانات، في المجموعة ماكرو، انقر فوق Visual Basic.

  2. في محرر Visual Basic، في القائمة تعليمات، انقر فوق تعليمات Visual Basic Microsoft.

  3. في النافذة تعليمات، انقر فوق مرجع Access VBA.

  4. في مربع اكتب كلمات للبحث عن، اكتب الأسلوب أو الخاصية أو الدالة أو البيان أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه، أو اكتب استعلام.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    لا يمكنني رؤية علامة التبويب مطور

    1. انقر فوق زر Microsoft Office‏صورة زر Office ، ثم انقر فوق خيارات Excel‏.

    2. انقر فوق شائع، ثم حدد خانة الاختيار إظهار علامة التبويب "المطور" في الشريط.

      ملاحظة: يشكل الشريط جزءاً من واجهة مستخدم Microsoft Office Fluent

  2. في القائمة تعليمات، انقر فوق تعليمات Visual Basic Microsoft.

  3. في مربع اكتب كلمات للبحث عن، اكتب الأسلوب أو الخاصية أو الدالة أو البيان أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه، أو اكتب استعلام.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    لا يمكنني رؤية علامة التبويب مطور

    1. من قائمة أدوات، انقر فوق خيارات.

    2. في علامة التبويب أخرى، انقر فوق خيارات متقدمة، ثم حدد خانة الاختيار إظهار علامة التبويب "المطور" في الشريط.

  2. في القائمة تعليمات، انقر فوق تعليمات Visual Basic Microsoft.

  3. في مربع اكتب كلمات للبحث عن، اكتب الأسلوب أو الخاصية أو الدالة أو البيان أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه، أو اكتب استعلام.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    لا يمكنني رؤية علامة التبويب مطور

    1. انقر فوق زر Microsoft Office‏ صورة زر Office ، ثم فوق خيارات PowerPoint‏.

    2. انقر فوق شائع، ثم حدد خانة الاختيار إظهار علامة التبويب "المطور" في الشريط.

      ملاحظة: يشكل الشريط جزءاً من واجهة مستخدم Microsoft Office Fluent

  2. في القائمة تعليمات، انقر فوق تعليمات Visual Basic Microsoft.

  3. في مربع اكتب كلمات للبحث عن، اكتب الأسلوب أو الخاصية أو الدالة أو البيان أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه، أو اكتب استعلام.

  1. في القائمة تعليمات، انقر فوق مرجع المطور.

    كيفية التشغيل في وضع المطور؟

    1. من قائمة أدوات، انقر فوق خيارات.

    2. في علامة التبويب خيارات متقدمة، ضمن خيارات متقدمة، حدد خانة الاختيار التشغيل في وضع المطور.

  2. في النافذة تعليمات، انقر فوق مرجع اللغة لـ Visual Basic for Applications

  3. في مربع اكتب كلمات للبحث عن، اكتب الأسلوب أو الخاصية أو الدالة أو البيان أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه، أو اكتب استعلام.

  1. في علامة التبويب مطور، انقر فوق Visual Basic.

    لا يمكنني رؤية علامة التبويب مطور

    1. انقر فوق زر Microsoft Office‏ صورة زر Office ، ثم انقر فوق خيارات Word‏.

    2. انقر فوق شائع، ثم حدد خانة الاختيار إظهار علامة التبويب "المطور" في الشريط.

      ملاحظة: يشكل الشريط جزءاً من واجهة مستخدم Microsoft Office Fluent

  2. في القائمة تعليمات، انقر فوق تعليمات Visual Basic Microsoft.

  3. في مربع اكتب كلمات للبحث عن، اكتب الأسلوب أو الخاصية أو الدالة أو البيان أو العنصر الذي تريد الحصول على تعليمات بشأن استخدامه، أو اكتب استعلام.

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×