استيراد البيانات أو إنشاء ارتباط إليها في قاعدة بيانات SQL Server

استيراد البيانات أو إنشاء ارتباط إليها في قاعدة بيانات SQL Server

يمكنك إنشاء ارتباط إلى البيانات أو استيرادها من قاعدة بيانات SQL، وهي قاعدة بيانات مدارة بأداء عالٍ تُستخدم مع التطبيقات ذات البيانات الحرجة. لمزيد من المعلومات، راجع SQL Server 2016‏.

  • عند إنشاء ارتباط إلى البيانات، يقوم Access بإنشاء اتصال ثنائي الاتجاه يقوم بمزامنة التغييرات على البيانات الموجودة في قاعدة بيانات SQL وAccess.

  • عند استيراد البيانات، يقوم Access بإنشاء نسخة من البيانات لمرة واحدة، لذلك لا تتم مزامنة التغييرات على البيانات الموجودة في قاعدة بيانات SQL أو Access.

نظرة عامة حول اتصال Access بـ SQL Server

قبل البدء

هل تريد أن تسير الأمور بسلاسة؟ قم بإعداد التحضيرات التالية قبل الاستيراد أو الارتباط:

  • تحديد اسم خادم قاعدة البيانات SQL Server وتحديد معلومات الاتصال اللازمة واختيار أسلوب مصادقة (Windows أو SQL Server). لمزيد من المعلومات حول أساليب المصادقة، راجع الاتصال بالخادم (محرك قاعدة البيانات) وتأمين قاعدة البيانات.

  • تحديد الجداول أو طرق العرض التي تريد إنشاء ارتباط إليها أو استيرادها، بالإضافة إلى الحقول ذات القيم الفريدة للجداول المرتبطة. يمكنك استيراد أكثر من جدول أو إنشاء ارتباط إليه أو عرضه في عملية واحدة.

  • مراعاة عدد الأعمدة الموجودة في كل جدول أو طريقة عرض. لا يدعم Access أكثر من 255 حقلاً في جدول، لذلك يقوم Access باستيراد أول 255 عموداً فقط أو إنشاء ارتباط إليها. ويمكنك، كحل بديل، إنشاء طريقة عرض في قاعدة بيانات SQL Server للوصول إلى الأعمدة التي تتجاوز الحد.

  • تحديد إجمالي مقدار البيانات التي يتم استيرادها. يبلغ الحد الأقصى لحجم قاعدة بيانات Access‎‏ 2 غيغابايت، مطروحاً منه المساحة اللازمة لعناصر النظام. إذا احتوت قاعدة بيانات SQL Server على جداول كبيرة، فقد لا تتمكن من استيرادها كلها إلى قاعدة بيانات Access واحدة. في هذه الحالة، يمكنك مراعاة إنشاء ارتباط إلى البيانات بدلاً من استيرادها.

  • تأمين قاعدة بيانات Access ومعلومات الاتصال التي يحتوي عليها باستخدام موقع موثوق به وكلمة مرور لقاعدة بيانات Access. هذا أمر في غاية الأهمية إذا كنت ترغب في حفظ كلمة مرور SQL Server في Access.

  • التخطيط لإنشاء علاقات إضافية. لا يقوم Access تلقائياً بإنشاء علاقات بين الجداول المرتبطة في نهاية عملية الاستيراد. يمكنك إنشاء العلاقات يدوياً بين الجداول الجديدة والموجودة باستخدام نافذة "علاقات". لمزيد من المعلومات، راجع ما هي نافذة "علاقات"؟ وإنشاء علاقة أو تحريرها أو حذفها.

المرحلة 1: بدء الاستخدام

  1. حدد بيانات خارجية > مصدر بيانات جديد > من قاعدة البيانات > من SQL Server‎‏.

  2. في مربع الحوار إحضار بيانات خارجية - قاعدة بيانات ODBC‎‏، قم بأحد الإجراءات التالية:

    • لاستيراد البيانات، حدد استيراد بيانات المصدر إلى جدول جديد في قاعدة البيانات الحالية.

    • لإنشاء ارتباط إلى البيانات، حدد إنشاء ارتباط إلى مصدر البيانات عن طريق إنشاء جدول مرتبط.

  3. حدد موافق.

المرحلة 2: إنشاء ملف DSN أو إعادة استخدامه

يمكنك إنشاء ملف DSN أو إعادة استخدام ملف موجود. استخدم ملف DSN عندما تريد الاعتماد على معلومات الاتصال نفسها لعمليات الربط والاستيراد المختلفة أو للمشاركة مع تطبيق آخر يستخدم ملفات DSN أيضاً. يمكنك إنشاء ملف DSN مباشرة باستخدام "إدارة اتصال البيانات". لمزيد من المعلومات، راجع إدارة مصادر بيانات ODBC‎‏.

على الرغم من أنه ما زال بإمكانك استخدام إصدارات سابقة من برنامج تشغيل SQL ODBC، نوصيك باستخدام الإصدار 13.1، الذي يحتوي على العديد من التحسينات، ويدعم ميزات SQL Server 2016 الجديدة. لمزيد من المعلومات، راجع برنامج تشغيل Microsoft ODBC لـ SQL Server في Windows‎‏.

  1. نفّذ أحد الإجراءات التالية:

    • إذا كان ملف DSN الذي تريد استخدامه موجوداً بالفعل، فحدده من القائمة.

      مربع الحوار "تحديد مصدر البيانات"

      وفقاً لأسلوب المصادقة الذي أدخلته في معلومات الاتصال، قد يتعين عليك إدخال كلمة مرور مجدداً.

    • لإنشاء ملف DSN جديد:

      1. حدد جديد.

        مربع حوار "إنشاء مصدر بيانات جديد"
      2. حدد برنامج تشغيل ODBC‎‏ 13 لـ SQL Server‎‏، ثم حدد التالي.

      3. أدخل اسم ملف DSN، أو انقر فوق استعراض لإنشاء الملف في موقع آخر.

  2. انقر فوق التالي لمراجعة المعلومات التلخيصية، ثم انقر فوق إنهاء.

المرحلة 3: استخدام المعالج "إنشاء مصدر بيانات جديد إلى SQL Server"

في المعالج إنشاء مصدر بيانات جديد إلى SQL Server‎‏، قم بما يلي:

  1. على الصفحة الأولى، أدخل معلومات التعريف:

    • في المربع الوصف، أدخل معلومات وثائقية حول ملف DSN اختيارياً.

    • في المربع خادم، أدخل اسم SQL Server. لا تنقر فوق السهم لأسفل.

  2. على الصفحة الثانية، حدد أحد أساليب المصادقة التالية:

    • باستخدام مصادقة Windows المتكاملة    يمكنك الاتصال عبر حساب مستخدم Windows. بشكل اختياري، أدخل اسم الخدمة الأساسية (SPN). لمزيد من المعلومات، راجع أسماء الخدمات الأساسية (SPN) في اتصالات العميل (‎‏‎‏‎‏ODBC‎‏‎‏)‎‏.

    • باستخدام مصادقة SQL Server‎‏...   ، يمكنك الاتصال باستخدام بيانات الاعتماد التي تم إعدادها في قاعدة البيانات من خلال إدخال معرف تسجيل الدخول وكلمة المرور.

  3. في الصفحتين الثالثة والرابعة، حدد خيارات مختلفة لتخصيص الاتصال. لمزيد من المعلومات حول هذه الخيارات، راجع برنامج تشغيل Microsoft ODBC لـ SQL Server‎‏.

  4. تظهر شاشة لتأكيد إعداداتك. حدد اختبار مصدر البيانات لتأكيد الاتصال.

  5. قد يتعين عليك تسجيل الدخول إلى قاعدة البيانات. في مربع الحوار تسجيل الدخول إلى SQL Server‏، أدخل معرف تسجيل الدخول وكلمة المرور. لتغيير إعدادات إضافية، حدد خيارات.

المرحلة 4: تحديد الجداول التي يجب إنشاء ارتباط إليها أو استيرادها

  1. في مربع الحوار إنشاء ارتباط إلى الجداول أو استيراد العناصر، ضمن الجداول، حدد كل جدول أو طريقة عرض تريد إنشاء ارتباط إليها أو استيرادها، ثم انقر فوق موافق.

    قائمة الجداول التي يجب إنشاء ارتباط إليها أو استيرادها
  2. في عملية إنشاء الارتباط، حدد ما إذا كنت تريد تحديد حفظ كلمة المرور.

    الأمان    يؤدي تحديد هذا الخيار إلى عدم ضرورة إدخال بيانات الاعتماد في كل مرة تفتح فيها Access وتصل إلى البيانات. غير أن هذا الخيار يخزن كلمة مرور غير المشفرة في قاعدة بيانات Access، مما يعني أنه يمكن للأشخاص الذين يمكنهم الوصول إلى محتويات المصدر الاطلاع على اسم المستخدم وكلمة المرور. إذا حددت هذا الخيار، فإننا نوصيك بشدة بتخزين قاعدة بيانات Access في موقع موثوق به وإنشاء كلمة مرور قاعدة بيانات Access. لمزيد من المعلومات، راجع اتخاذ قرار الثقة في قاعدة بيانات وتشفير قاعدة البيانات باستخدام كلمة مرور قاعدة البيانات.

المرحلة 5: إنشاء المواصفات والمهام (استيراد فقط)

النتائج

عند اكتمال عملية إنشاء الارتباط أو الاستيراد، تظهر الجداول في "جزء التنقل" باستخدام نفس اسم جدول SQL Server أو طريقة العرض المقترنة باسم المالك. على سبيل المثال، إذا كان اسم SQL هو dbo. فإن اسم Access هو dbo_Product. إذا كان هذا الاسم قيد الاستخدام بالفعل، يقوم Access بإلحاق "1" إلى اسم الجدول الجديد، على سبيل المثال، dbo_Product1. إذا كان أيضاً dbo_Product1 قيد الاستخدام بالفعل، فسيقوم Access بإنشاء dbo_Product2، وهكذا. ولكن يمكنك إعادة تسمية الجداول بأسماء ذات معنى أكثر وضوحاً.

في عملية الاستيراد، لا يقم Access بالكتابة فوق جدول موجود في قاعدة البيانات. على الرغم من أنه لا يمكنك إلحاق بيانات SQL Server مباشرة إلى جدول موجود، يمكنك إنشاء استعلام إلحاق لإلحاق البيانات بعد استيرادها من جداول مماثلة.

في عملية إنشاء الارتباط، إذا كانت الأعمدة للقراءة فقط في جدول SQL Server، فهي أيضاً للقراءة فقط في Access.

تلميح    للاطلاع على سلسلة الاتصال، مرّر الماوس فوق الجدول الموجود في جزء التنقل في Access.

تحديث تصميم الجدول المرتبط

لا يمكنك إضافة الأعمدة أو حذفها أو تعديلها أو تغيير أنواع البيانات الموجودة في جدول مرتبط. إذا كنت تريد إجراء تغييرات على التصميم، فبإمكانك إجراء ذلك في قاعدة بيانات SQL Server. للاطلاع على تغييرات التصميم في Access، قم بتحديث الجداول المرتبطة:

  1. حدد بيانات خارجية > إدارة الجداول المرتبطة.

  2. حدد كل جدول مرتبط تريد تحديثه، وحدد موافق، ثم حدد إغلاق.

مقارنة أنواع البيانات

تختلف تسمية أنواع البيانات في Access عن أنواع البيانات في SQL Server. على سبيل المثال، يتم استيراد عمود SQL Server لنوع البيانات بت أو يتم إنشاء ارتباط إليه في Access باستخدام نوع البيانات نعم/لا. يعرض الجدول التالي مقارنة بين أنواع بيانات Access وSQL Server.

نوع بيانات SQL Server

نوع بيانات Access

حجم الحقل في Access

عدد صحيح كبير

رقم كبير

راجع استخدام نوع البيانات "رقم كبير".

ثنائي (حجم الحقل)

ثنائي

نفس حجم الحقل في SQL Server

بت

نعم/لا

حرف (حجم الحقل)، حيث يكون حجم الحقل أقل من 255 أو مساوياً له

النص

نفس حجم الحقل في SQL Server

حرف (حجم الحقل)، حيث يكون حجم الحقل أكبر من 255

مذكرة

datetime

التاريخ/الوقت

الرقم العشري (الدقة والمقياس)

الرقم

الرقم العشري (تتطابق خصائص Precision and Scale في Access مع خصائص الدقة والمقياس في SQL Server).

الحُر

الرقم

مزدوج

صورة

كائن OLE

int

الرقم

عدد صحيح طويل

الأموال

العملة

nchar (حجم الحقل)، حيث يكون حجم الحقل أقل من 255 أو مساوياً له

النص

نفس حجم الحقل في SQL Server

nchar (حجم الحقل)، حيث يكون حجم الحقل أكبر من 255

مذكرة

ntext

مذكرة

الرقمي (الدقة والمقياس)

الرقم

الرقم العشري (تتطابق خصائص Precision and Scale في Access مع خصائص الدقة والمقياس في SQL Server).

nvarchar (حجم الحقل)، حيث يكون حجم الحقل أقل من 255 أو مساوياً له

النص

نفس حجم الحقل في SQL Server

nvarchar (حجم الحقل)، حيث يكون حجم الحقل أكبر من 255

مذكرة

nvarchar(MAX)

مذكرة

حقيقي

الرقم

مفرد

smalldatetime

التاريخ/الوقت

smallint

الرقم

عدد صحيح

smallmoney

العملة

sql_variant

النص

255

النص

مذكرة

طابع زمني

ثنائي

8

tinyint

الرقم

بايت

uniqueidentifier

الرقم

مُعرف التكرار

varbinary

ثنائي

نفس حجم الحقل في SQL Server

varbinary (الحد الأقصى)

كائن OLE

varchar (حجم الحقل)، حيث يكون حجم الحقل أقل من 255 أو مساوياً له

النص

نفس حجم الحقل في SQL Server

varchar (حجم الحقل)، حيث يكون حجم الحقل أكبر من 255

مذكرة

varchar(الحد الأقصى)

مذكرة

xml

مذكرة

يمكنك استخدام البيانات المخزنة في SQL Server عبر إنشاء ارتباط إليها أو استيراد البيانات في قاعدة بيانات Access. ويُعد إنشاء الارتباط خياراً جيداً إذا كنت تشارك البيانات مع أشخاص آخرين لأن البيانات مخزنة في مكان مركزي، ويمكنك عرض أحدث البيانات وإضافة البيانات أو تحريرها وتشغيل الاستعلامات أو التقارير في Access.

ملاحظة: لا تنطبق هذه المقالة على التطبيقات في Access وهي النوع الجديد من قواعد البيانات حيث تقوم بتصميم التطبيقات باستخدام Access وتنشرها عبر الإنترنت. للحصول على مزيد من المعلومات، راجع إنشاء تطبيق في Access‏.

الخطوة 1: التحضير لإنشاء الارتباط

  1. ابحث عن قاعدة بيانات SQL Server التي تريد الارتباط بها. عند الضرورة، اتصل بمسؤول قاعدة البيانات للحصول على معلومات الاتصال.

  2. حدد الجداول وطرق العرض التي سترتبط بها في قاعدة بيانات SQL. يمكنك الارتباط بكائنات متعددة في وقت واحد.

راجع بيانات المصدر للاعتبارات التالية:

  • يدعم Access ما يصل إلى 255 حقلاً (عموداً) في الجدول الواحد، لذلك سيتضمن الجدول الذي تم ربطه الحقول الأولى البالغ عددها 255 حقلاً فقط من الكائن الذي ترتبط به.

  • تظل الأعمدة للقراءة فقط في جدول SQL Server كما هي للقراءة فقط في Access.

  1. لإنشاء الجدول المرتبط في قاعدة بيانات جديدة: انقر فوق ملف ‏> جديد>‏قاعدة بيانات كمبيوتر سطح المكتب فارغة. لإنشاء الجداول المرتبطة في قاعدة بيانات موجودة في Access، تأكد من حصولك على الأذونات الضرورية لإضافة البيانات إلى قاعدة البيانات.

    ملاحظة:  تتم تسمية الجدول المرتبط الذي يتم إنشاؤه في قاعدة بيانات Access موجودة بالاسم نفسه كما في الكائن المصدر. لذلك، إذا كان لديك جدول آخر بالاسم نفسه بالفعل، فستتم إضافة "1" إلى اسم الجدول المرتبط الجديد — على سبيل المثال، "جهات اتصال1". (إذا كان الجدول "جهات اتصال1" موجوداً بالفعل، فسينشئ Access "جهات اتصال2"، وما إلى ذلك.)

الخطوة 2: إنشاء ارتباط بالبيانات

عند الارتباط بجدول أو عرضه في قاعدة بيانات SQL Server، يقوم Access بإنشاء جدول جديد (المعروف باسم الجدول المرتبط) يعكس بنية الجدول المصدر ومحتوياته. يمكنك تغيير البيانات إما في SQL Server، أو في طريقة عرض "ورقة البيانات"، أو طريقة عرض "النموذج" من Access، وتظهر التغييرات في كلٍّ من SQL وAccess. يجب إجراء أي تغييرات على البنية في الجداول المرتبطة مثل إزالة أعمدة أو تغييرها من SQL Server وليس من Access.

  1. افتح قاعدة بيانات Access الوجهة.

  2. من علامة التبويب بيانات خارجية، انقر فوق قاعدة بيانات ODBC.

  3. انقر فوق الارتباط بمصدر البيانات بإنشاء جدول مرتبط > موافق واتبع الخطوات في المعالج. في المربع تحديد مصدر البيانات، إذا كان ملف dsn. الذي تريد استخدامه موجوداً بالفعل، فانقر فوق الملف في القائمة.

    لإنشاء ملف .dsn جديد:

    في المربع تحديد مصدر البيانات، انقر فوق جديد‏> SQL Server‏> التالي.

    1. اكتب اسماً لملف ‎.dsn، أو انقر فوق استعراض.

      ملاحظة: يجب أن تكون لديك أذونات كتابة للمجلد لحفظ ملف .dsn.

    2. انقر فوق التالي لمراجعة معلومات الملخص، وانقر فوق إنهاء.

      اتبع الخطوات الواردة في المعالج إنشاء مصدر بيانات جديد لـ SQL Server‏.

  4. انقر فوق موافق، وضمن الجداول، انقر فوق كل جدول أو اعرض الجدول الذي تريد الارتباط به، ثم انقر فوق موافق.

إذا ظهر تحديد معرف السجل الفريد، فهذا يعني أن Access غير قادر على تحديد الحقل أو الحقول التي تعرّف كل صف من صفوف بيانات المصدر بشكل فريد. ما عليك سوى تحديد الحقل أو مجموعة الحقول الفريدة لكل صف، وإذا لم تكن متأكداً، فتحقق من ذلك مع مسؤول قاعدة بيانات SQL Server.

عند إتمام عملية الارتباط، يمكنك مشاهدة الجدول أو الجداول المرتبطة الجديدة في "جزء التنقل".

تطبيق أحدث بنية لكائن SQL Server

عند فتح جدول مرتبط أو كائن مصدر، يمكنك الاطلاع على أحدث البيانات. مع ذلك، إذا تم إجراء أي تغييرات على البنية في كائن SQL Server، فستحتاج إلى تحديث الجدول (الجداول) المرتبط(ة) للاطلاع على هذه التغييرات.

  1. انقر بزر الماوس الأيمن فوق الجدول الموجود في "جزء التنقل"، ثم انقر فوق إدارة الجداول المرتبطة في القائمة المختصرة.

  2. حدد خانة الاختيار الموجودة بجانب كل جدول مرتبط تريد تحديثه، أو انقر فوق تحديد الكل لتحديد كل الجداول المرتبطة.

  3. انقر فوق موافق ‏> إغلاق.

ملاحظة: بما أن أنواع بيانات Access تختلف عن أنواع بيانات SQL Server، يرتبط Access بنوع البيانات الأنسب لكل عمود. يمكنك مراجعة أنواع البيانات المعينة في Access فقط ولا يمكنك تغييرها.

لمزيد من المعلومات، راجع طرق مشاركة قاعدة بيانات كمبيوتر سطح المكتب في Access‏.

أعلى الصفحة

إذا كان لديك قسم أو مجموعة عمل تستخدم Microsoft SQL Server لتخزين البيانات، فقد يتعين عليك استخدام بعض بيانات SQL Server في Access.

يمكنك إحضار البيانات من عناصر SQL Server (الجداول وطرق العرض) إلى Access بطريقتين؛ وهما الاستيراد أو إنشاء ارتباط. ويمكن التفريق بين العمليتين كما يلي:

  • عند استيراد البيانات، يقوم Access بإنشاء نسخة من بيانات SQL Server ولا تنعكس التغييرات اللاحقة التي يتم إجراؤها على بيانات قاعدة بيانات Access في قاعدة بيانات SQL Server. وبالمثل، لا تنعكس التغييرات اللاحقة التي تم إجراؤها في جدول SQL Server أو طريقة عرضه في Access.

  • عند إنشاء ارتباط إلى بيانات SQL Server، تتصل بالبيانات المصدر مباشرةً حيث تنعكس التغييرات اللاحقة التي يتم إجراؤها على البيانات في Access في SQL Server، والعكس صحيح.

توضح هذه المقالة كيفية الاستيراد أو إنشاء ارتباط إلى بيانات SQL Server.

تحديد الاختيار بين الاستيراد أو إنشاء ارتباط

الحالات التي يكون فيها الاستيراد خياراً مناسباً

عادةً، يمكنك استيراد بيانات SQL Server إلى قاعدة بيانات Access للأسباب التالية:

  • نقل بيانات SQL Server نهائياً إلى قاعدة بيانات Access لأنه لم يعد هناك حاجة إلى البيانات في قاعدة بيانات SQL Server. وبعد استيراد البيانات إلى Access، يمكنك حذف البيانات من قاعدة بيانات SQL Server.

  • استخدام Access بواسطة القسم أو مجموعة عملك، ولكنك ترجع في بعض الأحيان إلى قاعدة بيانات SQL Server للحصول على بيانات إضافية يجب دمجها في إحدى قواعد بياناتك.

ونظراً لأن استيراد بيانات SQL Server يؤدي إلى إنشاء نسخة من البيانات في قاعدة بيانات Access أثناء عملية الاستيراد، يمكنك تحديد الجداول أو طرق العرض التي تريد نسخها.

الحالات التي يكون فيها إنشاء الارتباط خياراً مناسباً

يمكنك عادةً إنشاء ارتباط إلى بيانات SQL Server للأسباب التالية:

  • الاتصال مباشرةً بالبيانات المصدر لتتمكن من عرض المعلومات الأحدث وتحريرها في قاعدة بيانات SQL Server وقاعدة بيانات Access.

  • إذا احتوت قاعدة بيانات SQL Server على جداول كبيرة وتعذر عليك استيرادها كلها في ملف .accdb واحد. الحد الأقصى لحجم قاعدة بيانات Access‎‏ يبلغ 2 غيغابايت مطروحاً منه المساحة اللازمة لعناصر النظام.

  • إذا دعت الحاجة إلى تشغيل الاستعلامات وإنشاء التقارير التي تستند إلي بيانات من SQL Server دون إنشاء نسخة من البيانات، ففكر في إنشاء ارتباط إلى SQL Server.

  • استخدام Access بواسطة قسمك أو مجموعة عملك لإنشاء تقارير واستعلامات واستخدام SQL Server لتخزين البيانات. من الممكن أن تنشئ الفرق الفردية جداول SQL Server وطرق عرضها للتخزين المركزي، ولكن ستحتاج في أغلب الأحيان إلى إحضار هذه البيانات إلى برامج سطح المكتب للتجميع وإعداد التقارير. في هذه الحالة، تكون عملية الارتباط هي الخيار المناسب، لأنها تسمح لمستخدمي قاعدة بيانات SQL Server وقاعدة بيانات Access بإضافة البيانات وتحديثها، كما تسمح دائماً بعرض أحدث البيانات واستخدامها.

  • إذا كنت أحد مستخدمي Access ممن استخدموا SQL Server مؤخراً. وقد قمت بترحيل العديد من قواعد البيانات إلى SQL Server، وكانت معظم الجداول في قواعد البيانات هذه جداول مرتبطة. اعتباراً من الآن، بدلاً من إنشاء جداول Access، ستقوم بإنشاء جداول وطرق عرض في SQL Server ثم إنشاء ارتباط لهذه الجداول من قواعد بيانات Access.

  • إذا كنت تريد الاستمرار في تخزين البيانات في SQL Server، ولكنك تريد أيضاً استخدام أحدث البيانات في Access لتشغيل الاستعلامات وطباعة التقارير التي صممتها في Access.

أعلى الصفحة

استيراد البيانات من SQL Server

الإعداد للاستيراد

أثناء عملية الاستيراد، ينشئ Access جدولاً ثم ينسخ البيانات من قاعدة بيانات SQL Server في هذا الجدول. وعند انتهاء عملية الاستيراد، يمكنك اختيار حفظ تفاصيل عملية الاستيراد كمواصفة.

ملاحظة: تساعدك مواصفات الاستيراد على تكرار عملية الاستيراد في المستقبل دون الحاجة إلى اتباع خطوات معالج الاستيراد كل مرة.

  1. حدد موقع قاعدة بيانات SQL Server التي تحتوي على البيانات التي تريد استيرادها. اتصل بمسؤول قاعدة البيانات للحصول على معلومات الاتصال.

  2. حدد الجداول أو طرق العرض التي تريد استيرادها. يمكنك استيراد العديد من العناصر في عملية استيراد واحدة.

  3. راجع البيانات المصدر وضع ما يلي في اعتبارك:

    • لا يدعم Access أكثر من 255 حقلاً في جدول، لذلك يقوم Access باستيراد أول 255 عموداً فقط.

    • يبلغ الحد الأقصى لحجم قاعدة بيانات Access‎‏ 2 غيغابايت، مطروحاً منه المساحة اللازمة لعناصر النظام. إذا احتوت قاعدة بيانات SQL Server على جداول كبيرة، فقد لا تتمكن من استيرادها كلها إلى ملف .accdb واحد. في هذه الحالة، يمكنك التفكير في ربط البيانات بقاعدة بيانات Access بدلاً من ذلك.

    • لا ينشئ Access تلقائياً علاقات بين الجداول المرتبطة في نهاية عملية الاستيراد. لذا، يجب إنشاء العلاقات بين مختلف الجداول الجديدة والموجودة يدوياً باستخدام الخيارات الموجودة في النافذة علاقات. لعرض النافذة علاقات:

      • انقر فوق علامة التبويب ملف، ثم على علامة التبويب معلومات وانقر فوق علاقات.

  4. افتح قاعدة بيانات Access التي تريد استيراد بيانات SQL Server فيها.

    تأكد من توفر الأذونات الضرورية لإضافة بيانات إلى قاعدة بيانات Access. إذا لم تكن ترغب في تخزين البيانات في أي من قواعد البيانات الموجودة، فأنشئ قاعدة بيانات فارغة بالنقر فوق علامة التبويب ملف، وفوق علامة التبويب جديد، ثم فوق قاعدة بيانات فارغة.

  5. راجع الجداول، في حال وجود أي منها، في قاعدة بيانات Access.

    تنشئ عملية الاستيراد جدولاً باسم مماثل لاسم عنصر SQL Server. إذا كان الاسم قيد الاستخدام، يُضيف Access الرقم "1" إلى اسم الجدول الجديد — على سبيل المثال، جهات الاتصال1، (إذا كان جهات الاتصال1 قيد الاستخدام، ينشئ Access جهات الاتصال2، وهكذا).

    ملاحظة: لا يكتب Access مطلقاً فوق جدول في قاعدة البيانات كجزء من عملية الاستيراد، كما يتعذر إلحاق بيانات SQL Server بجدول موجود.

استيراد البيانات

  1. افتح قاعدة البيانات الوجهة.

    من علامة التبويب بيانات خارجية، في المجموعة استيراد وربط، انقر فوق قاعدة بيانات ODBC‏.

  2. انقر فوق استيراد البيانات المصدر إلى جدول جديد في قاعدة البيانات الحالية، ثم فوق موافق.

  3. في مربع الحوار تحديد مصدر البيانات، إذا كان الملف .dsn الذي تريد استخدامه موجوداً بالفعل، فانقر فوق الملف في القائمة.

    أريد إنشاء ملف .dsn جديد

    ملاحظة: قد تختلف الخطوات الواردة في هذا الإجراء بدرجة طفيفة، حسب البرنامج الذي يتم تثبيته على الكمبيوتر.

    1. انقر فوق جديد لإنشاء اسم لمصدر البيانات الجديد (DSN).

      يبدأ المعالج "إنشاء مصدر بيانات جديد".

    2. في المعالج، حدد SQL Server في قائمة برامج التشغيل ومن ثم انقر فوق التالي.

    3. اكتب اسماً لملف .dsn أو انقر فوق استعراض لحفظ الملف في موقع آخر.

      ملاحظة: يجب أن تكون لديك أذونات كتابة للمجلد لحفظ ملف .dsn.

    4. انقر فوق التالي لمراجعة معلومات الملخص، ثم انقر فوق إنهاء لإكمال المعالج.

      يظهر مربع الحوار إنشاء مصدر بيانات جديد إلى SQL Server‏.

    5. في المربع الوصف، اكتب وصفاً لمصدر البيانات. هذه الخطوة اختيارية.

    6. ضمن ‏‏ما هو SQL Server الذي تريد الاتصال به؟، في المربع الخادم، اكتب اسم SQL Server الذي تريد الاتصال به أو حدده، ثم انقر فوق التالي للمتابعة.

    7. قد تحتاج إلى المعلومات من مسؤول قاعدة بيانات SQL Server، مثل ما إذا كنت تريد استخدام مصادقة Microsoft Windows NT أو مصادقة SQL Server. انقر فوق التالي للمتابعة.

    8. إذا كنت تريد الاتصال بقاعدة بيانات محددة، فتأكد من تحديد خانة الاختيار تغيير قاعدة البيانات الافتراضية إلى. وحدد قاعدة البيانات التي تريد استخدامها، ثم انقر فوق التالي.

    9. انقر فوق إنهاء.

    10. انقر فوق اختبار مصدر البيانات لمراجعة معلومات الملخص.

    11. راجع نتائج الاختبار ثم انقر فوق موافق لإغلاق مربع الحوار.

      إذا نجح الاختبار، فانقر فوق موافق مرة أخرى أو انقر فوق إلغاء لتغيير الإعدادات.

  4. في مربع الحوار تحديد مصدر البيانات، انقر فوق موافق.

    يعرض Access مربع الحوار استيراد العناصر.

  5. ضمن الجداول، انقر فوق كل جدول أو طريقة عرض تريد استيرادها، ثم انقر فوق موافق.

  6. إذا ظهر مربع الحوار تحديد معرف السجل الفريد، فهذا يعني أن Access يتعذر عليه تحديد الحقل أو الحقول التي تعرّف كل صف من صفوف بيانات المصدر بشكل فريد. ما عليك سوى تحديد الحقل أو مجموعة الحقول الفريدة لكل صف، ثم انقر فوق موافق. وإذا لم تكن متأكداً، فتحقق من ذلك مع مسؤول قاعدة بيانات SQL Server.

    يقوم access باستيراد البيانات. إذا كنت تخطط لتكرار عملية الاستيراد لاحقاً، يمكنك حفظ خطوات الاستيراد كمواصفة استيراد وإعادة تشغيل خطوات الاستيراد نفسها بسهولة في وقت لاحق. وقد تحتاج إلى تثبيت Microsoft Office Outlook على الكمبيوتر لإنشاء مهمة.

  7. انقر فوق إغلاق ضمن حفظ خطوات الاستيراد في مربع الحوار إحضار بيانات خارجية - قاعدة بيانات ODBC‏. ينهي Access عملية الاستيراد ويعرض الجدول أو الجداول الجديدة في "جزء التنقل".

إذا كنت تريد حفظ الاستيراد كمهمة لإعادة استخدامه، فتابع إلى القسم التالي.

أعلى الصفحة

حفظ إعدادات الاستيراد واستخدامها

ملاحظة: يجب تثبيت Microsoft Office Outlook لإنشاء مهمة.

  1. ضمن حفظ خطوات الاستيراد الواردة في مربع الحوار "إحضار بيانات خارجية - قاعدة بيانات ODBC‏"، حدد خانة الاختيار حفظ خطوات الاستيراد. تظهر مجموعة من عناصر التحكم الإضافية.

  2. في المربع حفظ باسم، اكتب اسماً لمواصفة الاستيراد.

  3. في مربع الوصف، اكتب وصفاً. هذه الخطوة اختيارية.

  4. إذا أردت تنفيذ العملية في فواصل زمنية ثابتة (أسبوعياً أو شهرياً مثلاً)، فحدد خانة الاختيار إنشاء مهمة في Outlook‏. يؤدي ذلك إلى إنشاء مهمة في Microsoft Outlook 2010 مما يسمح بتشغيل المواصفة.

  5. انقر فوق حفظ الاستيراد.

إذا لم يتم تثبيت Outlook، يعرض Access رسالة خطأ عند النقر فوق حفظ الاستيراد.

ملاحظة: إذا لم يتم تكوين Outlook 2010 بطريقة صحيحة، يبدأ المعالج "بدء تشغيل Microsoft Outlook 2010". اتبع الإرشادات الواردة في المعالج لتكوين Outlook.

يمكنك إنشاء مهمة في Outlook اختيارياً. وقد يكون إنشاء مهمة في Outlook مفيداً إذا كنت تريد تشغيل عملية الاستيراد في فواصل زمنية منتظمة أو متكررة. على الرغم من ذلك، إذا لم تنشئ مهمة، فلا يزال يحتفظ Access بالمواصفة.

إنشاء مهمة في Outlook

إذا حددت خانة الاختيار إنشاء مهمة في Outlook‏، يبدأ Access تشغيل Office Outlook 2010 ويعرض مهمة جديدة. اتبع هذه الخطوات لتكوين المهمة:

ملاحظة: إذا لم يكن Outlook مثبتاً، فسيعرض Access رسالة خطأ. إذا لم يكن Outlook مكوناً بطريقة صحيحة، فسيبدأ معالج تكوين Outlook. اتبع الإرشادات الواردة في المعالج لتكوين Outlook.

  1. راجع إعدادات المهمة وعدّلها، على سبيل المثال تاريخ البدء وتاريخ الاستحقاق وتذكير.

    لتحويل عملية الاستيراد إلى حدث متكرر، انقر فوق تكرار وأدخل المعلومات المناسبة.

  2. انقر فوق حفظ وإغلاق.

تشغيل مهمة محفوظة

  1. في "جزء التنقل" في Outlook، انقر فوق المهام، ثم انقر نقراً مزدوجاً فوق المهمة التي تريد تشغيلها.

  2. في علامة التبويب مهمة، في المجموعة Microsoft Access، انقر فوق تشغيل الاستيراد.

  3. ارجع إلى نافذة Access ثم اضغط على F5 لتحديث "جزء التنقل".

  4. انقر نقراً مزدوجاً فوق الجدول الذي تم استيراده لفتحه في طريقة العرض "ورقة البيانات".

  5. تأكد من استيراد جميع الحقول والسجلات ومن عدم وجود أي أخطاء.

  6. انقر بزر الماوس الأيمن فوق الجدول الذي تم استيراده في جزء التنقل، ثم انقر فوق عرض التصميم في القائمة المختصرة. راجع أنواع بيانات الحقول وخصائص الحقول الأخرى.

أعلى الصفحة

الارتباط ببيانات SQL Server

نظراً لأنه يتم تخزين البيانات في الجداول عند إنشاء ارتباط لجدول أو طريقة عرض في قاعدة بيانات SQL Server، ينشئ Access جدولاً جديداً (المعروف غالباً بجدول مرتبط) يعكس بنية ومحتويات العنصر المصدر. يمكنك تغيير البيانات في SQL Server أو في طريقه عرض ورقة البيانات أو طريقة عرض النموذج من Access. تنعكس التغييرات التي تدخلها على البيانات في أحد المواقع في الموقع الآخر. غير أنه، إذا كنت تريد إجراء تغييرات هيكلية، مثل إزالة عمود أو تغييره، فيجب القيام بذلك من قاعدة بيانات SQL Server أو من مشروع Access يتصل بقاعدة البيانات هذه. فلا يمكنك إضافة حقول في جدول مرتبط أو حذفها أو تغييرها أثناء العمل في Access.

الإعداد لإنشاء ارتباط

  1. حدد موقع قاعدة بيانات SQL Server التي تحتوي على البيانات التي تريد إنشاء ارتباط إليها. اتصل بمسؤول قاعدة البيانات للحصول على معلومات الاتصال.

  2. حدد الجداول وطرق العرض التي تريد ربطها. يمكنك ربط عدة عناصر في عملية ربط واحدة.

  3. راجع البيانات المصدر وضع ما يلي في اعتبارك:

    • لا يدعم Access أكثر من 255 حقلاً في جدول، لذلك سيتضمن الجدول الذي تم ربطه أول 255 حقلاً فقط من العنصر الذي ترتبط به.

    • تظل الأعمدة للقراءة فقط في عنصر SQL Server كما هي للقراءة فقط في Access.

    • لن تتمكن من إضافة الأعمدة في الجدول المرتبط في Access أو حذفها أو تعديلها.

  4. حدد قاعدة بيانات Access التي تريد إنشاء جداول مرتبطة فيها. تأكد من توفر الأذونات الضرورية لإضافة بيانات إلى قاعدة البيانات. إذا لم تكن ترغب في تخزين البيانات في أي من قواعد البيانات الموجودة، فأنشئ قاعدة بيانات فارغة وجديدة بالنقر فوق علامة التبويب ملف وفي علامة التبويب جديد بالنقر فوق قاعدة بيانات فارغة.

  5. راجع الجداول في قاعدة بيانات Access. عند إنشاء ارتباط إلى جدول أو طريقة عرض في SQL Server، ينشئ Access جدولاً مرتبطاً باسم مماثل لاسم العنصر المصدر. إذا كان هذا الاسم قيد الاستخدام، يضيف Access الرقم "1" إلى اسم الجدول الجديد — على سبيل المثال، جهات الاتصال1. (إذا كان جهات الاتصال1 قيد الاستخدام، فسينشئ Access جهات الاتصال2، وهكذا.)

  6. لإنشاء ارتباط إلى البيانات، افتح قاعدة البيانات الوجهة.

  7. من علامة التبويب بيانات خارجية، في المجموعة استيراد وربط، انقر فوق قاعدة بيانات ODBC‏.

  8. انقر فوق الارتباط بمصدر البيانات بإنشاء جدول مرتبط، ثم فوق التالي.

  9. في مربع الحوار تحديد مصدر البيانات، انقر فوق الملف .dsn الذي تريد استخدامه أو انقر فوق جديد لإنشاء اسم مصدر بيانات (DSN) جديد.

  10. في مربع الحوار تحديد مصدر البيانات، إذا كان الملف .dsn الذي تريد استخدامه موجوداً بالفعل، فانقر فوق الملف في القائمة.

    أريد إنشاء ملف .dsn جديد

    ملاحظة: قد تختلف الخطوات الواردة في هذا الإجراء بدرجة طفيفة، حسب البرنامج الذي يتم تثبيته على الكمبيوتر.

    1. انقر فوق جديد لإنشاء اسم لمصدر البيانات الجديد (DSN).

      يبدأ المعالج "إنشاء مصدر بيانات جديد".

    2. في المعالج، حدد SQL Server في قائمة برامج التشغيل ومن ثم انقر فوق التالي.

    3. اكتب اسماً لملف .dsn أو انقر فوق استعراض لحفظ الملف في موقع آخر.

      ملاحظة: يجب أن تكون لديك أذونات كتابة للمجلد لحفظ ملف .dsn.

    4. انقر فوق التالي لمراجعة معلومات الملخص، ثم انقر فوق إنهاء لإكمال المعالج "إنشاء بيانات مصدر جديد".

      يبدأ المعالج "إنشاء مصدر بيانات جديد إلى SQL Server".

    5. في المعالج، اكتب وصفاً لمصدر البيانات في مربع الوصف. هذه الخطوة اختيارية.

    6. ضمن ‏‏ما هو SQL Server الذي تريد الاتصال به؟، في المربع الخادم، اكتب اسم كمبيوتر SQL Server الذي تريد الاتصال به أو حدده، ثم انقر فوق التالي للمتابعة.

    7. في صفحة المعالج هذه، قد تحتاج إلى الحصول على المعلومات من مسؤول قاعدة بيانات SQL Server، مثل ما إذا كنت تريد استخدام مصادقة Windows NT أو مصادقة SQL Server. انقر فوق التالي للمتابعة.

    8. في الصفحة التالية للمعالج، قد تحتاج إلى الحصول على المزيد من المعلومات من مسؤول قاعدة بيانات SQL Server. إذا كنت تريد الاتصال بقاعدة بيانات محددة، فتأكد من تحديد خانة الاختيار تغيير قاعدة البيانات الافتراضية إلى، ثم حدد قاعدة بيانات SQL Server التي تريد استخدامها ومن ثم انقر فوق التالي.

    9. انقر فوق إنهاء. راجع معلومات الملخص، ثم انقر فوق اختبار مصدر البيانات.

    10. راجع نتائج الاختبار، ثم انقر فوق موافق لإغلاق مربع الحوار اختبار مصدر بيانات ODBC في SQL Server‏.

      إذا نجح الاختبار، فانقر فوق موافق مرة أخرى لإكمال المعالج أو انقر فوق إلغاء للعودة إلى المعالج وتغيير الإعدادات.

  11. انقر فوق موافق.

    يعرض Access مربع الحوار ربط الجداول.

  12. ضمن جداول، انقر فوق كل جدول أو طريقة عرض تريد الارتباط بها، ثم انقر فوق موافق.

    1. إذا ظهر مربع الحوار تحديد معرف السجل الفريد، فهذا يعني أن Access يتعذر عليه تحديد الحقل أو الحقول التي تحدد كل صف من صفوف البيانات المصدر بشكل فريد. في هذه الحالة، ما عليك سوى تحديد الحقل أو مجموعة الحقول الفريدة لكل صف، ثم انقر فوق موافق. وإذا لم تكن متأكداً، فتحقق من ذلك مع مسؤول قاعدة بيانات SQL Server.

ينهي Access عملية الارتباط ويعرض الجدول أو الجداول المرتبطة الجديدة في "جزء التنقل".

هام: في كل مرة تفتح فيها جدولاً مرتبطاً أو العنصر المصدر، سيتم عرض البيانات الأحدث فيه. على الرغم من ذلك، لا تنعكس التغييرات الهيكلية التي تم إجراؤها على عنصر SQL Server تلقائياً في جدول مرتبط.

تحديث جدول مرتبط بتطبيق هيكل عنصر SQL Server الأحدث

  1. انقر بزر الماوس الأيمن فوق الجدول الموجود في "جزء التنقل"، ثم انقر فوق إدارة الجداول المرتبطة في القائمة المختصرة.

  2. حدد خانة الاختيار الموجودة بجانب كل جدول مرتبط تريد تحديثه، أو انقر فوق تحديد الكل لتحديد كل الجداول المرتبطة.

  3. انقر فوق موافق.

    إذا نجح التحديث، يعرض Access رسالة بشأن هذا الأمر. أو، يعرض Access رسالة.

  4. انقر فوق إغلاق لإغلاق إدارة الجداول المرتبطة.

أعلى الصفحة

كيف يحدد Access أنواع بيانات SQL Server

نظراً لاختلاف أنواع البيانات في Access عن أنواع البيانات في SQL Server، يجب أن يحدد Access نوع بيانات Access الأكثر ملاءمة للاستخدام لكل عمود من أعمدة كل جدول أو طريقة عرض SQL Server التي تريد استيرادها أو إنشاء ارتباط إليها. على سبيل المثال، يتم استيراد عمود SQL Server بنوع البيانات بت أو يتم إنشاء ارتباط إليه في Access باستخدام نوع البيانات نعم/لا. مثال آخر، يتم استيراد عمود SQL Server من نوع البيانات nvarchar(255) (أو أقل) أو ربطها بنوع البيانات نص، ولكن يتم استيراد عمود من نوع البيانات nvarchar(256) (أو أكبر) كحقل مذكرة في Access. وبعد إكمال عملية الاستيراد أو الربط، يمكنك فتح الجدول في طريقه عرض التصميم والتأكد من أنواع البيانات التي قام Access بتعيينها إلى حقوله. ويمكنك تغيير أنواع بيانات الحقول في الجداول التي تم استيرادها. إلا أنه، لا يمكنك تغيير أنواع بيانات الحقول في الجداول المرتبطة إلا إذا تم تغييرها في قاعدة بيانات SQL Server نفسها أو في مشروع Access المتصل بقاعدة البيانات هذه.

ويسرد الجدول التالي أنواع بيانات SQL Server الرئيسية. ويبين العمودان الثاني والثالث كيفية تفسير Access لكل نوع من أنواع البيانات.

نوع بيانات SQL Server‏

نوع بيانات Access‏

حجم الحقل في Access‏

bigint

نص

255

‏binary‏( حجم الحقل )

ثنائي

نفس حجم الحقل في SQL Server

bit

نعم/لا

‏char‏( حجم الحقل )، حيث يكون حجم الحقل أقل من 255 حرفاً أو مساوياً له

نص

نفس حجم الحقل في SQL Server

‏char‏( حجم الحقل )، حيث يكون حجم الحقل أكبر من 255

مذكرة

datetime

التاريخ/الوقت

‏decimal‏( الدقة ، المقياس )

رقم

عشري (تتطابق خصائص المقياس والدقة في Access مع خصائص الدقة والمقياس في SQL Server).

float

رقم

مزدوج

image

عنصر OLE‏

int

رقم

عدد صحيح طويل

money

عملة

‏nchar‏( حجم الحقل )، حيث يكون حجم الحقل أقل من 255 أو مساوياً له

نص

نفس حجم الحقل في SQL Server

‏nchar‏( حجم الحقل )، حيث يكون حجم الحقل أكبر من 255

مذكرة

ntext

مذكرة

‏numeric(‏ الدقة ، المقياس )

رقم

عشري (تتطابق خصائص المقياس والدقة في Access مع خصائص الدقة والمقياس في SQL Server).

‏nvarchar‏( حجم الحقل )، حيث يكون حجم الحقل أقل من 255 أو مساوياً له

نص

نفس حجم الحقل في SQL Server

‏nvarchar‏( حجم الحقل )، حيث يكون حجم الحقل أكبر من 255

مذكرة

nvarchar(MAX)

مذكرة

real

رقم

مفرد

smalldatetime

التاريخ/الوقت

smallint

رقم

عدد صحيح

smallmoney

عملة

sql_variant

نص

255

text

مذكرة

timestamp

ثنائي

8

tinyint

رقم

بايت

uniqueidentifier

رقم

مُعرف التكرار

varbinary

ثنائي

نفس حجم الحقل في SQL Server

varbinary(MAX)

عنصر OLE‏

‏varchar‏( حجم الحقل )، حيث يكون حجم الحقل أقل من 255 أو مساوياً له

نص

نفس حجم الحقل في SQL Server

‏varchar‏( حجم الحقل)، حيث يكون حجم الحقل أكبر من 255

مذكرة

varchar(MAX)

مذكرة

xml

مذكرة

أعلى الصفحة

إذا كان لديك قسم أو مجموعة عمل تستخدم Microsoft SQL Server لتخزين البيانات، فقد تواجه بعض السيناريوهات التي يتعين عليك فيها استخدام بعض بيانات SQL Server في Microsoft Office Access 2007.

إذا لم يكن SQL Server مألوفاً بالنسبة لك وتريد معرفة المزيد، فتفضل بزيارة الصفحة الرئيسية في Microsoft SQL Server. اتبع الارتباط في القسم راجع أيضاً من هذه المقالة.

يمكنك إحضار البيانات من عناصر SQL Server (الجداول أو طرق العرض) إلى Office Access 2007 بطريقتين؛ وهما الاستيراد أو إنشاء ارتباط. فإذا كنت تستورد البيانات، فأنت تنسخها في قاعدة بيانات Access. ولن تنعكس التغييرات اللاحقة التي تدخلها إلى البيانات في Access على قاعدة بيانات SQL Server. وبالمثل، لا تنعكس التغييرات اللاحقة التي تم إجراؤها في جدول SQL Server أو طريقة عرضه في جدول Access. على النقيض، في حالة الربط ببيانات SQL Server، تظل البيانات على كمبيوتر SQL Server وينشئ Access اتصالاً إلى هذه البيانات. وتنعكس التغييرات اللاحقة التي تدخلها إلى البيانات في Access على بيانات SQL Server وتنعكس التغييرات التي تدخلها إلى قاعدة بيانات SQL Server في الجدول المرتبط في Access.

توضح هذه المقالة خطوات استيراد بيانات SQL Server وربطها في Access 2007.

استيراد بيانات SQL Server

يؤدي استيراد بيانات SQL Server إلى إنشاء نسخة من البيانات في قاعدة بيانات Access. وأثناء عملية الاستيراد، يمكنك تحديد الجداول أو طرق العرض التي تريد نسخها.

تؤدي عملية الاستيراد إلى إنشاء جدول في Access ثم نسخ البيانات من قاعدة بيانات SQL Server إلى الجدول في Access. للحصول على مزيد من المعلومات حول الجداول وكيفية إنشاء قاعدة بيانات، ابحث عن الروابط في القسم راجع أيضاً.

في نهاية عملية الاستيراد، يمكنك أن تختار حفظ تفاصيل عملية الاستيراد كمواصفة. وتساعدك مواصفة الاستيراد على تكرار عملية الاستيراد فيما بعد دون الحاجة إلى اتباع خطوات "معالج الاستيراد" في كل مرة.

سيناريوهات شائعة لاستيراد جدول SQL Server إلى Access

عادةً، يمكنك استيراد بيانات SQL Server إلى قاعدة بيانات Access للأسباب التالية:

  • نقل بيانات SQL Server نهائياً إلى قاعدة بيانات Access لأنه لم يعد هناك حاجة إلى البيانات في قاعدة بيانات SQL Server. يمكنك استيراد البيانات إلى Access، ثم حذفها من قاعدة بيانات SQL Server.

  • استخدام Access بواسطة القسم أو مجموعة عملك، ولكنك ترجع في بعض الأحيان إلى قاعدة بيانات SQL Server للحصول على بيانات إضافية يجب دمجها في إحدى قواعد بياناتك.

تشرح الخطوات التالية كيفيه استيراد بيانات SQL Server إلى قاعدة بيانات Access.

التحضير لعملية الاستيراد

  1. حدد موقع قاعدة بيانات SQL Server التي تحتوي على البيانات التي تريد نسخها. اتصل بمسؤول قاعدة البيانات للحصول على معلومات الاتصال.

  2. حدد الجداول أو طرق العرض التي تريد نسخها في قاعدة بيانات Access. يمكنك استيراد العديد من العناصر في عملية استيراد واحدة.

  3. راجع البيانات المصدر وضع ما يلي في اعتبارك:

    • لا يدعم Access أكثر من 255 حقلاً في جدول، لذلك يقوم Access باستيراد أول 255 عموداً فقط.

    • يبلغ الحد الأقصى لحجم قاعدة بيانات Access‎‏ 2 غيغابايت، مطروحاً منه المساحة اللازمة لعناصر النظام. إذا احتوت قاعدة بيانات SQL Server على جداول كبيرة، فقد لا تتمكن من استيرادها كلها إلى ملف .accdb واحد. في هذه الحالة، يمكنك التفكير في ربط البيانات بقاعدة بيانات Access بدلاً من ذلك.

    • لا ينشئ Access تلقائياً علاقات بين الجداول المرتبطة في نهاية عملية الاستيراد. بل، يجب إنشاء العلاقات بين مختلف الجداول الجديدة والموجودة يدوياً باستخدام الخيارات الموجودة في علامة التبويب علاقات. لعرض علامة التبويب علاقات‏:
      في علامة التبويب أدوات قاعدة البيانات في المجموعة إظهار/إخفاء، انقر فوق علاقات.‏ صورة الزر

  4. افتح قاعدة بيانات Access التي تريد استيراد بيانات SQL Server فيها.

    تأكد من توفر الأذونات الضرورية لإضافة بيانات إلى قاعدة بيانات Access. إذا لم تكن ترغب في تخزين البيانات في أي من قواعد البيانات الموجودة، فأنشئ قاعدة بيانات فارغة بالنقر فوق زر Microsoft Office‏ صورة زر Office ثم النقر فوق جديد.

  5. راجع الجداول، في حال وجود أي منها، في قاعدة بيانات Access.

    تنشئ عملية الاستيراد جدولاً باسم مماثل لاسم عنصر SQL Server. إذا كان الاسم قيد الاستخدام، يُضيف Access الرقم "1" إلى اسم الجدول الجديد — على سبيل المثال، جهات الاتصال1، (إذا كان جهات الاتصال1 قيد الاستخدام، ينشئ Access جهات الاتصال2، وهكذا).

    ملاحظة: لا يكتب Access مطلقاً فوق جدول في قاعدة البيانات كجزء من عملية الاستيراد، كما يتعذر إلحاق بيانات SQL Server بجدول موجود.

استيراد البيانات

  1. افتح قاعدة البيانات الوجهة.

    من علامة التبويب بيانات خارجية، في المجموعة استيراد، انقر فوق المزيد.

  2. انقر فوق قاعدة بيانات ODBC‏ صورة الزر .

  3. انقر فوق استيراد البيانات المصدر إلى جدول جديد في قاعدة البيانات الحالية، ثم فوق موافق.

  4. في مربع الحوار تحديد مصدر البيانات، إذا كان الملف .dsn الذي تريد استخدامه موجوداً بالفعل، فانقر فوق الملف في القائمة.

    أريد إنشاء ملف .dsn جديد

    ملاحظة: قد تختلف الخطوات الواردة في هذا الإجراء بدرجة طفيفة، حسب البرنامج الذي يتم تثبيته على الكمبيوتر.

    1. انقر فوق جديد لإنشاء اسم لمصدر البيانات الجديد (DSN).‏
      يبدأ المعالج "إنشاء مصدر بيانات جديد".

    2. في المعالج، حدد SQL Server في قائمة برامج التشغيل ومن ثم انقر فوق التالي.

    3. اكتب اسماً لملف .dsn أو انقر فوق استعراض لحفظ الملف في موقع آخر.

      ملاحظة: يجب أن تكون لديك أذونات كتابة للمجلد لحفظ ملف .dsn.

    4. انقر فوق التالي لمراجعة معلومات الملخص، ثم انقر فوق إنهاء لإكمال المعالج.
      يبدأ المعالج "إنشاء مصدر بيانات جديد إلى SQL Server".

    5. في المعالج، اكتب وصفاً لمصدر البيانات في مربع الوصف. هذه الخطوة اختيارية.

    6. ضمن ‏‏ما هو SQL Server الذي تريد الاتصال به؟، في المربع الخادم، اكتب اسم SQL Server الذي تريد الاتصال به أو حدده، ثم انقر فوق التالي للمتابعة.

    7. في صفحة المعالج هذه، قد تحتاج إلى الحصول على المعلومات من مسؤول قاعدة بيانات SQL Server، مثل تحديد ما إذا كنت تريد استخدام مصادقة Microsoft Windows NT أو مصادقة SQL Server. انقر فوق التالي للمتابعة.

    8. في الصفحة التالية للمعالج، قد تحتاج إلى الحصول على المزيد من المعلومات من مسؤول قاعدة بيانات SQL Server قبل المتابعة. إذا كنت تريد الاتصال بقاعدة بيانات محددة، فتأكد من تحديد خانة الاختيار تغيير قاعدة البيانات الافتراضية إلى. وحدد قاعدة البيانات التي تريد استخدامها، ثم انقر فوق التالي.

    9. انقر فوق إنهاء. راجع معلومات الملخص، ثم انقر فوق اختبار مصدر البيانات.

    10. راجع نتائج الاختبار، ثم انقر فوق موافق لإغلاق مربع الحوار اختبار مصدر بيانات ODBC في SQL Server‏.

      إذا نجح الاختبار، فانقر فوق موافق مرة أخرى لإكمال المعالج أو انقر فوق إلغاء للعودة إلى المعالج وتغيير الإعدادات.

  5. في مربع الحوار تحديد مصدر البيانات، انقر فوق موافق.

    يعرض Access مربع الحوار استيراد العناصر.

  6. ضمن الجداول، انقر فوق كل جدول أو طريقة عرض تريد استيرادها، ثم انقر فوق موافق.

  7. إذا ظهر مربع الحوار تحديد معرف السجل الفريد، فهذا يعني أن Access يتعذر عليه تحديد الحقل أو الحقول التي تعرّف كل صف من صفوف بيانات المصدر بشكل فريد. ما عليك سوى تحديد الحقل أو مجموعة الحقول الفريدة لكل صف، ثم انقر فوق موافق. وإذا لم تكن متأكداً، فتحقق من ذلك مع مسؤول قاعدة بيانات SQL Server.

يقوم access باستيراد البيانات. إذا كنت تخطط لتكرار عملية الاستيراد لاحقاً، يمكنك حفظ خطوات الاستيراد كمواصفة استيراد وإعادة تشغيل خطوات الاستيراد نفسها بسهولة في وقت لاحق. انتقل إلى القسم التالي من هذه المقالة لإكمال هذه المهمة. إذا كنت لا تريد حفظ تفاصيل مواصفة الاستيراد، فانقر فوق إغلاق ضمن حفظ خطوات الاستيراد في مربع الحوار إحضار بيانات خارجية -قاعدة بيانات ODBC‏. يُكمل Access عملية الاستيراد ويعرض الجدول أو الجداول الجديدة في "جزء التنقل".

حفظ إعدادات الاستيراد كمواصفة

  1. ضمن حفظ خطوات الاستيراد في مربع الحوار إحضار بيانات خارجية - قاعدة بيانات ODBC‏، حدد خانة الاختيار حفظ خطوات الاستيراد.

    تظهر مجموعة من عناصر التحكم الإضافية.

  2. في المربع حفظ باسم، اكتب اسماً لمواصفة الاستيراد.

  3. في مربع الوصف، اكتب وصفاً. هذه الخطوة اختيارية.

  4. إذا أردت تنفيذ العملية عند فواصل زمنية ثابتة (أسبوعياً أو شهرياً مثلاً)، فحدد خانة الاختيار إنشاء مهمة Outlook. يؤدي ذلك إلى إنشاء مهمة في Microsoft Office Outlook 2007 مما يسمح بتشغيل المواصفة.

  5. انقر فوق حفظ الاستيراد.

تكوين مهمة Outlook

إذا حددت خانة الاختيار إنشاء مهمة Outlook‏ في الإجراء السابق، يبدأ Access في تشغيل Office Outlook 2007 وعرض مهمة جديدة. اتبع هذه الخطوات لتكوين المهمة.

ملاحظة: إذا لم يكن Outlook مثبتاً، فسيعرض Access رسالة خطأ. إذا لم يكن Outlook مكوناً بطريقة صحيحة، فسيبدأ معالج تكوين Outlook. اتبع الإرشادات الواردة في المعالج لتكوين Outlook.

  1. نافذة المهمة في Outlook، راجع إعدادات المهمة وعدّلها، مثل تاريخ الاستحقاق وتذكير.

    لتكرار المهمة، انقر فوق تكرار وقم بتعبئة المعلومات المناسبة.

    يعرض هذا الشكل جدولة المهام باستخدام بعض الإعدادات النموذجية.

    جدولة المهام في Outlook

    للحصول على المزيد من المعلومات حول جدولة المهام في Outlook، راجع المقالة جدولة عملية استيراد أو تصدير.

  2. عند الانتهاء من إعدادات المهمة في Outlook، في علامة التبويب مهمة، في المجموعة إجراءات، انقر فوق حفظ وإغلاق.

تشغيل مهمة محفوظة

  1. في "جزء التنقل" في Outlook، انقر فوق المهام، ثم انقر نقراً مزدوجاً فوق المهمة التي تريد تشغيلها.

  2. في علامة التبويب مهمة، في المجموعة ‏Microsoft Office Access، انقر فوق تشغيل الاستيراد صورة الزر .

  3. ارجع إلى نافذة Access ثم اضغط على F5 لتحديث "جزء التنقل".

  4. انقر نقراً مزدوجاً فوق الجدول الذي تم استيراده لفتحه في طريقة العرض "ورقة البيانات".

  5. تأكد من استيراد جميع الحقول والسجلات ومن عدم وجود أي أخطاء.

  6. انقر بزر الماوس الأيمن فوق الجدول الذي تم استيراده في جزء التنقل، ثم انقر فوق عرض التصميم في القائمة المختصرة. راجع أنواع بيانات الحقول وخصائص الحقول الأخرى.

أعلى الصفحة

الارتباط ببيانات SQL Server

يتيح الربط الاتصال بالبيانات دون استيراد هذه المعلومات، حتى يمكنك عرض البيانات الأحدث في قاعدة بيانات SQL Server وقاعدة بيانات Access بدون إنشاء نسخة من البيانات في Access وحفظها. إذا كنت لا تريد نسخ بيانات SQL Server إلى قاعدة بيانات Access، ولكنك بدلاً من ذلك ترغب في تشغيل الاستعلامات وإنشاء تقارير مستندة إلى تلك البيانات، فيجب عليك الربط بدلاً من الاستيراد.

عند إنشاء ارتباط لجدول أو طريقة عرض في قاعدة بيانات SQL Server، ينشئ Access جدولاً جديداً (المعروف غالباً بجدول مرتبط) يعكس بنية العنصر المصدر ومحتوياته. يمكنك تغيير البيانات في SQL Server أو في طريقة عرض ورقة البيانات أو طريقة عرض النموذج في Access. تنعكس التغييرات التي تدخلها على البيانات في أحد المواقع في الموقع الآخر. غير أنه، إذا كنت تريد إجراء تغييرات هيكلية، مثل إزالة عمود أو تغييره، فيجب القيام بذلك من قاعدة بيانات SQL Server أو من مشروع Access يتصل بقاعدة البيانات هذه. فلا يمكنك إضافة حقول في جدول مرتبط أو حذفها أو تعديلها أثناء العمل في Access.

إذا احتوت قاعدة بيانات SQL Server على كمية كبيرة من البيانات، فيجب تفضيل الربط على الاستيراد، لأن الحد الأقصى لحجم قاعدة بيانات Access يبلغ 2 غيغابايت (مطروحاً منه المساحة اللازمة لعناصر النظام). وقد يؤدي استيراد العديد من الجداول الكبيرة أو طرق العرض إلى تجاوز هذا الحد، في حين أن إنشاء ارتباط إلى البيانات قد لا يؤدي إلى زيادة حجم قاعدة بيانات Access بدرجة كبيرة.

سيناريوهات شائعة لإنشاء ارتباط إلى قاعدة بيانات SQL Server

عادةً، يمكنك إنشاء ارتباط إلى جدول SQL Server أو طريقة عرضه من قاعدة بيانات Access للأسباب التالية:

  • استخدام Access بواسطة قسمك أو مجموعة عملك لإنشاء تقارير واستعلامات واستخدام SQL Server لتخزين البيانات. من الممكن أن تنشئ الفرق الفردية جداول SQL Server وطرق عرضها للتخزين المركزي، ولكن ستحتاج في أغلب الأحيان إلى إحضار هذه البيانات إلى برامج سطح المكتب للتجميع وإعداد التقارير. في هذه الحالة، تكون عملية الارتباط هي الخيار المناسب، لأنها تسمح لمستخدمي قاعدة بيانات SQL Server وقاعدة بيانات Access بإضافة البيانات وتحديثها، كما تسمح دائماً بعرض أحدث البيانات واستخدامها.

  • إذا كنت أحد مستخدمي Access ممن استخدموا SQL Server مؤخراً. وقد قمت بترحيل العديد من قواعد البيانات إلى SQL Server، وكانت معظم الجداول في قواعد البيانات هذه جداول مرتبطة. اعتباراً من الآن، بدلاً من إنشاء جداول Access، ستقوم بإنشاء جداول وطرق عرض في SQL Server ثم إنشاء ارتباط لهذه الجداول من قواعد بيانات Access.

  • إذا كنت تريد الاستمرار في تخزين البيانات في SQL Server، ولكنك تريد أيضاً استخدام أحدث البيانات في Access لتشغيل الاستعلامات وطباعة التقارير التي صممتها في Access.

التحضير لإنشاء ارتباط إلى جدول SQL Server

  1. حدد موقع قاعدة بيانات SQL Server التي تحتوي على البيانات التي تريد إنشاء ارتباط إليها. اتصل بمسؤول قاعدة البيانات للحصول على معلومات الاتصال.

  2. حدد الجداول وطرق العرض التي تريد ربطها. يمكنك ربط عدة عناصر في عملية ربط واحدة.

  3. راجع البيانات المصدر وضع ما يلي في اعتبارك:

    • لا يدعم Access أكثر من 255 حقلاً في جدول، لذلك سيتضمن الجدول الذي تم ربطه أول 255 حقلاً فقط من العنصر الذي ترتبط به.

    • تظل الأعمدة للقراءة فقط في عنصر SQL Server كما هي للقراءة فقط في Access.

    • لن تتمكن من إضافة الأعمدة في الجدول المرتبط في Access أو حذفها أو تعديلها.

  4. حدد قاعدة بيانات Access التي تريد إنشاء جداول مرتبطة فيها. وتأكد من توفر الأذونات الضرورية لإضافة بيانات إلى قاعدة البيانات. إذا لم تكن ترغب في تخزين البيانات في أي من قواعد البيانات الموجودة، فأنشئ قاعدة بيانات فارغة وجديدة باستخدام الأمر التالي:

    انقر فوق زر Microsoft Office صورة زر Office ، ثم انقر فوق جديد.

  5. راجع الجداول في قاعدة بيانات Access. عند إنشاء ارتباط إلى جدول أو طريقة عرض في SQL Server، ينشئ Access جدولاً مرتبطاً باسم مماثل لاسم العنصر المصدر. إذا كان هذا الاسم قيد الاستخدام، يضيف Access الرقم "1" إلى اسم الجدول الجديد — على سبيل المثال، جهات الاتصال1. (إذا كان جهات الاتصال1 قيد الاستخدام، فسينشئ Access جهات الاتصال2، وهكذا.)

الربط بالبيانات

  1. افتح قاعدة البيانات الوجهة.

  2. من علامة التبويب بيانات خارجية، في المجموعة استيراد، انقر فوق المزيد.

  3. انقر فوق قاعدة بيانات ODBC‏.

  4. انقر فوق الارتباط بمصدر البيانات بإنشاء جدول مرتبط، ثم فوق التالي.

  5. في مربع الحوار تحديد مصدر البيانات، انقر فوق الملف .dsn الذي تريد استخدامه أو انقر فوق جديد لإنشاء اسم مصدر بيانات (DSN) جديد.

  6. في مربع الحوار تحديد مصدر البيانات، إذا كان الملف .dsn الذي تريد استخدامه موجوداً بالفعل، فانقر فوق الملف في القائمة.

    أريد إنشاء ملف .dsn جديد

    ملاحظة: قد تختلف الخطوات الواردة في هذا الإجراء بدرجة طفيفة، حسب البرنامج الذي يتم تثبيته على الكمبيوتر.

    1. انقر فوق جديد لإنشاء اسم لمصدر البيانات الجديد (DSN).‏
      يبدأ المعالج "إنشاء مصدر بيانات جديد".

    2. في المعالج، حدد SQL Server في قائمة برامج التشغيل ومن ثم انقر فوق التالي.

    3. اكتب اسماً لملف .dsn أو انقر فوق استعراض لحفظ الملف في موقع آخر.

      ملاحظة: يجب أن تكون لديك أذونات كتابة للمجلد لحفظ ملف .dsn.

    4. انقر فوق التالي لمراجعة معلومات الملخص، ثم انقر فوق إنهاء لإكمال المعالج "إنشاء بيانات مصدر جديد".
      يبدأ المعالج "إنشاء مصدر بيانات جديد إلى SQL Server".

    5. في المعالج، اكتب وصفاً لمصدر البيانات في مربع الوصف. هذه الخطوة اختيارية.

    6. ضمن ‏‏ما هو SQL Server الذي تريد الاتصال به؟، في المربع الخادم، اكتب اسم كمبيوتر SQL Server الذي تريد الاتصال به أو حدده، ثم انقر فوق التالي للمتابعة.

    7. في صفحة المعالج هذه، قد تحتاج إلى الحصول على المعلومات من مسؤول قاعدة بيانات SQL Server، مثل ما إذا كنت تريد استخدام مصادقة Windows NT أو مصادقة SQL Server. انقر فوق التالي للمتابعة.

    8. في الصفحة التالية للمعالج، قد تحتاج إلى الحصول على المزيد من المعلومات من مسؤول قاعدة بيانات SQL Server. إذا كنت تريد الاتصال بقاعدة بيانات محددة، فتأكد من تحديد خانة الاختيار تغيير قاعدة البيانات الافتراضية إلى، ثم حدد قاعدة بيانات SQL Server التي تريد استخدامها ومن ثم انقر فوق التالي.

    9. انقر فوق إنهاء. راجع معلومات الملخص، ثم انقر فوق اختبار مصدر البيانات.

    10. راجع نتائج الاختبار، ثم انقر فوق موافق لإغلاق مربع الحوار اختبار مصدر بيانات ODBC في SQL Server‏.

      إذا نجح الاختبار، فانقر فوق موافق مرة أخرى لإكمال المعالج أو انقر فوق إلغاء للعودة إلى المعالج وتغيير الإعدادات.

  7. انقر فوق موافق.‏
    يعرض Access مربع الحوار ربط الجداول.

  8. ضمن جداول، انقر فوق كل جدول أو طريقة عرض تريد الارتباط بها، ثم انقر فوق موافق.

  9. إذا ظهر مربع الحوار تحديد معرف السجل الفريد، فهذا يعني أن Access يتعذر عليه تحديد الحقل أو الحقول التي تحدد كل صف من صفوف البيانات المصدر بشكل فريد. في هذه الحالة، ما عليك سوى تحديد الحقل أو مجموعة الحقول الفريدة لكل صف، ثم انقر فوق موافق. وإذا لم تكن متأكداً، فتحقق من ذلك مع مسؤول قاعدة بيانات SQL Server.

يكمل Access عملية الارتباط ويعرض الجدول أو الجداول المرتبطة الجديدة في "جزء التنقل".

هام: في كل مرة تفتح فيها جدولاً مرتبطاً أو العنصر المصدر، سيتم عرض البيانات الأحدث فيه. على الرغم من ذلك، لا تنعكس التغييرات الهيكلية التي تم إجراؤها على عنصر SQL Server تلقائياً في جدول مرتبط.


لتحديث جدول مرتبط بتطبيق هيكل عنصر SQL Server الأحدث، نفذّ ما يلي:

  1. انقر بزر الماوس الأيمن فوق الجدول الموجود في "جزء التنقل"، ثم انقر فوق إدارة الجداول المرتبطة في القائمة المختصرة.

  2. حدد خانة الاختيار الموجودة بجانب كل جدول مرتبط تريد تحديثه، أو انقر فوق تحديد الكل لتحديد كل الجداول المرتبطة.

  3. انقر فوق موافق.

    إذا نجح التحديث، يعرض Access رسالة بشأن هذا الأمر. أو، يعرض Access رسالة خطأ.

  4. انقر فوق إغلاق لإغلاق إدارة الجداول المرتبطة.

أعلى الصفحة

تعرّف على كيفية تفسير Access لأنواع بيانات SQL Server

نظراً لاختلاف أنواع البيانات في Access عن أنواع البيانات في SQL Server، يجب أن يحدد Access نوع بيانات Access الأكثر ملاءمة للاستخدام لكل عمود من أعمدة كل جدول أو طريقة عرض SQL Server التي تريد استيرادها أو إنشاء ارتباط إليها. على سبيل المثال، يتم استيراد عمود SQL Server بنوع البيانات بت أو يتم إنشاء ارتباط إليه في Access باستخدام نوع البيانات نعم/لا. كمثال آخر، يتم استيراد عمود SQL Server من نوع البيانات nvarchar(255) (أو أقل) أو ربطها في Access بنوع البيانات نص، ولكن يتم إحضار عمود من نوع البيانات nvarchar(256) (أو أكبر) كحقل مذكرة في Access. بعد إكمال عملية الاستيراد أو الربط، يتعين عليك فتح الجدول في طريقة عرض التصميم والتأكد من أنواع البيانات التي عيّنها Access إلى حقولها. يمكنك تغيير أنواع بيانات الحقول في الجداول التي تم استيرادها؛ إلا أنه، لا يمكنك تغيير أنواع بيانات الحقول في الجداول المرتبطة إلا إذا تم تغييرها في قاعدة بيانات SQL Server أو في مشروع Access متصل بقاعدة البيانات هذه.

ويسرد الجدول التالي أنواع بيانات SQL Server الرئيسية. ويبين العمودان الثاني والثالث كيفية تفسير Access لكل نوع من أنواع البيانات.

نوع بيانات SQL Server‏

نوع بيانات Access‏

حجم الحقل في Access‏

bigint

نص

255

‏binary‏( حجم الحقل )

ثنائي

نفس حجم الحقل في SQL Server

bit

نعم/لا

‏char‏( حجم الحقل )، حيث يكون حجم الحقل أقل من 255 حرفاً أو مساوياً له

نص

نفس حجم الحقل في SQL Server

‏char‏( حجم الحقل )، حيث يكون حجم الحقل أكبر من 255

مذكرة

datetime

التاريخ/الوقت

‏decimal‏( الدقة ، المقياس )

رقم

عشري (تتطابق خصائص المقياس والدقة في Access مع خصائص الدقة والمقياس في SQL Server).

float

رقم

مزدوج

image

عنصر OLE‏

int

رقم

عدد صحيح طويل

money

عملة

‏nchar‏ ‏( حجم الحقل )، حيث يكون حجم الحقل أقل من 255 أو مساوياً له

نص

نفس حجم الحقل في SQL Server

‏nchar‏ ‏( حجم الحقل )، حيث يكون حجم الحقل أكبر من 255

مذكرة

ntext

مذكرة

‏numeric(‏ الدقة ، المقياس )

رقم

عشري (تتطابق خصائص المقياس والدقة في Access مع خصائص الدقة والمقياس في SQL Server).

‏nvarchar‏ ( حجم الحقل )، حيث يكون حجم الحقل أقل من 255 أو مساوياً له

نص

نفس حجم الحقل في SQL Server

‏nvarchar‏ ( حجم الحقل )، حيث يكون حجم الحقل أكبر من 255

مذكرة

nvarchar (MAX)

مذكرة

real

رقم

مفرد

smalldatetime

التاريخ/الوقت

smallint

رقم

عدد صحيح

smallmoney

عملة

sql_variant

نص

255

text

مذكرة

timestamp

ثنائي

8

tinyint

رقم

بايت

uniqueidentifier

رقم

مُعرف التكرار

varbinary

ثنائي

نفس حجم الحقل في SQL Server

varbinary (MAX)

عنصر OLE‏

‏varchar‏ ( حجم الحقل )، حيث يكون حجم الحقل أقل من 255 أو مساوياً له

نص

نفس حجم الحقل في SQL Server

‏varchar‏ ( حجم الحقل)، حيث يكون حجم الحقل أكبر من 255

مذكرة

varchar (MAX)

مذكرة

xml

مذكرة

أعلى الصفحة

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×