ادراج كائن في جدول بيانات Excel

هام: تمت ترجمة هذه المقالة ترجمة آلية، راجع إقرار إخلاء المسؤولية. يرجى الاطلاع على النسخة الإنجليزية من هذه المقالة. هنا للرجوع إليها.

يمكنك استخدام "ربط الكائنات" و# تضمينها (OLE) ل# تضمين محتوي من برامج اخري، مثل Word او Excel.

يكون معتمدا OLE ب# العديد من برامج مختلفه، و# يتم استخدام OLE ل# جعل المحتوي الذي تم انشاؤه في احد البرامج المتوفره في برنامج اخر. علي سبيل المثال، يمكنك ادراج مستند Office Word في مصنف Office Excel. ل# معرفه ما هي انواع المحتويات التي يمكنك ادراج، انقر فوق كائن في المجموعه " نص " ضمن علامه التبويب ادراج. تظهر فقط البرامج التي تم تثبيتها علي الكمبيوتر و# التي تعتمد كائنات OLE في المربع نوع الكائن.

اذا قمت ب# نسخ المعلومات بين Excel او اي برنامج يعتمد OLE، مثل Word، يمكنك نسخ المعلومات ب# صفه عنصر مرتبط او عنصر مضمّن. الاختلافات الاساسيه بين الكائنات المرتبطه و# المضمنه يتم تخزين البيانات و# كيفيه تحديث الكائن بعد وضعها في الملف الوجهة. يتم تخزين كائنات مضمنه في المصنف الذي تم ادراجها به، و# لا يتم تحديث. تظل الكائنات المرتبطه ك# ملفات منفصله، و# تحديثها.

الكائنات المرتبطة والمُضمنة في مستند

العناصر المرتبطة والمضمنة في مستند Office for Windows

1. كائن مضمن يحتوي علي اي اتصال ب# الملف المصدر.

2. ترتبط كائن مرتبط ب# الملف المصدر.

3. الملف المصدر ب# تحديث الكائن المرتبط.

متي يجب استخدام الكائنات المرتبطه

اذا كنت تريد المعلومات في موقعك الملف الوجهة يتم تحديث عند تغيير البيانات الموجوده في الملف المصدر، استخدم الكائنات المرتبطه.

ب# استخدام كائن مرتبط، تبقي المعلومات الاصليه مخزنه في الملف المصدر. الملف الوجهه يعرض تمثيل ل# المعلومات المرتبطه و# لكنه يقوم ب# تخزين فقط موقع البيانات الاصليه (و# حجم اذا كان الكائن كائن مخطط Excel). يجب ان يظل الملف المصدر متوفره علي الكمبيوتر او الشبكه ل# الحفاظ علي الارتباط ب# البيانات الاصليه.

يمكنك تحديث المعلومات المرتبطه تلقائيا اذا قمت ب# تغيير البيانات الاصليه في الملف المصدر. علي سبيل المثال، اذا كنت تحديد فقره في مستند Word و# قم ب# لصق الفقره ك# كائن مرتبط في مصنف Excel، يمكنك تحديث المعلومات الموجوده في Excel اذا قمت ب# تغيير المعلومات الموجوده في مستند Word.

متي يجب استخدام الكائنات المضمنه

اذا لم ترغب في تحديث البيانات المنسوخه عندما يتغير شكله في الملف المصدر، استخدم كائن مضمن. اصدار المصدر مضمن الكامل في المصنف. اذا قمت ب# نسخ المعلومات ك# كائن مضمن، يتطلب الملف الوجهه مساحه القرص اكثر من اذا قمت ب# ربط المعلومات.

عند قيام مستخدم ب# فتح الملف علي كمبيوتر اخر، يمكنك عرض الكائن المضمن دون حق الوصول الي البيانات الاصليه. نظرا ل# كائن مضمن يحتوي علي ايه ارتباطات الي الملف المصدر، لا يتم تحديث الكائن اذا قمت ب# تغيير البيانات الاصليه. ل# تغيير كائن مضمن، انقر نقرا مزدوجا فوق الكائن ل# فتحه و# تحريره في البرنامج المصدر. يجب تثبيت البرنامج المصدر (او برنامج اخر يمكنه الاتصال ب# تحرير الكائن) علي الكمبيوتر الخاص بك.

تغيير طريقه ظهور كائن OLE

يمكنك عرض عنصر مرتبط او عنصر مضمّن في مصنف تماما كما يظهر في برنامج مصدر او ك# رمز. اذا كان يمكن عرض المصنف عبر الانترنت، و# كنت لا تنوي طباعه المصنف، يمكنك عرض الكائن ك# رمز. هذا ب# تصغير حجم العرض المساحه التي يشغلها الكائن. يمكنك النقر نقرا مزدوجا العارضين الذين تريد عرض المعلومات الرمز.

تضمين كائن في ورقه عمل

  1. انقر داخل خليه جدول البيانات حيث تريد ادراج الكائن.

  2. علي علامه التبويب ادراج، في المجموعه نص، انقر فوق الكائن ايقونه الكائن علي الشريط .
    دراج كائن

  3. في مربع الحوار كائن ، انقر فوق علامه التبويب انشاء من ملف.

  4. انقر فوق استعراض، و# حدد الملف الذي تريد ادراجه.

  5. اذا كنت تريد ادراج رمز في جدول البيانات بدلا من اظهار محتويات الملف، حدد خانه الاختيار عرض ك# رمز . اذا لم تقم ب# تحديد اي خانات الاختيار، يعرض Excel الصفحه الاولي من الملف. و# في الحالتين، يفتح الملف الكامل ب# النقر المزدوج. انقر فوق موافق.

    ملاحظة: بعد اضافه رمز او الملفات، يمكنك سحب و# افلته في اي مكان في ورقه العمل. يمكنك ايضا تغيير حجم رمز او ملف ب# استخدام مقابض تغيير الحجم. ل# البحث عن المقابض، انقر فوق الملف او ايقونه مره واحده.

ادراج ارتباط الي ملف

قد ترغب في اضافه ارتباط الي الكائن بدلا من الكامل تضمينه فقط. يمكنك القيام ب# ذلك اذا كان المصنف الخاص بك و# الكائن الذي تريد اضافته كليهما المخزنه علي موقع SharePoint او محرك اقراص شبكه مشترك او موقع مماثله، و# اذا كان موقع الملفات و# ستبقي نفسه. هذا مفيده اذا الكائن المرتبط التغييرات نظرا ل# ان الارتباط دائما ب# فتح المستند احدث.

ملاحظة: اذا قمت ب# نقل ملف الارتباط الي موقع اخر، لن يعمل الارتباط بعد الان.

  1. انقر داخل خليه جدول البيانات حيث تريد ادراج الكائن.

  2. علي علامه التبويب ادراج، في المجموعه نص، انقر فوق الكائن ايقونه الكائن علي الشريط .
    دراج كائن

  3. انقر فوق علامه التبويب انشاء من ملف .

  4. انقر فوق استعراض، و# من ثم حدد الملف الذي تريد ربطه.

  5. حدد خانه الاختيار ارتباط ب# الملف، ثم انقر فوق موافق.

انشاء كائن جديد من داخل Excel

يمكنك انشاء كائن جديد ب# الكامل استنادا الي برنامج اخر دون ترك المصنف الخاص بك. علي سبيل المثال، اذا اردت اضافه شرح اكثر تفصيلا ل# جدول او مخطط، يمكنك انشاء مستند مضمن، مثل ملف Word او PowerPoint، في Excel. يمكنك اما تعيين الكائن المراد عرضها ل# اليمين في ورقه عمل او اضافه رمز الذي يفتح الملف.

هذا العنصر المضمّن عبارة عن مستند Word.
  1. انقر داخل خليه جدول البيانات حيث تريد ادراج الكائن.

  2. علي علامه التبويب ادراج، في المجموعه نص، انقر فوق الكائن ايقونه الكائن علي الشريط .
    دراج كائن

  3. علي علامه التبويب انشاء جديد، حدد نوع الكائن الذي تريد ادراج من القائمه المعروضه. اذا كنت تريد ل# ادراج رمز في جدول البيانات بدلا من الكائن نفسه، حدد خانه الاختيار عرض ك# رمز.

  4. انقر فوق موافق. استنادا الي نوع الملف الذي تقوم ب# ادراج، يتم فتح نافذه برنامج جديد او تظهر نافذه تحرير داخل Excel.

  5. انشاء كائن الجديده التي تريد ادراجها.

    عند الانتهاء من ذلك، اذا Excel فتح اطار برنامج جديد الذي قمت ب# انشائه علي الكائن، يمكنك العمل ضمنه مباشره.

    يمكنك تحرير مستند Word المضمّن مباشرةً في Excel.

    عندما تنهي عملك في العمل في النافذه، يمكنك القيام ب# مهام اخري دون حفظ الكائن المضمن. عند اغلاق المصنف سيتم حفظ الكائنات الجديده تلقائيا.

    ملاحظة: بعد اضافه الكائن، يمكنك سحب و# افلته في اي مكان في ورقه العمل Excel. يمكنك ايضا تغيير حجم الكائن ب# استخدام مقابض تغيير الحجم. ل# البحث عن المقابض، انقر فوق الكائن مره واحده.

تضمين كائن في ورقه عمل

  1. انقر داخل خليه جدول البيانات حيث تريد ادراج الكائن.

  2. ضمن علامة التبويب إدراج، في المجموعة نص، انقر فوق كائن.

    يوجد الخيار «عنصر» في علامة التبويب «إدراج».
  3. انقر فوق علامه التبويب انشاء من ملف.

    علامة التبويب "إنشاء من ملف" في مربع الحوار «عنصر».
  4. انقر فوق استعراض، و# حدد الملف الذي تريد ادراجه.

  5. اذا كنت تريد ادراج رمز في جدول البيانات بدلا من اظهار محتويات الملف، حدد خانه الاختيار عرض ك# رمز . اذا لم تقم ب# تحديد اي خانات الاختيار، يعرض Excel الصفحه الاولي من الملف. و# في الحالتين، يفتح الملف الكامل ب# النقر المزدوج. انقر فوق موافق.

    ملاحظة: بعد اضافه رمز او الملفات، يمكنك سحب و# افلته في اي مكان في ورقه العمل. يمكنك ايضا تغيير حجم رمز او ملف ب# استخدام مقابض تغيير الحجم. ل# البحث عن المقابض، انقر فوق الملف او ايقونه مره واحده.

ادراج ارتباط الي ملف

قد ترغب في اضافه ارتباط الي الكائن بدلا من الكامل تضمينه فقط. يمكنك القيام ب# ذلك اذا كان المصنف الخاص بك و# الكائن الذي تريد اضافته كليهما المخزنه علي موقع SharePoint او محرك اقراص شبكه مشترك او موقع مماثله، و# اذا كان موقع الملفات و# ستبقي نفسه. هذا مفيده اذا الكائن المرتبط التغييرات نظرا ل# ان الارتباط دائما ب# فتح المستند احدث.

ملاحظة: اذا قمت ب# نقل ملف الارتباط الي موقع اخر، لن يعمل الارتباط بعد الان.

  1. انقر داخل خليه جدول البيانات حيث تريد ادراج الكائن.

  2. ضمن علامة التبويب إدراج، في المجموعة نص، انقر فوق كائن.

    يوجد الخيار «عنصر» في علامة التبويب «إدراج».
  3. انقر فوق علامه التبويب انشاء من ملف .

  4. انقر فوق استعراض، و# من ثم حدد الملف الذي تريد ربطه.

  5. حدد خانه الاختيار ارتباط ب# الملف، ثم انقر فوق موافق.

    من علامة التبويب «إنشاء من ملف»، حدد «ارتباط بالملف.»

انشاء كائن جديد من داخل Excel

يمكنك انشاء كائن جديد ب# الكامل استنادا الي برنامج اخر دون ترك المصنف الخاص بك. علي سبيل المثال، اذا اردت اضافه شرح اكثر تفصيلا ل# جدول او مخطط، يمكنك انشاء مستند مضمن، مثل ملف Word او PowerPoint، في Excel. يمكنك اما تعيين الكائن المراد عرضها ل# اليمين في ورقه عمل او اضافه رمز الذي يفتح الملف.

هذا العنصر المضمّن عبارة عن مستند Word.
  1. انقر داخل خليه جدول البيانات حيث تريد ادراج الكائن.

  2. ضمن علامة التبويب إدراج، في المجموعة نص، انقر فوق كائن.

    يوجد الخيار «عنصر» في علامة التبويب «إدراج».
  3. علي علامه التبويب انشاء جديد، حدد نوع الكائن الذي تريد ادراج من القائمه المعروضه. اذا كنت تريد ل# ادراج رمز في جدول البيانات بدلا من الكائن نفسه، حدد خانه الاختيار عرض ك# رمز.

    علامة التبويب «إنشاء جديد» في مربع الحوار «عنصر».
  4. انقر فوق موافق. استنادا الي نوع الملف الذي تقوم ب# ادراج، يتم فتح نافذه برنامج جديد او تظهر نافذه تحرير داخل Excel.

  5. انشاء كائن الجديده التي تريد ادراجها.

    عند الانتهاء من ذلك، اذا Excel فتح اطار برنامج جديد الذي قمت ب# انشائه علي الكائن، يمكنك العمل ضمنه مباشره.

    يمكنك تحرير مستند Word المضمّن مباشرةً في Excel.

    عندما تنهي عملك في العمل في النافذه، يمكنك القيام ب# مهام اخري دون حفظ الكائن المضمن. عند اغلاق المصنف سيتم حفظ الكائنات الجديده تلقائيا.

    ملاحظة: بعد اضافه الكائن، يمكنك سحب و# افلته في اي مكان في ورقه العمل Excel. يمكنك ايضا تغيير حجم الكائن ب# استخدام مقابض تغيير الحجم. ل# البحث عن المقابض، انقر فوق الكائن مره واحده.

ربط او تضمين محتوي من برنامج اخر ب# استخدام OLE

يمكنك ربط او تضمين ب# اكمله او جزءا من المحتوي من برنامج اخر.

انشاء ارتباط الي محتوي من برنامج اخر

  1. انقر في ورقه العمل حيث تريد وضع عنصر مرتبط.

  2. ضمن علامة التبويب إدراج، في المجموعة نص، انقر فوق كائن.

    شكل شريط Excel

  3. انقر فوق علامه التبويب انشاء من ملف.

  4. في المربع اسم الملف، اكتب اسم الملف، او انقر فوق استعراض ل# تحديد من قائمه.

  5. حدد خانه الاختيار ارتباط ب# الملف.

  6. قم بأحد الإجراءات التالية:

    • ل# عرض المحتوي، قم ب# الغاء تحديد خانه الاختيار عرض ك# رمز.

    • ل# عرض رمز، حدد خانه الاختيار عرض ك# رمز. ب# شكل اختياري، ل# تغيير صوره الرمز الافتراضي او التسميه، انقر فوق تغيير الرمز، ثم انقر فوق الرمز الذي تريده من القائمه ايقونه، او اكتب تسميه في المربع تسميه توضيحيه.

    ملاحظة: لا يمكنك استخدام الامر كائن ل# ادراج الرسومات و# بعض انواع الملفات. ل# ادراج رسم او ملف، ضمن علامه التبويب ادراج، في المجموعه رسومات توضيحيه، انقر فوق صوره.

تضمين محتوي من برنامج اخر

  1. انقر في ورقه العمل حيث تريد وضع عنصر مضمّن.

  2. ضمن علامة التبويب إدراج، في المجموعة نص، انقر فوق كائن.

    شكل شريط Excel

  3. اذا كان المستند غير موجود مسبقا، انقر فوق علامه التبويب انشاء جديد. في المربع نوع الكائن، انقر فوق نوع الكائن الذي تريد انشاء.

    اذا كان المستند موجود ب# الفعل، ف# انقر فوق انشاء من ملف. في المربع اسم الملف، اكتب اسم الملف، او انقر فوق استعراض ل# تحديد من قائمه.

  4. قم ب# الغاء تحديد خانه الاختيار ارتباط ب# الملف.

  5. قم بأحد الإجراءات التالية:

    • ل# عرض المحتوي، قم ب# الغاء تحديد خانه الاختيار عرض ك# رمز.

    • ل# عرض رمز، حدد خانه الاختيار عرض ك# رمز. ل# تغيير صوره الرمز الافتراضي او التسميه، انقر فوق تغيير الرمز، ثم انقر فوق الرمز الذي تريده من القائمه ايقونه، او اكتب تسميه في المربع تسميه توضيحيه.

ربط او تضمين محتوي جزئيه من برنامج اخر

  1. من برنامج بدلا من Excel، حدد المعلومات التي تريد نسخ ك# مرتبط او عنصر مضمّن.

  2. في علامة التبويب الصفحة الرئيسية في المجموعة الحافظة، انقر فوق نسخ.

    المجموعة "الحافظة" ضمن علامة التبويب "الصفحة الرئيسية"

  3. التبديل الي ورقه العمل التي تريد وضع المعلومات الموجوده في و# من ثم انقر فوق المكان الذي تريد ظهور المعلومات فيه.

  4. على علامة تبويب الصفحة الرئيسية في المجموعةالحافظة، انقر فوق السهم الموجود أسفل لصق، ثم انقر فوق لصق خاص.

  5. قم بأحد الإجراءات التالية:

    • للصق المعلومات ككائن مرتبط، انقر فوق لصق الارتباط.

    • ل# لصق المعلومات ك# كائن مضمن، انقر فوق لصق. في المربع ب# اسم، انقر فوق الادخال ب# استخدام الكلمه "كائن" في اسمه. علي سبيل المثال، اذا قمت ب# نسخ المعلومات من مستند Word، انقر فوق كائن مستند Microsoft Word.

تغيير طريقه ظهور كائن OLE

  1. انقر ب# زر الماوس علي ايقونه او الكائن، و# اشر الي نوع الكائنكائن (علي سبيل المثال، كائن مستند )، و# ثم انقر فوق تحويل.

  2. قم بأحد الإجراءات التالية:

    • ل# عرض المحتوي، قم ب# الغاء تحديد خانه الاختيار عرض ك# رمز.

    • ل# عرض رمز، حدد خانه الاختيار عرض ك# رمز. ب# شكل اختياري، يمكنك تغيير صوره الرمز الافتراضي او التسميه. ل# تنفيذ هذا الاجراء، انقر فوق ايقونه "تغيير"، ثم انقر فوق الرمز الذي تريده من القائمه ايقونه، او اكتب تسميه في المربع تسميه توضيحيه.

عنصر تحكم التحديثات التي تطرا علي كائنات مرتبطه

يمكنك تعيين الارتباطات الي برامج اخري ل# يتم تحديث ب# الطرق التاليه: تلقائيا، عند فتح الملف الوجهة ؛ يدويا، عندما تريد رؤيه البيانات السابقه قبل تحديث ب# البيانات الجديده من الملف المصدر ؛ او عند طلبت التحديث، غض النظر عن ما اذا كان التحديث التلقائي او اليدوي قيد التشغيل.

تعيين ارتباط الي برنامج اخر ل# تحديث يدويا

  1. ضمن علامة التبويب البيانات، في المجموعة الاتصالات، انقر فوق تحرير الارتباطات.

    شكل شريط Excel

    ملاحظة: لا يتوفر الامر تحرير الارتباطات اذا كان الملف لا يحتوي علي ارتباطات الي ملفات اخري.

  2. في القائمه المصدر، انقر فوق الكائن المرتبط الذي تريد تحديثه. A في العمود تحديث يعني ان الارتباط تلقائيا، و# تعيين M في وسائل العمود تحديث التي يتم الارتباط ل# التحديث اليدوي.

    تلميح: ل# تحديد كائنات مرتبطه متعدده، اضغط ب# استمرار علي CTRL و# انقر فوق كل كائن مرتبط. ل# تحديد كافه الكائنات المرتبطه، اضغط علي CTRL + A.

  3. ل# تحديث كائن مرتبط فقط عند النقر فوق تحديث القيم، انقر فوق يدوي.

تعيين ارتباط الي برنامج اخر ل# يتم تحديثه تلقائيا

  1. ضمن علامة التبويب البيانات، في المجموعة الاتصالات، انقر فوق تحرير الارتباطات.

    شكل شريط Excel

    ملاحظة: لا يتوفر الامر تحرير الارتباطات اذا كان الملف لا يحتوي علي ارتباطات الي ملفات اخري.

  2. في القائمه المصدر، انقر فوق الكائن المرتبط الذي تريد تحديثه. A في العمود تحديث يعني انه سيتم تحديث الارتباط تلقائيا، و M في العمود تحديث يعني انه يجب ان يتم تحديث الارتباط يدويا.

    تلميح: ل# تحديد كائنات مرتبطه متعدده، اضغط ب# استمرار علي CTRL و# انقر فوق كل كائن مرتبط. ل# تحديد كافه الكائنات المرتبطه، اضغط علي CTRL + A.

  3. انقر فوق موافق.

المشكله: لا يمكن تحديث الارتباطات التلقائيه علي ورقه العمل الخاصه بي

يمكن تجاوز الخيار التلقائي ب# الخيار Excel ب# تحديث الارتباطات الي مستندات اخري.

ل# التاكد من ان هذه الارتباطات التلقائيه ل# كائنات OLE يمكن تحديثها تلقائيا:

  1. انقر فوق زر Microsoft Office صورة زر Office و# انقر فوق خيارات Excel، و# من ثم انقر فوق الفئه خيارات متقدمه.

  2. ضمن عند حساب هذا المصنف، تاكد من تحديد خانه الاختيار تحديث الارتباطات الي مستندات اخري.

تحديث ارتباط الي برنامج اخر الان

  1. ضمن علامة التبويب البيانات، في المجموعة الاتصالات، انقر فوق تحرير الارتباطات.

    شكل شريط Excel

    ملاحظة: لن يتوفر الأمر تحرير الارتباطات إذا لم يتضمن الملف معلومات مرتبطة.

  2. من القائمة المصدر، انقر فوق الكائن المرتبط الذي تريد تحديثه.

    تلميح: ل# تحديد كائنات مرتبطه متعدده، اضغط ب# استمرار علي CTRL و# انقر فوق كل كائن مرتبط. ل# تحديد كافه الكائنات المرتبطه، اضغط علي CTRL + A.

  3. انقر فوق تحديث القيم.

تحرير محتوي من برنامج OLE

اثناء عملك في Excel، يمكنك تغيير المحتوي ربطها او تضمينها من برنامج اخر.

تحرير كائن مرتبط في البرنامج المصدر

  1. ضمن علامة التبويب البيانات، في المجموعة الاتصالات، انقر فوق تحرير الارتباطات.

    شكل شريط Excel

    ملاحظة: لن يتوفر الأمر تحرير الارتباطات إذا لم يتضمن الملف معلومات مرتبطة.

  2. في قائمه الملف المصدر، انقر فوق المصدر ل عنصر مرتبط، و# من ثم انقر فوق فتح المصدر.

  3. ادخل التغييرات التي تريدها ل# الكائن المرتبط.

  4. قم ب# انهاء برنامج مصدر ل# العوده الي الملف الوجهه.

تحرير كائن مضمن في البرنامج المصدر

  1. انقر نقرا مزدوجا فوق عنصر مضمّن ل# فتحه.

  2. ادخل التغييرات التي تريدها ل# الكائن.

  3. اذا كنت تقوم ب# تحرير الكائن في داخل البرنامج المفتوح، انقر فوق اي مكان خارج الكائن ل# العوده الي الملف الوجهة.

    اذا قمت ب# تحرير الكائن المضمن في البرنامج المصدر في نافذه منفصله، قم ب# انهاء البرنامج المصدر ل# العوده الي الملف الوجهه.

ملاحظة: النقر نقرا مزدوجا فوق بعض الكائنات المضمنه، مثل مقاطع الفيديو و# الصوت، تشغيل الكائن بدلا من فتح برنامج. ل# تحرير احد هذه الكائنات المضمنه، زر الماوس الايمن فوق ايقونه او الكائن، و# اشر الي نوع الكائنكائن (علي سبيل المثال، كائن قصاصه وسائط )، و# ثم انقر فوق تحرير.

تحرير كائن مضمن في برنامج بدلا من البرنامج المصدر

  1. حدد عنصر مضمّن الذي تريد تحريره.

  2. انقر ب# زر الماوس علي ايقونه او الكائن، و# اشر الي نوع الكائنكائن (علي سبيل المثال، كائن مستند )، و# ثم انقر فوق تحويل.

  3. قم بأحد الإجراءات التالية:

    • ل# تحويل الكائن المضمن الي النوع الذي تحدده في القائمه، انقر فوق تحويل الي.

    • ل# فتح الكائن المضمن ك# نوع الذي تحدده في القائمه دون تغيير نوع الكائن المضمن، انقر فوق تنشيط.

تحديد كائن OLE ب# استخدام لوحه المفاتيح

  1. اضغط علي CTRL + G ل# عرض مربع الحوار الانتقال الي.

  2. انقر فوق خاص و# تحديد كائنات، و# من ثم انقر فوق موافق.

  3. اضغط علي TAB الي ان يتم تحديد الكائن الذي تريده.

  4. اضغط SHIFT+F10.

  5. اشر الي كائن او مخطط، و# من ثم انقر فوق تحرير.

المشكله: عند النقر نقرا مزدوجا فوق كائن مرتبط او مضمن، "لا يمكن التحرير" تظهر رساله

تظهر هذه الرساله عند تعذر فتح الملف المصدر او برنامج مصدر.

تاكد من ان البرنامج المصدر المتوفره     اذا كان البرنامج المصدر غير مثبته علي الكمبيوتر الخاص بك، تحويل الكائن الي تنسيق الملف ل# البرنامج الذي قمت ب# تثبيته.

تاكد من ان الذاكره كافيه     تاكد من ان لديك ذاكره كافيه ل# تشغيل البرنامج المصدر. اغلق البرامج الاخري ل# تحرير الذاكره، اذا لزم الامر.

اغلاق كافه مربعات الحوار     اذا تم تشغيل البرنامج المصدر، تاكد من انه لا يحتوي علي مربعات الحوار المفتوحه. التبديل الي البرنامج المصدر، ثم اغلاق مربعات الحوار المفتوحه.

اغلق الملف المصدر     اذا كان الملف المصدر كائن مرتبط، تاكد من انه لا يملك المستخدم اخر فتحه.

تاكد من عدم تغيير اسم الملف المصدر     اذا كان الملف المصدر الذي تريد تحرير كائن مرتبط، تاكد من به ب# الاسم نفسه كما كان عند انشاء الارتباط و# من انه لم يتم نقل. حدد الكائن المرتبط، و# من ثم انقر فوق الامر تحرير الارتباطات في المجموعه " الاتصالات " علي علامه التبويب بيانات ل# الاطلاع علي اسم الملف المصدر. اذا تمت اعاده تسميه او نقل الملف المصدر، استخدم الزر تغيير المصدر في مربع الحوار تحرير الارتباطات ل# تحديد موقع الملف المصدر و# اعاده توصيل الارتباط.

هل تحتاج إلى مزيد من المساعدة؟

ويمكنك دائماً الاستفسار من أحد الخبراء في مجتمع Excel‏ التقني،أو الحصول على الدعم من خلال إجابات المجتمع،أو اقتراح ميزة جديدة أو تحسين عن طريق ‏Excel User Voice‏.

ملاحظة: إقرار إخلاء المسؤولية للترجمة الآلية: تمت ترجمة هذه المقالة بواسطة نظام كمبيوتر دون تدخل العامل البشري. توفر Microsoft هذه الترجمات الآلية لمساعدة المستخدمين الذين لا يتحدثون الإنجليزية على استخدام منتجات Microsoft، وخدماتها، وتقنياتها والاستمتاع بها. قد تحتوي هذه المقالة على أخطاء في المفردات، أو بناء الجملة، أو القواعد نظرًا لترجمتها آليًا.

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×