إنشاء مخطط هيكلي تلقائياً من بيانات الموظفين

إنشاء مخطط هيكلي تلقائياً من بيانات الموظفين

المخطط الهيكلي هو عبارة عن رسم تخطيطي يُظهر العلاقات بين الموظفين والمسميات الوظيفية والمجموعات.

إذا كان لديك كل معلومات الموظفين في مستند مثل ورقة عمل Excel أو دليل Exchange Server، فيمكن أن يقوم Visio بإنشاء رسم تخطيطي يضيف الأشكال والموصلات لك. إذا لم تكن تريد إنشاء مخطط تلقائياً، فيمكنك رسم مخطط دون استخدام مصدر بيانات خارجي.

لبدء "معالج المخطط الهيكلي"، انقر فوق ملف > جديد وانقر فوق الفئة مخطط هيكلي، ثم انقر فوق إنشاء

في Visio 2016، انقر فوق ملف > جديد > الأعمال > مخطط هيكلي، ثم انقر فوق إنشاء.

مخطط هيكلي

إنشاء تلقائي لمخطط من مصدر بيانات موجود

عند النقر لإنشاء مخطط من القالب، فإنه يتم بدء تشغيل معالج المخطط الهيكلي. في الصفحة الأولى من المعالج، حدد المعلومات التي تم تخزينها مسبقاً في ملف أو قاعدة بيانات ثم اتبع التوجيهات الموجودة في المعالج.

مصادر البيانات التي يمكن استخدامها

  • ورقة عمل Microsoft Excel

  • ملف نصي

  • دليل Microsoft Exchange Server

  • مصدر بيانات متوافق مع ODBC

الأعمدة المطلوبة في مصدر البيانات

يجب أن يتضمن مصدر البيانات أعمدة لاسم الموظف، والمعرف الفريد، والمدير المباشر للموظف. أسماء الأعمدة في مصدر البيانات ليست مهمة، لأنه في المعالج يمكنك يدوياً تحديد الأعمدة (أو أسماء الحقول) التي تحتوي على اسم الموظف واسم المدير المباشر.

  • اسم الموظف    الطريقة التي تظهر بها أسماء الموظفين في هذا الحقل هي الطريقة التي تظهر بها في أشكال المخطط الهيكلي.

  • المعرّف الفريد     يمكن أن يكون هذا العمود هو عمود "اسم الموظف" إذا كانت جميع الأسماء فريدة. وإلا، فقم بتضمين عمود مع قيمة تعرف كل موظف بشكل فريد.

  • المدير المباشر للموظف    يجب أن يحتوي هذا الحقل على المعرّف الفريد لكل مدير وما إذا كان هذا المعرّف عبارة عن اسم أم رقم معرّف. بالنسبة للموظف الموجود في قمة المخطط الهيكلي، اترك هذا الحقل فارغاً.

مثال حول ملف نصي كمصدر بيانات

يعطي النص التالي مثالاً حول ملف نصي محدد بفواصل يتضمن خمسة أعمدة وأربعة صفوف، مع اعتبار الصف الأول هو صف رأس. سيقوم Visio بإنشاء ملف نص العينة هذا لك - ابدأ معالج المخطط الهيكلي، وحدد المعلومات التي يتم إدخالها باستخدام المعالج، وانقر فوق التالي. على الصفحة التالية حدد نص محدد، اكتب اسم ملف، وانقر فوق التالي. يفتح Visio محرر نص مع بيانات العينة هذه كدليل توجيه.

الاسم،المدير المباشر،المسمى الوظيفي،القسم،رقم الهاتف

عيسى نادر، ،رئيس مجلس الإدارة،مدير تنفيذي،x5555
منار كريم،عيسى نادر،مدير التطوير،تطوير المنتجات،x6666
وليد حلو،منار كريم،مطور برامج،تطوير المنتجات،x6667

إنشاء مخطط هيكلي من ملف بيانات جديد

إذا لم تكن البيانات لديك موجودة مسبقاً في برنامج مختلف ولكنك ترغب في ذلك، فسيقوم Visio بفتح Excel أو محرر نص مع بيانات عينة ضمن تنسيق مثال جيد. استبدل بيانات العينة ببياناتك الحقيقية وقم بإنهاء المعالج لإنشاء المخطط الهيكلي.

  1. لبدء "معالج المخطط الهيكلي"، انقر فوق ملف > جديد وانقر فوق الفئة مخطط هيكلي، ثم انقر فوق إنشاء

    في Visio 2016، انقر فوق ملف > جديد > الأعمال > مخطط هيكلي، ثم انقر فوق إنشاء.

  2. في الصفحة الأولى من المعالج، حدد المعلومات التي يتم إدخالها باستخدام المعالج ثم انقر فوق التالي.

  3. حدد Excel أو نص محدد، واكتب اسماً للملف الجديد، ثم انقر فوق التالي.
    إذا حددت Excel، فسيتم فتح ورقة عمل Microsoft Excel مع نص العينة. وإذا حددت نص محدد، فسيتم فتح صفحة "مفكرة" مع نص العينة.

  4. عند فتح أي من Excel أو "المفكرة"، استخدم نص العينة كمثال على نوع المعلومات المراد تضمينها واكتب معلوماتك فوق ما هو موجود هناك. يعتبر عمود اسم الموظف وعمود المدير المباشر مطلوبين، ولكن يمكنك إضافة الأعمدة الأخرى أو حذفها.

  5. قم بإنهاء إما Excel أو "المفكرة"، ثم أكمل المعالج.

تغيير التخطيط، وتغيير الأشكال، وإدراج صور

تقوم قوالب المخطط الهيكلي بإضافة علامة التبويب مخطط هيكلي إلى الشريط. استخدم الأدوات الموجودة في هذا التبويب لإجراء تغييرات كبيرة في مظهر الرسم التخطيطي.

تتضمن مجموعتي التخطيطات والترتيب أدوات لتغيير تخطيط الأشكال وتسلسلها الهيكلي.

استخدم معرض الأشكال لاختيار نمط الأشكال في المخطط. استخدم الأدوات الموجودة في مجموعة الصور لإدراج صورة في الشكل المحدد، وحذف العنصر النائب للصورة، وتغيير الصورة بعد إدراجها في الشكل. إذا لم تقم بإضافة صور إلى كل الأشكال باستخدام المعالج، يمكنك إضافتها الآن. في علامة التبويب مخطط هيكلي، انقر فوق إدراج > صور متعددة. يجب أن تكون كل الصور في مجلد واحد، ويجب أن يكون اسم الملف بالتنسيق "Employee Name.FileType" – على سبيل المثال، Issa Nadar.jpg (يجب أن يتطابق الاسم تماماً مع الاسم الموجود في مصدر البيانات).

تتضمن مجموعة بيانات الهيكل أدوات لاستيراد البيانات من مصدر خارجي باستخدام المعالج، تصدير بيانات الهيكل إلى Excel أو ملف نصي، ومقارنة البيانات في الرسم التخطيطي مع مصدر البيانات الخارجي.

إظهار الفرق باستخدام إطار الفريق أو خطوط منقطة

بعد قيامك بإنشاء مخطط هيكلي، يمكنك إعادة ترتيب المعلومات لتعكس علاقات الفريق الظاهرية. انقل الأشكال ذات الصلة بالقرب من بعضها البعض، ثم أضف موصلات خطية منقطة لعرض هياكل الرؤساء الثانوية. أو قم بتمييز فريق ظاهري باستخدام إطار فريق. اسحب الشكل "إطار فريق" من النافذة "أشكال" إلى الرسم، ثم استخدم مقابض التحجيم الموجودة على الجوانب لجعله يتضمن الأفراد الموجودين في الفريق الظاهري.

إطار فريق

تحديث مخطط هيكلي يستخدم مصدر بيانات خارجي

لعكس التغييرات في البنية لمؤسسة ما، يمكنك القيام بتحديث مخطط البيانات أو المخطط الهيكلي يدوياً:

  • انقر فوق بيانات >‏ بيانات خارجية >‏ تحديث الكل.

إذا لم تكن البيانات الجديدة متطابقة تماماً مع البيانات التي تم إنشاء المخطط بها، فقد يكون من الضروري نقل الأفراد يدوياً.

إذا كان لديك مخطط جديد، فاستخدم Visio لمقارنته مع مخططك القديم وتعريفك بما تم تغييره.

  1. افتح إما الإصدار الجديد أو الإصدار القديم من المخطط الهيكلي.

  2. انقر فوق مخطط هيكلي >‏ بيانات الهيكل >‏ مقارنة. ابحث عن الإصدار الذي تريد إجراء المقارنة معه في المربع مقارنة بيانات الهيكل.

  3. حدد الحالة، استناداً إلى الإصدار الذي فتحته، ضمن نوع المقارنة.

  4. حدد الخيار الذي تريده ضمن نوع التقرير.

  5. انقر فوق موافق.

إذا كنت لا تزال غير قادر على تحديث المخطط كما تريد، فقد تحتاج إلى إعادة إنشاء هذا المخطط.

تعزيز مهارات Office
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×