إنشاء ماكرو أو تشغيله أو تحريره أو حذفه

هام: تمت ترجمة هذه المقالة ترجمة آلية، راجع إقرار إخلاء المسؤولية. يرجى الاطلاع على النسخة الإنجليزية من هذه المقالة. هنا للرجوع إليها.

ل# توفير الوقت علي المهام ب# شكل متكرر، يمكنك تسجيل خطوات تلك المهام ل# ماكرو. بعد ذلك، عندما تريد نفذ واحدا من هذه المهام المسجله، يمكنك تنشيط الماكرو ل# تنفيذ الخطوات ب# النيابه عنك.

Word

في Word 2016 for Mac، يمكنك انشاء ماكرو يحتوي علي اختصار لوحه مفاتيح، و# تشغيل ماكرو، و# حذف ماكرو لم تعد ب# حاجه اليها.

  1. انقر فوق عرض >‏ وحدات ماكرو >‏ تسجيل الماكرو.

    علي علامه التبويب عرض، انقر فوق الماكرو، و# من ثم انقر فوق "تسجيل ماكرو" ل# بدء انشاء ماكرو.
  2. اكتب اسما للماكرو، او اقبل الخيار الافتراضي يوفر ذلك Word.

    ادخل اسما للماكرو في اسم الماكرو، او قبول الاسم العام المتوفره في Word.
  3. ل# استخدام الماكرو في اي مستندات جديده تقوم ب# انشاء، تاكد من ان يتم تحديد كافه المستندات (عادي) في القائمه تخزين الماكرو.

  4. انقر فوق لوحه المفاتيح ل# تعيين مجموعه مفاتيح ل# الماكرو.

    Word ل# عرض مربع الحوار تخصيص لوحه المفاتيح.

  5. اكتب تركيبه المفاتيح في المربع اضغط اختصار لوحه المفاتيح الجديده.

    يعرض Word الامر او الماكرو التي يتم تعيينها ب# الفعل تركيبه مفاتيح، ان وجدت، بعد الضغط علي تركيبه.

    عند الضغط علي تركيبه مفاتيح، يعرض Word الامر او الاجراء معينه حاليا ل# تركيبه المفاتيح تلك، ان وجدت.

  6. اذا تم تعيين علي تركيبه المفاتيح التي تختارها، حذفها من المربع اضغط اختصار لوحه المفاتيح الجديده،، ثم اختر مجموعه مفاتيح جديده.

    انتقل الي الخطوه التاليه بعد العثور علي تركيبه مفاتيح غير معينه.

    تعرف Word عند لديك الضغط علي تركيبه مفاتيح التي لم يتم تعيين بعد ل# امر او ماكرو.
  7. ل# استخدام اختصار لوحه المفاتيح هذا في اي مستندات جديده، يتم التاكيد Normal.dotm، يتم تحديد القالب العمومي، في القائمه حفظ التغييرات.

    حدد Normal.dotm ل# جعل ماكرو متوفرا ل# الاستخدام في المستندات الجديده التي تقوم ب# انشائها.
  8. انقر فوق تعيين.

  9. عندما تكون جاهزا ل# تسجيل الماكرو، انقر فوق موافق.

  10. انقر فوق الاوامر او اضغط علي مفاتيح ل# كل خطوه في المهمه.

    سجلات Word نقرات و# ضغطات المفاتيح الخاصه بك، و# لكن لا يسجل النص الذي قمت ب# تحديد ب# استخدام الماوس. ل# تحديد النص اثناء تسجيل ماكرو، استخدم لوحه المفاتيح.

  11. لإيقاف التسجيل، انقر فوق عرض >‏ وحدات ماكرو >‏ إيقاف التسجيل.

    انقر فوق "ايقاف التسجيل" في القائمه وحدات الماكرو ل# ايقاف تسجيل ماكرو.

ل# تشغيل ماكرو، اضغط علي اختصار لوحه المفاتيح المعينه لها، او تشغيل الماكرو من القائمه وحدات الماكرو.

  1. انقر فوق عرض >‏ وحدات ماكرو >‏ عرض وحدات الماكرو.

    انقر فوق "عرض وحدات الماكرو" ل# عرض و# تحرير وحدات الماكرو المقترن ب# المستند الحالي.
  2. في القائمه الموجوده ضمن اسم الماكرو، حدد الماكرو الذي تريد تشغيله.

  3. انقر فوق تشغيل.

    بعد تحديد ماكرو ضمن اسم الماكرو، انقر فوق تشغيل ل# تشغيله.

  1. انقر فوق عرض >‏ وحدات ماكرو >‏ عرض وحدات الماكرو.

    انقر فوق "عرض وحدات الماكرو" ل# عرض و# تحرير وحدات الماكرو المقترن ب# المستند الحالي.
  2. تاكد من ان الموقع المحدد ب# واسطه وحدات الماكرو في يتضمن موقع الماكرو الذي تريد حذفه.

    حدد موقع وحدات الماكرو التي تريد عرضها من وحدات الماكرو في القائمه.

    تتضمن القائمه مستند مفتوح في الاطار الحالي، ب# الاضافه الي الاوامر القالب و Word العموميه.

  3. ضمن اسم الماكرو، حدد الماكرو الذي تريد حذفه، و# من ثم انقر فوق علامه الطرح اسفل القائمه.

    حدد الماكرو الذي تريد حذفه، و# من ثم انقر فوق علامه الطرح ضمن القائمه.
  4. عندما يطلب Word ل# تاكيد رغبتك في حذف الماكرو، انقر فوق نعم.

Excel

في Excel 2016 for Mac، يمكنك انشاء ماكرو يحتوي علي اختصار لوحه مفاتيح، و# تشغيل ماكرو، و# حذف ماكرو لم تعد ب# حاجه اليها.

عند تسجيل ماكرو، السجلات مسجل الماكرو كل الخطوات المطلوبه ل# اكمال الاجراءات التي تريد الماكرو ل# تنفيذ. يمكنك تضمين الخطوات كتابه نص او ارقام، النقر فوق الخلايا او الاوامر علي الشريط او في القوائم، التنسيق و# تحديد خلايا او صفوف او اعمده و# سحب الماوس ل# تحديد الخلايا في جدول البيانات.

ملاحظة: تتوفر الاوامر ل# التسجيل و# انشاء، و# حذف وحدات الماكرو، ب# الاضافه الي الميزات المتقدمه الاخري، علي علامه التبويب المطور علي الشريط. ل# الحصول علي مزيد من المعلومات حول استخدام علامه التبويب المطور، راجع استخدام علامه التبويب "المطور" ل# انشاء ماكرو او حذفه في Excel 2016 for Mac.

  1. حدد ادوات > ماكرو > السجل الجديد.

    حدد ادوات، ثم الماكرو، ثم قم ب# تسجيل ماكرو جديد

  2. في المربع اسم الماكرو، أدخل اسماً للماكرو.

    ادخال مفتاح اسم و# موقع اختصار الماكرو

  3. ل# انشاء اختصار لوحه مفاتيح ل# الماكرو، اكتب رساله في المربع Option + Cmd.

  4. حدد موقعا ل# الماكرو من القائمه المنسدله.

    حفظ الماكرو

    انقر فوق

    في المستند الذي كنت تقوم ب# انشاء ماكرو في

    هذا المصنف

    في كافة المستندات المفتوحة

    مصنف جديد

    بحيث يكون متوفراً كلما استخدمت Excel

    مصنف الماكرو الشخصي

  5. (اختياري) اضافه وصف الماكرو الخاص بك.

  6. عندما تكون جاهزا ل# تسجيل، انقر فوق موافق.

  7. انقر فوق الاوامر او اضغط علي مفاتيح ل# كل خطوه في المهمه.

  8. ل# ايقاف التسجيل، حدد ادوات > ماكرو > ايقاف التسجيل. (هذه الخطوه لن يتم تسجيل في الماكرو.)

    حدد ايقاف التسجيل

ل# تشغيل ماكرو، اضغط علي اختصار لوحه المفاتيح المعينه لها، او تشغيل الماكرو في مربع الحوار وحدات الماكرو.

  1. على علامة التبويب عرض، انقر فوق عرض وحدات الماكرو.

  2. انقر فوق وحدات ماكرو في القائمه المنبثقه و# حدد هذا المصنف.

  3. حدد الماكرو من القائمة، ثم انقر فوق تشغيل.

    مربع الحوار "وحدات ماكرو" في Excel for Mac

  1. حدد ادوات > ماكرو > وحدات ماكرو.

    حدد الماكرو، ثم حدد وحدات الماكرو

  2. حدد الماكرو ل# حذف، و# من ثم اضغط علي علامه الطرح.

    حدد اسم الماكرو، ثم حدد علامه الطرح

  3. تظهر رساله تاكيد. انقر فوق نعم ل# التاكيد علي الحذف.

    تاكيد الحذف

يمكنك ايضا حذف ماكرو من علامه التبويب المطور.

  1. على علامة تبويب المطور، انقر فوق وحدات ماكرو.

  2. في القائمة، انقر فوق الماكرو الذي تريد حذفه، وانقر فوق الزر "حذف".

    حدد ماكرو وانقر فوق علامة الطرح لحذفه

Word

لأتمتة مهمة مكررة، يمكنك إنشاء الماكرو بسرعة في Word. يمكنك أيضاً استخدام محرر Visual Basic في Microsoft Visual Basic for Applications (VBA)‎ لكتابة البرنامج النصي للماكرو الخاص بك، أو نسخ الماكرو بأكمله أو جزء منه إلى ماكرو جديد.

عند تسجيل ماكرو، يتم تسجيل كل الخطوات المطلوبه ل# اكمال الاجراءات التي تريد الماكرو ل# تنفيذ. و# مع ذلك، لا يتم تضمين التنقل العوده الي علامه التبويب ل# ايقاف التسجيل في الخطوات المسجله.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق تسجيل.

    علامة التبويب "المطور"، المجموعة Visual Basic في Word

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في المربع اسم الماكرو، أدخل اسماً للماكرو.

  3. في القائمة المنبثقة تخزين الماكرو في، قم بواحد مما يلي:

    لحفظ الماكرو

    انقر فوق

    في المستند الذي تعمل على إنشاء الماكرو فيه

    [اسم المستند] (مستند)

    في كافة المستندات المفتوحة

    جميع المستندات (عادي)

  4. انقر فوق موافق، ثم قم بتنفيذ الإجراءات التي تريد تسجيلها.

  5. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق إيقاف.

يمكنك استخدام محرر Visual Basic المضمن لإنشاء ماكرو.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق محرر.

    علامة التبويب "المطور"، المجموعة Visual Basic في Word

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. إذا أردت إدراج وحدة نمطية، في محرر Visual Basic، في قائمة إدراج، انقر فوق وحدة نمطية.

  3. في نافذة التعليمات البرمجية الخاصة بالوحدة النمطية، اكتب التعليمات البرمجية للماكرو التي تريد استخدامها أو الصقها.

  4. عندما تنهي عملك، في قائمة Word، انقر فوق إغلاق والعودة إلى Microsoft Word.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Word

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد تشغيله، ثم انقر فوق تشغيل.

لتحرير ماكرو، ستستخدم محرر Visual Basic.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Word

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذين تريد تحريره، ثم انقر فوق تحرير.

    يفتح محرر Visual Basic.

  3. أجرِ التغييرات المطلوبة.

  4. عندما تنهي عملك، في قائمة Word، انقر فوق إغلاق والعودة إلى Microsoft Word.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Word

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد نسخه، ثم انقر فوق تحرير.

    يفتح محرر Visual Basic.

  3. في نافذة التعليمات البرمجية لمحرر Visual Basic، حدد أسطر الماكرو التي تريد نسخها.

    تلميح: لنسخ الماكرو بأكمله، قم بتضمين السطرين Sub وEnd Sub في التحديد.

  4. من القائمة تحرير، انقر فوق نسخ.

  5. في المربع مشروع في نافذة التعليمات البرمجية، انقر فوق الوحدة النمطية حيث تريد وضع التعليمات البرمجية.

  6. من القائمة تحرير، انقر فوق لصق.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Word

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد حذفه، ثم انقر فوق حذف.

PowerPoint

ب# شكل تلقائي مهمه متكرره، يمكنك استخدام Visual Basic for Applications ل# انشاء الماكرو في PowerPoint.

يمكنك استخدام محرر Visual Basic المضمن لإنشاء ماكرو.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق محرر.

    علامة التبويب "المطور"، المجموعة Visual Basic في PowerPoint

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. إذا أردت إدراج وحدة نمطية، في محرر Visual Basic، في قائمة إدراج، انقر فوق وحدة نمطية.

  3. في نافذة التعليمات البرمجية الخاصة بالوحدة النمطية، اكتب التعليمات البرمجية للماكرو التي تريد استخدامها أو الصقها.

  4. عندما تنهي عملك، في قائمة PowerPoint، انقر فوق إغلاق والعودة إلى Microsoft PowerPoint.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في PowerPoint

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد تشغيله، ثم انقر فوق تشغيل.

لتحرير ماكرو، ستستخدم محرر Visual Basic.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في PowerPoint

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذين تريد تحريره، ثم انقر فوق تحرير.

    يفتح محرر Visual Basic.

  3. أجرِ التغييرات المطلوبة.

  4. عندما تنهي عملك، في قائمة PowerPoint، انقر فوق إغلاق والعودة إلى Microsoft PowerPoint.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في PowerPoint

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد نسخه، ثم انقر فوق تحرير.

    يفتح محرر Visual Basic.

  3. في نافذة التعليمات البرمجية لمحرر Visual Basic، حدد أسطر الماكرو التي تريد نسخها.

    تلميح: لنسخ الماكرو بأكمله، قم بتضمين السطرين Sub وEnd Sub في التحديد.

  4. من القائمة تحرير، انقر فوق نسخ.

  5. في المربع مشروع في نافذة التعليمات البرمجية، انقر فوق الوحدة النمطية حيث تريد وضع التعليمات البرمجية.

  6. من القائمة تحرير، انقر فوق لصق.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في PowerPoint

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد حذفه، ثم انقر فوق حذف.

Excel

لأتمتة مهمة مكررة، يمكنك إنشاء الماكرو بسرعة في Excel. يمكنك أيضاً استخدام محرر Visual Basic في Microsoft Visual Basic for Applications (VBA)‎ لكتابة البرنامج النصي للماكرو الخاص بك، أو نسخ الماكرو بأكمله أو جزء منه إلى ماكرو جديد.

يتم تسجيل كل الخطوات المطلوبة لإكمال الإجراءات التي تريد أن ينفذها الماكرو. ومع ذلك، لا تتضمن الخطوات المسجّلة العودة إلى علامة التبويب لإيقاف التسجيل.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق تسجيل.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في المربع اسم الماكرو، أدخل اسماً للماكرو.

    تلميح: لإنشاء اختصار لوحة مفاتيح للماكرو، اكتب حرفاً في المربع Option+Cmd+.

  3. في القائمة المنبثقة تخزين الماكرو في، قم بواحد مما يلي:

    لحفظ الماكرو

    انقر فوق

    في المستند الذي تعمل على إنشاء الماكرو فيه

    هذا المصنف

    في كافة المستندات المفتوحة

    مصنف جديد

    بحيث يكون متوفراً كلما استخدمت Excel

    مصنف الماكرو الشخصي

    مصنف الماكرو الشخصي يقع في المستخدمين / اسم المستخدم/ مكتبه / التطبيق دعم / Microsoft / Office / Excel.

  4. انقر فوق موافق، ثم قم بتنفيذ الإجراءات التي تريد تسجيلها.

  5. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق تسجيل مرة أخرى.

يمكنك استخدام محرر Visual Basic المضمن لإنشاء ماكرو.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق محرر.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. إذا أردت إدراج وحدة نمطية، في محرر Visual Basic، في قائمة إدراج، انقر فوق وحدة نمطية.

  3. في نافذة التعليمات البرمجية الخاصة بالوحدة النمطية، اكتب التعليمات البرمجية للماكرو التي تريد استخدامها أو الصقها.

  4. عندما تنهي عملك، في قائمة Excel، انقر فوق إغلاق والعودة إلى Microsoft Excel.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد تشغيله، ثم انقر فوق تشغيل.

    تلميح: لتشغيل ماكرو باستخدام اختصار لوحة مفاتيح، اضغط على OPTION + الأمر +الحرف الذي كتبته عندما أنشأت اختصار لوحة المفاتيح.

لتحرير ماكرو، ستستخدم محرر Visual Basic.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذين تريد تحريره، ثم انقر فوق تحرير.

    يفتح محرر Visual Basic.

  3. أجرِ التغييرات المطلوبة.

  4. عندما تنهي عملك، في قائمة Excel، انقر فوق إغلاق والعودة إلى Microsoft Excel.

بعد إكمال هذا الإجراء، سيتم تشغيل الماكرو كلما فتحت المصنف الذي يحتوي على الماكرو.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق تسجيل.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في المربع اسم الماكرو، اكتب Auto_Open.

  3. في القائمة المنبثقة تخزين الماكرو في، قم بواحد مما يلي:

    لحفظ الماكرو

    انقر فوق

    في المستند الذي تعمل على إنشاء الماكرو فيه

    هذا المصنف

    في كافة المستندات المفتوحة

    مصنف جديد

    بحيث يكون متوفراً كلما استخدمت Excel

    مصنف الماكرو الشخصي

  4. انقر فوق موافق، ثم قم بتنفيذ الإجراءات التي تريد تسجيلها.

  5. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق تسجيل مرة أخرى.

  6. في قائمة ملف، انقر فوق حفظ باسم.

  7. في القائمة المنبثقة تنسيق، انقر فوق Excel Macro-Enabled Workbook (.xlsm)، ثم فوق حفظ.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد نسخه، ثم انقر فوق تحرير.

    يفتح محرر Visual Basic.

  3. في نافذة التعليمات البرمجية لمحرر Visual Basic، حدد أسطر الماكرو التي تريد نسخها.

    تلميح: لنسخ الماكرو بأكمله، قم بتضمين السطرين Sub وEnd Sub في التحديد.

  4. من القائمة تحرير، انقر فوق نسخ.

  5. في المربع مشروع في نافذة التعليمات البرمجية، انقر فوق الوحدة النمطية حيث تريد وضع التعليمات البرمجية.

  6. من القائمة تحرير، انقر فوق لصق.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد حذفه، ثم انقر فوق حذف.

ملاحظة: إقرار إخلاء المسؤولية للترجمة الآلية: تمت ترجمة هذه المقالة بواسطة نظام كمبيوتر دون تدخل العامل البشري. توفر Microsoft هذه الترجمات الآلية لمساعدة المستخدمين الذين لا يتحدثون الإنجليزية على استخدام منتجات Microsoft، وخدماتها، وتقنياتها والاستمتاع بها. قد تحتوي هذه المقالة على أخطاء في المفردات، أو بناء الجملة، أو القواعد نظرًا لترجمتها آليًا.

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×