إنشاء ماكرو أو تشغيله أو تحريره أو حذفه في Office for Mac

ملاحظة: إننا نرغب في تزويدك بأحدث محتوى تعليمات لدينا بأسرع ما يمكن، وبلغتك الخاصة. وقد تمت ترجمة هذه الصفحة آلياً، وقد تحتوي على أخطاء نحوية أو أخطاء تتعلق بالدقة. إن هدفنا هو أن يكون هذا المحتوى مفيداً لك. هل يمكنك إخبارنا إذا ما كانت المعلومات مفيدة لك في أسفل هذه الصفحة؟ فيما يلي المقالة باللغة الإنجليزية لتكون مرجعاً سهلاً لك.

لتوفير الوقت في المهام التي تقوم بها باستمرار، يمكنك تسجيل خطوات هذه المهام كماكرو. بعد ذلك ، عندما تريد اجراء أحدي المهام المسجلة ، يمكنك تنشيط الماكرو لتنفيذ الخطوات التي تريدها.

Word

في Word 2016 for Mac ، يمكنك إنشاء ماكرو يحتوي علي اختصار لوحه مفاتيح ، وتشغيل ماكرو ، وحذف الماكرو الذي لم تعد بحاجه اليه.

  1. انقر فوق عرض >‏ وحدات ماكرو >‏ تسجيل الماكرو.

    علي علامة التبويب عرض ، انقر فوق ماكرو ، ثم انقر فوق تسجيل ماكرو لبدء إنشاء ماكرو.
  2. اكتب اسما للماكرو ، أو اقبل الاعداد الافتراضي الذي يوفره Word.

    ادخل اسما لماكرو في اسم الماكرو ، أو اقبل الاسم العام الذي يوفره Word.
  3. لاستخدام هذا الماكرو في اي مستندات جديده تقوم بإنشاءها ، تاكد من تحديد كافة المستندات (عادي) في القائمة تخزين الماكرو في .

  4. انقر فوق لوحه المفاتيح لتعيين تركيبه مفاتيح إلى الماكرو.

    يعرض Word مربع الحوار " تخصيص لوحه المفاتيح ".

  5. اكتب مجموعه مفاتيح في المربع اضغط علي اختصار لوحه المفاتيح الجديد .

    يعرض Word الأمر أو الماكرو الذي تم تعيينه بالفعل إلى تركيبه مفاتيح ، إذا كانت هناك ، بعد الضغط علي التركيبة.

    عند الضغط علي تركيبه مفاتيح ، يعرض Word الأمر أو الاجراء المعين حاليا لمجموعه المفاتيح هذه ، إذا كانت هناك.

  6. إذا كانت مجموعه المفاتيح التي اخترتها معينه بالفعل ، فاحذفها من المربع اضغط علي اختصار لوحه المفاتيح الجديد ، ثم اختر تركيبه مفاتيح جديده.

    انتقل إلى الخطوة التالية بعد العثور علي مجموعه مفاتيح غير معينه.

    يحدد Word كيفيه الضغط علي تركيبه مفاتيح لم يتم تعيينها بعد إلى أمر أو ماكرو.
  7. لاستخدام اختصار لوحه المفاتيح هذا في اي مستندات جديده ، تاكد من تحديد normal.dotm، القالب العمومي ، في القائمة حفظ التغييرات في .

    حدد normal.dotm لجعل الماكرو متوفرا للاستخدام في المستندات الجديدة التي تقوم بإنشاءها.
  8. انقر فوق تعيين.

  9. عندما تصبح جاهزا لتسجيل الماكرو ، انقر فوق موافق.

  10. انقر فوق الأوامر أو اضغط على المفاتيح لكل خطوة في المهمة.

    Word تسجيل النقرات وضغطات المفاتيح ، ولكنه لا يقوم بتسجيل النص الذي تحدده باستخدام الماوس. لتحديد نص اثناء تسجيل ماكرو ، استخدم لوحه المفاتيح.

  11. لإيقاف التسجيل، انقر فوق عرض >‏ وحدات ماكرو >‏ إيقاف التسجيل.

    انقر فوق إيقاف التسجيل في القائمة وحدات الماكرو لإيقاف تسجيل ماكرو.

لتشغيل ماكرو ، اضغط علي اختصار لوحه المفاتيح المعين له ، أو قم بتشغيل الماكرو من قائمه وحدات الماكرو .

  1. انقر فوق عرض >‏ وحدات ماكرو >‏ عرض وحدات الماكرو.

    انقر فوق عرض وحدات الماكرو لعرض وحدات الماكرو المقترنة بالمستند الحالي وتحريرها.
  2. في القائمة ضمن اسم الماكرو، حدد الماكرو الذي تريد تشغيله.

  3. انقر فوق تشغيل.

    بعد تحديد ماكرو ضمن اسم الماكرو ، انقر فوق تشغيل لتشغيله.

  1. انقر فوق عرض >‏ وحدات ماكرو >‏ عرض وحدات الماكرو.

    انقر فوق عرض وحدات الماكرو لعرض وحدات الماكرو المقترنة بالمستند الحالي وتحريرها.
  2. تاكد من تضمين الموقع المحدد بواسطة وحدات الماكرو في موقع الماكرو الذي تريد حذفه.

    حدد موقع وحدات الماكرو التي تريد عرضها من وحدات الماكرو في القائمة.

    ستتضمن القائمة المستند المفتوح في النافذة الحالية ، بالاضافه إلى الأوامر العمومية والWord.

  3. ضمن اسم الماكرو، حدد الماكرو الذي تريد حذفه ، ثم انقر فوق علامة الطرح الموجودة أسفل القائمة.

    حدد الماكرو الذي تريد حذفه ، ثم انقر فوق علامة الطرح ضمن القائمة.
  4. عندما يطلب Word تاكيدا بانك تريد حذف الماكرو ، انقر فوق نعم.

Excel

في Excel 2016 for Mac ، يمكنك إنشاء ماكرو يحتوي علي اختصار لوحه مفاتيح ، وتشغيل ماكرو ، وحذف الماكرو الذي لم تعد بحاجه اليه.

عند تسجيل ماكرو، يسجل مسجل الماكرو كافة الخطوات المطلوبة لإكمال الإجراءات التي تريد أن يجريها الماكرو. ويمكن لهذه الخطوات أن تتضمّن كتابة نص أو أرقام، والنقر فوق الخلايا أو الأوامر على الشريط أو القوائم، وتنسيق خلايا أو صفوف أو أعمدة وتحديدها، وسحب الماوس لتحديد الخلايا في جدول بياناتك.

ملاحظة: تتوفر أيضا الأوامر لتسجيل وحدات الماكرو وإنشاءها وحذفها ، بالاضافه إلى الميزات المتقدمة الأخرى ، علي علامة التبويب المطور علي الشريط. للحصول علي مزيد من المعلومات حول استخدام علامة التبويب المطور ، راجع استخدام علامة التبويب المطور لإنشاء ماكرو أو حذفه في Excel 2016 for Mac.

  1. حدد أدوات _gt_ الماكرو _gt_ الجديد.

    تحديد أدوات ، ثم ماكرو ، ثم تسجيل ماكرو جديد

  2. في المربع اسم الماكرو، أدخل اسماً للماكرو.

    ادخل اسم ماكرو وموقعا ومفتاح اختصار

  3. لإنشاء اختصار لوحه مفاتيح للماكرو ، اكتب حرفا في مربع الخيارات + Cmd .

  4. حدد موقعا للماكرو من القائمة المنسدلة.

    لحفظ الماكرو

    انقر فوق

    في المستند الذي تقوم بإنشاء ماكرو فيه

    هذا المصنف

    في كافة المستندات المفتوحة

    مصنف جديد

    بحيث يكون متوفراً كلما استخدمت Excel

    مصنف الماكرو الشخصي

  5. مكرر أضف وصفا للماكرو.

  6. عندما تصبح جاهزا للتسجيل ، انقر فوق موافق.

  7. انقر فوق الأوامر أو اضغط على المفاتيح لكل خطوة في المهمة.

  8. لإيقاف التسجيل ، حدد أدوات _gt_ الماكرو _gt_ إيقاف التسجيل. (لن يتم تسجيل هذه الخطوة في الماكرو.)

    تحديد إيقاف التسجيل

لتشغيل ماكرو ، اضغط علي اختصار لوحه المفاتيح المعين له ، أو قم بتشغيل الماكرو من مربع الحوار وحدات الماكرو .

  1. على علامة التبويب عرض، انقر فوق عرض وحدات الماكرو.

  2. انقر فوق وحدات الماكرو في القائمة المنبثقة وحدد هذا المصنف.

  3. حدد الماكرو من القائمة، ثم انقر فوق تشغيل.

    مربع الحوار "وحدات ماكرو" في Excel for Mac

  1. حدد أدوات _gt_ الماكرو _gt_ وحدات ماكرو.

    تحديد ماكرو ثم تحديد وحدات الماكرو

  2. حدد الماكرو الذي تريد حذفه ، ثم اضغط علي علامة الطرح.

    حدد اسم الماكرو ، ثم حدد علامة الطرح

  3. ستظهر رسالة تاكيد. انقر فوق نعم للتأكيد على الحذف.

    تاكيد الحذف

يمكنك أيضا حذف ماكرو من علامة التبويب المطور.

  1. على علامة تبويب المطور، انقر فوق وحدات ماكرو.

  2. في القائمة، انقر فوق الماكرو الذي تريد حذفه، وانقر فوق الزر "حذف".

    حدد ماكرو وانقر فوق علامة الطرح لحذفه

Word

لأتمتة مهمة مكررة، يمكنك إنشاء الماكرو بسرعة في Word. يمكنك أيضاً استخدام محرر Visual Basic في Microsoft Visual Basic for Applications (VBA)‎ لكتابة البرنامج النصي للماكرو الخاص بك، أو نسخ الماكرو بأكمله أو جزء منه إلى ماكرو جديد.

عند تسجيل ماكرو ، يتم تسجيل كل الخطوات المطلوبة لإكمال الإجراءات التي تريد ان ينفذها الماكرو. ومع ذلك، لا تتضمن الخطوات المسجّلة العودة إلى علامة التبويب لإيقاف التسجيل.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق تسجيل.

    علامة التبويب "المطور"، المجموعة Visual Basic في Word

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في المربع اسم الماكرو، أدخل اسماً للماكرو.

  3. في القائمة المنبثقة تخزين الماكرو في، قم بواحد مما يلي:

    لحفظ الماكرو

    انقر فوق

    في المستند الذي تعمل على إنشاء الماكرو فيه

    [اسم المستند] (مستند)

    في كافة المستندات المفتوحة

    جميع المستندات (عادي)

  4. انقر فوق موافق، ثم قم بتنفيذ الإجراءات التي تريد تسجيلها.

  5. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق إيقاف.

يمكنك استخدام محرر Visual Basic المضمن لإنشاء ماكرو.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق محرر.

    علامة التبويب "المطور"، المجموعة Visual Basic في Word

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. إذا أردت إدراج وحدة نمطية، في محرر Visual Basic، في قائمة إدراج، انقر فوق وحدة نمطية.

  3. في نافذة التعليمات البرمجية الخاصة بالوحدة النمطية، اكتب التعليمات البرمجية للماكرو التي تريد استخدامها أو الصقها.

  4. عندما تنهي عملك، في قائمة Word، انقر فوق إغلاق والعودة إلى Microsoft Word.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Word

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد تشغيله، ثم انقر فوق تشغيل.

لتحرير ماكرو، ستستخدم محرر Visual Basic.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Word

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذين تريد تحريره، ثم انقر فوق تحرير.

    يفتح محرر Visual Basic.

  3. أجرِ التغييرات المطلوبة.

  4. عندما تنهي عملك، في قائمة Word، انقر فوق إغلاق والعودة إلى Microsoft Word.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Word

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد نسخه، ثم انقر فوق تحرير.

    يفتح محرر Visual Basic.

  3. في نافذة التعليمات البرمجية لمحرر Visual Basic، حدد أسطر الماكرو التي تريد نسخها.

    تلميح: لنسخ الماكرو بأكمله، قم بتضمين السطرين Sub وEnd Sub في التحديد.

  4. من القائمة تحرير، انقر فوق نسخ.

  5. في المربع مشروع في نافذة التعليمات البرمجية، انقر فوق الوحدة النمطية حيث تريد وضع التعليمات البرمجية.

  6. من القائمة تحرير، انقر فوق لصق.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Word

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد حذفه، ثم انقر فوق حذف.

PowerPoint

لاتمته مهمة متكررة ، يمكنك استخدام Visual Basic for Applications لإنشاء الماكرو في PowerPoint.

يمكنك استخدام محرر Visual Basic المضمن لإنشاء ماكرو.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق محرر.

    علامة التبويب "المطور"، المجموعة Visual Basic في PowerPoint

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. إذا أردت إدراج وحدة نمطية، في محرر Visual Basic، في قائمة إدراج، انقر فوق وحدة نمطية.

  3. في نافذة التعليمات البرمجية الخاصة بالوحدة النمطية، اكتب التعليمات البرمجية للماكرو التي تريد استخدامها أو الصقها.

  4. عندما تنهي عملك، في قائمة PowerPoint، انقر فوق إغلاق والعودة إلى Microsoft PowerPoint.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في PowerPoint

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد تشغيله، ثم انقر فوق تشغيل.

لتحرير ماكرو، ستستخدم محرر Visual Basic.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في PowerPoint

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذين تريد تحريره، ثم انقر فوق تحرير.

    يفتح محرر Visual Basic.

  3. أجرِ التغييرات المطلوبة.

  4. عندما تنهي عملك، في قائمة PowerPoint، انقر فوق إغلاق والعودة إلى Microsoft PowerPoint.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في PowerPoint

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد نسخه، ثم انقر فوق تحرير.

    يفتح محرر Visual Basic.

  3. في نافذة التعليمات البرمجية لمحرر Visual Basic، حدد أسطر الماكرو التي تريد نسخها.

    تلميح: لنسخ الماكرو بأكمله، قم بتضمين السطرين Sub وEnd Sub في التحديد.

  4. من القائمة تحرير، انقر فوق نسخ.

  5. في المربع مشروع في نافذة التعليمات البرمجية، انقر فوق الوحدة النمطية حيث تريد وضع التعليمات البرمجية.

  6. من القائمة تحرير، انقر فوق لصق.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في PowerPoint

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد حذفه، ثم انقر فوق حذف.

Excel

لأتمتة مهمة مكررة، يمكنك إنشاء الماكرو بسرعة في Excel. يمكنك أيضاً استخدام محرر Visual Basic في Microsoft Visual Basic for Applications (VBA)‎ لكتابة البرنامج النصي للماكرو الخاص بك، أو نسخ الماكرو بأكمله أو جزء منه إلى ماكرو جديد.

يتم تسجيل كل الخطوات المطلوبة لإكمال الإجراءات التي تريد أن ينفذها الماكرو. ومع ذلك، لا تتضمن الخطوات المسجّلة العودة إلى علامة التبويب لإيقاف التسجيل.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق تسجيل.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في المربع اسم الماكرو، أدخل اسماً للماكرو.

    تلميح: لإنشاء اختصار لوحة مفاتيح للماكرو، اكتب حرفاً في المربع Option+Cmd+.

  3. في القائمة المنبثقة تخزين الماكرو في، قم بواحد مما يلي:

    لحفظ الماكرو

    انقر فوق

    في المستند الذي تعمل على إنشاء الماكرو فيه

    هذا المصنف

    في كافة المستندات المفتوحة

    مصنف جديد

    بحيث يكون متوفراً كلما استخدمت Excel

    مصنف الماكرو الشخصي

    يتواجد مصنف الماكرو الشخصي في المستخدمون/ اسم المستخدم/library/application support/Microsoft/Office/Excel.

  4. انقر فوق موافق، ثم قم بتنفيذ الإجراءات التي تريد تسجيلها.

  5. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق تسجيل مرة أخرى.

يمكنك استخدام محرر Visual Basic المضمن لإنشاء ماكرو.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق محرر.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. إذا أردت إدراج وحدة نمطية، في محرر Visual Basic، في قائمة إدراج، انقر فوق وحدة نمطية.

  3. في نافذة التعليمات البرمجية الخاصة بالوحدة النمطية، اكتب التعليمات البرمجية للماكرو التي تريد استخدامها أو الصقها.

  4. عندما تنهي عملك، في قائمة Excel، انقر فوق إغلاق والعودة إلى Microsoft Excel.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد تشغيله، ثم انقر فوق تشغيل.

    تلميح: لتشغيل ماكرو باستخدام اختصار لوحة مفاتيح، اضغط على OPTION + COMMAND +الحرف الذي كتبته عندما أنشأت اختصار لوحة المفاتيح.

لتحرير ماكرو، ستستخدم محرر Visual Basic.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذين تريد تحريره، ثم انقر فوق تحرير.

    يفتح محرر Visual Basic.

  3. أجرِ التغييرات المطلوبة.

  4. عندما تنهي عملك، في قائمة Excel، انقر فوق إغلاق والعودة إلى Microsoft Excel.

بعد إكمال هذا الإجراء، سيتم تشغيل الماكرو كلما فتحت المصنف الذي يحتوي على الماكرو.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق تسجيل.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في المربع اسم الماكرو، اكتب Auto_Open.

  3. في القائمة المنبثقة تخزين الماكرو في، قم بواحد مما يلي:

    لحفظ الماكرو

    انقر فوق

    في المستند الذي تعمل على إنشاء الماكرو فيه

    هذا المصنف

    في كافة المستندات المفتوحة

    مصنف جديد

    بحيث يكون متوفراً كلما استخدمت Excel

    مصنف الماكرو الشخصي

  4. انقر فوق موافق، ثم قم بتنفيذ الإجراءات التي تريد تسجيلها.

  5. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق تسجيل مرة أخرى.

  6. في قائمة ملف، انقر فوق حفظ باسم.

  7. في القائمة المنبثقة تنسيق، انقر فوق Excel Macro-Enabled Workbook (.xlsm)، ثم فوق حفظ.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد نسخه، ثم انقر فوق تحرير.

    يفتح محرر Visual Basic.

  3. في نافذة التعليمات البرمجية لمحرر Visual Basic، حدد أسطر الماكرو التي تريد نسخها.

    تلميح: لنسخ الماكرو بأكمله، قم بتضمين السطرين Sub وEnd Sub في التحديد.

  4. من القائمة تحرير، انقر فوق نسخ.

  5. في المربع مشروع في نافذة التعليمات البرمجية، انقر فوق الوحدة النمطية حيث تريد وضع التعليمات البرمجية.

  6. من القائمة تحرير، انقر فوق لصق.

  1. على علامة التبويب المطور، ضمن Visual Basic، انقر فوق وحدات ماكرو.

    علامة التبويب "المطور"، المجموعة Visual Basic في Excel

    إذا لم تكن علامة التبويب المطور متوفرة

    1. على الجهة اليسرى من الشريط، انقر فوق قائمة "الإجراء" المنبثقة ، ثم انقر فوق تفضيلات الشريط.

    2. ضمن تخصيص، حدد خانة الاختيار المطور.

  2. في القائمة، انقر فوق الماكرو الذي تريد حذفه، ثم انقر فوق حذف.

تعزيز مهارات Office
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×