إضافة اتصال بيانات باستخدام إعدادات مكتبة الاتصال

هام: تمت ترجمة هذه المقالة ترجمة آلية، راجع إقرار إخلاء المسؤولية. يرجى الاطلاع على النسخة الإنجليزية من هذه المقالة. هنا للرجوع إليها.

في هذا المقال

نظرة عامة

قبل أن تبدأ

إضافة اتصال بيانات خاص بالاستعلام

إضافة اتصال بيانات خاص بالإرسال

نظرة عامة

اذا كنت تقوم ب# تصميم العديد من قوالب النماذج التي تستخدم اتصالات البيانات مماثله، ضع في اعتبارك استخدام ملف اتصال بيانات بدلا من انشاء اتصال بيانات ل# مصدر بيانات خارجي ل# كل قالب النموذج. هذه الطريقه، ستحتاج الي تحديث ملف اتصال بيانات واحده فقط عندما تتغير معلومات اتصال البيانات ل# مجموعه من قوالب النماذج ذات الصله. علي سبيل المثال، عند نقل قوالب النماذج من شبكه اختبار ب# شبكه انتاج، تحتاج الي تحديث اعدادات اتصال البيانات مره واحده فقط في مكتبه ملفات اتصال بدلا من تحديث اتصال البيانات في كل قالب النموذج. عندما تستخدم نموذج يستند الي قالب نموذج الذي يستخدم ملف اتصال بيانات اتصال البيانات، يتم تلقائيا تحديث اتصال البيانات ب# استخدام الاعدادات الجديده.

ملف اتصال بيانات عباره عن ملف XML ب# استخدام ملحق ملف .xml او .udcx الذي يحتوي علي معلومات الاتصال ل# مصدر بيانات خارجي. يتم تخزين هذا الملف في مكتبه ملفات اتصال بيانات علي خادم يقوم ب# تشغيل Microsoft Office SharePoint Server 2007. يتم انشاء ملف اتصال بيانات ب# مطور او عن طريق تحويل اتصال بيانات في قالب نموذج موجود الي ملف اتصال بيانات عن طريق النقر فوق الزر " تحويل " في مربع الحوار اتصالات البيانات (القائمهادوات ).

تتضمن فوائد استخدام ملفات اتصال البيانات:

  • يمكنك استخدام نماذج متعدده نفس ملف اتصال البيانات، حيث لا داعي ل# انشاء اتصال البيانات نفسه من البدايه ل# كل قالب النموذج.

  • إذا حدث تغيير في موقع مصدر البيانات الخارجي أو إعدادات الاتصال الخاصة به، سوف تحتاج إلى تحديث ملف اتصال البيانات فقط بدلاً من قوالب النماذج.

  • يمكن ان تحتوي علي ملف اتصال البيانات معلومات مصادقه بديله التي يمكنك استخدامها ب# واسطه الخادم عند مستخدم ب# تعبئه نموذج ب# استخدام مستعرض ويب.

  • النماذج التي تستند الي قالب نموذج متوافق مع المستعرض التي تتم تعبئتها في مستعرض الاتصال ب# خوادم في مجال اخر فقط ب# استخدام اتصالات البيانات التي تستخدم ملفات اتصال البيانات.

ملاحظة: تستخدم Microsoft Office InfoPath ملفات اتصال البيانات التي تلي ب# تنسيق الملف 2.0 الاصدار "العالمي اتصال البيانات". هذا الاصدار مجموعه فرعيه من تنسيق الملف 1.0 الاصدار المستخدمه ب# واسطه Microsoft Office FrontPage و Microsoft Office Excel. لا يمكن استخدام InfoPath ملفات اتصال البيانات ب# تنسيق الملف 1.0 الاصدار.

عند إضافة اتصال بيانات إلى قالب نموذج باستخدام إعدادات مكتبة اتصال بيانات، فإنك تقوم بإنشاء اتصال بيانات ثانوي في قالب النموذج هذا. ويختلف اتصال البيانات هذا عن اتصال البيانات الرئيسي الذي يتم إنشاؤه عند تصميم قالب نموذج يستند إلى قاعدة بيانات أو خدمة ويب أو إعدادات مكتبة ملفات اتصال البيانات. وتحتاج إلى إضافة اتصال بيانات ثانوي فقط في حالة تعذر الحصول على البيانات أو إرسالها عبر اتصال البيانات الرئيسي.

أعلى الصفحة

قبل أن تبدأ

لإضافة اتصال بيانات إلى قالب النموذج الخاص بك باستخدام الإعدادات المخزنة في مكتبة ملفات اتصال البيانات، تحتاج إلى الحصول على المعلومات التالية من مسؤول الموقع:

  • موقع الخادم المستخدم Microsoft Office SharePoint Server 2007، الذي يتضمن الموقع المشتمل على مكتبة ملفات اتصال البيانات

  • اسم ملف اتصال البيانات الموجود في مكتبة ملفات اتصال البيانات والذي تريد استخدامه

  • تحديد ما إذا كان ملف اتصال البيانات يحتوي على إعدادات اتصال البيانات الخاص بالاستعلام أو اتصال البيانات الخاص بالإرسال.

  • تحديد إمكانية تكوين قالب النموذج لتخزين نتائج الاستعلام بأمان في النموذج أو لتوفير إمكانية الاستخدام دون الاتصال

أعلى الصفحة

إضافة اتصال بيانات خاص بالاستعلام

لإضافة اتصال بيانات إلى قالب النموذج الخاص بك باستخدام إعدادات مكتبة الاتصال، لابد من استكمال الإجراءات التالية:

  1. إضافة اتصال بيانات ثانوي إلى قالب النموذج.

  2. ربط عناصر التحكم بالاستعلام وحقول البيانات في مصدر البيانات الثانوي.

  3. تكوين قالب النموذج لاستخدام اتصال البيانات باستخدام قاعدة أو زر.

خطوة 1: إضافة اتصال بيانات ثانوي

  1. من القائمة أدوات انقر فوق اتصالات البيانات.

  2. في مربع الحوار اتصالات البيانات، انقر فوق اضافه.

  3. في معالج اتصال البيانات، انقر فوق البحث عن الاتصالات على Microsoft Office SharePoint Server، ثم انقر فوق التالي.

  4. في الصفحة التالية من المعالج، في القائمة موقع، انقر فوق اسم الموقع الموجود على خادم يتم تشغيل Office SharePoint Server 2007 عليه مع مكتبة الاتصالات.

    الموقع الخاص بي ليس مدرجاً على القائمة

    لإضافة الموقع الخاص بك إلى القائمة، قم بتنفيذ الإجراءات التالية:

    1. انقر فوق إدارة المواقع.

    2. في مربع الحوار اداره المواقع، انقر فوق اضافه.

    3. في المربع URL، اكتب موقع مكتبه ملفات اتصال البيانات.

    4. في المربع اسم العرض، اكتب اسما ل# مكتبه ملفات اتصال البيانات. يظهر هذا الاسم في القائمه " الموقع " في "معالج اتصال البيانات".

    5. انقر فوق موافق.

    6. انقر فوق إغلاق.

  5. انقر فوق اسم مكتبة ملفات اتصال البيانات لرؤية القائمة التي تضم ملفات اتصالات البيانات، قم بالنقر فوق اسم ملف اتصال البيانات الذي تريد استخدامه مع اتصال البيانات هذا ثم انقر فوق التالي.

  6. وفقاً لإعدادات الاتصال في ملف اتصال البيانات، قد تطلب منك الصفحة التالية من المعالج تحديد قيمة العينة لكل معلمة.

    كيف تحدد قيمة العينة؟

    1. حدد معلمه في الجدول معلمات، و# ثم انقر فوق تعيين قيمه عينه.

    2. في المربع القيمه العينه، اكتب قيمه التي المستخدم الخاص بك قد ل# هذا الحقل، و# ثم انقر فوق موافق.

    3. كرر هذه الخطوات ل# كل معلمه في الجدول معلمات، و# من ثم انقر فوق التالي.

    ملاحظة تقنية

    عند تكوين اتصال بيانات خدمه ويب في "معالج اتصال البيانات"، يتم الاتصال ب# خدمه ويب Microsoft Office InfoPath و# طلبات ملف لغه وصف خدمه ويب (WSDL). يحتوي ملف WSDL علي المخطط المستخدمه ب# واسطه خدمه ويب. خدمه ويب يستجيب ل# الطلب عن طريق ارسال هذا الملف الي InfoPath. يستخدم InfoPath المعلومات الموجوده في هذا الملف ل# اضافه الحقول المناسبه و# المجموعات ب# مصدر بيانات ثانوي في قالب النموذج. اذا عثر InfoPath نوع عنصر غير معروف في ملف WSDL، يستخدم بيانات نموذجيه ل# تحديد تعريف نوع عنصر غير معروف InfoPath وثم تضيف الحقول المناسبه و# المجموعات ب# مصدر بيانات ثانوي.

  7. إذا كنت ترغب في توفير نتائج الاستعلام في حالة عدم اتصال النموذج بشبكة، قم بتحديد خانة الاختيار تخزين نسخة من البيانات في قالب النموذج.

    ملاحظة بشأن الأمان : عند تحديد خانه الاختيار هذه تخزين نتائج الاستعلام في قالب النموذج. نظرا ل# تخزين البيانات في قالب النموذج، يتوفر في النماذج التي يقوم المستخدمون ب# تعبئه، حتي اذا كان الكمبيوتر الخاص به غير متصل ب# الشبكه. اذا كنت تحصل علي بيانات حساسه من اتصال البيانات هذا، قد تحتاج الي تعطيل هذه الميزه ل# المساعده في حمايه البيانات في حال فقدان الكمبيوتر او سرقه.

  8. انقر فوق التالي.

    تعرض الصفحة التالية من المعالج ملخصاً للإعدادات الخاصة باتصال البيانات هذا.

  9. اكتب اسماً وصفياً لاتصال البيانات. هذا هو الاسم الذي يظهر في القائمة مصدر البيانات في جزء المهام مصدر البيانات.

  10. لتمكين النماذج التي تستند إلى قالب النموذج هذا من استخدام اتصال البيانات عند فتح النماذج، قم بتحديد خانة الاختيار استرداد البيانات بشكل تلقائي عند فتح النموذج.

أعلى الصفحة

خطوة 2: إضافة عنصر تحكم لعرض البيانات للمستخدمين

  1. إذا لم يكن جزء المهام عناصر التحكم مرئياً، فانقر فوق عناصر تحكم إضافية على القائمة إدراج، أو اضغط على ALT+I، ‏C.

  2. قم بسحب عنصر تحكم إلى قالب النموذج.

  3. في مربع الحوار ربط عنصر التحكم، حدد الحقل الذي ترغب في تخزين بيانات عنصر التحكم به، ثم انقر فوق موافق.

الخطوة 3: تكوين قالب النموذج لاستخدام اتصال البيانات

إذا كنت ترغب في أن يتمكن المستخدمون من استرداد البيانات من اتصال البيانات هذا بعد فتح النموذج، يمكنك إضافة قاعدة أو زر إلى قالب النموذج الخاص بك لاستخدام اتصال البيانات وفقاً لشرط معين، أو يمكنك إضافة زر إلى قالب النموذج يقوم المستخدمون بالنقر فوقه لاستخدام اتصال البيانات.

إضافة قاعدة

يمكنك إضافة قاعدة إلى قالب النموذج تقوم بتشغيل اتصال البيانات الخاص بالاستعلام متى تم استيفاء شرط القاعدة. يفترض الإجراء التالي أنك قمت بإنشاء اتصال بيانات خاص بالاستعلام لقالب النموذج الخاص بك، وأنك قمت بتكوين عنصر تحكم في قالب النموذج لعرض البيانات من اتصال البيانات.

  1. اذا كان قالب النموذج طرق عرض متعدده، انقر فوق اسم طريقه عرض القائمه " عرض " ل# الانتقال الي طريقه عرض ب# عنصر التحكم حيث تريد عرض البيانات من مصدر بيانات ثانوي.

  2. انقر نقراً مزدوجاً فوق عنصر التحكم الذي تريد إضافة قاعدة إليه.

  3. انقر فوق علامة التبويب بيانات.

  4. ضمن التحقق من الصحة والقواعد، انقر فوق قواعد.

  5. في مربع الحوار قواعد، انقر فوق إضافة.

  6. في المربع اسم، اكتب اسماً للقاعدة.

  7. ل# تحديد شرط عند الذي يجب تشغيل القاعده، انقر فوق تعيين شرط، و# ادخل الشرط. يتم تشغيل القاعده عندما يحدث الشرط. في حال عدم تعيين شرط، يتم تشغيل القاعده كلما المستخدم ب# تغيير القيمه في عنصر التحكم، و# من ثم ينتقل المؤشر الخاصه به او بها بعيدا عن عنصر التحكم هذا.

  8. انقر فوق إضافة إجراء.

  9. من القائمة إجراء انقر فوق الاستعلام باستخدام اتصال البيانات.

  10. من القائمة اتصال البيانات، انقر فوق اتصال البيانات الخاص بالاستعلام الذي تريد استخدامه، ثم انقر فوق موافق لإغلاق مربعات الحوار المفتوحة.

  11. لاختبار التغييرات، انقر فوق معاينة على شريط الأدوات قياسي، أو اضغط على CTRL+SHIFT+B.

إضافة زر لاستخدام اتصال البيانات الخاص بالاستعلام

يمكنك إضافة عنصر تحكم زر إلى قالب النموذج الخاص بك بحيث يمكن للمستخدم النقر فوقه عند تعبئة النموذج الذي يستند إلى قالب النموذج الخاص بك. إذا تم النقر فوق هذا الزر، يمكن حينئذ استرداد البيانات من اتصال البيانات الخاص بالاستعلام.

  1. اذا كان قالب النموذج طرق عرض متعدده، انقر فوق اسم طريقه عرض القائمه " عرض " ل# الانتقال الي طريقه عرض ب# عنصر التحكم حيث تريد عرض البيانات من مصدر بيانات ثانوي.

  2. إذا لم يكن جزء المهام عناصر التحكم مرئياً، فانقر فوق عناصر تحكم إضافية على القائمة إدراج، أو اضغط على ALT+I، ‏C.

  3. قم بسحب عنصر تحكم زر إلى قالب النموذج الخاص بك.

  4. انقر نقراً مزدوجاً فوق عنصر تحكم الزر الذي قمت تواً بإضافته إلى قالب النموذج الخاص بك.

  5. انقر فوق علامة التبويب عام.

  6. من القائمة إجراء انقر فوق تحديث.

  7. في المربع تسمية انقر فوق الاسم الذي تريد ظهوره على الزر في قالب النموذج الخاص بك.

  8. انقر فوق إعدادات.

  9. في مربع الحوار تحديث انقر فوق مصدر بيانات واحد ثانوي.

  10. من القائمة اختيار مصدر البيانات الثانوي انقر فوق مصدر البيانات الثانوي المقترن باتصال البيانات الخاص بالاستعلام.

  11. انقر فوق موافق لإغلاق مربعات الحوار المفتوحة.

  12. لاختبار التغييرات، انقر فوق معاينة على شريط الأدوات قياسي، أو اضغط على CTRL+SHIFT+B.

أعلى الصفحة

إضافة اتصال بيانات خاص بالإرسال

إذا كان ملف اتصال البيانات يحتوي على إعدادات اتصال البيانات الخاص بالإرسال، يمكنك تكوين قالب النموذج الخاص بك للسماح للمستخدمين بإرسال بيانات النماذج الخاصة بهم عبر اتصال البيانات هذا. عندما تقوم بتكوين قالب النموذج الخاص بك للسماح للمستخدمين بإرسال بيانات النماذج الخاصة بهم، يضيف InfoPath الزر إرسال إلى شريط الأدوات قياسي ويقوم بإضافة الأمر إرسال إلى القائمة ملف. يمكنك تكوين خيارات الإرسال لقالب النموذج في مربع الحوار خيارات الإرسال (القائمة أدوات). يتم تكوين خيارات الإرسال بنفس الطريقة المتبعة مع إضافة اتصال بيانات ثانوي كما في اتصال البيانات الخاص بالإرسال. يمكنك العثور على ارتباطات للحصول على مزيد من المعلومات حول إضافة اتصال بيانات خاص بالإرسال إلى قالب النموذج الخاص بك في المقطع انظر أيضاً.

  1. من القائمة أدوات انقر فوق اتصالات البيانات.

  2. في مربع الحوار اتصالات البيانات، انقر فوق اضافه.

  3. في معالج اتصال البيانات، انقر فوق البحث عن الاتصالات على Microsoft Office SharePoint Server Server، ثم انقر فوق التالي.

  4. في الصفحة التالية من المعالج، من القائمة موقع انقر فوق اسم الموقع مع مكتبة الاتصال.

    اسم الموقع الخاص بي ليس مدرجاً على القائمة

    لإضافة الموقع الخاص بك إلى القائمة، قم بتنفيذ الإجراءات التالية:

    1. انقر فوق إدارة المواقع.

    2. في مربع الحوار اداره المواقع، انقر فوق اضافه.

    3. في المربع URL، اكتب موقع مكتبه ملفات اتصال البيانات.

    4. في المربع اسم العرض، اكتب اسما ل# مكتبه ملفات اتصال البيانات. يظهر هذا الاسم في القائمه " الموقع " في "معالج اتصال البيانات".

    5. انقر فوق موافق.

    6. انقر فوق إغلاق.

  5. انقر فوق اسم مكتبة ملفات اتصال البيانات لرؤية قائمة تضم ملفات اتصالات البيانات، ثم انقر فوق ملف اتصال البيانات الذي تريده لاستخدام اتصال بيانات خاص بالإرسال، بعد ذلك انقر فوق التالي.

  6. إذا كانت الإعدادات تخص اتصال البيانات الخاص بالإرسال إلى خدمة ويب، يمكن أن يقوم InfoPath بالكشف عن المعلمات الموجودة في خدمة ويب والتي يمكنها تلقي البيانات. ويمكنك تكوين اتصال بيانات خاص بالإرسال وذلك لإرسال كافة البيانات أو جزء من البيانات الموجودة في قالب النموذج.

    كيف؟

    1. في القائمة معلمات انقر فوق المعلمة التي تقوم بتلقي البيانات من النموذج.

    2. لإرسال كافة البيانات الموجودة في النموذج إلى هذه المعلمة، بما في ذلك عنصر الجذر وإرشادات المعالجة، قم بتنفيذ الإجراءات التالية:

      1. انقر فوق النموذج بأكمله (مستند XML بما في ذلك إرشادات المعالجة).

      2. لإرسال البيانات كسلسلة، قم بتحديد خانة الاختيار إرسال البيانات كسلسلة. عادةً تقوم بتحديد خانة الاختيار تلك لإرسال بيانات موقعة توقيعاً رقمياً. في معظم الأحوال قم بإلغاء تحديد خانة الاختيار هذه.

    3. لتحديد حقل أو مجموعة لهذه المعلمة، قم بتنفيذ الإجراءات التالية:

      1. ضمن خيارات المعلمة، انقر فوق حقل أو مجموعة.

      2. انقر فوق تعديل الزر "مصدر البيانات" .

      3. في مربع الحوار تحديد حقل أو مجموعة انقر فوق الحقل أو المجموعة التي تريد إرسال البيانات الخاصة بها، ثم انقر فوق موافق.

      4. من القائمة تضمين انقر فوق العناصر النصية والتابعة فقط لإرسال محتوى الحقل أو المجموعة فقط، أو انقر فوق شجرة XML الفرعية، بما في ذلك العنصر المحدد لإرسال كل من المحتوى والمجموعة المحددة أو الحقل.

    4. كرر هذه الخطوات لكل معلمة.

  7. انقر فوق التالي.

  8. علي الصفحه التاليه من المعالج، في المربع ادخل اسما ل# اتصال البيانات هذا، اكتب اسما وصفيا ل# هذا اتصال بيانات ارسال.

أعلى الصفحة

ملاحظة: إقرار إخلاء المسؤولية للترجمة الآلية: تمت ترجمة هذه المقالة بواسطة نظام كمبيوتر دون تدخل العامل البشري. توفر Microsoft هذه الترجمات الآلية لمساعدة المستخدمين الذين لا يتحدثون الإنجليزية على استخدام منتجات Microsoft، وخدماتها، وتقنياتها والاستمتاع بها. قد تحتوي هذه المقالة على أخطاء في المفردات، أو بناء الجملة، أو القواعد نظرًا لترجمتها آليًا.

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×