إضافة أعمدة مكتبة مستندات أو أعمدة موقع أو إزالتها أو تعديلها

هام: تمت ترجمة هذه المقالة ترجمة آلية، راجع إقرار إخلاء المسؤولية. يرجى الاطلاع على النسخة الإنجليزية من هذه المقالة. هنا للرجوع إليها.

عند تصميم قالب نموذج Microsoft Office InfoPath، يمكنك اختيار عرض البيانات التي يقوم المستخدمون بإدخالها في حقول محددة في النموذج مثل الأعمدة الموجودة في طريقة العرض الافتراضية لمكتبة مستندات في موقع Microsoft Windows SharePoint. يمكنك اختيار أي الحقول تستخدمها كأعمدة عند تصميم قالب النموذج أو يمكنك الانتظار لتحديد الأعمدة عند نشر قالب النموذج إلى مكتبة المستندات.

يتضمن هذا المقال

قبل البدء

تحديد أعمدة مكتبة المستندات عند تصميم قالب النموذج

تحديد أعمدة مكتبة المستندات عند نشر قالب النموذج إلى مكتبة مستندات جديدة

تحديد أعمدة مكتبة المستندات عند نشر قالب نموذج إلى مكتبة مستندات موجودة

قبل أن تبدأ

عندما تقوم ب# نشر قالب نموذج الي مكتبه مستندات، سيتم يستند الي كل نموذج الذي تم انشاؤه في مكتبه المستندات هذه علي قالب النموذج. نشر قالب نموذج الي مكتبه مستندات يسمح لك ب# سرعه نشر نموذج تستخدم مره واحده، مثل استطلاع غير رسميه ل# التقاط تفضيلات المطاعم الغداء فريق.

اذا قمت ب# نشر قالب نموذج ل# خادم الذي يقوم ب# تشغيل Windows SharePoint Services 3.0، ف# يمكنك ايضا القيام ب# ما يلي:

نشر قالب نموذج ك# نوع محتوي موقع     عندما تقوم ب# نشر قالب نموذج ك# نوع محتوي موقع، يمكنك تمكين المستخدمين ل# تعيين قوالب نماذج متعدده الي مكتبه مستندات واحده او ل# تعيين قالب النموذج ل# مكتبات متعدده عبر مجموعه مواقع مشتركه. مجموعه مواقع مشتركه عباره عن مجموعه من مواقع ويب علي خادم ظاهري التي لها نفس المالك و# اعدادات اداره المشاركه. كل مجموعه مواقع مشتركه تحتوي علي موقع ويب من المستوي اعلي و# يمكن ان تحتوي علي مواقع فرعيه واحده او اكثر. يمكن ان يكون هناك عده مجموعات المواقع المشتركه علي كل خادم ظاهري. استخدم نوع محتوي موقع عندما تريد ل# نطاق واسع اعاده استخدام المعلومات او ل# تمكين مجموعه البيانات من نماذج متعدده في مكان واحد.

تمكين المستخدمين من تحرير الحقول ب# استخدام طريقه عرض ورقه البيانات    يمكنك السماح ل# المستخدمين ل# اضافه او تحرير البيانات ل# حقل ب# استخدام طريقه عرض ورقه بيانات او ب# تحرير الخصائص ل# نموذج في مكتبه المستندات. يمكن المستخدمين من اضافه البيانات او تحديثها ل# النماذج واحد او اكثر من دون فتحها النماذج.

ملاحظة: يتم تمكين طرق عرض ورقه البيانات في مستعرض ويب فقط ل# المستخدمين الذين لديهم Microsoft Office Access 2007 مثبتا.

ملاحظة: يختلف الدعم ل# المكتبات و# انواع محتويات الموقع، استنادا الي ما اذا كان الخادم يشغل Microsoft Windows SharePoint Services 2.0 او Windows SharePoint Services 3.0. ل# ذلك، يجب ان تطلب مسؤول الخادم اذا لم تكن متاكدا من اصدار Windows SharePoint Services يتم تشغيله علي الخادم.

أعلى الصفحة

تحديد أعمدة مكتبة المستندات عند تصميم قالب النموذج

  1. قم بفتح قالب النموذج.

  2. من القائمة أدوات، انقر فوق خيارات النموذج.

  3. انقر فوق ترقية الخصائص.

  4. نفّذ أحد الإجراءات التالية:

    • لإضافة عمود، انقر فوق إضافة، انقر فوق الحقل أو المجموعة المكررة التي ترغب في إنشاء عمود بها، ثم اكتب اسماً للعمود في المربع اسم العمود.

      ملاحظة: اذا قمت ب# تحديد حقل مكرر ل# عرض البيانات في مكتبه المستندات، يمكنك تحديد كيفيه عرض الحقل في مكتبه المستندات ب# النقر فوق قيمه في قائمه الدالات. يمكنك اختيار ما اذا كنت تريد عرض القيمه الاولي في الحقل، و# القيمه الاخيره في الحقل، او عدد كافه تكرارات الحقل او ما اذا كنت تريد دمج كافه القيم معا.

    • لإزالة عمود، انقر فوق العمود في القائمة، ثم انقر فوق إزالة.

    • لتعديل عمود، انقر فوق العمود في القائمة، وانقر فوق تعديل، ثم قم بعمل التغييرات الملاءمة.

      ملاحظة: تتوفر بعض خيارات إضافة أعمدة أو إزالتها أو تعديلها فقط عند النشر إلى موقع SharePoint.

أعلى الصفحة

تحديد أعمدة مكتبة المستندات عند نشر قالب النموذج إلى مكتبة مستندات جديدة

  1. قم بحفظ قالب النموذج.

  2. من القائمة ملف، انقر فوق نشر.

  3. في "معالج النشر"، انقر فوق إلى خادم SharePoint باستخدام InfoPath Forms Services أو بدون استخدامها، ثم انقر فوق التالي.

  4. في المربع ادخل موقع SharePoint أو موقع InfoPath Forms Services الخاص بك، اكتب موضع موقع SharePoint، ثم انقر فوق التالي.

  5. في الصفحة التالية من المعالج، انقر فوق مكتبة المستندات، ثم انقر فوق التالي.

    ملاحظة: إذا كنت تقوم بنشر قالب النموذج المتوافق مع المستعرض إلى موقع SharePoint، تكون خانة الاختيار تمكين هذا النموذج بحيث تتم تعبئته عن طريق استخدام المستعرض غير متوفرة. لإنشاء قالب نموذج ممكَّن على المستعرض، يتعين عليك نشر قالب النموذج إلى خادم يقوم بتشغيل InfoPath Forms Services. ابحث عن ارتباطات للحصول على المزيد من المعلومات حول InfoPath Forms Services في المقطع انظر أيضاً.

  6. انقر فوق إنشاء مكتبة مستندات جديدة، ثم انقر فوق التالي.

  7. اكتب اسماً ووصفاً لمكتبة المستندات، ثم انقر فوق التالي.

    يظهر اسم قالب النموذج ووصفه في طريقة العرض الافتراضية لمكتبة المستندات.

  8. نفّذ أحد الإجراءات التالية:

    إضافة عمود

    1. انقر فوق إضافة.

    2. نفّذ أحد الإجراءات التالية:

      • لإضافة عمود جديد إلى مكتبة المستنداتـ حدد الحقل الذي ترغب في ظهور بياناته في العمود، حدد (بلا: إنشاء عمود جديد في هذه المكتبة) من القائمة مجموعة أعمدة الموقع، ثم اكتب اسماً للعمود في المربع اسم العمود.

      • لاستخدام عمود موقع موجود، حدد الفئة من القائمة مجموعة أعمدة الموقع، ثم حدد اسماً من القائمة اسم العمود.

        ملاحظة: اذا قمت ب# تحديد حقل مكرر ل# عرض البيانات في مكتبه المستندات، يمكنك تحديد كيفيه عرض الحقل في مكتبه المستندات ب# النقر فوق قيمه في قائمه الدالات. يمكنك اختيار ما اذا كنت تريد عرض القيمه الاولي في الحقل، و# القيمه الاخيره في الحقل، او عدد كافه تكرارات الحقل او ما اذا كنت تريد دمج كافه القيم معا.

        1. ل# تمكين المستخدمين من اضافه او تحرير البيانات ل# هذا الحقل ب# استخدام طريقه عرض ورقه بيانات او ب# تحرير الخصائص ل# نموذج في مكتبه المستندات، حدد خانه الاختيار السماح ل# المستخدمين ب# تحرير البيانات الموجوده في هذا الحقل ب# استخدام صفحه خصائص او ورقه البيانات.

          ملاحظة: ل# استخدام طريقه عرض ورقه بيانات، يجب علي المستخدمين Microsoft Office Access 2007 مثبتا علي الكمبيوتر الخاص به.

    إزالة عمود

    1. ضمن اسم العمود، انقر فوق اسم الحقل الذي العمود المناظر الذي تريد ازالته، و# من ثم انقر فوق ازاله.

    تعديل عمود

    1. ضمن اسم العمود، انقر فوق اسم الحقل الذي ترغب في تعديل العمود المقابل له، ثم انقر فوق تعديل.

    2. نفّذ أحد الإجراءات التالية:

      • اكتب اسم جديد للعمود في المربع اسم العمود.

      • حدد الفئة من القائمة مجموعة أعمدة الموقع، ثم حدد اسماً من القائمة اسم العمود.

        ملاحظة: اذا قمت ب# تحديد حقل مكرر ل# عرض البيانات في مكتبه المستندات، يمكنك تحديد كيفيه عرض الحقل في مكتبه المستندات ب# النقر فوق قيمه في قائمه الدالات. يمكنك اختيار ما اذا كنت تريد عرض القيمه الاولي في الحقل، و# القيمه الاخيره في الحقل، او عدد كافه التكرارات الحقل او ما اذا كنت تريد دمج كافه القيم معا.

        1. ل# تمكين المستخدمين من اضافه او تحرير البيانات ل# هذا الحقل ب# استخدام طريقه عرض ورقه بيانات او ب# تحرير الخصائص ل# نموذج في مكتبه المستندات، حدد خانه الاختيار السماح ل# المستخدمين ب# تحرير البيانات الموجوده في هذا الحقل ب# استخدام صفحه خصائص او ورقه البيانات.

          ملاحظة: ل# استخدام طريقه عرض ورقه بيانات، يجب علي المستخدمين Microsoft Office Access 2007 مثبتا علي الكمبيوتر الخاص به.

  9. عند الانتهاء من تعريف الأعمدة للمكتبة، انقر فوق التالي.

  10. في الصفحة التالية من المعالج، تأكد من صحة المعلومات، ثم انقر فوق نشر.

أعلى الصفحة

تحديد أعمدة مكتبة المستندات عند نشر قالب النموذج إلى مكتبة مستندات موجودة

  1. قم بحفظ قالب النموذج.

  2. من القائمة ملف، انقر فوق نشر.

  3. في "معالج النشر"، انقر فوق إلى خادم SharePoint باستخدام InfoPath Forms Services أو بدون استخدامها، ثم انقر فوق التالي.

  4. في المربع ادخل موقع SharePoint أو موقع InfoPath Forms Services الخاص بك، اكتب موضع موقع SharePoint، ثم انقر فوق التالي.

  5. في الصفحة التالية من المعالج، انقر فوق مكتبة المستندات، ثم انقر فوق التالي.

    ملاحظة: إذا كنت تقوم بنشر قالب النموذج المتوافق مع المستعرض إلى موقع SharePoint، تكون خانة الاختيار تمكين هذا النموذج بحيث تتم تعبئته عن طريق استخدام المستعرض غير متوفرة. لإنشاء قالب نموذج ممكَّن على المستعرض، يتعين عليك نشر قالب النموذج إلى خادم يقوم بتشغيل InfoPath Forms Services. ابحث عن ارتباطات للحصول على المزيد من المعلومات حول InfoPath Forms Services في المقطع انظر أيضاً.

  6. انقر فوق تحديث قالب النموذج الموجود في مكتبة مستندات موجودة، ثم انقر فوق مكتبة المستندات التي ترغب في تحديثها.

  7. انقر فوق التالي.

  8. نفّذ أحد الإجراءات التالية:

    إضافة عمود

    1. انقر فوق إضافة.

    2. نفّذ أحد الإجراءات التالية:

      • لإضافة عمود جديد إلى مكتبة المستندات حدد الحقل الذي ترغب في ظهور بياناته في العمود، حدد (بلا: إنشاء عمود جديد في هذه المكتبة) من القائمة مجموعة أعمدة الموقع، ثم اكتب اسماً للعمود في المربع اسم العمود.

      • لاستخدام عمود مكتبة مستندات أو عمود موقع موجود، حدد الفئة من القائمة مجموعة أعمدة الموقع، ثم حدد الاسم من القائمة اسم العمود.

        ملاحظة: اذا قمت ب# تحديد حقل مكرر ل# عرض البيانات في مكتبه المستندات، يمكنك تحديد كيفيه عرض الحقل في مكتبه المستندات ب# النقر فوق قيمه في قائمه الدالات. يمكنك اختيار ما اذا كنت تريد عرض القيمه الاولي في الحقل، و# القيمه الاخيره في الحقل، او عدد كافه تكرارات الحقل او ما اذا كنت تريد دمج كافه القيم معا.

        1. ل# تمكين المستخدمين من اضافه او تحرير البيانات ل# هذا الحقل ب# استخدام طريقه عرض ورقه بيانات او ب# تحرير الخصائص ل# نموذج في مكتبه المستندات، حدد خانه الاختيار السماح ل# المستخدمين ب# تحرير البيانات الموجوده في هذا الحقل ب# استخدام صفحه خصائص او ورقه البيانات.

          ملاحظة: ل# استخدام طريقه عرض ورقه بيانات، يجب ان يكون لدي المستخدمين Microsoft Office Access 2007 مثبتا علي الكمبيوتر الخاص به.

    إزالة عمود

    1. ضمن اسم العمود، انقر فوق اسم الحقل الذي العمود المناظر الذي تريد ازالته، و# من ثم انقر فوق ازاله.

    تعديل عمود

    1. ضمن اسم العمود، انقر فوق اسم الحقل الذي ترغب في تعديل العمود المقابل له، ثم انقر فوق تعديل.

    2. نفّذ أحد الإجراءات التالية:

      • اكتب اسم جديد للعمود في المربع اسم العمود.

      • حدد الفئة من القائمة مجموعة أعمدة الموقع، ثم حدد اسماً من القائمة اسم العمود.

        ملاحظة: اذا قمت ب# تحديد حقل مكرر ل# عرض البيانات في مكتبه المستندات، يمكنك تحديد كيفيه عرض الحقل في مكتبه المستندات ب# النقر فوق قيمه في قائمه الدالات. يمكنك اختيار ما اذا كنت تريد عرض القيمه الاولي في الحقل، و# القيمه الاخيره في الحقل، او عدد كافه تكرارات الحقل او ما اذا كنت تريد دمج كافه القيم معا.

        1. ل# تمكين المستخدمين من اضافه او تحرير البيانات ل# هذا الحقل ب# استخدام طريقه عرض ورقه بيانات او ب# تحرير الخصائص ل# نموذج في مكتبه المستندات، حدد خانه الاختيار السماح ل# المستخدمين ب# تحرير البيانات الموجوده في هذا الحقل ب# استخدام صفحه خصائص او ورقه البيانات.

          ملاحظة: ل# استخدام طريقه عرض ورقه بيانات، يجب ان يكون لدي المستخدمين Microsoft Office Access 2007 مثبتا علي الكمبيوتر الخاص به.

  9. عند الانتهاء من تعريف الأعمدة للمكتبة، انقر فوق التالي.

  10. في الصفحة التالية من المعالج، تأكد من صحة المعلومات، ثم انقر فوق نشر.

أعلى الصفحة

ملاحظة: إقرار إخلاء المسؤولية للترجمة الآلية: تمت ترجمة هذه المقالة بواسطة نظام كمبيوتر دون تدخل العامل البشري. توفر Microsoft هذه الترجمات الآلية لمساعدة المستخدمين الذين لا يتحدثون الإنجليزية على استخدام منتجات Microsoft، وخدماتها، وتقنياتها والاستمتاع بها. قد تحتوي هذه المقالة على أخطاء في المفردات، أو بناء الجملة، أو القواعد نظرًا لترجمتها آليًا.

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×