إرسال بيانات النموذج إلى مواقع متعددة

هام: تمت ترجمة هذه المقالة ترجمة آلية، راجع إقرار إخلاء المسؤولية. يرجى الاطلاع على النسخة الإنجليزية من هذه المقالة. هنا للرجوع إليها.

يمكن تصميم قالب النموذج بحيث يمكن للمستخدمين إرسال بيانات النماذج الخاصة بهم إلى مواقع مختلفة عند النقر فوق الزر إرسال.

في هذا المقال

نظره عامه

الخطوه 1: اضافه اتصالات بيانات الارسال

الخطوه 2: تكوين قالب النموذج ل# السماح ب# الارسال

نظرة عامة

للسماح للمستخدمين بإرسال بيانات النماذج إلى مواقع متعددة، يجب إضافة اتصال بيانات ثانوي إلى قالب النموذج يقوم بإرسال البيانات إلى كل موقع من المواقع التي ترغب في أن يقوم المستخدمون بإرسال البيانات إليها. بعد إضافة كافة اتصالات بيانات الإرسال، قم بتكوين قالب النموذج بحيث يسمح للمستخدمين بإرسال بيانات النموذج إلى مواقع متعددة باستخدام قاعدة. كنتيجة لذلك، يضيف Microsoft Office InfoPath الزر إرسال إلى شريط الأدوات قياسي، كما يضيف الأمر إرسال إلى القائمة ملف عند قيام المستخدمين بتعبئة النموذج. يقوم InfoPath بإرسال بيانات النموذج إلى اتصالات البيانات الثانوية حسب الترتيب الذي تم به سرد البيانات في القاعدة. لا يمكن تكوين قاعدة لاستخدام كافة اتصالات بيانات الإرسال في نفس الوقت.

عند تكوين قالب النموذج بحيث يسمح للمستخدمين بإرسال بيانات النماذج، يمكن أيضاً تخصيص خيارات الإرسال باستخدام الطرق التالية:

  • تغيير النص الذي يظهر في الزر إرسال من شريط الأدوات قياسي والأمر إرسال من القائمة ملف.

  • تغيير مفاتيح الاختصار الخاصة بالزر إرسال من شريط الأدوات قياسي والأمر إرسال من القائمة ملف.

  • إنشاء رسائل مخصصة لعرضها للمستخدمين عند إرسال النماذج الخاصة بهم.

  • تحديد إما ترك النموذج مفتوحاً أو إغلاق النموذج أو فتح نموذج فارغ آخر بعد إرسال النموذج.

اعلي الصفحه

خطوة 1: إضافة اتصالات بيانات الإرسال

لتكوين قالب النموذج بحيث يسمح للمستخدمين بإرسال النماذج المكتملة إلى مواقع متعددة، تقوم بإضافة اتصالات بيانات الإرسال الضرورية إلى قالب النموذج. يمكن إضافة اتصالات بيانات إلى المواقع التالية:

  • خدمة ويب

  • مكتبة مستندات على خادم يستخدم Microsoft Windows SharePoint Services

  • في رسالة بريد إلكتروني

    ملاحظة: يحتاج المستخدمون إلى تثبيت Microsoft Office Outlook على أجهزة الكمبيوتر الخاصة بهم لإرسال بيانات النموذج في رسالة بريد إلكتروني.

توضح الإجراءات التالية كيفية إضافة اتصالات بيانات الإرسال إلى هذه المواقع.

إضافة اتصال بيانات يقوم بإرسال البيانات إلى خدمة ويب

  1. من القائمة أدوات انقر فوق اتصالات البيانات.

  2. في مربع الحوار اتصالات البيانات، انقر فوق اضافه.

  3. في معالج اتصال البيانات قم بالنقر فوق إنشاء اتصال جديد لـ وانقر فوق إرسال بيانات ثم انقر فوق التالي.

  4. في الصفحة التالية من المعالج، انقر فوق إلى خدمة ويب، ثم انقر فوق التالي.

  5. في الصفحة التالية من المعالج، اكتب موقع خدمة ويب حيث يقوم المستخدمون بإرسال النماذج، ثم انقر فوق التالي.

    إذا كنت تريد البحث في خادم Universal Description, Discovery, and Integration (UDDI) على خدمة ويب، انقر فوق بحث في UDDI، أدخل خادم UDDI الذي تريد البحث عنه، حدد ما إذا كنت ترغب في البحث عن طريق الموفر أم عن طريق الخدمات المتوفرة، أدخل كلمة أساسية للبحث، ثم انقر فوق بحث. تظهر خدمات ويب التي تطابق الكلمة الأساسية للبحث في القائمة نتائج البحث.

  6. في الصفحة التالية من المعالج، في القائمة حدد عملية، انقر فوق عملية خدمة ويب التي ستقوم بتلقي بيانات النموذج، ثم انقر فوق التالي.

  7. في الصفحة التالية من المعالج، نفّذ أحد الإجراءات التالية:

    ارسال البيانات الموجوده في حقل او مجموعه

    1. في القائمة المعلمات، انقر فوق معلمة خدمة ويب التي ستقوم بتلقي البيانات من النموذج.

    2. في خيارات المعلمة، انقر فوق حقل أو مجموعة.

    3. انقر فوق تعديل الزر "مصدر البيانات" .

    4. في مربع الحوار تحديد حقل أو مجموعة، انقر فوق الحقل أو المجموعة التي ترغب في إرسال بياناتها، ثم انقر فوق موافق.

    5. في المربع تضمين، انقر فوق العناصر النصية والتابعة فقط لإرسال المحتوى وأية عناصر تابعة موجودة داخل الحقل أو المجموعة فقط، أو انقر فوق شجرة XML الفرعية، بما في ذلك العنصر المحدد لإرسال كلاً من المحتوى والحقل أو المجموعة المحددة.

    ارسال كافه البيانات الموجوده في النموذج

    1. انقر فوق النموذج بأكمله (مستند XML، بما في ذلك الإرشادات الخاصة بالمعالجة).

    ارسال البيانات ك# سلسله

    1. حدد خانة الاختيار إرسال البيانات كسلسلة.

      تقوم عادةً بتحديد خانة الاختيار هذه لإرسال البيانات الموقّعة رقمياً. في أغلب الأحيان، قم بإلغاء تحديد خانة الاختيار هذه.

  8. انقر فوق التالي.

  9. علي الصفحه التاليه من المعالج، في المربع ادخل اسما ل# اتصال البيانات هذا، اكتب اسما وصفيا ل# هذا اتصال بيانات ارسال.

  10. التحقق من صحة المعلومات في المقطع ملخص، ثم انقر فوق إنهاء.

إضافة اتصال بيانات يقوم بإرسال البيانات إلى مكتبة مستندات

  1. من القائمة أدوات انقر فوق اتصالات البيانات.

  2. في مربع الحوار اتصالات البيانات، انقر فوق اضافه.

  3. في معالج اتصال البيانات قم بالنقر فوق إنشاء اتصال جديد لـ وانقر فوق إرسال بيانات ثم انقر فوق التالي.

  4. في الصفحة التالية من المعالج، انقر فوق إلى مكتبة مستندات موجودة على موقع SharePoint، ثم انقر فوق التالي.

  5. في الصفحة التالية من المعالج، في المربع مكتبة المستندات، اكتب موقع مكتبة مستندات SharePoint.

  6. في المربع اسم الملف، اكتب اسماً يستخدم لتعريف النموذج في مكتبة المستندات. يمكن أيضاً استخدام صيغة للتأكد من أن يكون لكل نموذج اسماً فريداً.

    كيف؟

    1. انقر فوق ادراج الصيغه الزر "صيغة" .

    2. في مربع الحوار إدراج صيغة، نفّذ أحد الإجراءات التالية:

      • لاستخدام حقل في المجموعة، انقر فوق إدراج حقل أو مجموعة، انقر فوق الحقل الذي ترغب في استخدامه في مربع الحوار تحديد حقل أو مجموعة، ثم انقر فوق موافق.

      • لاستخدام دالة في الصيغة، انقر فوق إدراج دالة، انقر فوق الدالة التي ترغب في استخدامها في مربع الحوار إدراج دالة، ثم انقر فوق موافق.

        إذا كانت الدالة تتطلب وجود معلمات، حدد الدالة في مربع الحوار إدراج دالة، ثم انقر فوق موافق، ثم في المربع صيغة في مربع الحوار إدراج صيغة، انقر نقراً مزدوجاً فوق الدالة التي قمت بإضافتها، ثم انقر فوق حقل أو مجموعة. يمكنك العثور على ارتباطات لمزيد من المعلومات حول الدوال في المقطع انظر أيضاً.

      • لإدراج قيمة أو عامل رياضي في الصيغة، اكتب القيمة أو الرمز للعملية الرياضية في المربع الصيغة.

    عملية

    الرمز

    الجمع

    +

    طرح

    -

    ضرب

    *

    قسمة

    /

    • ملاحظة: إذا كانت الصيغة تستخدم عامل تشغيل القسمة (/)، تأكد من وجود مسافة قبل عامل التشغيل وبعده. إذا لم يكن هناك مسافة قبل عامل التشغيل وبعده، فقد يقوم InfoPath بتفسير "/" كفاصل لخطوات تحديد موقع XPath بدلاً من عامل تشغيل القسمة.

    • للتحقق من البناء الصحيح لجملة الصيغة، في مربع الحوار إدراج صيغة، انقر فوق التحقق من الصيغة.

      يمكنك العثور على ارتباطات لمزيد من المعلومات حول الصيغ في المقطع انظر أيضاً.

  7. للكتابة فوق أي نماذج موجودة بنفس الاسم في مكتبة المستندات، حدد خانة الاختيار السماح بالكتابة الفوقية إذا كان الملف موجوداً.

  8. انقر فوق التالي.

  9. علي الصفحه التاليه من المعالج، في المربع ادخل اسما ل# اتصال البيانات هذا، اكتب اسما وصفيا ل# هذا اتصال بيانات ارسال.

  10. التحقق من صحة المعلومات في المقطع ملخص، ثم انقر فوق إنهاء.

إضافة اتصال بيانات يقوم بإرسال البيانات في رسالة بريد إلكتروني

  1. من القائمة أدوات انقر فوق اتصالات البيانات.

  2. في مربع الحوار اتصالات البيانات، انقر فوق اضافه.

  3. في معالج اتصال البيانات قم بالنقر فوق إنشاء اتصال جديد لـ وانقر فوق إرسال بيانات ثم انقر فوق التالي.

  4. في الصفحة التالية من المعالج، انقر فوق كرسالة بريد إلكتروني، ثم انقر فوق التالي.

  5. في الصفحة التالية من المعالج، اكتب عنوان البريد الإلكتروني الخاص بمستلمي الرسالة والموضوع الذي تريده أن يظهر في الرسالة وأي نص مقدمة تريد ظهوره في المربعات المناسبة له، ثم انقر فوق التالي. يمكن أيضاً استخدام صيغة في كل من هذه المربعات باستثناء المربع مقدمة.

    كيف؟

    1. انقر فوق ادراج الصيغه الزر "صيغة" .

    2. في مربع الحوار إدراج صيغة، نفّذ أحد الإجراءات التالية:

      • لاستخدام حقل في المجموعة، انقر فوق إدراج حقل أو مجموعة، انقر فوق الحقل الذي ترغب في استخدامه في مربع الحوار تحديد حقل أو مجموعة، ثم انقر فوق موافق.

      • لاستخدام دالة في الصيغة، انقر فوق إدراج دالة، انقر فوق الدالة التي ترغب في استخدامها في مربع الحوار إدراج دالة، ثم انقر فوق موافق.

        إذا كانت الدالة تتطلب وجود معلمات، حدد الدالة في مربع الحوار إدراج دالة، ثم انقر فوق موافق، ثم في المربع صيغة في مربع الحوار إدراج صيغة، انقر نقراً مزدوجاً فوق الدالة التي قمت بإضافتها، ثم انقر فوق حقل أو مجموعة. يمكنك العثور على ارتباطات لمزيد من المعلومات حول الدوال في المقطع انظر أيضاً.

      • لإدراج قيمة أو عامل رياضي في الصيغة، اكتب القيمة أو الرمز للعملية الرياضية في المربع الصيغة.

    عملية

    الرمز

    الجمع

    +

    طرح

    -

    ضرب

    *

    قسمة

    /

    • ملاحظة: إذا كانت الصيغة تستخدم عامل تشغيل القسمة (/)، تأكد من وجود مسافة قبل عامل التشغيل وبعده. إذا لم يكن هناك مسافة قبل عامل التشغيل وبعده، فقد يقوم InfoPath بتفسير "/" كفاصل لخطوات تحديد موقع XPath بدلاً من عامل تشغيل القسمة.

    • للتحقق من البناء الصحيح لجملة الصيغة، في مربع الحوار إدراج صيغة، انقر فوق التحقق من الصيغة.

      يمكنك العثور على ارتباطات لمزيد من المعلومات حول الصيغ في المقطع انظر أيضاً.

  6. في الصفحة التالية من المعالج، نفّذ أحد الإجراءات التالية:

    1. لعرض النموذج في نص رسالة بريد إلكتروني، انقر فوق إرسال طريقة العرض النشطة فقط الخاصة بالنموذج دون إرسال مرفقات.

    2. ل# ارسال بيانات النموذج ك# مرفق الي رساله البريد الالكتروني، انقر فوق ارسال بيانات النموذج ك# مرفق و# حدد خانه الاختيار ارفاق قالب النموذج ل# التاكد من قدره المستخدمين علي فتح النموذج، و# من ثم اكتب اسما ل# النموذج في المربع اسم المرفق. يمكنك ايضا تحديد حقل او استخدام صيغه ل# التاكد من ان كل اسم النموذج فريدا. يتوفر هذا الخيار قارئي فقط اذا تم تكوين ل# تحديد مستوي الامان ب# شكل تلقائي قالب النموذج او تم تكوينه ل# مستوي الامان ب# المحظوره او ثقه كامله.

      كيف؟

      1. انقر فوق ادراج الصيغه الزر "صيغة" .

      2. في مربع الحوار إدراج صيغة، نفّذ أحد الإجراءات التالية:

        • لاستخدام حقل في المجموعة، انقر فوق إدراج حقل أو مجموعة، انقر فوق الحقل الذي ترغب في استخدامه في مربع الحوار تحديد حقل أو مجموعة، ثم انقر فوق موافق.

        • لاستخدام دالة في الصيغة، انقر فوق إدراج دالة، انقر فوق الدالة التي ترغب في استخدامها في مربع الحوار إدراج دالة، ثم انقر فوق موافق.

          إذا كانت الدالة تتطلب وجود معلمات، حدد الدالة في مربع الحوار إدراج دالة، ثم انقر فوق موافق، ثم في المربع صيغة في مربع الحوار إدراج صيغة، انقر نقراً مزدوجاً فوق الدالة التي قمت بإضافتها، ثم انقر فوق حقل أو مجموعة. يمكنك العثور على ارتباطات لمزيد من المعلومات حول الدوال في المقطع انظر أيضاً.

        • لإدراج قيمة أو عامل رياضي في الصيغة، اكتب القيمة أو الرمز للعملية الرياضية في المربع الصيغة.

      عملية

      الرمز

      الجمع

      +

      طرح

      -

      ضرب

      *

      قسمة

      /

      • ملاحظة: إذا كانت الصيغة تستخدم عامل تشغيل القسمة (/)، تأكد من وجود مسافة قبل عامل التشغيل وبعده. إذا لم يكن هناك مسافة قبل عامل التشغيل وبعده، فقد يقوم InfoPath بتفسير "/" كفاصل لخطوات تحديد موقع XPath بدلاً من عامل تشغيل القسمة.

      • للتحقق من البناء الصحيح لجملة الصيغة، في مربع الحوار إدراج صيغة، انقر فوق التحقق من الصيغة.

        يمكنك العثور على ارتباطات لمزيد من المعلومات حول الصيغ في المقطع انظر أيضاً.

      يحتاج مستلموا بيانات النموذج التي تم إرسالها كمرفق إلى تثبيت InfoPath على أجهزة الكمبيوتر الخاصة بهم ليتمكنوا من فتح المرفق.

  7. انقر فوق التالي.

  8. علي الصفحه التاليه من المعالج، في المربع ادخل اسما ل# اتصال البيانات هذا، اكتب اسما وصفيا ل# هذا اتصال بيانات ارسال.

  9. التحقق من صحة المعلومات في المقطع ملخص، ثم انقر فوق إنهاء.

اعلي الصفحه

خطوة 2: تكوين قالب النموذج للسماح بالإرسال

بعد إضافة اتصالات البيانات الثانوية اللازمة إلى قالب النموذج، تقوم بتكوين قالب النموذج يسمح للمستخدمين بإرسال بيانات النموذج. عند تنفيذ ذلك، يقوم InfoPath بإضافة الأمر إرسال إلى القائمة ملف وإضافة الزر إرسال إلى شريط الأدوات قياسي عند قيام المستخدمين بتعبئة النموذج. يمكنك تكوين الإجراء الذي يظهر عندما ينقر المستخدم فوق الأمر إرسال من القائمة ملف أو فوق الزر إرسال من شريط الأدوات قياسي. وفي هذه الحالة، تقوم بإضافة قاعدة تقوم بإرسال بيانات النموذج لكل اتصال بيانات إرسال عند قيام المستخدم بالنقر فوق الزر إرسال.

في نفس مربع الحوار، يمكن تكوين خيارات الإرسال.

  1. علي القائمه ادوات، انقر فوق خيارات الارسال.

  2. في مربع الحوار خيارات الارسال، حدد خانه الاختيار السماح ل# المستخدمين ب# ارسال هذا النموذج.

    عند تحديد خانة الاختيار هذه، يضيف InfoPath الزر إرسال إلى شريط الأدوات قياسي والأمر إرسال إلى القائمة ملف عند قيام المستخدمين بتعبئة النموذج.

  3. انقر فوق تنفيذ إجراء مخصص باستخدام القواعد، ثم انقر فوق قواعد.

  4. في مربع الحوار القواعد الخاصة بإرسال النماذج، انقر فوق إضافة.

  5. انقر فوق إضافة إجراء.

  6. في المربع إجراء، انقر فوق الإرسال باستخدام اتصال البيانات، انقر فوق اتصال البيانات الذي ترغب في استخدامه لإجراء الإرسال في القائمة اتصال البيانات، ثم انقر فوق موافق.

  7. كرر الخطوات 5 و6 لكل اتصال بيانات إرسال قمت بإضافته إلى قالب النموذج.

  8. بعد إضافة شروط إلى اتصالات بيانات الإرسال في قالب النموذج، انقر فوق موافق مرتين.

    1. ل# تغيير اسم الزر " ارسال " الذي يظهر علي شريط الادوات القياسي و# الامر " ارسال " الذي يظهر في القائمه ملف عند المستخدمون ب# تعبئه النموذج، اكتب الاسم الجديد في المربع تسميه توضيحيه في مربع الحوار خيارات الارسال.

      اذا كنت تريد تعيين اختصار لوحه مفاتيح هذا الزر الي و# الاوامر، اكتب علامه ضم (&) قبل الحرف الذي تريد استخدامه ك# اختصار لوحه مفاتيح. علي سبيل المثال، ل# تعيين ALT + B ك# اختصار لوحه المفاتيح ل# الاوامر و# الزر ارسال، اكتب Su & بميت.

  9. لمنع المستخدمين من استخدام الأمر إرسال أو الزر إرسال من شريط الأدوات قياسي عند قيامهم بتعبئة النموذج، قم بإلغاء تحديد خانة الاختيار إظهار عنصر القائمة "إرسال" وزر شريط الأدوات "إرسال".

    1. ب# شكل افتراضي، بعد قيام المستخدمين ب# ارسال نموذج، InfoPath يحتفظ النموذج المفتوحه و# يعرض رساله ل# الاشاره الي اذا تم ارسال النموذج ب# شكل ناجح. ل# تغيير هذا السلوك الافتراضي، انقر فوق خيارات متقدمه، و# من ثم قم ب# واحد مما يلي:

      • ل# اغلاق النموذج او انشاء نموذج فارغ جديد بعد قيام المستخدم ب# ارسال نموذج مكتمل، انقر فوق الخيار الذي تريده في القائمه بعد ارسال.

      • ل# انشاء رساله مخصصه ل# الاشاره الي اذا تم ارسال النموذج ب# نجاح، حدد خانه الاختيار استخدام الرسائل المخصصه، و# اكتب رسائلك في المربعين علي النجاح و# الفشل.

        استخدام رساله في المربع عند فشل ل# اعلام المستخدمين ما يجب ف# عله في حال تعذر ارسال النموذج. علي سبيل المثال، يمكنك يقترح ان المستخدمين احفظ النموذج و# الاتصال ب# شخص ما ل# الحصول علي ارشادات اضافيه.

      • اذا كنت لا تريد عرض رساله بعد قيام المستخدم ب# ارسال نموذج، قم ب# الغاء تحديد خانه الاختيار اظهار رسائل النجاح و# الفشل.

اعلي الصفحه

ملاحظة: إقرار إخلاء المسؤولية للترجمة الآلية: تمت ترجمة هذه المقالة بواسطة نظام كمبيوتر دون تدخل العامل البشري. توفر Microsoft هذه الترجمات الآلية لمساعدة المستخدمين الذين لا يتحدثون الإنجليزية على استخدام منتجات Microsoft، وخدماتها، وتقنياتها والاستمتاع بها. قد تحتوي هذه المقالة على أخطاء في المفردات، أو بناء الجملة، أو القواعد نظرًا لترجمتها آليًا.

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×